Linux下Apache服务器配置
Linux下Apache服务器配置
httpd-2.2.3-29.e15.i386.rpm //主程序包httpd-devel-2.2.3-29.e15.i386.rpm //开发程序包httpd-manual-2.2.3-29.e15.i386.rpm //手册文档system-config-httpd-1.3.3.3-1.e15.noarch.rpm //配置工具注:安装时会出现依赖包问题,可用YUM安装来解决启用时需要配置防火墙来放行
chkconfig --level 3 httpd on
例1:部门内搭建一台WEB服务器,采用的IP地址和端口为192.168.0.3:80,首页采用index.html文件。管理员E- mail地址为root@sales.com,网页的编码类型采用GB2312,所有网站资源都存放在/var/www/html目录下,并将 Apache的根目录设置为/etc/httpd目录。编辑主配置文件httpd.confvim /etc/httpd/conf/httpd.conf //编辑主配置文件ServerRoot "/etc/httpd" //设置Apache的主目录Timeout 120 //设置请求超时Listen 80 //设置监听端口ServerAdmin root@sales.com //设置管理员邮箱ServerName 192.168.0.3:80 //设置主机或IPDocumentRoot "/var/www/html" //设置Apache文档目录DirectoryIndex index.html //设置主页文件AddDefaultCharset GB2312 //设置网站编码编辑主页文件用作测试:cd /var/www/htmlecho "This is web test sample.">>index.htmlchmod 705 index.html重新加载服务:service httpd restart
(基于IP)mkdir /var/www/ip1 /var/www/ip2 //创建两个主目录编辑httpd.conf文件:<Virtualhost 192.168.0.2> //设置虚拟主机的IPDocumentRoot /var/www/ip1 //设置虚拟主机的主目录DirectoryIndex index.html //设置主页文件ServerAdmin root@sales.com //设置管理员邮箱ErrorLog logs/ip1-error_log //设置错误日志的存放位置CustomLog logs/ip1-access_log common //设置访问日志的存放位置</Virtualhost><Virtualhost 192.168.0.3> //设置相应的IPDocumentRoot /var/www/ip2DirectoryIndex index.htmlServerAdmin root@sales.comErrorLog logs/ip2-error_logCustomLog logs/ip2-access_log common</Virtualhost>
(基于域名)mkdir /var/www/smile /var/www/long //创建两个主目录编辑httpd.conf文件:<Virtualhost 192.168.0.3> //设置虚拟主机的IPDocumentRoot /var/www/smile //设置虚拟主机的主目录DirectoryIndex index.html //设置主页文件ServerName www.smile.com //设置虚拟主机完全域名ServerAdmin root@sales.com //设置管理员邮箱ErrorLog logs/smile-error_log //设置错误日志的存放位置CustomLog logs/smile-access_log common //设置访问日志的存放位置</Virtualhost><Virtualhost 192.168.0.3>DocumentRoot /var/www/longDirectoryIndex index.htmlServerName www.smile.com //设置虚拟主机完全域名ServerAdmin root@sales.comErrorLog logs/long-error_logCustomLog logs/long-access_log common</Virtualhost>
(基于端口)mkdir /var/www/port8080 /var/www/port8090 //创建两个主目录编辑httpd.conf文件:Listen 8080Listen 8090<Virtualhost 192.168.0.3:8080> //设置相应的端口DocumentRoot /var/www/port8080 //设置虚拟主机的主目录DirectoryIndex index.html //设置主页文件ServerAdmin root@sales.com //设置管理员邮箱ErrorLog logs/port8080-error_log //设置错误日志的存放位置CustomLog logs/port8080-access_log common //设置访问日志的存放位置</Virtualhost><Virtualhost 192.168.0.3:8090> //设置相应的端口DocumentRoot /var/www/port8090DirectoryIndex index.htmlServerAdmin root@sales.comErrorLog logs/port8090-error_logCustomLog logs/port8090-access_log common</Virtualhost>
Linux下Apache服务器配置的更多相关文章
- [Linux]Linux下Apache服务器配置
Linux下Apache服务器配置 相关包: httpd-2.2.3-29.e15.i386.rpm //主程序包 httpd-devel-2.2.3-29.e15.i ...
- linux 下 apache相关;启动、停止、重启命令;配置文件位置等等
linux 下 apache启动.停止.重启命 基本的操作方法: 本文假设你的apahce安装目录为/usr/local/apache2,这些方法适合任何情况 apahce启动命令: 推荐/usr/l ...
- Linux下apache+phppgadmin+postgresql安装配置
Linux下apache+phppgadmin+postgresql安装配置 操作系统:CentOS 安装包:httpd(首选yum), php(包括php以及php-pgsql,php-mbstri ...
- 分享:linux下apache服务器的配置和管理
linux下apache服务器的配置和管理. 一.两个重要目录: Apache有两个重要的目录:1.配置目录/etc/httpd/conf:2.文档目录/var/www: 二.两种配置模式: Apac ...
- linux 下apache安装、启动和配置
linux 下 apache安装 1:系统安装,这里就不说了,网上有很多,也很简单.顺便说下,我用的是redhat 9: 2:在图形界面下下载apache 安装包,我下的是 httpd-2.2.9.t ...
- linux 下 apache启动、停止、重启命令
原文:linux 下 apache启动.停止.重启命令 基本的操作方法: 本文假设你的apahce安装目录为/usr/local/apache2,这些方法适合任何情况 apahce启动命令: 推荐/u ...
- MAC下 Apache服务器配置
今天做了一个注册登录提交的页面,后续操作需要用到后端的知识 php+Mysql,之前只是有些了解,现在开始具体操作了,首先从配置环境开始.查了好几篇文档与博客,了解了挺多知识. Mac下Apache服 ...
- Linux下Apache服务部署静态网站------网站服务程序
文章链接(我的CSDN博客): Linux下Apache服务部署静态网站------网站服务程序
- linux下apache和tomcat整合
一 Apache与Tomcat比较联系 apache支持静态页,tomcat支持动态的,比如servlet等. 一般使用apache+tomcat的话,apache只是作为一个转发,对jsp的处理是由 ...
随机推荐
- LeetCode第[91]题(Java):Decode Ways(解码方法数)
题目:解码方法数 难度:Medium 题目内容: A message containing letters from A-Z is being encoded to numbers using the ...
- sqlserver存储过程杀掉数据库中死锁
Create proc p_lockinfo @kill_lock_spid bit=1, --是否杀掉死锁的进程,1 杀掉, 0 仅显示 @show_spid_if_nolock ...
- Kotlin------类和对象(二)
get/set方法 声明一个属性的完整语法是 var <propertyName>[: <PropertyType>] [= <property_initializer& ...
- linux五大搜索命令学习
五大搜索命令学习 分别解释locate,find,which,whereis,grep 五大linux搜索命令 locate 解释:由man手册可以看出,locate查找就是根据文件名进行查找,只是依 ...
- 重新学习MySQL数据库1:无废话MySQL入门
重新学习Mysql数据库1:无废话MySQL入门 开始使用 我下面所有的SQL语句是基于MySQL 5.6+运行. MySQL 为关系型数据库(Relational Database Manageme ...
- JS中将对象转化为数组
前言 其实这本来应该是一个很基础的问题了,但我之做一想记录一下是因为之前因为对象转数组的时候卡住了后来弄了出来,但最近再遇到这个问题时竟然又卡主了,所以,关于这个问题,如何把一个对象{'未完成':5, ...
- 初次学习AngularJS
一.指令1.AngularJS 指令是扩展的 HTML 属性,带有前缀 ng-. ng-app 指令初始化一个 AngularJS 应用程序. ng-app 指令定义了 AngularJS 应用程序的 ...
- bzoj3000
题解: n!k进制的位数 首先考虑n!十进制的位数 =log10(n!) 然后用阶乘近似公式 继而换底 得到答案 代码: #include<bits/stdc++.h> using nam ...
- kappa系数在大数据评测中的应用
◆版权声明:本文出自胖喵~的博客,转载必须注明出处. 转载请注明出处:http://www.cnblogs.com/by-dream/p/7091315.html 前言 最近打算把翻译质量的人工评测好 ...
- New Concept English there (5)
25w/m Editors of newspapers and magazines often go to extremes to provide their readers with unimpor ...