Redis集群环境之linux搭建单机版
Redis解决的问题是:作为一个缓存nosql数据库,能够支持高并发,关系型数据库是存储在磁盘中,通过io读写,而redis是存储在内存中,因此,能够实现高可用,他主要是解决数据库性能瓶颈而产生的。
当单机版redis在访问量高的时候,可能出现承载的性能问题,于是对他进行扩容就产生了多机版,多机版有一个同步问题,为了解决该问题应用了集群,集群是有一个master和多个slave之间进行同步,Redis3.0之后的Redis cluster集群更便捷,为此本篇主要是讲Redis cluster-slaver集群。
现在开始搞集群
集群之前先用大白话简单说一下自己的理解
根据学习知识,总结为比较简单的大白话来说其集群就是将几台redis服务器连接在一起,他们之间彼此连接,当客户对任何一台服务器发起请求的时候 ,其效果都是一样的,有点工厂模式的意思,工厂模式是问工厂要东西就成,这个就是有点像是存储数据到工厂,给工厂以后,不用管为什么我请求的是存储到集群中a服务器的,但是当我再次从集群中b服务器读取刚在a上存储的数据竟然能读取到,这里面的原理在集群以后,应用端是不需要关注的,所以集群后的服务器可以看作是一个整体的更大的服务器,这个大整体中的任何节点服务器一致对外提供一样的服务,彼此之间信息共享,所以当这个集群中一些服务宕机后(只要不超过一半)仍然不受影响。
经过多次失败尝试,多次修改
首先说明,Redis集群需要依赖ruby环境,我的安装环境是linux centOS6.7,他直接采用 yum install ruby 安装的只是1.8.7版本的,版本过低,redis cluster集群需要的ruby版本要高于2.2.2故而,在安装匹配的ruby环境时候折腾了好久,而管理ruby版本采用rvm比较好,姑且可以认为ruby依赖rvm吧并不准确。
官网上说:To create a cluster, the first thing we need is to have a few empty Redis instances running in cluster mode.
要创建集群,首先需要创建几个空的redis实例运行,也就是几个节点的意思。
集群的大体思路就是:
1.先安装好一个redis
2.解压的redis目录下创建节点
3.拷贝相关配置文件到各个节点并修改端口号
4.安装集群环境
这里坑比较多大家一定要看好了,redis集群需要依赖ruby2.2.2以上版本,而ruby版本需要rvm来管理,同时ruby需要集成zlib和openssl库(并需要配置Makefile文件)
所以安装集成环境需要:
- rvm
- ruby2.2.2以上版本
- zlib(并需要配置Makefile文件)
- openssl(并需要配置Makefile文件)
- redis-4.0.1.gem文件
5.进行集群
一、安装第一个redis
Redis的安装见之前的博客。安装的是4.0.9 make后在本目录下安装
进入安装目录查看,如下有bin目录表示安装成功
进入bin目录启动
./redis-server 启动后如下成功
启动成功后,不能再进行其他操作,此时可以拷贝redis.conf到刚才的user/local/redis/bin目录中,并修改其中的配置
编辑daemonize设置为yes如下:(尤其是节点中如果没有设置就会出现问题,后面有介绍,主要是无法编辑容易导致刚刚启动的服务关闭)
二、创建节点
按照官网来,
The following is a minimal Redis cluster configuration file:
port 7000
cluster-enabled yes
cluster-config-file nodes.conf
cluster-node-timeout 5000
appendonly yes
就是说如果进行集群,在redis.conf中必须至少配置上如上的信息(这里建议加上daemonize=yes 主要是启动服务后服务在前台还是后台进行的区别,yes有助于操作)
Note that the minimal cluster that works as expected requires to contain at least three master nodes. For your first tests it is strongly suggested to start a six nodes cluster with three masters and three slaves.
To do so, enter a new directory, and create the following directories named after the port number of the instance we'll run inside any given directory.
官网强烈建议6个节点,3个主节点和3个从节点,并且节点的命令以端口号命名
mkdir cluster-test
cd cluster-test
mkdir 7000 7001 7002 7003 7004 7005
三、在新建的节点文件夹700~7005中新建配置redis.conf文件将官网要求的至少配置信息配置在里面,可以配置一个后拷贝修改端口号就成
cd 7000 ------>touch redis.conf----->vim redis.conf------>写入配置信息
退出,然后拷贝到其他5个节点文件夹下,并修改配置文件中端口号与各节点名相同即可。
分别启动
启动各个服务启动命令为
./+redis-4.0.9下src下的路径/server-redis 节点路径 (需要注意的是这些路径都是相对当前文件夹下的,一定要注意,否则启动不起来)
启动方式二,写个启动脚本start-all.sh
内容为:
修改这个命令的权限
此时启动发现一个问题,全部没有在后台启动,当我ctrl+c一次就会关闭一个服务,导致在我最后能够写查看命令
ps aux|grep redis的时候只有一个显示出来如图红框中,因为其他四个被关闭了,解决办法是,在7000~7005目录下的redis.conf中都添加daemonize yes 的参数设置,再次启动,就OK 了,如下图全部
四、搭建集群
使用ruby脚本搭建集群,需要ruby的运行环境
运行命令yum install ruby
查看状态
安装gem组件 yum install rubygems
检查安装情况
执行集群命令
出错了
ruby版本太低,明天在搞吧
现在我们来换一种安装方法
在网上下载ruby高版本的源码网址是:下载ruby,我下载的是2.5.1
然后将其拷贝到linux相应的文件夹下,既然是redis的依赖,我就放在local下面redis里面把
解压 tar -xzvf ruby-2.5.1.tar.gz
cd ruby-2.5.1
之后配置并编译源代码执行命令
./configure
make
sudo make install
上述命令完成后
安装RVM管理ruby
如下gpg --keyserver hkp://.......................................的命令
然后执行curl -sSL https://get.rvm.io | bash -sstable,执行后如下:
开启一个新终端或者重启虚拟机查看rvm -v是否安装成功(可以免去source 命令去载入rvm环境的命令,因为会自动载入)
下面是重新打开终端:
如下是重启后:
同时发现ruby已经变成2.5.1版本了,没按装rvm之前我运行查看的时候是1.8.7版本的ruby。
接下来个进行gem install redis时有如下问题(可以参考参考解决1,参考参考解决2)代码也贴出来
- ERROR: Loading command: install (LoadError)
- cannot load such file -- zlib
- ERROR: While executing gem ... (NoMethodError)
- undefined method `invoke_with_build_args' for nil:NilClass
先解决错误一,解决办法分为两步:
一、安装zlib库,如果已经安装,跳过,直接进入第二步。本博主是下载的zlib解压安装的
因为本centos是32位的所以采用的是如上的zlib-devel rpm文件
- yum install zlib-devel
二、集成zlib库到ruby环境
cd /你对应的文件夹/ruby-2.4.2
cd ext/zlib
ruby extconf.rb
//在操作下一步之前需要修改Makefile文件中的zlib.o: $(top_srcdir)/include/ruby.h,将$(top_srcdir)修改为../..如下
//zlib.o: ../../include/ruby.h
//这一步如果不修改,make时会爆出另外一个错误
//make:*** No rule to make target `/include/ruby.h', needed by `zlib.o'. Stop
make && make install
之后如果直接运行gem install redis会报错如下:
- ERROR: While executing gem ... (Gem::Exception)
- Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources
提示缺少openssl库,这两个库可以通过yum安装,但是安装了需要集成到ruby中。
一、安装openssl库,如果已经安装可以跳过,直接进入第二步。
- yum install openssl-devel
不要只用yum install openssl来安装,否则会缺少pcre等相关库,执行ruby extconf.rb会提示找不到ssl.h文件。
- checking for t_open() in -lnsl... no
- checking for socket() in -lsocket... no
- checking for openssl/ssl.h... no
第二步、集成openssl库到ruby
cd /data/ruby-2.4.2
cd ext/openssl
ruby extconf.rb
//同样修改Makefile中的$(top_srcdir)为../..
make && make install
成功之后,再次运行gem install redis,本博主运行后的界面贴出来如下:
集群
首先开启所有节点服务,./start.sh,然后
注意选择yes
注意地方,一个是需要绑定ip 另一个绑定的端口一个也不能写错。否则集群的时候就给你报sorry,连接不上XX节点
测试:
至此Redis集群终于完成。
Redis集群环境之linux搭建单机版的更多相关文章
- Redis集群环境之linux搭建多机版---已完结,跟着一步一步来你就可以集群成功
上一篇踩着各种坑写了Redis集群环境之linux搭建单机版,这一篇准备就多机版集群进行搭建,主要目的一来是在上一篇的基础上进行精华提粹总结,二来是把单机版与多机版的区别进行记录. 首先软硬件环境: ...
- 带你自行搭建虚拟机和Redis集群环境,值得收藏!
前言: 我们看到分析 Redis 使用或原理的文章不少,但是完整搭建一套独立的 redis 集群环境的介绍,并不是很多或者说还不够详细. 那么,本文会手把手带着大家搭建一套 Redis 集群环境,Re ...
- redis集群环境的搭建和错误分析
redis集群环境的搭建和错误分析 redis集群时,出现的几个异常问题 09 redis集群的搭建 以及遇到的问题
- Redis集群环境搭建实践
0 Redis集群简介 Redis集群(Redis Cluster)是Redis提供的分布式数据库方案,通过分片(sharding)来进行数据共享,并提供复制和故障转移功能.相比于主从复制.哨兵模式, ...
- centos7 快速搭建redis集群环境
本文主要是记录一下快速搭建redis集群环境的方式. 环境简介:centos 7 + redis-3.2.4 本次用两个服务6个节点来搭建:192.168.116.120 和 192.168.1 ...
- Redis 集群环境的搭建
下载与解压 [root@localhost ~]# cd /usr/temp/ [root@localhost temp]# wget http://download.redis.io/release ...
- SpringBoot系列教程之Redis集群环境配置
之前介绍的几篇redis的博文都是基于单机的redis基础上进行演示说明的,然而在实际的生产环境中,使用redis集群的可能性应该是大于单机版的redis的,那么集群的redis如何操作呢?它的配置和 ...
- Redis集群的原理和搭建(转载)
转载来源:https://www.jianshu.com/p/c869feb5581d Redis集群的原理和搭建 前言 Redis 是我们目前大规模使用的缓存中间件,由于它强大高效而又便捷的功能,得 ...
- redis集群环境配置
为什么需要集群 redis是一个开源的 key->value 高速存储系统,但是由于redis单线程运行,在系统中,只能利用单核的性能 当redis的调用越来越频繁时,可能会出现redis过于繁 ...
随机推荐
- nginx_2_nginx进程模型
1.nginx进程模型概述 在上一节我们已经已经成功在linux服务器上安装了nginx,启动nginx后,查看进程:ps -ef | grep nginx 能看到启动nginx进程后,有一个mast ...
- java连接sql server 2008
请先确保已经设置好了sa,如果不是,可以参照下面链接修改http://jingyan.baidu.com/article/8cdccae9452b3c315513cd52.html 然后重启数据库,重 ...
- 今日份学习: Docker 和 Docker的使用
笔记 Docker 能做什么? 保证开发.测试.交付.部署的环境完全一致 保证资源的隔离 启动临时的.用完即弃的环境,例如测试 迅速(秒级)超大规模部署和扩容 Docker 基本概念 镜像 image ...
- Spring注解@ConfigurationPropertie
@ConfigurationPropertie作用 参考的博客 springboot中@ConfigurationProperties注解的工作原理 @ConfigurationProperties是 ...
- Linux 创建网卡子接口
创建网卡子接口,添加IP别名 ifconfig eth0:0 2.2.2.2/24 或 ip addr add 2.2.2.2/24 dev eth0 label eth0:0 清除网卡子接口,删除 ...
- java中将图片上传到配置好的ftp服务器上
测试用例: @Test public void testFtp() throws Exception { //1.连接ftp服务器 FTPClient ftpClient = new FTPClien ...
- Day1-D-CF-1144C
简述:给你一个数组,判断是否能拆分成2个数组,一个递增一个递减,若不行输出No,可以就Yes并分别输出 思路:统计每个数出现的次数,若有大于2的肯定无法组成严格单调,这样就只需要将出现两次的组成递,剩 ...
- Django 数据库访问性能优化
使用标准的数据库优化技术: 在进行Django数据库访问性能优化之前,首先应该使用标准的数据库技术对其进行优化,比如给字段加索引,通过使用 django.db.models.Field.db_inde ...
- 给服务器做pve系统(可以通过web管理物理机集群资源与虚拟机)
做此系统前,可以先进入bios,设置一下ipmi的网络地址.可以远程管理服务器 输入服务器的ipmi里面配置的ip 默认账号与密码admin 点击launch 会自动下载认证文件 下载好java软件环 ...
- 【QSBOJ】字符串编辑
题目链接:https://bbs.csdn.net/topics/390289884?page=1 AC代码: #include<bits/stdc++.h> using namespac ...