ORA-16014 ORA-00312
打开alert日志发现如下错误信息
Errors in file /oracle/app/oracle/admin/hncdfhq/bdump/hncdfhq_arc0_45285882.trc:
ORA-19504: failed to create file "/oradata2/arch/1_58634_826681854.dbf"
ORA-27044: unable to write the header block of file
IBM AIX RISC System/6000 Error: 28: No space left on device
Additional information: 4
打开对应的 /oracle/app/oracle/admin/hncdfhq/bdump/hncdfhq_arc0_45285882.trc文件
$ cat /oracle/app/oracle/admin/hncdfhq/bdump/hncdfhq_arc0_45285882.trc
/oracle/app/oracle/admin/hncdfhq/bdump/hncdfhq_arc0_45285882.trc
Oracle Database 10g Enterprise Edition Release 10.2.0.5.0 - 64bit Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options
ORACLE_HOME = /oracle/app/oracle/product/10.2.0/db_1
System name: AIX
Node name: hncdfdb1
Release: 1
Version: 6
Machine: 00F8B9D44C00
Instance name: hncdfhq
Redo thread mounted by this instance: 1
Oracle process number: 23
Unix process pid: 45285882, image: oracle@hncdfdb1 (ARC0)
*** 2014-02-28 03:15:19.780
*** SERVICE NAME:(SYS$BACKGROUND) 2014-02-28 03:15:19.770
*** SESSION ID:(5484.1) 2014-02-28 03:15:19.770
Control file resized from 348 to 366 blocks
kccrsd_append: rectype = 11, lbn = 174, recs = 441
*** 2014-03-06 18:01:31.362
Control file resized from 466 to 552 blocks
kccrsd_append: rectype = 11, lbn = 233, recs = 2110
*** 2014-07-01 11:42:54.302
*** 2014-07-01 11:42:54.302 22384 kcrr.c
ORA-16014: log 1 sequence# 57712 not archived, no available destinations
ORA-00312: online log 1 thread 1: '/oradata2/hncdfhq/redo11.log'
ORA-00312: online log 1 thread 1: '/oradata2/hncdfhq/redo12.log'
*** 2014-07-02 14:52:50.351
Failed to create file '/oradata2/arch/1_58634_826681854.dbf' (file not accessible?)
ORA-19504: failed to create file "/oradata2/arch/1_58634_826681854.dbf"
ORA-27044: unable to write the header block of file
IBM AIX RISC System/6000 Error: 28: No space left on device
Additional information: 4
*** 2014-07-02 14:52:50.358 64896 kcrr.c
ARC0: Error 19504 Creating archive log file to '/oradata2/arch/1_58634_826681854.dbf'
*** 2014-07-02 14:52:50.358 63005 kcrr.c
kcrrfail: dest:1 err:19504 force:0 blast:1
*** 2014-07-02 14:52:50.364 22384 kcrr.c
ORA-16038: log 2 sequence# 58634 cannot be archived
ORA-19504: failed to create file ""
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo21.log'
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo22.log'
*** 2014-07-02 14:58:17.299
*** 2014-07-02 14:58:17.299 64896 kcrr.c
ARC0: Encountered disk I/O error 19502
Exception 19502 encountered when closing file
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 18433 (blocksize=512)
ORA-27063: number of bytes read/written is incorrect
IBM AIX RISC System/6000 Error: 28: No space left on device
Additional information: -1
Additional information: 1048576
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 1 (blocksize=512)
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 18433 (blocksize=512)
ORA-27063: number of bytes read/written is incorrect
IBM AIX RISC System/6000 Error: 28: No space left on device
Additional information: -1
Additional information: 1048576
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 1 (blocksize=512)
*** 2014-07-02 14:58:17.300 64896 kcrr.c
ARC0: I/O error 19502 archiving log 2 to '/oradata2/arch/1_58634_826681854.dbf'
*** 2014-07-02 14:58:17.300 63005 kcrr.c
kcrrfail: dest:1 err:19502 force:0 blast:1
*** 2014-07-02 14:58:17.302 22384 kcrr.c
ORA-16038: log 2 sequence# 58634 cannot be archived
ORA-19502: write error on file "", blockno (blocksize=)
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo21.log'
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo22.log'
*** 2014-07-02 15:04:17.301
*** 2014-07-02 15:04:17.301 64896 kcrr.c
ARC0: Encountered disk I/O error 19502
Exception 19502 encountered when closing file
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 18433 (blocksize=512)
ORA-27063: number of bytes read/written is incorrect
IBM AIX RISC System/6000 Error: 28: No space left on device
Additional information: -1
Additional information: 1048576
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 1 (blocksize=512)
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 18433 (blocksize=512)
ORA-27063: number of bytes read/written is incorrect
IBM AIX RISC System/6000 Error: 28: No space left on device
Additional information: -1
Additional information: 1048576
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 1 (blocksize=512)
*** 2014-07-02 15:04:17.303 64896 kcrr.c
ARC0: I/O error 19502 archiving log 2 to '/oradata2/arch/1_58634_826681854.dbf'
*** 2014-07-02 15:04:17.303 63005 kcrr.c
kcrrfail: dest:1 err:19502 force:0 blast:1
*** 2014-07-02 15:04:17.304 22384 kcrr.c
ORA-16038: log 2 sequence# 58634 cannot be archived
ORA-19502: write error on file "", blockno (blocksize=)
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo21.log'
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo22.log'
*** 2014-07-02 15:05:15.957
*** 2014-07-02 15:05:15.957 22384 kcrr.c
ORA-16014: log 2 sequence# 58634 not archived, no available destinations
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo21.log'
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo22.log'
*** 2014-07-02 15:10:15.964
*** 2014-07-02 15:10:15.964 64896 kcrr.c
ARC0: Encountered disk I/O error 19502
Exception 19502 encountered when closing file
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 18433 (blocksize=512)
ORA-27063: number of bytes read/written is incorrect
IBM AIX RISC System/6000 Error: 28: No space left on device
Additional information: -1
Additional information: 1048576
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 1 (blocksize=512)
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 18433 (blocksize=512)
ORA-27063: number of bytes read/written is incorrect
IBM AIX RISC System/6000 Error: 28: No space left on device
Additional information: -1
Additional information: 1048576
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 1 (blocksize=512)
*** 2014-07-02 15:10:15.965 64896 kcrr.c
ARC0: I/O error 19502 archiving log 2 to '/oradata2/arch/1_58634_826681854.dbf'
*** 2014-07-02 15:10:15.965 63005 kcrr.c
kcrrfail: dest:1 err:19502 force:0 blast:1
*** 2014-07-02 15:10:15.966 22384 kcrr.c
ORA-16038: log 2 sequence# 58634 cannot be archived
ORA-19502: write error on file "", blockno (blocksize=)
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo21.log'
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo22.log'
*** 2014-07-02 15:15:17.308
*** 2014-07-02 15:15:17.308 64896 kcrr.c
ARC0: Encountered disk I/O error 19502
Exception 19502 encountered when closing file
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 18433 (blocksize=512)
ORA-27063: number of bytes read/written is incorrect
IBM AIX RISC System/6000 Error: 28: No space left on device
Additional information: -1
Additional information: 1048576
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 1 (blocksize=512)
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 18433 (blocksize=512)
ORA-27063: number of bytes read/written is incorrect
IBM AIX RISC System/6000 Error: 28: No space left on device
Additional information: -1
Additional information: 1048576
ORA-19502: write error on file "/oradata2/arch/1_58634_826681854.dbf", blockno 1 (blocksize=512)
*** 2014-07-02 15:15:17.309 64896 kcrr.c
ARC0: I/O error 19502 archiving log 2 to '/oradata2/arch/1_58634_826681854.dbf'
*** 2014-07-02 15:15:17.309 63005 kcrr.c
kcrrfail: dest:1 err:19502 force:0 blast:1
*** 2014-07-02 15:15:17.310 22384 kcrr.c
ORA-16038: log 2 sequence# 58634 cannot be archived
ORA-19502: write error on file "", blockno (blocksize=)
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo21.log'
ORA-00312: online log 2 thread 1: '/oradata2/hncdfhq/redo22.log'
*** 2014-07-02 15:24:43.708
*** 2014-07-02 15:24:43.708 22431 kcrr.c
看了一下空间,归档所在的目录已经满了。清理一下空间,然后手工切归档,问题解决
ORA-16014 ORA-00312的更多相关文章
- listener.ora/sqlnet.ora/tnsnames.ora配置文件详解
oracle网络配置 三个配置文件 listener.ora.sqlnet.ora.tnsnames.ora ,都是放在$ORACLE_HOME/network/admin目录下. 英文说明: The ...
- oracle的listener.ora sqlnet.ora tnsnames.ora三个文件的关联性
学习:http://www.cnblogs.com/william-lee/archive/2010/10/20/1856261.html 之前因为安装的是windows server 2008 r2 ...
- ORACLE RAC 下非缺省端口监听配置(listener.ora tnsnames.ora)
不论是单实例还是RAC,对于非缺省端口下(1521)的监听器,pmon进程不会将service/instance注册到监听器,即不会实现动态注册.与单实例相同,RAC非缺省端口的监听器也是通过设置参数 ...
- oracle的sqlnet.ora,tnsnames.ora,listener.ora三个配置文件
总结: 1 .三个配置文件都是放在$ORACLE_HOME\network\admin目录下. 2 .sqlnet.ora确定解析方式 3 .listener.ora上设SID_NAME,通常用于JD ...
- oracle的sqlnet.ora , tnsnames.ora , Listener.ora 文件的作用(转)
oracle网络配置三个配置文件 listener.ora.sqlnet.ora.tnsnames.ora ,都是放在$ORACLE_HOME/network/admin目录下.1. sqlnet.o ...
- oracle错误(ORA:12154 ORA:01034 和 ORA:27101 ORA-18008 ORA-01081)
按照正常操作流程,启动项目,发现项目报错,原因是连接不上oracle数据库, PLSQL连接时报错,错误码 ORA:12154 无法解析指定的连接标识符 第一次,遇到这个错误,在网上找了资料都是需要 ...
- ORACLE RAC 监听配置 (listener.ora tnsnames.ora)
Oracle RAC 监听器的配置与单实例稍有不同,但原理和实现方法基本上是相同的.在Oracle中 tns进程用于为指定网络地址上的一个或多个Oracle 实例提供服务注册,并响应来自客户端对该服务 ...
- Oracle的tnsnames.ora配置(PLSQL Developer)
首先打开tnsnames.ora的存放目录,一般为D:\app\Administrator\product\11.2.0\client_1\network\admin,就看安装具体位置了. 步骤阅读 ...
- tnsnames.ora配置注意(连接新的数据库)
文件地址D:\app\think\product\11.2.0\instantclient_11_2\network\admin\tnsnames.ora# tnsnames.ora Network ...
- tnsnames.ora 监听配置文件详解
今天是重要的一天.将XML数据导入ORACLE遇到很多问题,学了好多,其中很长时间花在网络配置上,刚开始学,具体原因不知道,先把搜集到的好文章存下来,以后慢慢研究. 监听配置文件 ...
随机推荐
- 通过视频展示如何通过Samba配置PDC
通过视频展示如何通过Samba配置PDC(Linux企业应用案例精解补充视频内容) 本文通过视频,真实地再现了在Linux平台下如何通过配置smb.conf文件而实现Samba Server模拟win ...
- 局域网ARP病毒的清理
局域网ARP病毒的清理 作者:IT动力源 来源:IT动力源收集整理 现在局域网中感染ARP 病毒的情况比较多,清理和防范都比较困难,给不少的网络管理员造成了很多的困扰.下面就是个人在处理这个 ...
- Inter-process Communication (IPC)
For Developers > Design Documents > Inter-process Communication (IPC) 目录 1 Overview 1.1 I ...
- 实现人脸识别性别之路---open CV将图片显示出来
import cv2filename='E:\\tensorflow\\bu.jpg'#图片的地址 # face_cascade=cv2.CascadeClassifier('C:\\anconda3 ...
- Linux下QQ的使用并手动设置QQ文件保存路径
一.背景&&目标 马化腾迟迟不肯做linux版本的QQ和微信,实在抠脚. 没有办法,要在linux上使用QQ,目前我找到最好的办法就是使用wine,然而wine这个杀千刀的又是个坑货, ...
- 【推荐】适合本科生的网络公开课(MOOC为主),不断更新……
题记:身在海大(湛江),是幸运还是不幸,每一个人有自己的定义.人生不能再来一次,唯有把握当下.提高自己,才可能在不能拼爹的年代靠自身实力前行.或许,我们做不了富二代.但我们每一个人.都有机会成为富二代 ...
- codeforce 571 B Minimization
题意:给出一个序列,经过合适的排序后.使得最小. 做法:将a升序排序后,dp[i][j]:选择i个数量为n/k的集合,选择j个数量为n/k+1的集合的最小值. 举个样例, a={1,2,3,4,5,6 ...
- adb logcat 使用
之前打印log的时候,使用的是别人配置好的快捷键,结果现在快捷键没有配置,具体的log命令就不会了.今天上网查了一下,记录下来 打印的log是 android.util.Log.e("zha ...
- vim-缓存区中打开另外一个文件的方法
现在有这么一种情况: 我现在在ubuntu用户根目录下-- 我根目录下有一个文件夹blogs,这个文件夹下面有两个文件:text1,text2. 我现在从-目录下进行如下操作 ...
- 在kafka/config/目录下面有3个配置文件参数说明(producer.properties。consumer.properties。server.properties)
(1).producer.properties:生产端的配置文件 #指定kafka节点列表,用于获取metadata,不必全部指定 #需要kafka的服务器地址,来获取每一个topic的分片数等元数据 ...