云服务器 ECS Linux 系统下使用 dig 命令查询域名解析
云服务器 ECS Linux 系统可以使用通常自带的 dig 命令来查询域名解析情况。本文对此进行简要说明。
查询域名 A 记录
命令格式:
dig <域名>
比如,查询域名 www.aliyun.com 的解析情况:
$ dig www.aliyun.com
; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.37.rc1.el6_7.7 <<>> www.aliyun.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15919
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 2, ADDITIONAL: 4
;; QUESTION SECTION:
;www.aliyun.com. IN A
;; ANSWER SECTION:
www.aliyun.com. 600 IN CNAME www-adns.aliyun.com.
www-adns.aliyun.com. 300 IN CNAME www-adns.aliyun.com.gds.alibabadns.com.
www-adns.aliyun.com.gds.alibabadns.com. 247 IN A 140.205.62.8
;; AUTHORITY SECTION:
gds.alibabadns.com. 82 IN NS gdsns2.alibabadns.com.
gds.alibabadns.com. 82 IN NS gdsns1.alibabadns.com.
;; ADDITIONAL SECTION:
gdsns1.alibabadns.com. 877 IN A 140.205.122.66
gdsns1.alibabadns.com. 877 IN A 198.11.138.254
gdsns2.alibabadns.com. 877 IN A 140.205.67.254
gdsns2.alibabadns.com. 877 IN A 140.205.122.88
;; Query time: 49 msec
;; SERVER: 10.242.197.247#53(10.242.197.247)
;; WHEN: Thu Jun 9 18:43:55 2016
;; MSG SIZE rcvd: 226
查询域名解析在指定 DNS 服务器解析是否生效
命令格式:
dig <域名> @<DNS 服务器地址>
比如,查询 www.aliyun.com 在 223.5.5.5 DNS 服务器是否解析生效:
$ dig www.aliyun.com @223.5.5.5
; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.37.rc1.el6_7.7 <<>> www.aliyun.com @223.5.5.5
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29651
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0
;; QUESTION SECTION:
;www.aliyun.com. IN A
;; ANSWER SECTION:
www.aliyun.com. 95 IN CNAME www-adns.aliyun.com. # 查询到的解析记录
www-adns.aliyun.com. 95 IN CNAME www-adns.aliyun.com.gds.alibabadns.com. # 查询到的解析记录
www-adns.aliyun.com.gds.alibabadns.com. 95 IN A 140.205.63.8
;; Query time: 0 msec
;; SERVER: 223.5.5.5#53(223.5.5.5)
;; WHEN: Thu Jun 9 18:44:42 2016
;; MSG SIZE rcvd: 120
查询域名的 CNAME 记录
命令格式:
dig CNAME <域名>
比如,查询域名 www.aliyun.com 的 CNAME 记录:
# dig CNAME www.aliyun.com
; <<>> DiG 9.9.4-RedHat-9.9.4-14.el7 <<>> CNAME www.aliyun.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4690
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 7
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;www.aliyun.com. IN CNAME
;; ANSWER SECTION:
www.aliyun.com. 120 IN CNAME www-intl-adns.aliyun.com. # 查询到的 CNAME 信息
;; AUTHORITY SECTION:
aliyun.com. 172800 IN NS ns5.aliyun.com.
aliyun.com. 172800 IN NS ns4.aliyun.com.
aliyun.com. 172800 IN NS ns3.aliyun.com.
;; ADDITIONAL SECTION:
ns3.aliyun.com. 432000 IN A 42.120.250.251
ns4.aliyun.com. 432000 IN A 110.75.20.27
ns4.aliyun.com. 432000 IN A 140.205.71.248
ns4.aliyun.com. 432000 IN A 42.156.241.248
ns5.aliyun.com. 432000 IN A 140.205.2.187
ns5.aliyun.com. 432000 IN A 198.11.138.248
;; Query time: 10 msec
;; SERVER: 10.202.72.118#53(10.202.72.118)
;; WHEN: Fri Jul 08 11:46:33 CST 2016
;; MSG SIZE rcvd: 221
查询 IP 反解记录
命令格式:
dig -x <目标 IP 地址>
$ dig -x 140.205.62.8
; <<>> DiG 9.9.4-RedHat-9.9.4-14.el7 <<>> -x 140.205.62.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 38256
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;8.62.205.140.in-addr.arpa. IN PTR
;; AUTHORITY SECTION:
140.in-addr.arpa. 945 IN SOA z.arin.net. dns-ops.arin.net. 2016031910 1800 900 691200 10800
;; Query time: 3 msec
;; SERVER: 10.202.72.118#53(10.202.72.118)
;; WHEN: Fri Jul 08 11:51:32 CST 2016
;; MSG SIZE rcvd: 108
查询域名的 mx 解析记录
命令格式:
dig mx <目标域名>
?比如,查询域名 aliyun.com 的 mx 解析记录:
$ dig mx aliyun.com
; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.37.rc1.el6_7.7 <<>> mx aliyun.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33606
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 7
;; QUESTION SECTION:
;aliyun.com. IN MX
;; ANSWER SECTION:
aliyun.com. 3600 IN MX 10 mx2.mail.aliyun.com.
;; AUTHORITY SECTION:
aliyun.com. 172800 IN NS ns4.aliyun.com.
aliyun.com. 172800 IN NS ns3.aliyun.com.
aliyun.com. 172800 IN NS ns5.aliyun.com.
;; ADDITIONAL SECTION:
mx2.mail.aliyun.com. 600 IN A 110.75.48.150
ns3.aliyun.com. 432000 IN A 42.120.250.251
ns4.aliyun.com. 432000 IN A 110.75.20.27
ns4.aliyun.com. 432000 IN A 140.205.71.248
ns4.aliyun.com. 432000 IN A 42.156.241.248
ns5.aliyun.com. 432000 IN A 198.11.138.248
ns5.aliyun.com. 432000 IN A 140.205.2.187
;; Query time: 1 msec
;; SERVER: 10.242.197.247#53(10.242.197.247)
;; WHEN: Thu Jun 9 18:59:44 2016
;; MSG SIZE rcvd: 219
云服务器 ECS Linux 系统下使用 dig 命令查询域名解析的更多相关文章
- 云服务器 ECS Linux 系统添加“回收站”
删除是危险系数很高的操作,一旦误删可能会造成难以估计的损失.在云服务器 ECS Linux 系统中这种危险尤为明显.比如,一条简单的语句:rm –rf /* 就会把整个系统全部删除,而 Linux 并 ...
- 云服务器 ECS Linux 系统 CPU 占用率较高问题排查思路
https://help.aliyun.com/knowledge_detail/41225.html?spm=5176.7841174.2.2.ifP9Sc 注意:本文相关配置及说明已在 CentO ...
- 云服务器 ECS Linux 系统中常见的日志文件介绍
云服务器 ECS Linux 系统中,日志文件是非常重要的文件,它们记录了很多系统中重要的事.Linux 系统中常见日志文件概述如下: /var/log/cron可以在 cron 文件中检查 cron ...
- 云服务器 ECS Linux 系统安装图形化桌面 (centos7 ubuntu14)
基于性能及通用性等因素,默认情况下,阿里云官方公共 Linux 系统镜像不会安装图形化桌面组件.本文简述了常用操作系统图形化桌面安装说明,您可以根据需求进行配置系统. 注意:图形化桌面可能会 显著降低 ...
- 阿里云服务器 ECS Ubuntu系统下PHP,MYSQL,APACHE2的安装配置
1.系统更新,必须更新,否则有些软件会找不到. apt-get update apt-get upgrade 2.安装mysql sudo apt-get install mysql-server 3 ...
- 云服务器 ECS Linux 系统 MySQL 备份的导入导出
MySQL 备份的导出 注意: 如果您使用的是帮助中心的一键环境配置,那么 MySQL 的安装目录是 /alidata/server/mysql. 如果您将 MySQL 安装到其他目录,您需要输入您 ...
- 云服务器 ECS Linux 服务器修改时区的两种方式
在云服务器 ECS Linux 系统中,以 Centos6.5 为例,可以通过如下两种方式,修改系统时区: 可以使用命令 tzselect,修改时区.操作示例: [root@localhost ~]# ...
- 在云服务器 ECS Linux CentOS 7 下重启服务不再通过 service 操作,而是通过 systemctl 操作
在云服务器 ECS Linux CentOS 7 下重启服务不再通过 service 操作,而是通过 systemctl 操作. 操作说明如下: 1. 查看 sshd 服务是否启动: 看到上述信息就 ...
- 云服务器 ECS Linux 误删除文件恢复方法介绍
云服务器 ECS Linux 下,rm -rf 意味着一旦删除的文件是无法挽回的.但如果在没有文件覆盖操作的前提下,可以先尝试相关方式进行文件恢复. 本文对此进行简要说明. https://help ...
随机推荐
- HDU 3584 Cube 【 三维树状数组 】
题意:还是那篇论文里面讲到的,三维树状数组http://wenku.baidu.com/view/1e51750abb68a98271fefaa8画个立方体出来对照一下好想一点 #include< ...
- 初识Git(一)
以前经常听到Git,作为一个菜鸟级自学选手从没有真正去了解Git,借刘铁猛老师在油管上的<对答如刘>初步认识了git,作以下记录. 1.初始化一个git管理的文件夹 首先我在我的电脑C盘P ...
- nginx 子进程 woker process 启动失败的问题
问题: 重启nginx服务,worker process 子进程启动失败,启动的都是master进程: 负载急速升高(平常都是4-5),占用CPU资源多的前十进程都是nginx : nginx 错误日 ...
- Unable to load annotation processor factory
很多人在项目开发中都会遇到项目名称左上角有个红叉,有些是Jar问题,有些是代码问题,有些是编译问题,对于我这种强迫症的是受不了这种情况发生的,如果不影响项目启动还好,废话少说,今天工作就出现了一个问题 ...
- Hadoop2.x 关于日志文件位置
查看日志是发现Hadoop问题和解决Hadoop问题的第一步. 开始我不知道该去哪找日志,后来我发现在我启动节点的时候,有打印信息以及明确告诉了日志写在哪. [root@master hadoop]# ...
- Node_进阶_5
Node进阶第五天 为什么mysql不用开mongod –dbpath xx… 答:因为mysql会在”服务”中运行,也就是开机时自动启动并且长久驻扎在内存中了. mongodb其实也能通过设置来设成 ...
- BZOJ 2141 排队(CDQ分治)
我们把每一次交换看做两个插入两个删除.然后就是一个三维偏序.时间一维,下标一维,权值一维. #include<iostream> #include<cstring> #incl ...
- luogu P1516 青蛙的约会(线性同余方程扩展欧几里德)
题意 题解 做了这道题,发现扩欧快忘了. 根据题意可以很快地列出线性同余方程. 设跳了k次 x+mkΞy+nk(mod l) (m-n)kΞ-(x-y)(mod l) 然后化一下 (m-n)k+(x- ...
- ubuntu 装tensorflow出现 conda install ERROR missing write permission错误
通过搜索tensorflow然后运行,例如:$ conda install --channel https://conda.anaconda.org/jjh_cio_testing tensorflo ...
- Object-C学习比较费劲的3点原因
作为一名有8年编程经验的资历不浅的程序员,学习Object-C和iOS,感觉效率有点低,至少和学习Android比起来,慢的不是一点点. 主要有以下3个原因: 1.Object-C,和C系列的语言(C ...