Linux 桥接网络不自动分配IP的问题
之前遇到过好多次,知道什么原因就是忘了命令怎么敲,还要去搜索,写一遍加强下记忆,并总结下。
情况一 :网卡冲突问题
1 , 网卡问题

有安装过oracle VM VirtualBox 的,会和VMwareWorstation 网卡冲突,导致网卡流量导流到Box的网卡上,保留一个(我是将盒子卸载了,并且卸载了相关的网卡)
2 ,Vm网络编辑器

在打开的网络编辑器页面看到虚拟机使用的桥接模式网卡不在列表中,右下角更改设置,


更改设置之后,VMware 重新加载设置,就能看到对应的桥接模式网卡,默认为自动模式

点击桥接模式,然后在下面可以看到它的设置选项,然后点击自动,这个时候可以看到前两天安装的VirtualBox桥接网卡(没有卸载盒子网卡的情况下),以及主机自己的实际物理网卡。
这是自动模式将所有虚拟机的流量都导入到Virtualbox的桥接网卡上面去了。这个时候我们点击实际的物理网卡名称。
然后它的模式就变成了实际的网卡名称,如下面图中所示。点击确定按钮保存配置。

然后我们回到虚拟机上,重新启动network这个服务,命令是:
systemctl restart network
重启完成后,可以看到获得了正确的IP地址,然后ping一下百度的网卡,可以看到有回复,到这里,网络就恢复正常了,可以判断是Virtualbox的桥接网卡的问题。
情况二: 配置文件问题
由于在安装Linux 时没有配置网络,或者机器中存在多个网络接口的情况下,就会导致网络接口配置文件没有自动配置。
文件 /etc/sysconfig/network-scripts/ifcfg-eth0在/etc/sysconfig/network-script在这个目录下面,存放的是网络接口(网卡)的脚本文件(控制文件),ifcfg-eth0是默认的第一个网络接口,如果机器中有多网络接口,
那么名字就将依此类推ifcfg-eth1,ifcfg-eth2,ifcfg-eth3......(这里面的文件是相当重要的,涉及到网络能否正常工作)。


vim ifcfg-ens33

没有启用, 修改为yes ,保存退出
service network restart 重启网络生效
设定项目项目如下:
*DEVICE : 接口名(设备,网卡)
*USERCTL [yes|no]: (非root用户是否可以控制该设备)
*BOOTPROTO : IP的配置方法[none|static|bootp|dhcp](引导时不使用协议|静态分配IP|BOOTP协议|DHCP协议)
*HWADDR : MAC地址
*ONBOOT : 系统启动的时候网络接口是否有效(yes/no)
*TYPE : 网络类型(通常是Ethemet)
*NETMASK : 网络掩码
*IPADDR : IP地址
*IPV6INIT : PV6是否有效(yes/no)
*GATEWAY : 默认网关IP地址
*BROADCAST: 广播地址
*NETWORK : 网络地址
====可参照下面的例子====
*DEVICE=eth0
*BOOTPROTO=static
*BROADCAST=192.168.1.255
*HWADDR=00:0C:2x:6x:0x:xx
*IPADDR=192.168.1.23
*NETMASK=255.255.255.0
*NETWORK=192.168.1.0
*ONBOOT=yes
*TYPE=Ethernet
重启完成后,可以看到获得了正确的IP地址,然后ping一下百度的网卡,


OK,网络连接正常
习惯了用 ifconfig 网络命令 , 安装 ifconfig 命令
如果直接运行 ifconfig 命令,则提示错误 :-bash: ifconfig: command not found
此时,查看 /sbin 目录下,其实是没有 ifconfig 文件的。

那么 如何安装ifconfig 呢?我们首先想到的是 运行 yum install ifconfig 。执行效果如何呢?

哦豁,,,结果是:
No package ifconfig available.Error: Nothing to do
没有 ifconfig 安装包,是不是 我们就要放弃了呢? 其实,我们 还可以通过yum 命令的search选项 来对 包 (package)进行再次搜索。
search:可以搜寻某个软件名称或者是描述(description)的重要关键字。此指令可以查找显示出相关的软件有哪些。 所以,在放弃前,我们运行以下命令: yum search ifconfig

惊不惊喜? 意不意外,匹配到了
以上运行结果,我们只要分析最好一行就可以。Matched: ifconfig 这个 分割行 是用来显示 匹配结果的。 最后一行 中 冒号(:)前面的数据,
(net-tools.x86_64 ) 是匹配的软件包;冒号(:)后面的数据,(Basic networking tools ) 是对前面包的描述。
结合上面的信息,即 通过运行 yum search ifconfig 提示我们: 安装ifconfig 包 只需要安装 net-tools.x86_64 即可。 所以,我们执行 yum install net-tools.x86_64

安装后,ifconfig 命令可以正常执行。并且,查看/sbin 目录,此时 ifconfig 文件也出现了。


Linux 桥接网络不自动分配IP的问题的更多相关文章
- Kali桥接模式DHCP自动获取IP失败(VMware)
Kali桥接模式DHCP自动获取IP失败笔者用的是VMware运行Kali Linux,突然发现桥接模式无法上网,只能使用NAT模式.身为有一点点强迫症的人来说,这就很不爽了.于是马上切换为桥接模式, ...
- 嵌入式linux的网络编程(1)--TCP/IP协议概述
嵌入式linux的网络编程(1)--TCP/IP协议概述 1.OSI参考模型及TCP/IP参考模型 通信协议用于协调不同网络设备之间的信息交换,它们建立了设备之间互相识别的信息机制.大家一定都听说过著 ...
- Linux根据MAC地址自动设置IP
Linux根据MAC地址自动设置IP #!/bin/sh #============config============ route_defa=60.12.70.65 addr_ip= link_ma ...
- EC2 开启 IPV6 访问 和 禁止重启后自动分配IP地址
EC2 开启 IPV6 访问 和 禁止重启后自动分配IP地址进入 VPC 控制台,对当前 VPC 添加 IPV6 CIDR 块对该 VPC 的路由表进行修改,添加其它路由,第一个空填::/0,第二个空 ...
- 自动分配ip的方法- 【Linux】
1. 查看本机无线网络使用的网卡 2. 设置vbox的网络连接为桥接,并选择本机无线网络对应的网卡 3. 进入系统,输入ifconfig命令,记录下系统的HWaddr 4. 修改系统ip配置文 ...
- DHCP服务自动分配IP地址原理
转载自:http://blog.csdn.net/lycb_gz/article/details/8499559 DHCP在提供服务时,DHCP客户端是以UDP 68号端口进行数据传输的,而DHCP服 ...
- Linux Shell脚本之自动修改IP
作为一名Linux SA,日常运维中很多地方都会用到脚本,而服务器的ip一般采用静态ip或者MAC绑定,当然后者比较操作起来相对繁琐,而前者我们可以设置主机名.ip信息.网关等配置.修改成特定的主机名 ...
- VirtualBox NAT Host-only模式下,自动分配IP上网。
修改宿主机上,virtualbox自建虚拟网卡Host-Only 2. 因为我使用了两个适配器,所以这两个适配器的名字分别是ifcfg-eth0, ifcfg-eth1. ifcfg-eh0一般默认就 ...
- 虚拟机Linux桥接模式下设置静态IP
之前一直使用NAT模式,测试时android端远程访问虚拟机的mysql时发现无法连接,但是访问同学拷过来的虚拟机Linux的mysql却成功了,想了下原因是他设置的桥接模式.关于两种模式的区别,网上 ...
随机推荐
- Android分包MultiDex源码分析
转载请标明出处:http://blog.csdn.net/shensky711/article/details/52845661 本文出自: [HansChen的博客] 概述 Android开发者应该 ...
- Linux job control
Linux 系统中有一个 job control 的概念,本文简单介绍什么是 job,以及常见的 job control 命令.本文中演示部分使用的环境为 ubuntu 18.04. 进程组(job) ...
- 【前端】之HTML5基础知识
HTML5 文件格式 <!DOCTYPE html> <html lang="en"> <head> <meta charset=&quo ...
- Beautifulsoup模块基础详解
Beautifulsoup模块 官方中文文档 Beautifulsoup官方中文文档 介绍 Beautiful Soup 是一个可以从HTML或XML文件中提取数据的Python库.它能够通过你喜欢的 ...
- 安装PHP5和PHP7
5月25日任务 课程内容: 11.10/11.11/11.12 安装PHP511.13 安装PHP7php中mysql,mysqli,mysqlnd,pdo到底是什么http://blog.csdn. ...
- 升级Xcode7&iOS9后,出现NSURLSession/NSURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -980X)
在info.plist里面添加如下内容即可: <key>NSAppTransportSecurity</key> <dict> <key>NSAllow ...
- wdCP v3.3.8apache阿里云ssl证书实现智慧软文http转换https的详细操作教程
先展示一下效果:智慧软文发布系统(https://www.zhihuiruanwen.com) 之前用的是传统的http,发现360浏览器,火狐浏览器,谷歌浏览器均提示不安全的链接,最主要的是第一次打 ...
- Ubuntu18.04下搭建LNMP教程-超详细图文(Nginx+MySQL+PHP含各种解决报错问题)
笔者最近在VM15.0上安装了Ubuntu18.,先来安装一个LNMP(Nginx+MySQL+PHP)网站服务器架构,为后续的实验做准备~ LNMP是指一组通常一起使用来运行动态网站或者服务 ...
- java多线程与线程池
1. 场景描述 以前多线程也常用,这次因需再页面上用到多线程,如下图,总结下,有需要的朋友可以参考下. 2. 解决方案 2.1 线程池概念 线程池官方定义不说了,通俗说下:池子的概念,事先(预定义)创 ...
- 在modelarts上部署backend为TensorFlow的keras模型
最近老山在研究在modelarts上部署mask-rcnn,源代码提供的是keras模型.我们可以将keras转化成savedModel模型,在TensorFlow Serving上部署,可参考老山的 ...