转: http://www.cnblogs.com/shanyou/archive/2012/07/14/2591838.html

CentOS 6 使用 yum 安装MongoDB及服务器端配置

 

安装MongoDB的方法有很多种,可以源代码安装,在Centos也可以用yum源安装的方法。由于MongoDB更新得比较快,我比较喜欢用yum源安装的方法。64位Centos下的安装步骤如下:

1、准备工作

运行yum命令查看MongoDB的包信息 [root@localhost~]# yum info mongo-10gen

(提示没有相关匹配的信息,) 说明你的centos系统中的yum源不包含MongoDB的相关资源,所以要在使用yum命令安装MongoDB前需要增加yum源,也就是在 /etc/yum.repos.d/目录中增加 *.repo yum源配置文件

2、vi /etc/yum.repos.d/10gen.repo,输入下面的语句:

[10gen]

name=10gen Repository

baseurl=http://downloads-distro.mongodb.org/repo/redhat/os/x86_64

gpgcheck=0

做好yum源的配置后,如果配置正确执行下面的命令便可以查询MongoDB相关的信息:

查看mongoDB的服务器包的信息

[root@localhost geffzhang]# yum info mongo-10gen-server
 * base: centos.ustc.edu.cn
 * extras: centos.ustc.edu.cn
 * updates: centos.ustc.edu.cn
Installed Packages
Name        : mongo-10gen-server
Arch        : x86_64
Version     : 2.0.6
Release     : mongodb_1
Size        : 13 M
Repo        : installed
From repo   : 10gen
Summary     : mongo server, sharding server, and support scripts
URL         : http://www.mongodb.org
License     : AGPL 3.0
Description : Mongo (from "huMONGOus") is a schema-free document-oriented
            : database.
            : 
            : This package provides the mongo server software, mongo sharding
            : server softwware, default configuration files, and init.d scripts.
查看客户端安装情况 
[root@localhost geffzhang]#

* base: centos.ustc.edu.cn
 * extras: centos.ustc.edu.cn
 * updates: centos.ustc.edu.cn
Installed Packages
Name        : mongo-10gen
Arch        : x86_64
Version     : 2.0.6
Release     : mongodb_1
Size        : 69 M
Repo        : installed
From repo   : 10gen
Summary     : mongo client shell and tools
URL         : http://www.mongodb.org
License     : AGPL 3.0
Description : Mongo (from "huMONGOus") is a schema-free document-oriented
            : database. It features dynamic profileable queries, full indexing,
            : replication and fail-over support, efficient storage of large
            : binary data objects, and auto-sharding.
            : 
            : This package provides the mongo shell, import/export tools, and
            : other client utilities.

3、安装MongoDB的服务器端和客户端工具  
[root@localhost geffzhang]#  yum install mongo-10gen-server

[root@localhost geffzhang]#  yum install mongo-10gen

4、启动Mongodb

service mongod start

以后有更新了,停掉mongodb,执行yum update mongo-10gen mongo-10gen-server 即可。

5、服务器配置: /etc/mongod.conf

  1. # mongo.conf
  2. #where to log
  3. logpath=/var/log/mongo/mongod.log
  4. logappend=true #以追加方式写入日志
  5. # fork and run in background
  6. fork = true
  7. #port = 27017 #端口
  8. dbpath=/var/lib/mongo #数据库文件保存位置
  9. directoryperdb=true
  10. # Enables periodic logging of CPU utilization and I/O wait
  11. #启用定期记录CPU利用率和 I/O 等待
  12. #cpu = true
  13. # Turn on/off security.  Off is currently the default
  14. # 是否以安全认证方式运行,默认是不认证的非安全方式
  15. #noauth = true
  16. #auth = true
  17. # Verbose logging output.
  18. # 详细记录输出
  19. #verbose = true
  20. # Inspect all client data for validity on receipt (useful for
  21. # developing drivers)用于开发驱动程序时的检查客户端接收数据的有效性
  22. #objcheck = true
  23. # Enable db quota management 启用数据库配额管理,默认每个db可以有8个文件,可以用quotaFiles参数设置
  24. #quota = true
  25. # 设置oplog记录等级
  26. # Set oplogging level where n is
  27. #   0=off (default)
  28. #   1=W
  29. #   2=R
  30. #   3=both
  31. #   7=W+some reads
  32. #oplog = 0
  33. # Diagnostic/debugging option 动态调试项
  34. #nocursors = true
  35. # Ignore query hints 忽略查询提示
  36. #nohints = true
  37. # 禁用http界面,默认为localhost:28017
  38. # Disable the HTTP interface (Defaults to localhost:27018).这个端口号写的是错的
  39. #nohttpinterface = true
  40. # 关闭服务器端脚本,这将极大的限制功能
  41. # Turns off server-side scripting.  This will result in greatly limited
  42. # functionality
  43. #noscripting = true
  44. # 关闭扫描表,任何查询将会是扫描失败
  45. # Turns off table scans.  Any query that would do a table scan fails.
  46. #notablescan = true
  47. # 关闭数据文件预分配
  48. # Disable data file preallocation.
  49. #noprealloc = true
  50. # 为新数据库指定.ns文件的大小,单位:MB
  51. # Specify .ns file size for new databases.
  52. # nssize = <size>
  53. # Accout token for Mongo monitoring server.
  54. #mms-token = <token>
  55. # mongo监控服务器的名称
  56. # Server name for Mongo monitoring server.
  57. #mms-name = <server-name>
  58. # mongo监控服务器的ping 间隔
  59. # Ping interval for Mongo monitoring server.
  60. #mms-interval = <seconds>
  61. # Replication Options 复制选项
  62. # in replicated mongo databases, specify here whether this is a slave or master 在复制中,指定当前是从属关系
  63. #slave = true
  64. #source = master.example.com
  65. # Slave only: specify a single database to replicate
  66. #only = master.example.com
  67. # or
  68. #master = true
  69. #source = slave.example.com

欢迎大家关注微信号opendotnet,微信公众号名称:dotNET跨平台。扫下面的二维码或者收藏下面的二维码关注吧(长按下面的二维码图片、并选择识别图中的二维码)

转: CentOS 6 使用 yum 安装MongoDB及服务器端配置的更多相关文章

  1. Hadoop 之Mong DB 之CentOS 6 使用 yum 安装MongoDB及服务器端配置

    安装MongoDB的方法有很多种,可以源代码安装,在Centos也可以用yum源安装的方法.由于MongoDB更新得比较快,我比较喜欢用yum源安装的方法.64位Centos下的安装步骤如下: 1.准 ...

  2. CentOS 6 使用 yum 安装MongoDB及服务器端配置

    安装MongoDB的方法有很多种,可以源代码安装,在Centos也可以用yum源安装的方法.由于MongoDB更新得比较快,我比较喜欢用yum源安装的方法.64位Centos下的安装步骤如下: 1.准 ...

  3. 在CentOS中使用 yum 安装MongoDB及服务器端配置

    转自 http://blog.csdn.net/zhangfeng19880710/article/details/20166853 一.准备工作: 运行yum命令查看MongoDB的包信息 [roo ...

  4. 最简单实用的MongoDB安装教程:在CentOS中使用 yum 安装MongoDB及服务器端配置详解

    一.准备工作: 运行yum命令查看MongoDB的包信息 [root@vm ~]# yum info mongo-10gen (提示没有相关匹配的信息,) 说明你的centos系统中的yum源不包含M ...

  5. Linux CentOS 6.5 yum安装MongoDB的操作

    安装MongoDB的方法有很多种,可以源代码安装,在CentOS也可以用yum源安装的方法.由于MongoDB更新得比较快,我比较喜欢用yum源安装的方法.64位CentOS下的安装步骤如下: 1.准 ...

  6. centos yum 安装 mongodb 以及php扩展

    centos yum 安装 mongodb 以及php扩展 投稿:hebedich 字体:[增加 减小] 类型:转载 MongoDB是一个基于分布式文件存储的数据库.由C++语言编写.旨在为WEB应用 ...

  7. YUM安装MONGODB发生Error in PREIN scriptlet in rpm package mongodb-enterprise-server-4.0.2-1.el6.x86_64错误

    YUM安装MONGODB发生Error in PREIN scriptlet in rpm package mongodb-enterprise-server-4.0.2-1.el6.x86_64错误 ...

  8. CentOS下通过yum安装svn及配置

    CentOS下通过yum安装svn及配置 1.环境centos5.5 2.安装svnyum -y install subversion 3.配置 建立版本库目录mkdir /www/svndata s ...

  9. CentOS 7 使用yum安装出现错误

    CentOS 7 使用yum安装软件出现错误: Loaded plugins: fastestmirror 此错误信息可能是因为DNS配置错误,可以通过更改配置文件来解决: 1. 使用vi打开DNS的 ...

随机推荐

  1. 初中级PHP面试基础汇总

    这是我整理的一套面试题,老铁们看看就当复习了哦 相关PHP面试题 搞定PHP面试 - 函数知识点整理 php 面试题目整理 PHP面试整理 PHP面试 概述 感觉现在发面试题有些冷门,就跟昨天德国那场 ...

  2. 【php】 自带的过滤机制

    <?php print_r(filter_list()); ?> 输出类似: Array ( [0] => int [1] => boolean [2] => float ...

  3. pytorch 加载数据集

    pytorch初学者,想加载自己的数据,了解了一下数据类型.维度等信息,方便以后加载其他数据. 1 torchvision.transforms实现数据预处理 transforms.Totensor( ...

  4. 删除mysql主从

    在创建数据库主从配置后,若想删除数据库的主从服务可根据以下步骤来删除数据库主从 1.停止slave服务器的主从同步   为了防止主从数据不同步,需要先停止slave上的同步服务, STOP SLAVE ...

  5. Lecture1 实验过程模型

    Part 1 基本概念 因变量:待检验理论重点关注的,受多个变量影响的变量.(实际考察的,结果) 自变量:影响因变量变化的变量. 因子:重点关注的自变量. 控制变量(control variables ...

  6. 项目-开发手机app

    一.  安装Hbuilder,和夜神安卓模拟器 注:夜神模拟器,如过windows中安装了hyper-v,需要卸载,不然会死机 二. Hbuilder简介 官网:http://www.dcloud.i ...

  7. 虚拟机里linux系统安装 CentOS 64-bit(6.4版本)——笔记

    使用的虚拟机是VMware WorkStation 9.0(9.0.0 build-812388) 1. 安装过程中 选择 桥接 此系统可以拥有独立ip.Nat模式跟主机ip一样 2. 安装过程中选择 ...

  8. poj2217 Secretary 后缀数组

    #include <iostream> #include <cstring> #include <string> #include <cstdio> u ...

  9. Leetcode 400.第n个数

    第n个数 在无限的整数序列 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, ...中找到第 n 个数字. 为整形范围内 ( n < 231). 示例 1: 输入: 3 输出 ...

  10. 九度oj 题目1026:又一版 A+B

    题目描述: 输入两个不超过整型定义的非负10进制整数A和B(<=231-1),输出A+B的m (1 < m <10)进制数. 输入: 输入格式:测试输入包含若干测试用例.每个测试用例 ...