9:48:49 [Apache] Apache Service detected with wrong path
9:48:49 [Apache] Change XAMPP Apache and Control Panel settings or
9:48:49 [Apache] Uninstall/disable the other service manually first
9:48:49 [Apache] Found Path: "D:\DownloadSoft\Apache\httpd-2.4.41-o111c-x64-vc15-r2\Apache24\bin\httpd.exe" -k runservice
9:48:49 [Apache] Expected Path: "d:\installsoft\xampp\apache\bin\httpd.exe" -k runservice
9:48:49 [Apache] Problem detected!
9:48:49 [Apache] Port 443 in use by ""D:\DownloadSoft\Apache\httpd-2.4.41-o111c-x64-vc15-r2\Apache24\bin\httpd.exe" -k runservice" with PID 464!
9:48:49 [Apache] Apache WILL NOT start without the configured ports free!
9:48:49 [Apache] You need to uninstall/disable/reconfigure the blocking application
9:48:49 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
9:48:49 [mysql] Problem detected!
9:48:49 [mysql] Port 3306 in use by ""C:\Program Files\MySQL\MySQL Server 5.7\bin\mysqld.exe" --defaults-file="C:\ProgramData\MySQL\MySQL Server 5.7\my.ini" MySQL57"!
9:48:49 [mysql] MySQL WILL NOT start without the configured ports free!
9:48:49 [mysql] You need to uninstall/disable/reconfigure the blocking application
9:48:49 [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
9:48:49 [Tomcat] Tomcat Service detected with wrong path
9:48:49 [Tomcat] Change XAMPP Tomcat and Control Panel settings or
9:48:49 [Tomcat] Uninstall/disable the other service manually first
9:48:49 [Tomcat] Found Path: "D:\InstallSoft\Apache Software Foundation\Tomcat 7.0\bin\Tomcat7.exe" //RS//Tomcat7
9:48:49 [Tomcat] Expected Path: d:\installsoft\xampp\tomcat\bin\tomcat7.exe //RS//Tomcat7
9:48:49 [main] Starting Check-Timer
9:48:49 [main] Control Panel Ready
9:49:23 [Apache] Problem detected!
9:49:23 [Apache] Port 443 in use by ""D:\DownloadSoft\Apache\httpd-2.4.41-o111c-x64-vc15-r2\Apache24\bin\httpd.exe" -k runservice" with PID 464!
9:49:23 [Apache] Apache WILL NOT start without the configured ports free!
9:49:23 [Apache] You need to uninstall/disable/reconfigure the blocking application
9:49:23 [Apache] or reconfigure Apache and the Control Panel to listen on a different port

9:48:49 [main] Starting Check-Timer
9:48:49 [main] Control Panel Ready
9:49:23 [Apache] Problem detected!
9:49:23 [Apache] Port 443 in use by ""D:\DownloadSoft\Apache\httpd-2.4.41-o111c-x64-vc15-r2\Apache24\bin\httpd.exe" -k runservice" with PID 464!
9:49:23 [Apache] Apache WILL NOT start without the configured ports free!
9:49:23 [Apache] You need to uninstall/disable/reconfigure the blocking application
9:49:23 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
9:49:23 [Apache] Attempting to start Apache service...
9:53:08 [Apache] Status change detected: running
9:53:34 [Apache] Attempting to stop Apache service...
9:53:38 [Apache] Status change detected: stopped

一开始以为是端口占用的问题,后来发现修改了端口也没有用。
解决方法:
1.首先,进入自己的注册表:win+R打开运行对话框;
2.然后,输入regedit回车,进入注册表--->点击HKEY_LOCAL_MACHINE---->SYSTEM---->currentControlSet---->Services---->找到Apache2.4,你就会在右边看到ImagePath,这时候的路径是以前那个版本的路径,选中ImagePath点击右键修改,把xampp里面提示的Expected Path后面的路径粘贴进去,然后确定:
3.最后,重启xampp就可以了。

参考资料:https://jingyan.baidu.com/article/fd8044fa3611eb5031137a1b.html

XAMPP启动Apache服务时启动失败的更多相关文章

  1. xampp的Apache服务无法启动 Apache的443端口被占用解决方法

    今天在使用本地的XAMPP的时候,发现Apache服务不能正常启动,根据以往的经验,可能是80端口或者443端口被占用导致的,所以对端口占用情况进行排查. 1. 执行xampp/apache/bin中 ...

  2. 启动Tomcat服务时,出现org.apache.catalina.startup.VersionLoggerListener报错

    启动Tomcat服务时,出现org.apache.catalina.startup.VersionLoggerListener报错解决办法:打开Tomcat安装后目录,进入conf文件夹,找到配置文件 ...

  3. 启动apache服务时报错【the requested operation has failed】

    想要解决错误,首先要找到错误的原因. 使用ApacheMonitor.exe启动apache服务看不到任何错误的原因. 找到问题原因:cmd--命令端--切换到apache的bin目录,执行如下命令: ...

  4. Android开发--Apache服务器安装,解决Apache服务无法启动的问题

    昨天学习Android XML解析的时候,想在自己的电脑上搭建一个最简单的Web服务器来存放一段XML文本,然后在Android程序中解析,查找了一些资料后,看到Apache服务器比较容易上手,使用范 ...

  5. Apache服务无法启动的解决方法

    apache服务无法启动的解决方法 在配置apache的时候,把apache安装为服务myweb,用apacheMonitor启动myweb发现无法启动,提示:the requested operat ...

  6. 启动weblogic服务时,还需要输入用户名和密码的解决方法

    当启动weblogic服务时,还需要输入用户名和密码,相当繁琐,如下: 而在生产环境中,一般会要求不要在每次启动时都输入用户名密码, 因此可以通过一些简单的配置达到此目的,通常的做法有两种: 1.修改 ...

  7. MySQL 服务正在启动 .MySQL 服务无法启动。系统出错。发生系统错误 1067。进程意外终止。

    MySQL 服务正在启动 .MySQL 服务无法启动.系统出错.发生系统错误 1067.进程意外终止. 检查了一个晚上才发现是---配置问题 #Path to installation directo ...

  8. MySQL 服务正在启动 MySQL 服务无法启动解决途径

    解决方案: 1.删除自己手动创建的data文件夹: 2.管理员权限CMD的bin目录下,移除已错误安装的mysqld服务: mysqld -remove MySQL出现删除成功! 3.在CMD的bin ...

  9. XAMPP中Apache和Mysql启动失败问题总结

    一.Apache启动失败 xampp启动时显示的错误为: 9:52:41  [Apache]  Attempting to start Apache app... 9:52:41  [Apache]  ...

随机推荐

  1. 集合运算 & 聚合函数

    SQL 查询之集合运算 & 聚合函数   1.集合运算 1.1.并集运算 UNION 1.2.差集运算 EXCEPT 1.3.交集运算 INTERSECT 1.4.集合运算小结 2.聚合函数 ...

  2. nload 源码安装

    nload 1.下载 wget http://www.roland-riegel.de/nload/nload-0.7.4.tar.gz 2.解压 tar zvxf nload-0.7.4.tar.g ...

  3. 035 Android Volley框架进行网络请求

    1.volley入门介绍 开发Android应用的时候不可避免地都需要用到网络技术,而多数情况下应用程序都会使用HTTP协议来发送和接收网络数据.Android系统中主要提供了两种方式来进行HTTP通 ...

  4. [转帖]MySQL语句大全

    MySQL语句大全 https://www.cnblogs.com/jicki/p/5548676.html 一.连接mysql. 格式: mysql -h主机地址 -u用户名 -p用户密码 二.修改 ...

  5. as报错 Multiple root tags Unexpected tokens 这个都是编译器识别问题

    从网上复制了个代码,直接复制上,结果一篇红线提示Unexpected tokens 通过去掉空格,还是无法根治,别的地方复制的就没有问题. 通过查看复制的网页源码 可以看到里边<> 这个符 ...

  6. SQL——INSERT INTO(增)

    一.INSERT INTO语句的基本用法 INSERT INTO 语句用于往表中插入新记录. student表: INSERT INTO语句有2种语法格式: 1.不指定列名,直接插入记录. 语法格式如 ...

  7. PHP Math常量

    常量名 常量名 常量值 PHP M_E e 2.7182818284590452354 4 M_EULER Euler 常量 0.57721566490153286061 5.2.0 M_LNPI l ...

  8. Asp.netCore 是用的Socket 吗?

    Asp.netCore 是用的Socket 的krestrel 用的是Socket! public static IWebHostBuilder CreateDefaultBuilder(string ...

  9. SVM支持向量机实例

    波士顿房价回归分析 1.导入波士顿房价数据集 ############################# svm实例--波士顿房价回归分析 ############################## ...

  10. element 右键菜单

    右键菜单 这是一个右键菜单的组件 <template> <div id="dropMenu" :style="style" style=&qu ...