使用innobackupex进行数据库备份,报如下错误:
innobackupex --compress --parallel=4  --user=root  --password=yoon /export/backup/
xtrabackup_56 version 2.1.9 for MySQL server 5.6.17 Linux (x86_64) (revision id: 744)
xtrabackup: uses posix_fadvise().
xtrabackup: cd to /var/lib/mysql
xtrabackup: open files limit requested 0, set to 1024
xtrabackup: using the following InnoDB configuration:
xtrabackup:   innodb_data_home_dir = ./
xtrabackup:   innodb_data_file_path = ibdata1:10M:autoextend
xtrabackup:   innodb_log_group_home_dir = ./
xtrabackup:   innodb_log_files_in_group = 2
xtrabackup:   innodb_log_file_size = 50331648
2016-01-21 21:41:29 7f343333b720  InnoDB: Operating system error number 2 in a file operation.
InnoDB: The error means the system cannot find the path specified.
InnoDB: File ./ib_logfile0: 'open' returned OS error 71. Cannot continue operation
innobackupex: Error: The xtrabackup child process has died at /usr/bin/innobackupex line 2622.

在生产库备份没问题,在虚拟机备份就出问题!

percona说修改配置文件路径权限:
https://www.percona.com/forums/questions-discussions/percona-xtrabackup/13396-file-name-ib_logfile0-innodb-file-operation-call-open-returned-os-error-71
[root@hank-yoon mysql]# ls -ltr
total 180
-rw-r--r--.  1 root root   2496 Jul 15  2015 README
-rw-r--r--.  1 root root  17987 Jul 15  2015 COPYING
-rw-r--r--.  1 root root 104897 Jul 15  2015 INSTALL-BINARY
drwxr-xr-x.  2 root root   4096 Dec 19 18:39 docs
drwxr-xr-x.  3 root root   4096 Dec 19 18:39 include
drwxr-xr-x.  4 root root   4096 Dec 19 18:39 man
drwxr-xr-x.  3 root root   4096 Dec 19 18:39 data
drwxr-xr-x.  3 root root   4096 Dec 19 18:39 lib
drwxr-xr-x.  2 root root   4096 Dec 19 18:39 scripts
drwxr-xr-x.  2 root root   4096 Dec 19 18:39 bin
drwxr-xr-x. 10 root root   4096 Dec 19 18:39 mysql-test
drwxr-xr-x.  2 root root   4096 Dec 19 18:39 support-files
drwxr-xr-x. 28 root root   4096 Dec 19 18:39 share
drwxr-xr-x.  4 root root   4096 Dec 19 18:39 sql-bench
-rw-r--r--.  1 root root    943 Dec 19 18:39 my.cnf
drwxr-xr-x.  2 root root   4096 Dec 19 18:40 etc
[root@hank-yoon mysql]# chown -R mysql.mysql etc/     问题依旧!

报错总是提示ib_logfile0,在配置文件中ib_logfile参数是存在的:
InnoDB: File ./ib_logfile0: 'open' returned OS error 71. Cannot continue operation

重新备份指定参数文件:
[root@hank-yoon backup]# innobackupex --compress --parallel=4 --defaults-file=/export/servers/mysql/etc/my.cnf  --user=root  --password=yoon /export/backup/

InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy
and Percona LLC and/or its affiliates 2009-2013.  All Rights Reserved.

This software is published under
the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

Get the latest version of Percona XtraBackup, documentation, and help resources:
http://www.percona.com/xb/p

160121 22:12:52  innobackupex: Connecting to MySQL server with DSN 'dbi:mysql:;mysql_read_default_file=/export/servers/mysql/etc/my.cnf;mysql_read_default_group=xtrabackup' as 'root'  (using password: YES).
160121 22:12:52  innobackupex: Connected to MySQL server
160121 22:12:52  innobackupex: Executing a version check against the server...
160121 22:12:52  innobackupex: Done.
IMPORTANT: Please check that the backup run completes successfully.
           At the end of a successful backup run innobackupex
           prints "completed OK!".

innobackupex: Using mysql server version 5.6.26-log

innobackupex: Created backup directory /export/backup/2016-01-21_22-12-52

160121 22:12:52  innobackupex: Starting ibbackup with command: xtrabackup_56  --defaults-file="/export/servers/mysql/etc/my.cnf"  --defaults-group="mysqld" --backup --suspend-at-end --target-dir=/export/backup/2016-01-21_22-12-52 --tmpdir=/export/data/mysql/tmp --compress --compress-threads=1 --parallel=4
innobackupex: Waiting for ibbackup (pid=5476) to suspend
innobackupex: Suspend file '/export/backup/2016-01-21_22-12-52/xtrabackup_suspended_2'

xtrabackup_56 version 2.1.9 for MySQL server 5.6.17 Linux (x86_64) (revision id: 744)
xtrabackup: uses posix_fadvise().
xtrabackup: cd to /export/data/mysql/data/
xtrabackup: open files limit requested 65535, set to 65535
xtrabackup: using the following InnoDB configuration:
xtrabackup:   innodb_data_home_dir = /export/data/mysql/data
xtrabackup:   innodb_data_file_path = ibdata1:2G;ibdata2:2G:autoextend
xtrabackup:   innodb_log_group_home_dir = /export/data/mysql/data
xtrabackup:   innodb_log_files_in_group = 3
xtrabackup:   innodb_log_file_size = 268435456
2016-01-21 22:12:52 7fa03bee9720 InnoDB: Using Linux native AIO
xtrabackup: using O_DIRECT
>> log scanned up to (1510934)
InnoDB: Opened 4 undo tablespaces
xtrabackup: Starting 4 threads for parallel data files transfer
[04] Compressing /export/data/mysql/data/ibdata1 to /export/backup/2016-01-21_22-12-52/ibdata1.qp
[03] Compressing /export/data/mysql/data/ibdata2 to /export/backup/2016-01-21_22-12-52/ibdata2.qp
[02] Compressing /export/data/mysql/undo/undo001 to /export/backup/2016-01-21_22-12-52/undo001.qp
[01] Compressing /export/data/mysql/undo/undo002 to /export/backup/2016-01-21_22-12-52/undo002.qp
[02]        ...done
[01]        ...done
>> log scanned up to (1510934)
[01] Compressing /export/data/mysql/undo/undo003 to /export/backup/2016-01-21_22-12-52/undo003.qp
[02] Compressing /export/data/mysql/undo/undo004 to /export/backup/2016-01-21_22-12-52/undo004.qp
[02]        ...done
[01]        ...done
[02] Compressing ./mysql/innodb_index_stats.ibd to /export/backup/2016-01-21_22-12-52/mysql/innodb_index_stats.ibd.qp
[02]        ...done
[01] Compressing ./mysql/innodb_table_stats.ibd to /export/backup/2016-01-21_22-12-52/mysql/innodb_table_stats.ibd.qp
[01]        ...done
[02] Compressing ./mysql/slave_master_info.ibd to /export/backup/2016-01-21_22-12-52/mysql/slave_master_info.ibd.qp
[02]        ...done
>> log scanned up to (1510934)
[01] Compressing ./mysql/slave_relay_log_info.ibd to /export/backup/2016-01-21_22-12-52/mysql/slave_relay_log_info.ibd.qp
[01]        ...done
[02] Compressing ./mysql/slave_worker_info.ibd to /export/backup/2016-01-21_22-12-52/mysql/slave_worker_info.ibd.qp
[02]        ...done
>> log scanned up to (1510934)
>> log scanned up to (1510934)
>> log scanned up to (1510934)
>> log scanned up to (1510934)
[04]        ...done
[03]        ...done
xtrabackup: Creating suspend file '/export/backup/2016-01-21_22-12-52/xtrabackup_suspended_2' with pid '5476'

160121 22:12:59  innobackupex: Continuing after ibbackup has suspended
160121 22:12:59  innobackupex: Starting to lock all tables...
160121 22:12:59  innobackupex: All tables locked and flushed to disk

160121 22:12:59  innobackupex: Starting to backup non-InnoDB tables and files
innobackupex: in subdirectories of '/export/data/mysql/data/'
innobackupex: Backing up files '/export/data/mysql/data//mysql/*.{frm,isl,MYD,MYI,MAD,MAI,MRG,TRG,TRN,ARM,ARZ,CSM,CSV,opt,par}' (74 files)
>> log scanned up to (1510934)
innobackupex: Backing up files '/export/data/mysql/data//performance_schema/*.{frm,isl,MYD,MYI,MAD,MAI,MRG,TRG,TRN,ARM,ARZ,CSM,CSV,opt,par}' (53 files)
160121 22:13:00  innobackupex: Finished backing up non-InnoDB tables and files

160121 22:13:00  innobackupex: Waiting for log copying to finish

xtrabackup: The latest check point (for incremental): '1510934'
xtrabackup: Stopping log copying thread.
.>> log scanned up to (1510934)

xtrabackup: Creating suspend file '/export/backup/2016-01-21_22-12-52/xtrabackup_log_copied' with pid '5476'
xtrabackup: Transaction log of lsn (1510934) to (1510934) was copied.
160121 22:13:01  innobackupex: All tables unlocked

innobackupex: Backup created in directory '/export/backup/2016-01-21_22-12-52'
innobackupex: MySQL binlog position: filename 'mysql-bin.000007', position 120
160121 22:13:01  innobackupex: Connection to database server closed
160121 22:13:01  innobackupex: completed OK!

innobackupex:Error:xtrabackup child process has died at /usr/bin/innobackupex的更多相关文章

  1. 记一次zabbix-server故障恢复导致的事故 zabbix-server.log -- One child process died

    前言 zabbix-server昨天出了个问题,不停的重启.昨天摆弄到晚上也不搞清楚原因,按照网上说的各种操作,各种CacheSize.TimeOut.StartPollers都改了,还有什么Incl ...

  2. 【笔记】mongodb启动不了:child process failed, exited with error number 100

    今天在启动mongodb的时候,发现起不来,报错:child process failed, exited with error number 100然后先去/var/log/mongo/mongod ...

  3. Mongodb中经常出现的错误(汇总)child process failed, exited with error number

    异常处理汇总-服 务 器 http://www.cnblogs.com/dunitian/p/4522983.html 异常处理汇总-数据库系列  http://www.cnblogs.com/dun ...

  4. ERROR: child process failed, exited with error number 100

    [root@localhost ~]# mongod --dbpath=/usr/local/mongodb/data --logpath=/usr/local/mongodb/logs --loga ...

  5. mongodb启动时报错ERROR: child process failed, exited with error number 1

    不多说,直接上干货! 前期博客 Ubuntu14.04下Mongodb安装部署步骤(图文详解) Ubuntu16.04下Mongodb安装部署步骤(图文详解) root@zhouls-virtual- ...

  6. Mongodb报错:ERROR: child process failed, exited with error number 1

    Mongodb在启动时报错: 2018-10-16T11:18:54.533+0800 I CONTROL [main] Automatically disabling TLS 1.0, to for ...

  7. Git bash Error: Could not fork child process: There are no available terminals (-1)

    错误信息:Error: Could not fork child process: There are no available terminals (-1) 截图如下: 解决办法: (1)使用cmd ...

  8. mongodb启动报错,child process failed, exited with error number 1

    error: child process failed, exited with error number 1 第一次安装mongodb,随后启动一般不会出现上面的错误,出现这种错误的原因一般是mon ...

  9. Child Process

    Child Process child_process 这个模块可以生成一个子进程.nodejs提供了好几个API,本质上都是调用child_process.spawn(): const spawn ...

随机推荐

  1. [课程相关]homework-09

    零.前言 这次的作业比较特殊,有两种做法.由于我对网页很熟悉,所以选择网页. 细节不赘述,下面写一下这次作业的几个亮点. 一.亮点 最大的亮点就是这个页面是纯客户端的,没有服务端.也就是说所有功能都是 ...

  2. IIS与JIRA的反向代理配置

    JIRA配置修改 JIRA与IIS ARR的集成,除了上篇(Visual SVN IIS反向代理设置)中讲到的基本的ARR配置之外,还需要在JIRA安装目录的conf\server.xml文件中做一个 ...

  3. jQuery .on() 绑定事件无效

    前几天,要在移动端实现一系列的功能,用 HTML + JS. 按照以往的思路,事件绑定就直接 $(document).on "click", "selector" ...

  4. Table of Contents - JMS

    JMS Specification v1.1 JMS 基本概念 Message QueueBrowser 消息选择器 消息确认 ConnectionMetaData ExceptionListener ...

  5. IE10 下兼容性问题

    昨天在IE10下遇到这样一个问题 用jquery 获取textarea里的值 其中内容这里包含HTML  用$("#Id").val().$("#Id").ht ...

  6. php中使用PHPExcel操作excel(xls)文件

    读取中文的xls.csv文件会有问题,网上找了下资料,发现PHPExcel类库好用,官网地址:http://phpexcel.codeplex.com/ 1.读取xls文件内容  代码如下 复制代码 ...

  7. SDWebImage缓存清理

    //计算缓存大小 [SDImageCache sharedImageCache] getSize] //清理缓存 SDImageCache *sd = [[SDImageCache alloc]ini ...

  8. 【ASP.NET】获取网站目录的方法

         获取网站物理路径: HttpRuntime.AppDomainAppPath 获取网站虚拟路径: HttpRuntime.AppDomainAppVirtualPath

  9. (转)文件系统缓存dirty_ratio与dirty_background_ratio两个参数区别

    这两天在调优数据库性能的过程中需要降低操作系统文件Cache对数据库性能的影响,故调研了一些降低文件系统缓存大小的方法,其中一种是通过修改/proc/sys/vm/dirty_background_r ...

  10. JVM内存分配

    内存分配:当JVM运行起来的时候就会给内存划分空间,那么这块空间称之为运行时数据区.(备注:当一个Java源程序编译成class字节码文件之后,字节码文件里存放的都是二进制的汇编命令,当程序运行的时候 ...