Win7系统中MySQL服务无法启动的解决方法
Win7系统中提示:本地无法启动MySQL服务,报的错误:1067,进程意外终止的解决方法。
在本地计算机无法启动MYSQL服务错误1067进程意外终止。
这种情况一般是my.ini文件配置出错了
1、首先找到这个文件: Win7下的默认安装路径
C:\ProgramData\MySQL\MySQL Server 5.6\my.ini
打开此文件找到:default-storage-engine=INNODB
将default-storage-engine的值改为:MYISAM。
2、但是还有问题:因为以前你创建的那些数据库还是存在的(如果没有删除),
默认路径:
C:\ProgramData\MySQL\MySQL Server 5.6\data
这时可能会出来这种问题:
第一次设置的efault-storage-engine与第二次设置的值不一样,可能会导致
(1)发现无法选择添加事务支持数据引擎InnoDB
(2)可能会说不支持InnoDB等
解决方法:
删除:C:\ProgramData\MySQL\MySQL Server 5.6\data目录下的
ib_logfile0
ib_logfile1
ibdata1
重启服务,再次生成就OK了
3、如果还是不行,检查
C:\ProgramData\MySQL\MySQL Server 5.6\data 这个目录中的错误日志(扩展名我为.err),显示如下内容:
2015-06-24 08:53:30 7736 [Note] Plugin 'FEDERATED' is disabled.
2015-06-24 08:53:30 1724 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2015-06-24 08:53:30 7736 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-06-24 08:53:30 7736 [Note] InnoDB: The InnoDB memory heap is disabled
2015-06-24 08:53:30 7736 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-06-24 08:53:30 7736 [Note] InnoDB: Memory barrier is not used
2015-06-24 08:53:30 7736 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-06-24 08:53:30 7736 [Note] InnoDB: Not using CPU crc32 instructions
2015-06-24 08:53:30 1724 InnoDB: Error: unable to create temporary file; errno: 2
2015-06-24 08:53:30 7736 [ERROR] Plugin 'InnoDB' init function returned error.
2015-06-24 08:53:30 7736 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2015-06-24 08:53:30 7736 [ERROR] Unknown/unsupported storage engine: INNODB
2015-06-24 08:53:30 7736 [ERROR] Aborting
其中核心提示是这句,临时文件无法创建:
2015-06-24 08:53:30 1724 InnoDB: Error: unable to create temporary file; errno: 2
因此查看my.ini
[mysqld]区段内加入:
#自己指定的临时文件目录
tmpdir=d:\mysqltemp
d:\mysqltemp这个目录可以自己指定
Win7系统中MySQL服务无法启动的解决方法的更多相关文章
- Win7系统中哪些服务可以关闭?
Win7系统中很多服务和进程其实大家在平时都用不上,这些服务和进程不仅占用了很大部分的资源,而且还会影响系统的运行速度和安全.我们可以关闭那些不常用的服务和进程来加快系统运行速度,但对于一般的用户来说 ...
- Win7系统打开防火墙出现0x6D9错误的解决方法
防火墙是Windows系统内的一道屏障,开启防火墙可以对系统起到一定的保护作用,可以说非常重要.但是有些Win7系统用户在开启防火墙时会被系统提示出现0x6D9的错误代码,从而不能打开防火墙. 当我们 ...
- Apache服务无法启动的解决方法
apache服务无法启动的解决方法 在配置apache的时候,把apache安装为服务myweb,用apacheMonitor启动myweb发现无法启动,提示:the requested operat ...
- 关于win7右下角显示“音频服务未运行”的解决方法
今天打开电脑发现右下角的的小喇叭多了个叉叉,显示“音频服务未运行”,百度了一下,解决方法还是挺多的,一下是百度到的解决方法,希望可以帮到出现这个问题的朋友们. 解决方法:(转载的) 1.Windows ...
- 关于MySQL5.6.25在Win7 64bit下重装后无法启动的解决方法
在重装MySQL5.6.25安装到进行配置的时候,一直在等待服务的启动.如果手动在系统服务启动会提示1067错误,这个错误在网上很常见,然而我试过了很多方法均无法解决. 于是看ProgramData\ ...
- 关于mysql-5.7.13-winx64服务无法启动的解决方法
从官网上下载免安装的5.7的mysql,但是无法启动mysql服务.原因是下载下来的mysql没有data这个文件夹,故需要在cmd下先执行mysql --initialize -insecure命令 ...
- TerraGate软件安装后,服务无法启动的解决方法
前些天有朋友问,TerraGate安装后,服务无法启动,而且启动按钮也是不可用的状态,不知道是为什么,如下图: 打开TerraGate的安装目录,发现里面缺少一些文件,如下图: *解决办法: 重新安装 ...
- 使用wamp扩展php时出现服务未启动的解决方法
今天在使用wamp扩展php的插件时,出现了如下图所示的错误提示 网上查了查,都说是端口原因,修改Apache的 80端口,但是并没有解决问题. 最后我终于找到了解决方法,步骤很简单,如下: 首先,在 ...
- 影像工作站的数据库安装错误之Win7系统下pg服务无法启动
1.关闭批处理 2.修改 PG安装路径下的Data文件下的pg_hba.conf文件中去掉IPv6的井号,如下图 3.结束pg进程 4.重启PG服务.
随机推荐
- [Leet Code]Path Sum II
此题如果 #1 和 #4 判断分支交换,大集合就会超时(因为每次对于非叶子节点都要判断是不是叶子节点).可见,有时候if else判断语句也会对于运行时间有较大的影响. import java.uti ...
- Android Lock Pattern 图案解锁
参考链接:http://www.cnblogs.com/dyingbleed/archive/2012/12/03/2800007.html http://blog.csdn.net/way_ping ...
- Java实现单链表翻转
单链表翻转比方有例如以下链表: watermark/2/text/aHR0cDovL2Jsb2cuY3Nkbi5uZXQvZmVuZ3NoaXp0eQ==/font/5a6L5L2T/fontsize ...
- Word实用教程——五分钟教你如何在任意页开始添加页码
最近在写一篇论文,但是在排版上遇到一点小问题,就是要加入页码,而且页码是从目录的下一页开始计数,于是我就在网上找如何在任意页添加页码.后来辗转终于搞定,真心觉得这一个小功能让微软做的如此的麻烦,真是活 ...
- 深度学习领域的Papers
https://github.com/songrotek/Deep-Learning-Papers-Reading-Roadmap 深度学习论文阅读路线图 Deep Learning Papers R ...
- MyBatis 问题列表
问题表现:The content of elements must consist of well-formed character data or markup 解决办法:1.配置的动态SQL语句里 ...
- error: insufficient permissions for device(解决adb shell问题)
今天在linux下连接平板usb,试用adb shell时出现error: insufficient permissions for device, 而且我们输入adb devices显示: xxna ...
- Asp.net页面中调用soapheader进行验证的操作步骤
Asp.net页面中调用以SOAP头作验证的web services操作步骤 第一步:用来作SOAP验证的类必须从SoapHeader类派生,类中Public的属性将出现在自动产生XML节点中,即: ...
- LeetCode: Best Time to Buy and Sell Stock II 解题报告
Best Time to Buy and Sell Stock IIQuestion SolutionSay you have an array for which the ith element i ...
- virsh的详细命令解析(一)
virsh的详细命令解析 virsh 有命令模式和交互模式如果直接在vrish后面添加参数是命令模式,如果直接写virsh,就会进入交互模式 virsh list 列出所有的虚拟机,虚拟机的状态有(8 ...