七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Server version: Apache Tomcat/7.0.91
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Server built: Sep 13 2018 19:52:12 UTC
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Server number: 7.0.91.0
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: OS Name: Windows 8.1
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: OS Version: 6.3
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Architecture: x86
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Java Home: C:\Program Files (x86)\Java\jdk1.7.0_80\jre
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: JVM Version: 1.7.0_80-b15
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: JVM Vendor: Oracle Corporation
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: CATALINA_BASE: C:\apache-tomcat-7.0.91
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: CATALINA_HOME: C:\apache-tomcat-7.0.91
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:15577
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dcatalina.home=C:\apache-tomcat-7.0.91
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dcatalina.base=C:\apache-tomcat-7.0.91
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Djava.endorsed.dirs=C:\apache-tomcat-7.0.91/common/endorsed
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Djava.io.tmpdir=C:\apache-tomcat-7.0.91\temp
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Djava.library.path=C:\Program Files (x86)\Java\jdk1.7.0_80\bin;C:\apache-tomcat-7.0.91\bin
七月 31, 2019 4:39:01 下午 org.apache.catalina.startup.VersionLoggerListener log
信息: Command line argument: -Dsun.io.useCanonCaches=false
七月 31, 2019 4:39:01 下午 org.apache.catalina.core.AprLifecycleListener lifecycleEvent
信息: Loaded APR based Apache Tomcat Native library 1.2.17 using APR version 1.6.3.
七月 31, 2019 4:39:01 下午 org.apache.catalina.core.AprLifecycleListener lifecycleEvent
信息: APR capabilities: IPv6 [true], sendfile [true], accept filters [false], random [true].
七月 31, 2019 4:39:02 下午 org.apache.catalina.core.AprLifecycleListener initializeSSL
信息: OpenSSL successfully initialized (OpenSSL 1.0.2o 27 Mar 2018)
七月 31, 2019 4:39:02 下午 org.apache.coyote.AbstractProtocol init
信息: Initializing ProtocolHandler ["http-apr-8080"]
七月 31, 2019 4:39:02 下午 org.apache.coyote.AbstractProtocol init
信息: Initializing ProtocolHandler ["ajp-apr-8009"]
七月 31, 2019 4:39:02 下午 org.apache.catalina.startup.Catalina load
信息: Initialization processed in 1706 ms
七月 31, 2019 4:39:02 下午 org.apache.catalina.core.StandardService startInternal
信息: Starting service Catalina
七月 31, 2019 4:39:02 下午 org.apache.catalina.core.StandardEngine startInternal
信息: Starting Servlet Engine: Apache Tomcat/7.0.91
七月 31, 2019 4:39:02 下午 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deploying web application directory C:\apache-tomcat-7.0.91\webapps\afunms
七月 31, 2019 4:39:03 下午 org.apache.catalina.loader.WebappClassLoaderBase validateJarFile
信息: validateJarFile(C:\apache-tomcat-7.0.91\webapps\afunms\WEB-INF\lib\com.ibm.ws.admin.client_6.1.0.jar) - jar not loaded. See Servlet Spec 3.0, section 10.7.2. Offending class: javax/servlet/Servlet.class
七月 31, 2019 4:39:03 下午 org.apache.catalina.loader.WebappClassLoaderBase validateJarFile
信息: validateJarFile(C:\apache-tomcat-7.0.91\webapps\afunms\WEB-INF\lib\servlet-api.jar) - jar not loaded. See Servlet Spec 3.0, section 10.7.2. Offending class: javax/servlet/Servlet.class
七月 31, 2019 4:39:22 下午 org.apache.catalina.core.ContainerBase addChildInternal
严重: ContainerBase.addChild: start:
org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/afunms]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:162)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:1018)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:994)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:652)
at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1296)
at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:2039)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask.run(FutureTask.java:262)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.IllegalStateException: Unable to complete the scan for annotations for web application [/afunms] due to a StackOverflowError. Possible root causes include a too low setting for -Xss and illegal cyclic inheritance dependencies. The class hierarchy being processed was [org.jaxen.util.AncestorAxisIterator->org.jaxen.util.AncestorOrSelfAxisIterator->org.jaxen.util.AncestorAxisIterator]
at org.apache.catalina.startup.ContextConfig.checkHandlesTypes(ContextConfig.java:2164)
at org.apache.catalina.startup.ContextConfig.processAnnotationsStream(ContextConfig.java:2110)
at org.apache.catalina.startup.ContextConfig.processAnnotationsJar(ContextConfig.java:1971)
at org.apache.catalina.startup.ContextConfig.processAnnotationsUrl(ContextConfig.java:1932)
at org.apache.catalina.startup.ContextConfig.processAnnotations(ContextConfig.java:1917)
at org.apache.catalina.startup.ContextConfig.webConfig(ContextConfig.java:1322)
at org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:878)
at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:388)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5566)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:145)
... 10 more
七月 31, 2019 4:39:22 下午 org.apache.catalina.startup.HostConfig deployDirectory
严重: Error deploying web application directory C:\apache-tomcat-7.0.91\webapps\afunms
java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/afunms]]
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:1022)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:994)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:652)
at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1296)
at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:2039)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask.run(FutureTask.java:262)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)
七月 31, 2019 4:39:22 下午 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deployment of web application directory C:\apache-tomcat-7.0.91\webapps\afunms has finished in 19,838 ms
七月 31, 2019 4:39:22 下午 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deploying web application directory C:\apache-tomcat-7.0.91\webapps\docs
七月 31, 2019 4:39:23 下午 org.apache.catalina.util.SessionIdGeneratorBase createSecureRandom
警告: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [355] milliseconds.
七月 31, 2019 4:39:23 下午 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deployment of web application directory C:\apache-tomcat-7.0.91\webapps\docs has finished in 604 ms
七月 31, 2019 4:39:23 下午 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deploying web application directory C:\apache-tomcat-7.0.91\webapps\examples
七月 31, 2019 4:39:24 下午 org.apache.catalina.core.ApplicationContext log
信息: ContextListener: contextInitialized()
七月 31, 2019 4:39:24 下午 org.apache.catalina.core.ApplicationContext log
信息: SessionListener: contextInitialized()
七月 31, 2019 4:39:24 下午 org.apache.catalina.core.ApplicationContext log
信息: ContextListener: attributeAdded('StockTicker', 'async.Stockticker@b0e8c4')
七月 31, 2019 4:39:24 下午 org.apache.catalina.core.ApplicationContext log
信息: ContextListener: attributeAdded('org.apache.jasper.compiler.TldLocationsCache', 'org.apache.jasper.compiler.TldLocationsCache@299278')
七月 31, 2019 4:39:24 下午 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deployment of web application directory C:\apache-tomcat-7.0.91\webapps\examples has finished in 925 ms
七月 31, 2019 4:39:24 下午 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deploying web application directory C:\apache-tomcat-7.0.91\webapps\host-manager
七月 31, 2019 4:39:24 下午 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deployment of web application directory C:\apache-tomcat-7.0.91\webapps\host-manager has finished in 136 ms
七月 31, 2019 4:39:24 下午 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deploying web application directory C:\apache-tomcat-7.0.91\webapps\manager
七月 31, 2019 4:39:51 下午 org.apache.catalina.core.ApplicationContext log
信息: No Spring WebApplicationInitializer types detected on classpath
七月 31, 2019 4:39:51 下午 com.sun.faces.config.ConfigureListener contextInitialized
信息: 初始化上下文 '/manager' 的 Mojarra 2.0.3 (FCS b03)
七月 31, 2019 4:40:04 下午 com.sun.faces.spi.InjectionProviderFactory createInstance
信息: JSF1048:有 PostConstruct/PreDestroy 注释。标有这些注释的 ManagedBeans 方法将表示注释已处理。
七月 31, 2019 4:40:05 下午 org.apache.catalina.startup.HostConfig deployDirectory
信息: Deployment of web application directory C:\apache-tomcat-7.0.91\webapps\manager has finished in 41,475 ms
七月 31, 2019 4:40:05 下午 org.apache.coyote.AbstractProtocol start
信息: Starting ProtocolHandler ["http-apr-8080"]
七月 31, 2019 4:40:05 下午 org.apache.coyote.AbstractProtocol start
信息: Starting ProtocolHandler ["ajp-apr-8009"]
七月 31, 2019 4:40:05 下午 org.apache.catalina.startup.Catalina start
信息: Server startup in 63130 ms

due to a StackOverflowError. Possible root causes include a too low setting for -Xss and illegal cyclic inheritance dependencies. The class hierarchy being processed was [org.jaxen.util.AncestorAxisIt的更多相关文章

  1. Unable to complete the scan for annotations for web application [/wrs] due to a StackOverflowError. Possible root causes include a too low setting for -Xss and illegal cyclic inheritance dependencies.

    tomcat启动报错:Jul 20, 2018 11:48:37 AM org.apache.catalina.core.ContainerBase addChildInternalSEVERE: C ...

  2. Tomcat启动报错:Possible root causes include a too low setting for -Xss and illegal cyclic inheritance dependencies

    错误代码如下: Caused by: java.lang.IllegalStateException: Unable to complete the scan for annotations for ...

  3. Caused by: java.lang.IllegalStateException: Unable to complete the scan for annotations for web application [/Cppcc] due to a StackOverflowError. Possible root causes include a too low setting for -Xs

    解决办法:(1)修改D:\Java\apache-tomcat-7.0.88\conf\catalina.properties (122line) (2)如org.apache.catalina.st ...

  4. tomcat启动时检测到循环继承而栈溢出的问题:Caused by: java.lang.IllegalStateException: Unable to complete the scan for annotations for web application [/test] due to a StackOverflowError. Possible root causes include

    最近在公司更新一个老项目的时候,发现部署项目后tomcat报错,错误如下: Caused by: java.lang.IllegalStateException: Unable to complete ...

  5. due to a StackOverflowError. Possible root causes include a too low。。

    我们可以用另外的办法来解决这个问题,我们让tomcat不扫描指定的jar包,tomcat就要轻松得多了,org.apache.tomcat.util.scan.StandardJarScanner中定 ...

  6. maven tomcat plugin 踩坑记

    今天在自己家里的电脑上改一个项目,安装的是社区版的 IntelliJ Idea, 没有办法安装 Tomcat 插件来启动项目.尝试用 jettry runer 启动,结果报 java.lang.Inc ...

  7. 解决Tomcat 7遇到StackOverflowError的异常

    参考网址:http://qingyuexiao.iteye.com/blog/1886059 前言:在写此博客前,首先感谢姚双琪.林瑞丰.网友qingyuexiao的倾囊相助!此博文不过是笔者对于他们 ...

  8. 一个jar包冲突引起的StackOverflowError

    项目运行中错误信息:java.lang.IllegalStateException: Unable to complete the scan for annotations for web appli ...

  9. Tomcat启动报StackOverflowError

    近期工程部署到Tomcat时,出现以下异常: 16-May-2018 09:35:25.590 严重 [localhost-startStop-1] org.apache.catalina.core. ...

随机推荐

  1. RabbitMQ使用(一)

    1. 安装与使用 1. 激活 RabbitMQ's Management Plugin (前面跟绝对路径) "D:\娱乐\rabbitmq_server-3.6.5\sbin\rabbitm ...

  2. Java进程Runtime、Process、ProcessBuilder调用外部程序

    原文地址:https://blog.csdn.net/c315838651/article/details/72085739 通过Java执行系统命令,与cmd中或者终端上一样执行shell命令,最典 ...

  3. Python的datetime模块使用

    两个常量 MAXYEAR:9999 MINYEAR:1 五个类 datetime.datetime:日期时间类 datetime.date:日期类 datetime.time:时间类 datetime ...

  4. C-Ubuntu中MySQL出现ERROR1698(28000):Access denied for user root@localhost错误解决方法

    卸载原先的MySQL,重新安装过程中没有提示设置密码, 当键入命令:mysql -uroot -p; 不知密码是什么,输入主机的密码以及不输入密码,回车后都出现标题错误. 寻找多篇相关博文,验证如下博 ...

  5. [Code+#3]博弈论与概率统计

    题目 记得曾经和稳稳比谁后抄这个题的题解,看来是我输了 不难发现\(p\)是给着玩的,只需要求一个总情况数除以\(\binom{n+m}{n}\)就好了 记\(i\)为无效的失败次数,即\(\rm A ...

  6. canvas-nest.js 设置网页背景

    只需要在HTML,body中加如这行代码就可以实现效果,可以在color中修改颜色 <!DOCTYPE html> <html> <head> <meta c ...

  7. react-router踩坑

    1.当用BrowserRouter时,<Link/>组件必须放在BrowserRouter里,如果是存在于某个组件里的Link,则该组件也必须放在Router里,不然会出现url改变页面为 ...

  8. centos7 sshd 安全设置

    ssh 的安全机制 1.SSH之所以能够保证安全,原因在于它采用了非对称加密技术(RSA)加密了所有传输的数据.   2.传统的网络服务程序,如FTP等在网络上用明文传送数据.用户帐号和用户口令,很容 ...

  9. 笔记40 Spring Web Flow——订单流程(构建订单)

    二.订单子流程 在识别完顾客之后,主流程的下一件事情就是确定他们想要什么类型 的披萨.订单子流程就是用于提示用户创建披萨并将其放入订单中 的,如下图所示. showOrder状态位于订单子流程的中心位 ...

  10. filter的使用场景

    1.filter的使用场景:假如有一个对象数组A,获取数组中的指定类型的对象放到B数组中 我们在ES5先进行for循环遍历数组,再进行if 判断,如果数组中某个对象的类型符合要求,push 到一个新数 ...