centos6.8上yum安装zabbix3.2

zabbix3.2安装文档:https://www.zabbix.com/documentation/3.2/manual/installation/install_from_packages/server_installation_with_mysql

zabbix-3.2.6-el6.tar下载地址:http://pan.baidu.com/s/1boLsCyj

1、yum安装
做centos6的yum源
1、把所有rpm包放到/tmp/packages/目录下
ll /tmp/packages/
total 17028
drwxr-xr-x 2 root root    4096 May 23 17:14 repodata
-rw-r--r-- 1 root root  345004 May 23 17:13 zabbix-agent-3.2.6-1.el6.x86_64.rpm
-rw-r--r-- 1 root root 4644164 May 23 17:13 zabbix-debuginfo-3.2.6-1.el6.x86_64.rpm
-rw-r--r-- 1 root root  241540 May 23 17:13 zabbix-get-3.2.6-1.el6.x86_64.rpm
-rw-r--r-- 1 root root  737848 May 23 17:13 zabbix-java-gateway-3.2.6-1.el6.x86_64.rpm
-rw-r--r-- 1 root root  647752 May 23 17:13 zabbix-proxy-mysql-3.2.6-1.el6.x86_64.rpm
-rw-r--r-- 1 root root  647780 May 23 17:13 zabbix-proxy-pgsql-3.2.6-1.el6.x86_64.rpm
-rw-r--r-- 1 root root  631564 May 23 17:13 zabbix-proxy-sqlite3-3.2.6-1.el6.x86_64.rpm
-rw-r--r-- 1 root root  252328 May 23 17:13 zabbix-sender-3.2.6-1.el6.x86_64.rpm
-rw-r--r-- 1 root root 1840552 May 23 17:13 zabbix-server-mysql-3.2.6-1.el6.x86_64.rpm
-rw-r--r-- 1 root root 1839560 May 23 17:13 zabbix-server-pgsql-3.2.6-1.el6.x86_64.rpm
-rw-r--r-- 1 root root 5489008 May 23 17:13 zabbix-web-3.2.6-1.el6.noarch.rpm
-rw-r--r-- 1 root root    5648 May 23 17:13 zabbix-web-japanese-3.2.6-1.el6.noarch.rpm
-rw-r--r-- 1 root root    5208 May 23 17:13 zabbix-web-mysql-3.2.6-1.el6.noarch.rpm
-rw-r--r-- 1 root root    5220 May 23 17:13 zabbix-web-pgsql-3.2.6-1.el6.noarch.rpm

2、执行下面--add-repo会添加tmp_packages_.repo源
yum install -y  yum-utils
yum-config-manager --add-repo=file:///tmp/packages/
ll
total 12
-rw-r--r-- 1 root root 1399 May 24 14:04 CentOS-Base.repo
-rw-r--r-- 1 root root  220 May 24 14:04 CentOS-Epel.repo
-rw-r--r-- 1 root root   97 May 24 14:18 tmp_packages_.repo

3、添加gpgcheck=0
echo 'gpgcheck=0' >> /etc/yum.repos.d/tmp_packages_.repo

4、cat tmp_packages_.repo
[tmp_packages_]
name=added from: file:///tmp/packages/
baseurl=file:///tmp/packages/
enabled=1

yum install  -y  epel-release
yum install  -y  zabbix-server-mysql zabbix-web-mysql zabbix-agent zabbix-java-gateway  zabbix-get  zabbix-web  zabbix-server 
rpm -Uvh http://mirror.webtatic.com/yum/el6/latest.rpm
yum install -y php56w.x86_64 php56w-cli.x86_64 php56w-common.x86_64 php56w-gd.x86_64 php56w-ldap.x86_64 php56w-mbstring.x86_64 php56w-mcrypt.x86_64 php56w-mysql.x86_64 php56w-pdo.x86_64  php56w-xml  php56w-xmlrpc php56w-bcmath

2、改zabbix端口为9672,清空zabbix.conf文件,再复制下面内容

cat >  /etc/httpd/conf.d/zabbix.conf <<EOF
#
# Zabbix monitoring system php web frontend
# Alias /zabbix /usr/share/zabbix
<VirtualHost *:>
ServerName localhost
<Directory "/usr/share/zabbix">
Options FollowSymLinks
AllowOverride None <IfModule mod_authz_core.c>
# Apache 2.4
Require all granted
</IfModule> <IfModule !mod_authz_core.c>
# Apache 2.2
Order allow,deny
Allow from all
</IfModule> </Directory> <Directory ~ "^/usr/share/zabbix/(conf|api|include)/">
<IfModule mod_authz_core.c>
# Apache 2.4
Require all denied
</IfModule> <IfModule !mod_authz_core.c>
# Apache 2.2
Order deny,allow
Deny from all
</IfModule> <files *.php>
<IfModule mod_authz_core.c>
# Apache 2.4
Require all denied
</IfModule> <IfModule !mod_authz_core.c>
Order deny,allow
Deny from all
</IfModule> </files>
</Directory>
</VirtualHost>
EOF

3、安装mysql
安装步骤省略
注意:做一个软链接
mkdir -p /var/lib/mysql
ln -s /data/mysql/mysql3306/tmp/mysql.sock /var/lib/mysql/mysql.sock

4、在 MySQL上创建zabbix数据库.
mysql -uroot   -p'123456'  -S /data/mysql/mysql3306/tmp/mysql.sock  -e " create database zabbix character set utf8 collate utf8_bin;"
mysql -uroot   -p'123456'  -S /data/mysql/mysql3306/tmp/mysql.sock -e "grant all privileges on zabbix.* to zabbix@'%' identified by 'zabbix'; "

5、导入表结构和数据.
#查看当前zabbix版本导入相应版本sql脚本
rpm -q zabbix-server-mysql  
gzip -d   /usr/share/doc/zabbix-server-mysql-3.2.6/create.sql.gz
mysql -uzabbix -pzabbix  -S  /data/mysql/mysql3306/tmp/mysql.sock  --default-character-set=utf8 zabbix </usr/share/doc/zabbix-server-mysql-3.2.6/create.sql

6、配置zabbix_server.conf里面的数据库信息
vi /etc/zabbix/zabbix_server.conf
DBHost=localhost   
DBName=zabbix
DBUser=zabbix
DBPassword=zabbix
DBSocket=/data/mysql/mysql3306/tmp/mysql.sock
DBPort=3306

7、设置php.ini
sed -i 's/^;date.timezone =/date.timezone = Asia\/Shanghai /' /etc/php.ini
sed -i 's/^expose_php = On/expose_php = Off/' /etc/php.ini
sed -i 's/^max_execution_time = 30/max_execution_time = 300/' /etc/php.ini
sed -i 's/^post_max_size = 8M/post_max_size = 32M/' /etc/php.ini
sed -i 's/^max_input_time = 60/max_input_time = 300/' /etc/php.ini
sed -i 's/^display_errors = Off/display_errors =on/' /etc/php.ini
sed -i 's/^;always_populate_raw_post_data = -1/always_populate_raw_post_data = -1/' /etc/php.ini
在/etc/httpd/conf/httpd.conf  加入
grep  9672  /etc/httpd/conf/httpd.conf  || sed -i '/Listen 80/a\Listen 9672'  /etc/httpd/conf/httpd.conf
sed -i '/AddType application\/x-gzip \.gz \.tgz/a\AddType application/x-httpd-php .php'  /etc/httpd/conf/httpd.conf
修改权限
chmod -R 755 /etc/zabbix/web/
chmod -R 755  /usr/share/zabbix/include/
chown -R apache:apache /etc/zabbix/web/

/usr/sbin/apachectl -t
/etc/init.d/httpd restart

8、 安装zabbix
/etc/init.d/zabbix-server restart
/etc/init.d/zabbix-agent restart

地址:http://122.152.212.203:9672/zabbix
默认用户名/密码: Admin/zabbix
数据库用户名/密码:zabbix/zabbix
zabbix名称:ZBXSERVER

配置完毕后会生成/etc/zabbix/web/zabbix.conf.php
Configuration file
"/etc/zabbix/web/zabbix.conf.php"
created: OK

9、设置开启自动启动
chkconfig httpd on
chkconfig mysql on
chkconfig zabbix-server on
chkconfig zabbix-agent on
/etc/init.d/zabbix-server start

10、禁用guest用户,修改Admin的密码
administration-》user groups-》点击guests这个组-》点击disable
administration-》users-》点击Admin-》点击change password-》输入两次密码-》update
用户名/密码: Admin/1qaz2wsx

11、配置zabbix服务器上的zabbix agent
vi /etc/zabbix/zabbix_agentd.conf
Server=127.0.0.1   
ServerActive=127.0.0.1     
Hostname=Zabbix server   
PidFile=/var/run/zabbix/zabbix_agentd.pid
LogFile=/var/log/zabbix/zabbix_agentd.log
# ListenPort=10050
# HostnameItem=system.hostname   
# Include=/etc/zabbix_agentd.userparams.conf
# Include=/etc/zabbix_agentd.conf.d/

其他都删掉,只保留上面几行

service zabbix-agent start


apache+php+mysql+zabbix yum zabbix 后访问报500错误
http://blog.sina.com.cn/s/blog_6311af050102vr6i.html
http://knowledge92.blog.51cto.com/7143076/1702892

apache+php+mysql+zabbix
这个是apache里的错误日志
[Sun May 17 10:09:09 2015] [error] [client 192.168.6.9] PHP Warning:  require_once(/etc/zabbix/web/maintenance.inc.php): failed to open stream: Permission denied in /usr/share/zabbix/include/classes/core/ZBase.php on line 292
[Sun May 17 10:09:09 2015] [error] [client 192.168.6.9] PHP Fatal error:  require_once(): Failed opening required '/etc/zabbix/web/maintenance.inc.php' (include_path='.:/usr/share/pear:/usr/share/php') in /usr/share/zabbix/include/classes/core/ZBase.php on line 292
 
原因是apache的启动用户对该目录  /etc/zabbix/web/maintenance.ini.php和/usr/share/zabbix/include/classes/core/ZBase.php 没有访问权限,把这两个目录的属组改为apache的启动用户即可

Fatal error: require_once(): Failed opening required '/etc/zabbix/web/maintenance.inc.php' (include_path='.:/usr/share/pear:/usr/share/php') in /usr/share/zabbix/include/classes/core/ZBase.php on line 269

修改权限
chmod -R 755 /etc/zabbix/web/
chmod -R 755  /usr/share/zabbix/include/


zabbix日志位置

/var/log/zabbix/zabbix_server.log

ll
total 76
-rw-rw-r-- 1 zabbix zabbix  2021 May 25 14:17 zabbix_agentd.log
-rw-rw-r-- 1 zabbix zabbix   310 Dec  1 03:35 zabbix_agentd.log-20161201.gz
-rw-rw-r-- 1 zabbix zabbix   619 Jan  1 03:40 zabbix_agentd.log-20170101.gz
-rw-rw-r-- 1 zabbix zabbix   370 Feb  1 03:47 zabbix_agentd.log-20170201.gz
-rw-rw-r-- 1 zabbix zabbix   313 Mar  1 03:12 zabbix_agentd.log-20170301.gz
-rw-rw-r-- 1 zabbix zabbix 51728 May 25 14:25 zabbix_server.log


连接不上zabbix数据库的解决方法

https://serverfault.com/questions/582526/zabbix-not-connecting-to-mysql-database

3805:20170525:145152.001 database is down: reconnecting in 10 seconds
3805:20170525:145202.002 [Z3001] connection to database 'zabbix' failed: [0] server closed the connection unexpectedly
This probably means the server terminated abnormally
before or while processing the request.
could not send startup packet: Broken pipe

1、注释掉DBSocket
vi /etc/zabbix/zabbix_server.conf
#DBSocket=/data/mysql/mysql3306/tmp/mysql.sock

2、删除zabbix-server-pgsql,pgsql端口是5432,不然会不停连接5432端口连接pgsql

yum remove -y zabbix-server-pgsql

zabbix-server正常

f

centos6.8上yum安装zabbix3.2的更多相关文章

  1. CentOS6.8通过yum安装MySQL5.7

    Centos6.8通过yum安装mysql5.7 1.安装mysql的yum源 a.下载配置mysql的yum源的rpm包 根据上面3张图片中的操作下载下来的rpm文件可以通过如下命令获取: wget ...

  2. centos6.7用yum安装redis解决办法及IP限制配置

    在centos6.7用yum安装redis解决办法 - bluesky1 - 博客园 http://www.cnblogs.com/lanblogs/p/6104834.html yum instal ...

  3. aliyun CentOS6.5 上 svn 安装笔记

    为了方便管理自己的一些学习资料.总结等,在CentOS6.5上安装SVN,记录过程如下: 1.1  安装方式  独立服务器  fsfs SVN服务器有2种运行方式:独立安装.SVN+Apache.独立 ...

  4. 自己编写的:centos6.6上编译安装apache2.4+php5.6+mysql5.6【亲自】

    在centos6.6上安装apache2.4+php5.6+mysql5.6 关于wget的安装 将之前装系统的.iso文件挂载到光驱 由于我在/home/jinnan/下建立了一个cdrom文件夹 ...

  5. 在centos6.3用yum安装redis

    一.centos默认的安装源在官方centos.org上,而redis在第三方的yum源里,所以无法安装,非官方的yum推荐用fedora的epel仓库.当然也可通过配置 /etc/yum.repos ...

  6. centos6.5下yum安装lnmp(适合刚入职的新手的方法)

    新入职的员工,开始的时候都是让配环境,本地写代码用的wamp,在lnmp或lamp测试,除非有些土豪公司 用的是(果机). 另外安装时,把整个流程在脑子里先过一篇(记不全也没关系,一回生二回熟),重在 ...

  7. 转载:centos上yum安装apache+php+mysql等

    1. 更新系统内核到最新. [root@linuxfei ~]#yum -y update 系统更新后,如果yum安装时提示错误信息,请执行以下命令修复. [root@linuxfei ~]#rpm ...

  8. [转]Centos6.5使用yum安装mysql—配置MySQL允许远程登录

    一.mysql安装 第1步.yum安装mysql[root@stonex ~]#  yum -y install mysql-server安装结果:Installed:    mysql-server ...

  9. CentOS7 yum安装zabbix3.2.6

    前言: 本人小白,在一个多月前通过面试进入公司,在进入公司的第一天,老板把我叫到他办公室,坐下来慢慢喝茶,吹牛,给我吹他们以前做的软件,经营的产品,还装作一副什么都告诉我的样子,其实这都是套路,我早已 ...

随机推荐

  1. spring与quartz定时器

    参考: http://www.iteye.com/topic/399980 http://www.cnblogs.com/xrab/p/5850186.html

  2. 【中间件安全】Tomcat 安全加固规范

    1. 适用情况 适用于使用Tomcat进行部署的Web网站. 2. 技能要求 熟悉Tomcat配置操作,能够利用Tomcat进行建站,并能针对站点使用Tomcat进行安全加固. 3. 前置条件 1.根 ...

  3. 《精通Python网络爬虫》

    抓包工具 Fiddler 爬虫的浏览器伪装技术 Python Scrapy 框架

  4. sqlzoo需要知道的那些事

    1.“Bahamas 巴哈馬”中有三個 a,還有嗎?找出所有國家,其名字包括三個或以上的a. SELECT name FROM world WHERE name LIKE '%a%a%a%' 2.“I ...

  5. 正确停掉 expdp 或 impdp

    1.查看视图dba_datapump_jobs SQL> set line 200 SQL> select job_name,state from dba_datapump_jobs; J ...

  6. Ubuntu下SSH无密码验证配置

    前言 SSH为Secure Shell 的缩写,是目前较可靠,专为远程登录会话和其他网络服务提供安全性的协议.越来越多的小伙伴们使用远程登录,而ssh安全性无疑是很高的,那么我们现在来看看如何实现ss ...

  7. A - 取(m堆)石子游戏

    m堆石子,两人轮流取.只能在1堆中取.取完者胜.先取者负输出No.先取者胜输出Yes,然后输出怎样取子.例如5堆 5,7,8,9,10先取者胜,先取者第1次取时可以从有8个的那一堆取走7个剩下1个,也 ...

  8. 移动端H5混合开发,Touch触控,拖拽,长按, 滑屏 实现方案

    概述 近期由于产品快速原型开发的需要,不想用原声的方式开发App两端一起搞时间来不及,目前产品处于大量上feature的阶段,采用混合开发是最合适的选择,所以花了3天的时间研究怎么去实现移动端,拖拽, ...

  9. Docker之OVS网络

    OVS介绍 什么是OpenVSwich? OpenvSwich:开放虚拟交换标准,是一种基于开源Apache2.0许可证的多层软件交换机,专门管理多租赁云计算网络环境,支持KVM.Xen等虚拟化技术. ...

  10. 9月16日,base 福州,2018MAD技术论坛邀您一起探讨最前沿AR技术!

    “ 人工智能新一波浪潮带动了语音.AR等技术的快速发展,随着智能手机和智能设备的普及,人机交互的方式也变得越来越自然. 9月16日,由网龙网络公司.msup联合主办的MAD技术论坛将在福州举行.本次论 ...