MySQL5.6启动报错The server quit without updating PID file
Mysql启动报错如下:
[root@db01 opt]# service mysqld start
Starting MySQL.... ERROR! The server quit without updating PID file (/opt/mysql-5.6.24/data/mysql.pid).
查看错误日志,发现问题根源在于下面红色部分:
2017-08-26 01:45:44 8525 [Note] InnoDB: Initializing buffer pool, size = 256.0M
2017-08-26 01:45:44 8525 [Note] InnoDB: Completed initialization of buffer pool
2017-08-26 01:45:44 8525 [Note] InnoDB: Highest supported file format is Barracuda.
2017-08-26 01:45:44 8525 [Note] InnoDB: 128 rollback segment(s) are active.
2017-08-26 01:45:44 8525 [Note] InnoDB: Waiting for purge to start
2017-08-26 01:45:44 8525 [Note] InnoDB: 5.6.24 started; log sequence number 1626194
2017-08-26 01:45:44 8525 [ERROR] --gtid-mode=ON or UPGRADE_STEP_1 requires --enforce-gtid-consistency
2017-08-26 01:45:44 8525 [ERROR] Aborting
2017-08-26 01:45:44 8525 [Note] Binlog end
2017-08-26 01:45:44 8525 [Note] Shutting down plugin 'rpl_semi_sync_slave'
2017-08-26 01:45:44 8525 [Note] Shutting down plugin 'rpl_semi_sync_master'
2017-08-26 01:45:44 8525 [Note] unregister_replicator OK
2017-08-26 01:45:44 8525 [Note] Shutting down plugin 'partition'
2017-08-26 01:45:44 8525 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
2017-08-26 01:45:44 8525 [Note] Shutting down plugin 'BLACKHOLE'
2017-08-26 01:45:44 8525 [Note] Shutting down plugin 'INNODB_SYS_DATAFILES'
解决办法:将/etc/my.cnf文件参数注释掉:
#gtid-mode = ON
#enforce-gtid-consistency = 1
重新启动mysql,成功。
MySQL5.6启动报错The server quit without updating PID file的更多相关文章
- mysql启动报错 The server quit without updating PID file
[root@uz6542 data]# /etc/init.d/mysqld startStarting MySQL... ERROR! The server quit without updatin ...
- mysql启动报错The server quit without updating PID file
现网mysql无法启动是很让人头疼的,数据很有可能恢复不了,解决方法如下: 查看mysql目录下的日志,根据日志来锁定错误原因(mysql的错误日志很抽象) a.如果日志不能提供任何帮助则可进行以下步 ...
- lnmp下启动mysql报错 The server quit without updating PID file
启动时候错误代码:Starting MySQL[FAIL.] The server quit without updating PID file (/var/run/mysqld/mysqld.pid ...
- Mysql启动报错 The server quit without updating PID
[root@db mysql]# service mysql restartMySQL server PID file could not be found![失败]Starting MySQL... ...
- Mysql启动失败 MYSQL:The server quit without updating PID file
MySQL5.6启动时出错 提示MYSQL:The server quit without updating PID file 首先执行 /bin/mysqld_safe --user=mysql & ...
- 启动mysqld报 mysql the server quit without updating pid file
查看mysql服务器的错误日志有一句: InnoDB: mmap(137363456 bytes) failed; errno 12 原来是内存不够用(需要131MB)呀,把my.cnf中的innod ...
- 启动MySql提示:The server quit without updating PID file(…)失败
1.可能是/usr/local/mysql/data/rekfan.pid文件没有写的权限解决方法 :给予权限,执行 "chown -R mysql:mysql /var/data" ...
- 数据库启动失败:The server quit without updating PID file
1.可能是/usr/local/mysql/data/mysql.pid文件没有写的权限解决方法 :给予权限,执行 “chown -R mysql:mysql /var/data” “chmod -R ...
- 缺乏libaio包导致报The server quit without updating PID file
背景: 直接解压安装mysql5.7.18,解压mysql-5.7.18-linux-glibc2.5-x86_64.tar.gz,直接拷贝另外一台数据库的数据目录,启动mysql过程无日志输出,报E ...
随机推荐
- 判断js数组包是否包含某个元素
要判断数组中是否包含某个元素,从原理来来说,就是遍历整个数组,然后判断是否相等,我们来造个轮子,名字就山寨PHP的数组函数in_array() Array.prototype.in_array = f ...
- golang----GC的实现原理
Golang从1.5开始引入了三色GC, 经过多次改进, 当前的1.9版本的GC停顿时间已经可以做到极短.停顿时间的减少意味着"最大响应时间"的缩短, 这也让go更适合编写网络服务 ...
- [svc]rsync简单部署
安装rsync服务端-backup服务器 yum install rsync -y useradd rsync -s /sbin/nologin -M chown -R rsync.rsync /da ...
- leetcode笔记:3Sum Closest
一.题目描写叙述 二.解题技巧 该题与3Sum的要求类似.不同的是要求选出的组合的和与目标值target最接近而不一定相等.但实际上,与3Sum的算法流程思路类似,先是进行排序.然后顺序选择数组A中的 ...
- 关于Unity中NGUI的背包实现之Scrollview(基于Camera)
基于UIPanel的scrollview实现方式在移动设备上的性能不如基于camera的方式.因为UIPanel的scrollview实现方式要渲染很多的道具图,性能自然就降低了.如果是用第二个摄像机 ...
- Go指南练习_切片
源地址 https://tour.go-zh.org/moretypes/18 一.练习题描述 实现 Pic.它应当返回一个长度为 dy 的切片,其中每个元素是一个长度为 dx,元素类型为 uint8 ...
- oracle函数详解-转
1.SQL 语句基础 下面给出SQL语句的基本介绍. 1.1.SQL语句所用符号 操作符 用途 例子 + - 表示正数或负数,正数可省去 + -1234.56 + 将两个数或表达式进行相加 A=c+b ...
- Python 中 __all__ 的作用(转)
之前看代码每次遇到import *时就会特别蒙,看到这篇文章一下子就弄明白了,原文地址:https://www.cnblogs.com/alamZ/p/6943869.html 1.测试文件foo.p ...
- Linux系统排查4——网络篇
用于排查Linux系统的网络故障. 网络排查一般是有一定的思路和顺序的,其实排查的思路就是根据具体的问题逐段排除故障可能发生的地方,最终确定问题. 所以首先要问一问,网络问题是什么,是不通,还是慢? ...
- spring quartz1.8.6集群结算服务定时任务与appserver独立分开
1.quartz集群如何处理同一个数据库,同一套sqtz表的lock问题,否则会导致打架. 思路如下: 1.com.xxx.quartz.BeanInvokingJobDetailFactoryBea ...