Unable to load dynamic library 'zip.so' on Centos 6.8 useing php7.3
背景:
Centos6.8服务器升级php版本,从7.1升级到7.3,常用扩展都安装完成之后,报:Class 'ZipArchive' not found。一看就是zip扩展没有,需要手动安装了。
中间一步步,一会说autoconf版本过低,一会说libzip版本过低,又说cmake版本过低,
安装:
安装zip过程中,发现要先安装 libzip1.5,安装 libzip 之前还要安装 cmake,而且这一个个包都有版本过低问题,需要升级,请耐心往下看如何一个一个overcome
参考链接:https://blog.csdn.net/Phplayers/article/details/101083313
以下是我最开始尝试的安装步骤,大家按这个而顺序来,中间出现的失败报错,我都做了记录并给出相应解决方案。
1、准备 php 开发包和扩展库:
yum install php-devel php-pear
2、安装php的zip扩展:(PECL:The PHP Extension Community Library是php的扩展库)
pecl install zip
此处开始若遇到失败,请看下面的“遇到问题 / 解决问题”。
3、开启扩展( vim /etc/php.ini ):
extension=zip.so
zlib.output_compression = On
4、重启服务:
service php-fpm restart
此处若出现警告:PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/zip.so' - libzip.so.5: cannot...
则zip扩展加载失败,仍然会Class 'ZipArchive' not found,解决方案请看下面的“加载zip.so”
###################################################################
遇到问题:
第二步安装zip扩展时报错:
autoconf version 2.64 or higher is required
解决问题
升级autoconf,参考:https://blog.csdn.net/prettyshuang/article/details/51395095
---------------------------------------------------------------------------------------------------------------
遇到问题:
升级autoconf后,继续 pecl install zip 报错:
checking for libzip... not found
configure: error: Please reinstall the libzip
解决问题:
安装或升级libzip,参考:https://www.jianshu.com/p/fdbdf834faca
#删除旧版本
yum remove libzip -y
#安装新版本
wget https://libzip.org/download/libzip-1.5.0.tar.gz
tar -zxvf libzip-*
cd libzip*
mkdir build && cd build && cmake .. && make && make install
---------------------------------------------------------------------------------------------------------------
遇到问题:
安装libzip时报错:
CMake Error at CMakeLists.txt:4 (CMAKE_MINIMUM_REQUIRED):
CMake 3.0.2 or higher is required. You are running version 2.8.12.2
解决问题:
查看Cmake版本: cmake --version
安装CMake:yum install cmake (yum方式通常也会遇到版本过低,可以手动安装)
手动安装请参考:https://www.cnblogs.com/gyfluck/p/10478470.html
安装好cmake后,回去继续安装libzip,然后再接着执行: pecl install zip 。一切顺序的话会在 /usr/lib64/php/modules/ 目录下生成了 zip.so 文件。
###################################################################
加载zip.so
参考链接:https://blog.csdn.net/ren593669257/article/details/100019391
vim /etc/ld.so.conf
include ld.so.conf.d/*.conf # 默认只有这一行
/usr/lib64
/usr/lib
/usr/local/lib
/usr/local/lib64 # 我的只要这行就够了
查看/usr/local/lib64里面的内容

最后一步,使修改生效
sudo ldconfig
重启php-fpm,警告消失。
网上还有一些其他的解决方案,但是我都没成功,比如ln -s建立软链接:
https://www.jianshu.com/p/393c83937949
总结:
网上有很多资料,同样的报错不同的解决方式,一个一个试过来, 最终摸索出一条正确的路,在此做个记录,供有同样问题的人参考
Unable to load dynamic library 'zip.so' on Centos 6.8 useing php7.3的更多相关文章
- PHP启动:动态库加载失败(PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/php7/lib/php/extensions/no-debug-non-zts-20151012/*.so')
今天在linux上面智障一般搞了好久,本来想安装个swoole的,然后用 php -m 的命令想看下安装的PHP扩展库,发现有的扩展库有的可以出来,有的加载失败, 加载失败的错误类型: PHP Wa ...
- PHP Startup: Unable to load dynamic library
昨天帮一朋友配置服务器结果发现apache日志中有PHP Warning: PHP Startup: Unable to load dynamic library 提示了,然后调试数据库连接发现提示C ...
- 安装完 swoole 后出现 PHP Warning: PHP Startup: Unable to load dynamic library 'swoole.so'的解决方法
安装完 swoole 后出现 PHP Warning: PHP Startup: Unable to load dynamic library 'swoole.so' (tried: /home/s ...
- ***XAMPP:报错 Unable to load dynamic library的解决方法
A PHP Error was encountered Severity: Core Warning Message: PHP Startup: Unable to load dynamic libr ...
- PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/event.so'
这是因为启动apche 的时候重复加载了php的动态库模块了, 将:/etc/php.d/ 目录下的event.ini中的内容注释掉或者将文件删除即可
- PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/php_mbstring.dll' 的解决方法
step 1: cd /etc/php/{$yourphpversion}/cli step 2: sudo vim php.ini step 3: 在extension=php_mbstring.d ...
- PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/phalcon.so' - /usr/lib64/php/mod
这个警告可能是,扩展在php.d里面加载了一遍,然后又在php.ini里写了一遍导致的
- PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/redis.so' - /usr/lib64/php/modules/redis.so: undefined symbol: igbinary_serialize in Unknown on line 0
网上找到两种解决方法, 1.先删除php-pecl-redis,再用pecl install redis 2.安装php-igbinary模块,不过我安装时包冲突了,没有安装成功,所以用了第一种方法
- PHP错误日志文件Warning:PHP Startup: Unable to load dynamic library...
由于我的环境是通过源码编译安装的,安装的时候配置信息和一些其他扩展没安装或设置好: php.err文件一直有这些提示,虽然不影响服务启动,但是看着心好累啊,决定要消灭他们. 问题描述: 出现原因: 上 ...
随机推荐
- JAVA一个文件写多个类
JAVA一个文件写多个类,并且是同级类,需注意: 在一个.java文件中可以有多个同级类, 其修饰符只可以public/abstract/final/和无修饰符 public修饰的只能有一个,且必须 ...
- HTML水平居中和垂直居中的实现方式
父元素是块元素,根据子元素不同分为以下几种: 1.子元素是行内元素: a.水平居中:在父元素上设置text-align:center; b.垂直居中:在行内子元素上设置行高与父元素相同line-hei ...
- Oracle package demo 包
1.package 程序包说明(由函数.过程.变量.常量.游标和异常组成) create or replace package pk_test is -- Author : CHEN -- Creat ...
- alert(1) to win 7
function escape(s) { // Pass inn "callback#userdata" var thing = s.split(/#/); if (!/^[a-z ...
- php 调用远程url
// ; Whether to allow the treatment of URLs (like http:// or ftp://) as files. // ; http://php.net/a ...
- mysql 通过navicat 添加函数或者过程
1. 添加函数时, 函数参数的 varchar(255) 一定要加上 255,返回也要加.不加一直保存不了,狂试: 2. 添加过程时, 进入课程体 编辑时 也要加上 varchar 的位数限制.不 ...
- 转载-使用Nodepad++来编辑我们服务器的配置文件
转自------------------ 作者:李阿昀 来源:CSDN 原文:https://blog.csdn.net/yerenyuan_pku/article/details/73128819 ...
- BZOJ 2286: [Sdoi2011]消耗战 虚树
Description 在一场战争中,战场由n个岛屿和n-1个桥梁组成,保证每两个岛屿间有且仅有一条路径可达.现在,我军已经侦查到敌军的总部在编号为1的岛屿,而且他们已经没有足够多的能源维系战斗,我军 ...
- sublime px转rem插件
http://www.cnblogs.com/phoebewang00/p/5593699.html lime 插件- px 转rem 一个CSS的px值转rem值的Sublime Text 3自 ...
- BUUCTF | [CISCN2019 华北赛区 Day1 Web1]Dropbox
步骤: 1.运行这个: <?php class User { public $db; } class File { public $filename; } class FileList { pr ...