weblogic10.3.6 自动启动服务后停止的解决方案
windows部署weblogic后,需要手动开启weblogic管理员服务器,即Start Admin Server for Weblogic Server Domain,不过这样的话每次重启或者不小心就关掉了cmd窗体,很不方便。幸好weblogic本身可以实现通过windows服务自动启动weblogic管理员服务器。
Weblogic的版本为10.3.6,在用installSvc.cmd安装服务后,自动启动服务时,提示如下 服务自动停止的错误。

安装服务的具体操作如下
编辑安装目录 C:\Oracle\Middleware\wlserver_10.3\server\bin里的installSvc.cmd文件,在
rem *** Install the service
"%WL_HOME%\server\bin\beasvc" -install -svcname:"beasvc %DOMAIN_NAME%_%SERVER_NAME%" -javahome:"%JAVA_HOME%" -execdir:"%USERDOMAIN_HOME%" -maxconnectretries:"%MAX_CONNECT_RETRIES%" -host:"%HOST%" -port:"%PORT%" -extrapath:"%EXTRAPATH%" -password:"%WLS_PW%" -cmdline:%CMDLINE%
代码前面 加上以下几句话
set JAVA_HOME=C:\Program Files\Java\jdk1.7.0_45
set DOMAIN_NAME=BASE_DOMAIN
set SERVER_NAME=AdminServer
set USERDOMAIN_HOME=C:\Oracle\Middleware\user_projects\domains\base_domain
set WLS_USER=weblogic
set WLS_PW=Pass@word1
JAVA_HOME即java JDK的安装目录,DOMAIN_NAME即weblogic server的域的名称(登录weblogic查看域),SERVER_NAME即weblogic 服务器的实例的名称(登录weblogic查看服务器),USERDOMAIN_HOME即当前登录用户域所在目录,WLS_USER和WLS_PW是登录weblogic的用户名和密码。
加上之后,以管理员身份打开cmd命令窗口,执行以下命令(每一行是一条命令)
cd C:\Oracle\Middleware\wlserver_10.3\server\bin
installSvc.cmd
之后在启动时,就遇上面图中的错误,现在说一下解决方案:
首先呢,在命令窗口执行如下命令(每一行是一条命令),进行服务的启动调试
cd C:\Oracle\Middleware\wlserver_10.3\server\bin
beasvc -debug "beasvc BASE_DOMAIN_AdminServer"
这时系统会提示服务启动不了得具体原因,如下图所示

这是提示unable to locate java.dll in c:\program files\java\jdk1.7.0_45\bin\jre\bin!,看黑色加粗部分我们可知,是我们的java环境路径不对,我们在installSvc.cmd里面搜索JAVA_HOME 发现JAVA_HOME变量让我设置错了,多加了一个bin,具体如下代码
set JAVA_HOME=C:\Program Files\Java\jdk1.7.0_45\bin
重新安装服务,运行beasvc -debug "beasvc BASE_DOMAIN_AdminServer"命令后,发现如下错误

这是我们注册表注册服务的时候出了问题,regedit打开注册表,找到HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\beasvc BASE_DOMAIN_AdminServer\Parameters,在CmdLine这个属性处,我们发现有个-client,具体如下图

编辑此属性,去除-client,重新运行服务,发现一切正常了.
另外今天(2014-3-14)在注册另一台机器weblogic的windows服务的时候,报这个错误

然后按要求打开注册表 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\beasvc BASE_DOMAIN_AdminServer\Parameters,把cmdline的-client去掉后,还是不可以,然后发现JAVAHOME的键值有些异常,如下图所示

果断去掉JAVAHome键值中路径的set beasvc……的值,重启服务,但过了一会还是自动停止。 于是卸载掉服务,重新安装,发现在安装文件installsvc.CMD里有句话写错了,具体如下

换行后,正常。
卸载服务
卸载此服务命令的方法如下,找到C:\Oracle\Middleware\wlserver_10.3\server\bin里的uninstallSvc.cmd
编辑里面的
"%WL_HOME%\server\bin\beasvc" -remove -svcname:"beasvc %DOMAIN_NAME%_%SERVER_NAME% 修改为
"%WL_HOME%\server\bin\beasvc" -remove -svcname:"beasvc BASE_DOMAIN_AdminServer"
(beasvc BASE_DOMAIN_AdminServer为你的服务名)
在命令窗口运行如下命令(每一行是一条命令),
cd C:\Oracle\Middleware\wlserver_10.3\server\bin
uninstallSvc.cmd
weblogic10.3.6 自动启动服务后停止的解决方案的更多相关文章
- 本地计算机 上的 OracleOraDb11g_home1TNSListener 服务启动后停止
今天玩oracle的时候突然遇到一个问题:本地计算机 上的 OracleOraDb11g_home1TNSListener 服务启动后停止.某些服务在未由其他服务或程序使用时将自动停止. 在网上找解决 ...
- MySQL 安装和启动服务,“本地计算机 上的 MySQL 服务启动后停止。某些服务在未由其他服务或程序使用时将自动停止。”
MySQL 安装和启动服务,以及遇到的问题 MySQL版本: mysql-5.7.13-winx64.zip (免安装,解压放到程序文件夹即可,比如 C:\Program Files\mysql-5. ...
- 本地计算机 上的 Redis Server 服务启动后停止
服务器上Redis服务安装正常..却启动不了.. 报错 : 本地计算机 上的 Redis Server 服务启动后停止.某些服务在未由其他服务或程序使用时将自动停止. 最后发现是Redis的配置 ...
- (转)解决:本地计算机 上的 OracleOraDb10g_home1TNSListener服务启动后停止
原文地址:http://justsee.iteye.com/blog/1320059 手动启动一个问题:本地计算机 上的 OracleOraDb10g_home1TNSListener服务启动后停止. ...
- 本地计算机上的OracleOraDb11g_home1TNSListener服务启动后停止。某些服务在未由其他服务或程序使用时将自动停止。——Oracle监听器服务无法启动!
问题: oracle服务设置为手动启动.但是开机后手动启动监听服务后弹出框,提示“本地计算机上的OracleOraDb11g_home1TNSListener服务启动后停止.某些服务在未由其他服务或程 ...
- 本地计算机上的XXX服务启动后停止。某些服务在未由其它服务或程序使用时将自动停止。咋整?
用C#写个windows服务,安装部署后去启动时,提示说“本地计算机上的XXX服务启动后停止.某些服务在未由其它服务或程序使用时将自动停止”.咋整?就像下面酱紫: 度娘说不知道咋整,我想把程序附加到w ...
- win10出现"本地计算机上的MySQL57服务启动后停止"
在window10下mysql57出现"本地计算机上的MySQL57服务启动后停止.某些服务在未由其他服务或程序使用时将自动停止"错误 环境:win10.MySQL Communi ...
- 本机mysql 5.7服务启动后停止,某些服务在未有其他应用程序使用时停止
本机mysql 5.7服务启动后停止,某些服务在未有其他应用程序使用时停止 出现这种报错,mysql服务启动不了: 错误的尝试: 1:尝试了这个博客:https://blog.csdn.net/wai ...
- 本地计算机上的MySQL服务启动后停止。某些服务在未由其他服务或程序使用时将自动
重新安装MySQL数据库,由于安装的时候马虎,一路next(事实上,某些地方需要严格的配置,我忘记注意了),导致现在出了很多麻烦. 错误信息: 本地计算机上的MySQL服务启动后停止.某些服务在未由其 ...
随机推荐
- shell字符串判空
主要用到两个命令 -n -z if [ -n "$PID" ]; then echo "PID is not empty" fi if[ -z "$ ...
- PHP基于数组的分页函数(核心函数array_slice())
关于数组的分页函数,用数组进行分页的好处是可以方便的进行联合多表查询,只需要将查询的结果放在数组中就可以了以下是数组分页的函数,函数page_array用于数组的分页,函数show_array用于分页 ...
- NK3C开发要点
1.业务逻辑:文档, 2.后端资料 框架:spring + mybatis + maven + Shiro + 数据库(Oracle.SQL Server.MySQL) 分层:nmodel,ndal, ...
- Android IOS WebRTC 音视频开发总结(六七)-- 在线教育虽火要做好其实不容易
本文主要介绍在线教育这个行业,文章最早发表在我们的微信公众号上,支持原创,详见这里, 欢迎关注微信公众号blackerteam,更多详见www.rtc.help 最近很多朋友在咨询在线教育的事(其实之 ...
- java学习第10天 (增加关于eclipse添项目)
自己遇到一个问题..觉得有必要说下,就是如何将别人发给你的文件也就是项目如何导入到你的eclipse中,不是直接add那么简单,首先右键找到import,找到general,展开找到existing ...
- http的响应对象
Servlet 服务器 HTTP 响应 正如前面的章节中讨论的那样,当一个 Web 服务器响应一个 HTTP 请求时,响应通常包括一个状态行.一些响应报头.一个空行和文档.一个典型的响应如下所示: H ...
- 使用nssm在windows服务器上部署nodejs
Linux上,可以轻松的使用forever或者pm2来部署nodejs应用.但是在windows下就麻烦了,pm2明确的说支持Linux & MacOS,forever在windows下貌似问 ...
- centos安装mysql5.6的正确姿态
1.准备工作 a)卸载centos默认软件 yum remove mariadb-libs-5.5.35-3.el7.x86_64 b)安装依赖包 yum install -y perl-Module ...
- 分布式HBase-0.98.4环境搭建
fesh个人实践,欢迎经验交流!Blog地址:http://www.cnblogs.com/fesh/p/3804072.html 本文有点简单,详细版本请参见<分布式Hbase-0.98.4在 ...
- LeetCode:Longest Palindromic Substring 最长回文子串
题目链接 Given a string S, find the longest palindromic substring in S. You may assume that the maximum ...