从svn上下的项目,部署到tomcat 7.0.19 上, 并且配置的是jdk7.  启动时出现以下问题。

Location:

com/genlot/loms/service/SysPermissionService.getPermissionCollection(Ljava/lang/Long;Z)Ljava/util/Collection; @19: ifnull

Reason:

   Expected stackmap frame at this location.

Bytecode:

0000000: 2ab4 01ec 2bb6 01ee 4ebb 01f4 59b7 01f6

0000010: 3a04 2dc6 010b 2ab4 01f7 2bb6 01f9 3a05

0000020: 1905 c700 0cbb 00a8 59b7 00aa 3a05 b201

0000030: fe2d b802 04b6 020a 9a00 a219 052a b401

0000040: f7b2 020b b602 11b9 0215 0200 571c 9a00

0000050: 1919 042a b200 5a2d b802 19b6 0183 b600

0000060: 50b9 021f 0200 5719 042a b202 202d b802

0000070: 23b6 0050 b902 1f02 0057 1904 2ab2 0227

0000080: 2db8 022a b600 50b9 021f 0200 5719 042a

0000090: b202 2d2d b802 04b6 0230 b600 50b9 021f

00000a0: 0200 5719 042a b202 312d b802 34b6 0050

00000b0: b902 1f02 0057 1302 372a b402 39b6 00af

00000c0: 9900 1a19 0413 023b b902 3d02 0057 1904

00000d0: 2db8 0234 b902 3d02 0057 1905 b900 7301

00000e0: 003a 07a7 0031 1907 b900 7901 00c0 023e

00000f0: 3a06 1906 b802 40b2 0246 a500 1a19 042a

0000100: b201 5519 06b8 0249 b601 83b6 0050 b902

0000110: 1f02 0057 1907 b900 f401 009a ffcb 1904

0000120: b0

at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveReference(BeanDefinitionValueResolver.java:334)

at 。。。。。。。

五月 05, 2016 9:01:28 下午 org.apache.catalina.startup.HostConfig deployDirectory

信息: Deploying web application directory D:\apache-tomcat-7.0.62\webapps\ROOT

五月 05, 2016 9:01:28 下午 org.apache.catalina.startup.HostConfig deployDirectory

信息: Deployment of web application directory D:\apache-tomcat-7.0.62\webapps\ROOT has finished in 47 ms

五月 05, 2016 9:01:28 下午 org.apache.coyote.AbstractProtocol start

信息: Starting ProtocolHandler ["http-bio-8080"]

五月 05, 2016 9:01:28 下午 org.apache.coyote.AbstractProtocol start

信息: Starting ProtocolHandler ["ajp-bio-8009"]

五月 05, 2016 9:01:28 下午 org.apache.catalina.startup.Catalina start

信息: Server startup in 14226 ms

解决办法: 修改jvm参数。添加 -XX:-UseSplitVerifier

打开springSource Tool suite( sts) (有些可能使用的是eclipse ) -----》 windows---> preferences--->java --- > installed JREs --- 选择你的jdk, 点击 edit  , 添加上面的参数 

启动Tomcat时报 Expected stackmap frame at this location.(JDK1.7编译)的更多相关文章

  1. Expected stackmap frame at this location

    使用eclipse,本来使用的是jdk1.7的,后来切换到jdk1.8版本就出现了这个问题,报错的Reason说的是Expected stackmap frame at this location,其 ...

  2. 用普通用户通过sudo进行启动tomcat时报如下异常

    用普通用户通过sudo进行启动tomcat时报如下异常 tomcat user 不在 sudoers 文件中.此事将被报告. 这是由于sudo命令使用root用户执行命令.而处于安全性的考虑,一般不允 ...

  3. MyEclipse 启动tomcat时报错:Cannot change deployment state from ERROR to REDEPLOYING.ds

    myeclipse 启动tomcat时报错:Cannot change deployment state from ERROR to REDEPLOYING.ds - 刘琦的专栏 - 博客频道 - C ...

  4. 启动tomcat时报classpath not found

    启动tomcat时报classpath  not found 原因是缺包,首先查看tomcat安装地址,然后找到webapps目录下,找到该项目,看lib下是否缺包,不能单纯的看项目下是否缺包.

  5. 用Eclipse的tomcat插件启动tomcat时报错:

    用Eclipse的tomcat插件启动tomcat时报错: FATAL ERROR in native method: JDWP No transports initialized, jvmtiErr ...

  6. 解决Eclipse启动Tomcat时报Error loading WebappClassLoader错误

    最近新建了一个JSF项目(网上查到用Struts,Spring MVC也会如此),配置好以后用Eclipse启动Tomcat报了如下错误:严重: Error loading WebappClassLo ...

  7. Eclipse启动tomcat时报错:Multiple Contexts have a path of "/xxx"

    今天使用Eclipse启动tomcat部署项目时,遇到一个奇怪的错误: Could not publish server configuration for Tomcat v6.0 Server at ...

  8. 启动tomcat时报错:http-nio-8080-exec-10

    启动Tomcat后访问  http://192.168.199.10:8080/jpress-web-newest  网页,查看日志有报错 问题原因:Java的内存溢出 故障现象为: cat /app ...

  9. eclipse启动Tomcat时报错:严重: Exception loading sessions from persistent storage

    我的项目工程是Spring+hibernate+structs  1.0,最近启动tomcat时多次遇到如下异常: 严重: IOException while loading persisted se ...

随机推荐

  1. 《JS高程》中的正则的复杂模式的总结

    复杂模式: *分组: var reDogDog=/dogdog/g;---------------var reDogDog=/(dog){2}/g; *引用:(注意带括号和不带括号) var sMat ...

  2. 慕课网-Java入门第一季-6-7 使用 Arrays 类操作 Java 中的数组

    来源:http://www.imooc.com/code/1556 Arrays 类是 Java 中提供的一个工具类,在 java.util 包中.该类中包含了一些方法用来直接操作数组,比如可直接实现 ...

  3. socket模块的getaddrinfo方法详解

    getaddrinfo方法用于通过url解析dns import sys,socket def dns_resolver(url): result = socket.getaddrinfo(url, ...

  4. AX7: Install a deployable package

    Table of Contents Introduction Key concepts Collect topology configuration data Generate a runbook f ...

  5. sublimetext 3 set

    from https://segmentfault.com/a/1190000002596724{ "font_size": 21, "highlight_line&qu ...

  6. SQLAlchemy模型使用

    SQLAchemy模型使用 简介: SQLAlchemy是Python编程语言下的一款ORM框架,该框架建立在数据库API之上,使用关系对象映射进行数据库操作,简言之便是:将对象转换成SQL,然后使用 ...

  7. 19.dnw打不开

    用dnw.exe烧写文件时,突然出现电脑死机,重启后,dnw就打不开了,dnw.ini的原因,该文件在c盘目录下,只需要删除它,就可以继续使用dnw了.

  8. 14.S5PV210串行通信编程实战

    1.整个程序流程分析(1)整个串口通信相关程序包含2部分:uart_init负责初始化串口,uart_putc负责发送一个字节2.串口控制器初始化关键步骤(1)初始化串口的Tx和Rx引脚所对应的GPI ...

  9. 使用Birt开发报表

    间隔一段时间未使用Birt开发报表后,本文章记录Birt开发报表的常遇到的开发问题及解决措施,方便自己和园内其他朋友学习. 一.Birt连接数据库配置 1.连接DB2数据库: 1.1.birt的数据连 ...

  10. MIME Sniffing

    Abstract: The web.config file does not include the required header to mitigate MIME sniffing attacks ...