DNS中的协议字段定义

1 概述

总结DNS协议中各字段的取值

2 DNS Classes

Decimal Name Reference
0 Reserved RFC6895
1 Internet(IN) RFC1035
2 Unassigned  
3 Chaos(CH)  
4 Hesiod(HS)  
5-253 Unassigned  
254 QCLASS NONE RFC2136
255 QCLASS * (ANY) RFC1035
256-65279 Unassigned  
65280-65534 Reserved for Private Use RFC6895
65535 Reserved RFC6895

3 DNS OpCodes

OpCode Name Reference
0 Query RFC1035
1 IQuery(Inverse Query) RFC3425
2 Status RFC1035
3 Unsassined  
4 Notify RFC1996
5 Update RFC2136
6-15 Unassigned  

4 DNS RCODEs

Rcode Name Description Reference
0 NoError No Error RFC1035
1 FormErr Format Error RFC1035
2 ServFail Server Failure RFC1035
3 NXDomain Non-Existent Domain RFC1035
4 NotImp Not Implemented RFC1035
5 Refused Query Refused RFC1035
6 YXDomain Name Exists when it should not RFC2136
7 YXRRSet RR Set Exists when it should not RFC2136
8 NXRRSet RR set that should exist does not RFC2136
9 NotAuth Server Not Authoritative for zone RFC2136
10 NotZone Not AUthorized RFC2845
11-15 Unassigned    
16 BADVERS Bad OPT Version RFC6891
16 BADSIG TSIG Signature Failure RFC2845
17 BADKEY Key not revognized RFC2845
18 BADTIME Signature out of time window RFC2845
19 BADMODE Bad TKEY Mode RFC2930
20 BADNAME Duplicate key name RFC2930
21 BADALG Algorithm not supported RFC2930
22 BADTRUNC Bad Truncation RFC4635
23-3840 Unassigned    
3841-4095 Reserved for Private Use    
4096-65534 Unassigned    
65535 Reserved    

5 DNS Label Types

DNS label的最高两位来标识该label的类型

Value Type Status Reference
0 0 普通label. 低6位是该label的长度 Standard RFC1035
1 1 压缩label. 低6位和接下来的8位标识它相对于包头的偏移量 Standard RFC1035
0 1 扩展类型的label. 低6位表示label的类型那个 Standard RFC1035
1 0 未分配    

6 DNS资源记录

TYPE Value Meaning Reference
A 1 a host address [RFC1035]
NS 2 an authoritative name server [RFC1035]
MD 3 a mail destination(OBSOLETE - use MX) [RFC1035]
MF 4 a mail forwarder(OBSOLETE - use MX) [RFC1035]
CNAME 5 the canonical name for an alias [RFC1035]
SOA 6 marks the start of a zone of authority [RFC1035]
MB 7 a mailbox domain name (EXPERIMENTAL) [RFC1035]
MG 8 a mail group member (EXPERIMENTAL) [RFC1035]
MR 9 a mail rename domain name (EXPERIMENTAL) [RFC1035]
NULL 10 a null RR (EXPERIMENTAL) [RFC1035]  
WKS 11 a well known service description [RFC1035]
PTR 12 a domain name pointer [RFC1035]
HINFO 13 host information [RFC1035]
MINFO 14 mailbox or mail list information [RFC1035]
MX 15 mail exchange [RFC1035]
TXT 16 text strings [RFC1035]
RP 17 for Responsible Person [RFC1183]
AFSDB 18 for AFS Data Base location [RFC1183][RFC5864]
X25 19 for X.25 PSDN address [RFC1183]
ISDN 20 for ISDN address [RFC1183]
RT 21 for Route Through [RFC1183]
NSAP 22 for NSAP address, NSAP style A record [RFC1706]
NSAP-PTR 23 for domain name pointer, NSAP style [RFC1348][RFC1637][RFC1706]
SIG 24 for security signature  
KEY 25 for security key  
PX 26 X.400 mail mapping information [RFC2163]
GPOS 27 Geographical Position [RFC1712]
AAAA 28 IP6 Address [RFC3596]
LOC 29 Location Information [RFC1876]
NXT 30 Next Domain (OBSOLETE) [RFC3755][RFC2535]
EID 31 Endpoint Identifier  
NIMLOC 32 Nimrod Locator  
SRV 33 Server Selection [RFC2782]
ATMA 34 ATM Address  
NAPTR 35 Naming Authority Pointer [RFC2915][RFC2168][RFC3403]
KX 36 Key Exchanger [RFC2230]
CERT 37 CERT [RFC4398]
A6 38 A6 (OBSOLETE - use AAAA) [RFC3226][RFC2874][RFC6563]
DNAME 39 DNAME [RFC6672]
SINK 40 SINK  
OPT 41 OPT [RFC6891][RFC3225]
APL 42 APL [RFC3123]
DS 43 Delegation Signer [RFC4034][RFC3658]
SSHFP 44 SSH Key Fingerprint [RFC4255]
IPSECKEY 45 IPSECKEY [RFC4025]
RRSIG 46 RRSIG [RFC4034][RFC3755]
NSEC 47 NSEC [RFC4034][RFC3755]
DNSKEY 48 DNSKEY [RFC4034][RFC3755]
DHCID 49 DHCID [RFC4701]
NSEC3 50 NSEC3 [RFC5155]
NSEC3PARAM 51 NSEC3PARAM [RFC5155]
TLSA 52 TLSA [RFC6698]
Unassigned 53-54    
HIP 55 Host Identity Protocol [RFC5205]
NINFO 56 NINFO [JimReid]
RKEY 57 RKEY [JimReid]
TALINK 58 Trust Anchor LINK [WouterWijngaards]
CDS 59 Child DS [GeorgeBarwood]
Unassigned 60-98    
SPF 99 [RFC-ietf-spfbis-4408bis-21]  
UINFO 100 [IANA-Reserved]  
UID 101 [IANA-Reserved]  
GID 102 [IANA-Reserved]  
UNSPEC 103 [IANA-Reserved]  
NID 104 [RFC6742]  
L32 105 [RFC6742]  
L64 106 [RFC6742]  
LP 107 [RFC6742]  
EUI48 108 an EUI-48 address [RFC7043]
EUI64 109 an EUI-64 address [RFC7043]
Unassigned 110-248    
TKEY 249 Transaction Key [RFC2930]  
TSIG 250 Transaction Signature [RFC2845]
IXFR 251 incremental transfer [RFC1995]
AXFR 252 transfer of an entire zone [RFC1035][RFC5936]
MAILB 253 mailbox-related RRs (MB, MG or MR) [RFC1035]
MAILA 254 mail agent RRs (OBSOLETE - see MX) [RFC1035]
* 255 all records the server/cache has available [RFC1035][RFC6895]
URI 256 URI [PatrikFaltstrom]
CAA 257 Certification Authority Restriction [RFC6844]
Unassigned 258-32767    
TA 32768 DNSSEC Trust Authorities  
DLV 32769 DNSSEC Lookaside Validation [RFC4431]
Unassigned 32770-65279    
Private use 65280-65534    
Reserved 65535    

7 EDNS Version

Range Description Reference
0 EDNS version 0 RFC6891
1-255 Unassigned  

8 DNS EDNS0 Option Codes (OPT)

Value Name Status Reference
0 Reserved   [RFC6891]
1 LLQ On-hold [http://files.dns-sd.org/draft-sekar-dns-llq.txt]
2 UL On-hold [http://files.dns-sd.org/draft-sekar-dns-ul.txt]
3 NSID Standard [RFC5001]
4 Reserved    
5 DAU Standard [RFC6975]
6 DHU Standard [RFC6975]
7 N3U Standard [RFC6975]
8 edns-client-subnet Optional  
9-65000 Unassigned    
65001-65534 Reserved for Local/Experimental Use   [RFC6891]
65535 Reserved for future expansion   [RFC6891]

Date: 2014-04-26T12:10+0800

Author: Cobbliu

Org version 7.9.3f with Emacs version 24

DNS 中的协议字段详细定义的更多相关文章

  1. 聊聊GIS中的坐标系|再版 详细定义、计算及高程系统

    本篇讲坐标系统的详细定义,有关坐标系的变换公式,以及简单说说高程坐标系统. 本文约6000字,阅读时间建议45分钟.硬内容比较多,如有疏漏错误请指出,建议有兴趣的朋友进一步阅读. 作者:博客园/B站/ ...

  2. TFS中工作项的定制- 字段功能定义

    参考,翻译此页面All FIELD XML Elements Reference(http://msdn.microsoft.com/en-us/library/ms194953.aspx) 对于每一 ...

  3. 让你提前认识软件开发(19):C语言中的协议及单元測试演示样例

    第1部分 又一次认识C语言 C语言中的协议及单元測试演示样例 [文章摘要] 在实际的软件开发项目中.常常要实现多个模块之间的通信.这就须要大家约定好相互之间的通信协议,各自依照协议来收发和解析消息. ...

  4. HTTP 首部字段详细介绍

    本文是HTTP解析系列第二篇,如果对http协议不是很了解,可以选去看第一篇:带新手走进神秘的HTTP协议,本文主要是对Http的首部字段进行详细解析. HTTP 协议的请求和响应报文中必定包含 HT ...

  5. 无线物联网中CoAP协议的研究与实现【转】

    无线物联网中CoAP协议的研究与实现 时间:2013-04-09 来源:电子科技 作者:汤春明,张 荧,吴宇平 关键字:CoAP   无线   物联网   协议 摘要:由于物联网中的很多设备都是资源受 ...

  6. 聊聊 iOS 开发中的协议

    前言 何为协议,简单来说在OC中我们使用关键字@protocol可以声明一个协议,并在协议中添加多个属性.方法供于遵循者实现,从某个角度上来说,这是一种不同于category机制的category.在 ...

  7. Java进阶(十五)Java中设置session的详细解释

    Java中设置session的详细解释 简单通俗的讲session就是象一个临时的容器,用来存放临时的东西.从你登陆开始就保存在session里,当然你可以自己设置它的有效时间和页面,举个简单的例子: ...

  8. 判断逻辑 先判断协议字段返回,再判断业务返回,最后判断交易状态 API密钥

    [微信支付]微信小程序支付开发者文档 https://pay.weixin.qq.com/wiki/doc/api/wxa/wxa_api.php?chapter=4_1 协议规则 商户接入微信支付, ...

  9. mysql中information_schema.columns字段说明

    1. 获取所有列信息(COLUMNS) SELECT  *  FROM information_schema.COLUMNS WHERE  TABLE_SCHEMA='数据库名';  COLUMNS表 ...

随机推荐

  1. Java Arrays类进行数组排序

    排序算法,基本的高级语言都有一些提供.C语言有qsort()函数,C++有sort()函数,java语言有Arrays类(不是Array).用这些排序时,都可以写自己的排序规则. Java API对A ...

  2. DS28E01芯片解密DS28E01-100单片机解密多少钱?

    DS28E01芯片解密DS28E01-100单片机解密多少钱? DS28E01-100将1024位EEPROM与符合ISO/IEC 10118-3安全散列算法(SHA-1)的质询响应安全认证结合在一起 ...

  3. JAVA Day10

      使用继承 编写继承: class Engineer{ //公共的属性和方法 }   编写子类,继承父类, class SoftEnineer extends Enginerr{ //子类持有的属性 ...

  4. 在visual studio2015中使用easyX画图

    配置:解压EasyX压缩包: 将文件内的include,lib,lib/amd64下的文件拷贝到visualstudio中VC文件夹内对应的地方: 然后再执行上图中的Setup.hta进行安装: 在v ...

  5. 关于HTML5的拖拽

    不介绍具体情况,先看API,注意看后面括号的说明 dragstart:拖拽开始(应用于被拖拽对象) drag:拖拽中(应用于被拖拽对象) dragenter:拖拽到指定位置(应用于拖拽目标) drag ...

  6. WPS 表格筛选两列相同数据

    选出B列中的数据是否在A列中出现:用countif 函数,在 B列右侧插入一列,C1输入 = countif 区域中选择 B列的内容区域(选择后加 按F4),条件选择B列所在的内容区域(选择后按F4) ...

  7. (iOS)Base64加密和DES加密、以及JAVA和iOS中DES加密统一性问题

    我们在项目中为了安全方面的考虑,通常情况下会选择一种加密方式对需要安全性的文本进行加密,而Base64加密和DES64加密是常用的加密算法.我记得我在前一个项目中使用的就是这两种加密算法的结合:Bas ...

  8. block fomating context

    http://www.w3help.org/zh-cn/kb/010/ 它与普通的块框类似,不同之处在于: 1可以包含浮动元素 2可以阻止外边距折叠 3可以防止元素被浮动元素覆盖 placeholde ...

  9. VirtualBox使用总结

    解决VirtualBox安装Mac OS X El Capitan开机卡住问题 在配置完新虚拟机后关闭VirtualBox,用管理员权限启动CMD,转到VirtualBox安装目录,依次运行下列指令: ...

  10. css before,after伪元素妙用

    我们知道,css伪元素包括after,before,first-letter等,通过合理的利用伪元素,我们可以让我们的结构更简洁. 通常写法如p::after{content:' '},其中conte ...