HTTP 500 - 内部服务器错误 

1.jdk版本与Tomcat版本不一样。

   问题: 配置一个Web应用的时候,源文件和server.xml、web.xml的配置都没有问题,但是在访问到一个Servlet的时候,就会出现一个Tomcat500的错误。
刚开始的时候以为是配置的错误,经改正后错误依然,重装Tomcat之后还是照样。无奈中仔细看了错误提示,居然发现错误提示: UnsupportedClassVersionError,
我才恍然大悟,原来自己家里的JDK版本是1.5的。
但公司的JDK版本是1.4的,错误很可能就是因为这个引起的。我重新用JDK1.4编译了这个文件,结果测试就通过了。 当JVM无法识别class文件的版本时,就会出现”UnsupportedClassVersionError”,在访问Web应用时如果出现该错误,是因为在Web应用的WEB-INF/classes目录下
出现了由高于当前JDK版本的class文件,
导致JVM无法识别所致,解决的方法是用低版本的JDK重新编译该源文件
出现500问题时,需要考虑到是不是安装的tomcat版本和自己安装的jdk的版本一致,如果不一致,建议将tomcat换成和jdk一致或者高于jdk版本的tomcat版本。
(比如安装的jdk是1.7,那么tomcat的版本一定要不低于1.7的版本)

2.数据库服务器配置不足

问题:今天发现公司服务器tomcat运行一段时间后会报500的错误,服务器可以正常响应静态资源,但是对于其他所有的操作,就算是一个链接都是报500的错误,求解!
可能性一:服务器错误500,一般都是由于程序导致的,可能你的项目后台运行有问题。
其次可能是tomcat的问题,检查一下,重新配置一个新的服务器;
可能性二:当tomcat并发过高(三台tomcat负载均衡),但是由于数据库的服务器配置不够,拖垮了

3.程序内部错误

500是指程序内部错误,多半是代码有问题

4.jdk和Tomcat的版本位数,端口占用

需要考虑安装的jdk和tomcat是不是都是32位的或者都是64位的,如果不是建议安装同样系统版本的版本。
如果还会出现相关的问题,就需要考虑是否是端口号被占用了,修改tomcat端口的代码在tomcat文件夹中的config文件夹里面的server.xml文件里面。
修改里面的
<Connector  port="8080"               maxHttpHeaderSize=""
maxThreads="" minSpareThreads="" maxSpareThreads=""
enableLookups="false" redirectPort="" acceptCount=""
connectionTimeout="" disableUploadTimeout="true" />
这段代码中的port的值就是端口号,可以修改为8081再重新启动运行。

5.部署WAR文件过大Tomcat7报HTTP Status 500异常 

本准备在Tomcat7.\webapps下部署一个65Mb左右的war包,先后两次都以失败告终。第一次直接将war包上传到文件夹,让它自解压,然后手动安装,
结果安装程序执行到70多个任务就卡住,最终只能停止Tomcat服务,当时不知原因。第二次用manager中的Deploy工具,结果出现如下错误:

message org.apache.tomcat.util.http.fileupload.FileUploadBase$SizeLimitExceededException:the request was rejected because its size (66704562) 
exceeds the configured maximum(52428800)
在%安装目录%\webapps\manager\WEB-INF文件夹下用打开web.xml配置文件,可以看到支持文件大小的限制
<multipart-config>
<!-- 50MB max -->
<max-file-size></max-file-size> <max-request-size></max-request-size> <file-size-threshold></file-size-threshold> </multipart-config> 最大支持50MB上传!
将它改为100MB
<multipart-config>
<!-- 100MB max -->
<max-file-size></max-file-size>
<max-request-size></max-request-size>
<file-size-threshold></file-size-threshold>
</multipart-config>
保存,重启Tomcat服务器。

以上整理自网络网友的错误总结,给各位出现Tomcat 500错误的大婶们提供解决思路。。错误总结不断更新中。。。。

Tomcat 500错误 问题集锦的更多相关文章

  1. Tomcat 400错误 问题集锦

    1.前后台参数类型不一致 上图错误提示就是客户端发送的请求不能找到你的具体的页面或者地址,这是Spring MVC抛出的错误,这样我们就要进行参数的检查,一定是JSP提交的参数和Controller里 ...

  2. JavaWeb错误处理集锦

    一:起因 (1)自己接下来想走算法的路子,打算把十大算法和数学模型学习一下,算是给自己之前 JavaWeb 的一个总结: (2)记得Java算是第一个比較上手的语言了,更是用JavaWeb走过了非常长 ...

  3. 关于http 500错误的小结分享

    一般情况下,http 500内部服务器(HTTP-Internal Server Error)错误说明IIS服务器无法解析ASP代码,访问一个静态页面试试是否也出现这个问题. 如果访问静态页面没问题, ...

  4. Tomcat 配置错误界面

    Tomcat发生错误时跳转到错误页面 注意 :5.0下操作需要删除掉注释语句,不然报错,原因未知 一.修改 tomcat 的配置文件 修改 tomcat 的配置文件,当页面发生错误时跳转到指定的页面, ...

  5. web工程关于500错误

    昨天一直被一个诡异问题困扰,解决了之后开心得的我连玩了一下午,哈哈哈哈哈哈哈哈-- 具体问题是这样的额,本地跑的贼正常,一发到测试服务器就报500错误,具体错误信息是.  HTTP Status 50 ...

  6. iis 7.5 0x80004005 静态文件 html、js、css 500错误

    环境:iis 7.5 win7 64位 vs2012 问题:本地环境F5直接运行,没有任何问题,发布到IIS,静态文件不能访问,出现500错误,网上找了一堆解决办法,排除路径不正确,iis全部功能勾了 ...

  7. apache 使用 .htaccess 导致500错误

    今天在win主机上配置了一个apache+mysql+php 的环境,一切看似正常了.结果将程序转移过来,打开网站的时候,出现了500错误.于是乎查原因: 首先,怀疑的是连接mysql出错了,找出配置 ...

  8. IIS上部署MVC网站,打开后ExtensionlessUrlHandler-Integrated-4.0解决方法IIS上部署MVC网站,打开后500错误

    IIS上部署MVC网站,打开后ExtensionlessUrlHandler-Integrated-4.0解决方法 IIS上部署MVC网站,打开后500错误:处理程序“ExtensionlessUrl ...

  9. ASP出500错误怎么办(理论上并不止500错误,其他错误可以同样可以获得更多信息以帮助解决问题)

    造成500错误常见原因有:ASP语法出错.ACCESS数据库连接语句出错.文件引用与包含路径出错.使用了服务器不支持的组件如FSO等. 为了定位500错误的具体原因,可以这样做: 让IE显示详细的出错 ...

随机推荐

  1. Java String 学习

    String, 首先,String有字面值常量的概念,这个字面值常量是在编译期确定下来的,类加载时直接存入常量池(注意,常量池是类的常量池,类与类之间隔离). 而运行时生成的字符串,是不在常量池中的. ...

  2. C# 使用SkinSharp皮肤库

    SkinSharp是Windows环境下一款强大的通用换肤库. SkinSharp作为通用换肤库,只需要在您的程序中添加一行代码,就能让您的界面焕然一新,并拥有多种主题风格和色调的动态切换功能以及Ae ...

  3. 【Java面试题】53 能不能自己写个类,也叫java.lang.String?

    可以,但是即使你写了这个类,也没有用. 这个问题涉及到加载器的委托机制,在类加载器的结构图(在下面)中,BootStrap是顶层父类,ExtClassLoader是BootStrap类的子类,ExtC ...

  4. 【Java面试题】7 构造器Constructor是否可被override?

    构造器Constructor不能被继承,因此不能重写Override,但可以被重载Overload. Constructor不能被继承,所以Constructor也就不能被override.每一个类必 ...

  5. poj 3414 Pots(广搜BFS+路径输出)

    转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接:id=3414">http://poj.org/probl ...

  6. 反编译工具 jad

    JAD(Java Decompiler)是一个比较流行的Java反编译工具,可以从网站 http://www.varaneckas.com/jad/ 下载,有多个系统下的应用程序,包括Windows. ...

  7. hadoop本地测试命令

    http://www.cnblogs.com/shishanyuan/p/4190403.html if have assign the /etc/profile: hadoop jar /usr/l ...

  8. Adobe Acrobat 不能打开在线pdf。Adobe Acrobat 应用程序正在被终止,因为内存错误

    Adobe Acrobat 应用程序正在被终止,因为内存错误. Adobe Acrobat 不能打开在线pdf. 当出现上面两种错误时. 原因可能是Acrobat的更新有问题. 解决方法:打开C:\D ...

  9. stylus入门使用方法

    https://segmentfault.com/a/1190000002712872

  10. jQuery中animate()的方法以及$(&quot;body&quot;).animate({&quot;scrollTop&quot;:top})不被Firefox支持问题的解决

    转载请注明出处:http://blog.csdn.net/dongdong9223/article/details/50846678 本文出自[我是干勾鱼的博客] jQuery中animate()的方 ...