Mysql5.7主主互备安装配置
一、安装说明
=======================================================================================
环境: 10.1.4.57 Centos7.1
10.1.4.58 Centos7.1
说明:需要root权限,遇到的问题都有说明
- 下载地址:
https://dev.mysql.com/downloads/mysql/(mysql-5.7.17-1.el7.x86_64.rpm-bundle.tar)
2. 压缩
tar xvf mysql-5.7.17-1.el7.x86_64.rpm-bundle.tar
3.安装
a) rpm –ivh mysql-community-libs-5.7.17-1.el7.x86_64.rpm
b) rpm –ivh mysql-community-common-5.7.17-1.el7.x86_64.rpm
c) rpm –ivh mysql-community-client-5.7.17-1.el7.x86_64.rpm
d) rpm –ivh mysql-community-server-5.7.17-1.el7.x86_64.rpm
注意: 1.安装步骤不能乱,先安装依赖
2.如果安装遇到软件矛盾,先把其他软件卸载(yum –e remove ***)
4. 启动
service mysqld start
5. 查找初始密码
vi /var/log/mysqld.log,找到root@localhost 后面就是密码

6. 修改密码(不修改密码控制台输入命令会一直报错)
alter user 'root'@'localhost' identified by 'newpassword';
新版mysql改密码会报错,因为有验证密码的插件,改密码前需要先修改配置
set global validate_password_policy=0;
set global validate_password_length=4;
第一个是把验证规则去掉,第二条修改密码长度,如果不输第二条命令,默认长度为8以上
7. 重启
service mysqld restart
8. 开始配置互备,修改配置文件,主要是设置id,其他是为了可能性的出错
vi /etc/my.cnf
[mysqld]
server-id = 1 #backup这台设置2
log-bin = mysql-bin
binlog-ignore-db = mysql,information_schema #忽略写入binlog日志的库
auto-increment-increment = 2 #字段变化增量值
auto-increment-offset = 1 #初始字段ID为1
slave-skip-errors = all #忽略所有复制产生的错误
9. 重启然后登录
service mysqld restart
mysql –u root –p newpassword
10. 查看状态
show master status;

11. 新建用户复制
mysql> GRANT REPLICATION SLAVE ON *.* TO 'replication'@'192.168.0.%' IDENTIFIED BY 'replication';
mysql> flush privileges;
mysql> change master to
-> master_host='10.1.4.58', #对方ip
-> master_user='replication',
-> master_password='replication',
-> master_log_file='mysql-bin.000001', #对方日志
-> master_log_pos=1334; #对端状态显示的值
mysql> start slave; #启动同步
12. 查看状态
show slave status\G;

图中显示为yes则启动成功.如果显示正在连接则等一会儿再查
结束啦,连接数据库验证就好了
二、一些问题
=======================================================================================
a. 登录root后新建用户(这里设置密码同样需要注意,权限可以不赋全部)
grant all privileges on *.* to ‘dc’@’10.1.4.%’ identified by '123';
b. 查看
show databases;

use mysql;
select Host,user from user;

可以看到用户和访问的机器,’%’代表所有,正常新建用户后需要更改这个值才可以在其他机器上访问
update user set Host = ‘%’ where user = ‘dc’;
c. 如果Firewall没有开放端口
Firewall-cmd –add-port=3306/tcp
结果succeed就正确了.
Mysql5.7主主互备安装配置的更多相关文章
- DRBD的主备安装配置
drbd软件包链接:https://pan.baidu.com/s/1eUcXVyU 密码:00ul 1.使用的资源:1.1 系统centos6.9 mini1.2 两台节点主机node1.node2 ...
- MySQL5.6.36 linux rpm包安装配置文档
一.卸载自带mysql,删除MySQL的lib库,服务文件 [root@localhost ~]#rpm -qa|grep mysql qt-mysql-4.6.2-26.el6_4.x86_64 m ...
- CentOS7.2+MySQL5.7_ yum源方式_ 安装配置教程
1)访问mysql官方网站 #访问网站 https://dev.mysql.com/downloads/file/?id=470281 2)下载安装包到linux #进入文件存放路径 cd /usr/ ...
- (转)MySQL主主互备结合keepalived实现高可用
MySQL主主互备结合keepalived实现高可用 原文:http://7424593.blog.51cto.com/7414593/1741717 试验环境: master:192.168.1.2 ...
- 【Keepalived+MySQL】MySQL双主互备+高可用
一.基本信息说明 [DB1] IP: 192.168.102.144 hostname: LVS-Real1 [DB2] IP: 192.168.102.145 hostname: LVS-Real2 ...
- psql主主复制
主主是mysql的概念,通常在mysql中为保证事务一致也是一台主写,一台做读.pg主从可以互为切换 之前没做数据库部署这部分,一个同事离职暂时没人,接受过来的!mysql做的是主主复制,我理解是可以 ...
- CentOS 7 MySql 解压版安装配置
下载 访问www.mysql.com 点击DOWNLOADS-->Community-->MySQL Community Server 选择要下载的版本,目前可选择的有:5.5.5.6.5 ...
- MySQL-5.7.10主主同步的安装和配置
目录 目录 1 1. 安装 1 2. 修改MySQL的root密码 4 3. mysqld_safe和mysql.server 4 4. 主主同步配置 4 4.1. 创建同步用户 4 4.2. my. ...
- Mysql双主互备+keeplived高可用架构介绍
一.Mysql双主互备+keeplived高可用架构介绍 Mysql主从复制架构可以在很大程度保证Mysql的高可用,在一主多从的架构中还可以利用读写分离将读操作分配到从库中,减轻主库压力.但是在这种 ...
随机推荐
- MySQL积累
从csv文件写入mysql表:从/root/failure.csv读取数据写入表d_disk_failure,每行中的每个项用逗号分割,每个项只取用"包含的内容,如果没有"则取全部 ...
- Feign请求中报错:Request header is too large 的解决方案。
现在我们项目中都已迁入spring boot和spring cloud. 服务间调用现在都改成feign的调用方式,但是上次在实际使用过程中出现过:Request header is too larg ...
- RocketMq 学习记录
最近因为工作需求,领导让我安装一下RocketMQ 这里简单记录一下 这里我的操作系统是centos 6.5 64位 我们看一下官网的RocketMQ安装要求 Prerequisite The fol ...
- android 的build.gradle 的API手册
问题:对于用gradle的来配置java的开发者都能在GRADLE_HOME/docs/dsl找到如何对其build.gradle文件的具体属性. 但是对于开发android的开发者就不能对于官方的& ...
- eclipse自动切换到debug视图
原文出自:http://blog.csdn.net/yizhizouxiaqu/article/details/7594502 当弹出"Confir Perspective Switch&q ...
- HTML杂记
1.URL uniform resource locator 遵循格式: scheme://host.domain:port/path/filename scheme - 定义因特网服务的类型.最常 ...
- HTML5学习笔记(八):CSS定位
CSS 定位 (Positioning) 属性允许你对元素进行定位. 定位和浮动 CSS 为定位和浮动提供了一些属性,利用这些属性,可以建立列式布局,将布局的一部分与另一部分重叠.定位的基本思想很简单 ...
- EF框架 对字段属性为NULL的空值处理 类型前面加上?保证EF列表读取显示数据不会报异常
譬如: public int? FlowStatus { get; set; } public DateTime? UpdateTime { get; set; }
- 如何使用ILSpy 把发布版本反编译成源码
有时候,看法别人写的代码比较好,想看看他们的代码到底是如何写的,于是就找方法,看看能否把发布版本变成源码.后来终于发现一个词“反编译”,我终于知道怎么办了. 工具:ILSpy 百度下载一个,该工具 ...
- linux Ctrl+z和Ctrl+c的区别
1.Ctrl+z 挂起进程,并不会结束,执行fg命令可以重新启动这个被挂起的命令. 2.Ctrl+c 终止进程