centos7 下手动安装MySQL-5.6.32-1.linux_glibc2.5.x86_64.rpm-bundle
由于centos7默认不再是mysql数据库,所以度算手动安装一个。
全程参考http://www.2cto.com/database/201501/371451.html
这里摘抄以下这个链接的内容,并根据自己的实际安装情况进行一些补充。
选择下载MySQL Community Server (GPL)版本,由于MySQL Community Server 5.7.14没有rpm格式文件下载,这里我们选择5.6.32版本的rpm格式文件下载。
下载得到MySQL-5.6.32-1.linux_glibc2.5.x86_64.rpm-bundle.tar文件,解压得到

进入MySQL-5.6.32-1.linux_glibc2.5.x86_64.rpm-bundle文件夹,可以看到:

双击安装其中的,MySQL-server-5.6.32-1.linux_glibc2.5.x86_64.rpm
MySQL-client-5.6.32-1.linux_glibc2.5.x86_64.rpm
MySQL-devel-5.6.32-1.linux_glibc2.5.x86_64.rpm文件(这里安装顺序,我是按着这个先后顺序来的,至于不按照这个先后来,我也不知道会不会有错误)。
关于初次登陆密码错误的解决办法:
首先停止mysql服务service mysql stop
然后/usr/bin/mysqld_safe --skip-grant-tables & 启动mysql(注意“&”符号别漏了)
上一句命令执行完以后,敲一个回车,再输入mysql -u root mysql

接下来更新mysql的root用户登陆密码:


至此就可以开始正常使用mysql了,未尽事项,查看文章开头链接。
特别注明:
有可能在安装完成以后,每次启动mysql的时候会报错
这里我们首先查看mysql运行状态
然后查看mysql的线程ID,然后使用kill -9命令杀死该线程。

然后再删除/var/lock/subsys/mysql文件就可以正常使用mysql了

我的centos7中的mysql每次启动都需要这几步,我暂时不知道为什么。。。
centos7 下手动安装MySQL-5.6.32-1.linux_glibc2.5.x86_64.rpm-bundle的更多相关文章
- centos7下快速安装mysql
CentOS 7的yum源中貌似没有正常安装MySQL时的mysql-sever文件,需要去官网上下载 # wget http://dev.mysql.com/get/mysql-community- ...
- centos7下yum安装mysql
CentOS 7的yum源中貌似没有正常安装mysql时的mysql-sever文件,需要去官网上下载 # wget http://dev.mysql.com/get/mysql-communit ...
- 安装mysql警告 warning: mysql-community-server-5.7.19-1.el6.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
摘自:https://www.cnblogs.com/royfans/p/7243641.html 红帽安装rpm安装MySQL时爆出警告: 警告:MySQL-server-5.5.46-1.linu ...
- centos7下编译安装mysql
推荐: http://www.cnblogs.com/yunns/p/4877333.html
- Centos7 下yum安装mysql
- (转)CentOS7下yum安装mysql配置多实例
原文:http://blog.csdn.net/poklau/article/details/54951798
- MySQL-client-5.6.36-1.linux_glibc2.5.x86_64.rpm安装详解
centos6.8已经安装了mysql,所以要卸载掉 查看命令 rpm -qa | grep mysql 注意:MySQL区分大小写 grep mysql 和grep MySQL 是不一样的!! 卸载 ...
- windows下手动安装 Apache+php+mysql
PHP 为什么先说php,因为apache的配置要写入php的一些路径 http://php.net/downloads.php 选择windows donwload 选择Thread Safe的版 ...
- linux下如何安装mysql和redis
linux下如何安装mysql(mariadb) linux下如何安装软件? 1. yum安装软件也得注意,一个是配置yum源 1.我们当前的是阿里云的yum源(下载速度特别快) 通过 yum ins ...
随机推荐
- 关于css雪碧图sprite
天气转凉了,又开始贪恋暖暖的被窝了. 早上不想起床的时候在被窝里看了有关于雪碧图的视频. 1.使用场景 V导航条,登录框img标签多次载入,性能低 X大图banner按需加载,如果做成雪碧图一次加载就 ...
- Linux 命令 - arp: 操作系统的 ARP 缓存
arp 命令可以查看 ARP 缓存或者手动添加.删除缓存中的条目. 命令格式 arp [-evn] [-H type] [-i if] -a [hostname] arp [-v] [-i if] - ...
- HDOJ2017字符串统计
字符串统计 Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submi ...
- MTKLogger日志记录打开
MTKLogger在 拨号界面用*#446633#(不同手机可能设置不一样) 向左滑动到Log and Debugging下面有个MTKLogger,点进去 点击右上角进入设置,打开MobileLog ...
- SSRS 传多值参数问题
SSRS报表参数是可单值或者多值.之前有个小伙伴问我,如果要传多值怎么传.然后我试了在各个参数之间,放换行符放逗号分号等都未能解决问题,最后想明白这个参数接受的应该是非字符类型,很大可能是数组,然后我 ...
- Debian8 加载NTFS 磁盘出错 解决方法
执行 ntfsfix /dev/sdb2 // sd* a代表第一块硬盘 b代表第2块硬盘 数字是分区号 执行后 就可以正常使用了.
- 使用visual studio 2015调用阿里云oss .net sdk 2.2的putobject接口抛出outofmemory异常
问题描述: 使用阿里云oss .net sdk 2.2版本,使用putobject接口上传文件时,抛出outofmemory异常. 原因分析: 上传时,用于准备上传的数据缓冲区内存分配失败.与应用软件 ...
- wampserver安装后 mysql 所有数据库丢失的解决方案
事情起源: 晚上十点客户紧急来电,说是网站全部瘫痪.同事登陆数据库一看,Mysql Workbench Database下一片空白.当时我们都傻了. 发现原因: 服务器环境是windows serve ...
- (转)持续化集成工具CruiseControl.NET
持续化集成工具CC.NET[ 引言: 团队开发需要 进行集中的项目文件管理与有效的协调,我们采用源代码管理工具协助我们管理,卓有成效.限定重要文件的访问权限.使用悲观锁杜绝成员同时编辑同一份文件. 不 ...
- linux gcc 和 g++ 编译
gcc编译 gcc -o test.out test.c g++ 编译 g++ -o test.out test.cpp