阿里云的CentOS 6.5上安装Docker会无法启动,如果直接运行docker -d会看到错误提示:Could not find a free IP address range for interface ‘docker0‘.

原因就是docker自动尝试的建立bridge的ip段正好被阿里云的路由表完全占据了

详细原因可以参见这个帖子:http://hanjianwei.com/2014/07/30/docker-on-aliyun/

网上有好多类似的解决方法,不过好麻烦,这里主要说下最方便的解决方法

先su到root

找一下docker的配置文件: find / -name "docker"

一般会在 /etc/sysconfig/docker

编辑这个文件 vi /etc/sysconfig/docker

修改other_args=这一行为:other_args=-bip=192.168.100.1/24

保存退出

重启docker没成功

修改路由表之后 Docker 成功启动。

service docker restart

参考:http://hanjianwei.com/2014/07/30/docker-on-aliyun/

http://www.bubuko.com/infodetail-969451.html

http://bbs.aliyun.com/read/152090.html?ordertype=desc&displayMode=1

http://blog.jamespan.me/2015/07/25/docker-on-the-cloud/

http://blog.csdn.net/minimicall/article/details/40119177

方法二:新建一个bridge也可以解决

https://docs.docker.com/articles/networking/#bridge-building

我想要测试使用自己的私有库,由于私有库没有配置证书,所以需要在Docker的启动项中修改配置,取消掉证书认证DOCKER_OPTS="-- insecure-registry 10.0.40.16:5000"。但是在启动Docker进程时,发现没有将DOCKER_OPTS的内容加载进来。

然后我又修改 /etc/default/docker ,在里面增加了

DOCKER_OPTS="--insecure-registry 10.0.40.16:5000"

再次启动Docker进程,DOCKER_OPTS的选项还是没有生效,什么情况?

接着,我再次修改另一个配置文件,/etc/init.d/docker ,同样,加入

DOCKER_OPTS="--insecure-registry 10.0.40.16:5000"

再启动,还是没有生效。。。

再修改另一个配置文件:/etc/init/docker.conf , 加入:

DOCKER_OPTS="--insecure-registry 10.0.40.16:5000"

再重启Docker进程,还是没有生效,无语了。

最后,在google上,查找资料,找到了一个连接,还是Docker的官方档:https://docs.docker.com/articles/systemd/

发现还可以修改:/lib/systemd/system/docker.service ,在里面增加:

EnvironmentFile=-/etc/default/docker

然后,修改: ExecStart=/usr/bin/docker -d -H fd://  ,改成:  ExecStart=/usr/bin/docker -d -H fd:// $DOCKER_OPTS

再次启动,终于生效了,我只能说这配置文件真多,主要是都是误导人的,真坑!

参考:

http://www.linuxidc.com/Linux/2015-08/121148.htm

https://docs.docker.com/articles/systemd/

https://docs.docker.com/articles/networking/#bridge-building

http://blog.csdn.net/yuanchao99/article/details/43114927

http://blog.csdn.net/minimicall/article/details/40119177

Docker无法启动 Could not find a free IP address range for interface 'docker0' 最方便的解决办法的更多相关文章

  1. proftpd启动失败提示unable to determine IP address of “xxx.com”

    proftpd启动失败提示unable to determine IP address of “xxx.com”这种proftpd启动失败的原因是无法解析后面主机的IP地址,解决方法是在DNS列表中增 ...

  2. 阿里云CentOS7.4启动Tomcat9没有报错,端口已经开放,但是浏览器一直等待响应解决办法7

    tomcat9,启动和退出均无报错.centOS7.4防火墙已关闭,阿里云防火墙已经开放端口,telnet测试服务器的端口也通过了,**浏览器访问以后没有提示"无法访问",而是一直 ...

  3. docker 容器挂载主机目录,访问出现 cannot open directory /mnt/home/webroot/: Permission denied 的解决办法

    问题原因及解决办法 原因是CentOS7中的安全模块selinux把权限禁掉了,至少有以下三种方式解决挂载的目录没有权限的问题: 1.在运行容器的时候,给容器加特权,及加上 --privileged= ...

  4. redis启动出错 Creating Server TCP listening socket 127.0.0.1:6379: bind: No error解决办法

    windows下安装Redis第一次启动报错: [2368] 21 Apr 02:57:05.611 # Creating Server TCP listening socket 127.0.0.1: ...

  5. 黄聪:VS2010启动程序提示文件加载 使用 简体中文(GB2312)编码加载文件解决办法

    vs2010 错误提示框:文件加载 使用 简体中文(GB2312)编码加载文件C:\Users\Administrator\AppData\Local\Temp\nxhgjasi.5au \Temp\ ...

  6. docker构建本地仓库后,无法登陆解决办法(CentOS/Ubuntu)

    docker版本为:Server Version: 1.12.6 从dockerhub上下载最新的registry镜像. 首先.构建registry 1.下载registry镜像 docker pul ...

  7. VirtualBOX启动错误the vm session was closed before any attempt to power it on解决办法

    昨天晚上笔记本休眠后,今天早上启动vm时,报错了. 点击详细启动错误:the vm session was closed before any attempt topower it on. 解决办法: ...

  8. 利用docker compose启动gitlab及runner

    添加docker compose配置文件 新建文件docker-compose.yml,输入如下内容: gitlab: image: 'gitlab/gitlab-ce:latest' contain ...

  9. docker 源码分析 一(基于1.8.2版本),docker daemon启动过程;

    最近在研究golang,也学习一下比较火的开源项目docker的源代码,国内比较出名的docker源码分析是孙宏亮大牛写的一系列文章,但是基于的docker版本有点老:索性自己就git 了一下最新的代 ...

随机推荐

  1. input的button和submit的区别

    故事由来: 其实这个问题,昨天已经遇到过,但是昨天是公司的一枚老员工帮助我这个实习生调的,而且我也确(猜)定(测)那枚老员工也不知道这个区别.然后今天又遇到相同问题. 故事梗概: 现在公司里面做一个项 ...

  2. 源自梦想 自定义ViewGroup的整理_2

    Android项目: 1.准备资源图片.图片放到hdip里和mdip里对想过的影响:对于320*480的模拟器,默认去mdip里去找图片资源,拿过来的图片可以直接用,清晰度不变.要是所要找的图片在hd ...

  3. 《MFC游戏开发》笔记六 图像双缓冲技术:实现一个流畅的动画

    本系列文章由七十一雾央编写,转载请注明出处.  http://blog.csdn.net/u011371356/article/details/9334121 作者:七十一雾央 新浪微博:http:/ ...

  4. DEDECMS 调用上级栏目标题

    在内容页,使用以下代码: {dede:field name='position' runphp='yes'} $tc="-"; //分隔符 $tw=$GLOBALS['cfg_li ...

  5. 【转】驱动中的类class和节点

    原文出处:http://blog.chinaunix.net/uid-23036581-id-2230558.html 一个类是一个设备的高级视图, 它抽象出低级的实现细节. 驱动可以见到一个SCSI ...

  6. jQuery过滤选择器:not()方法使用介绍

    在jQuery的早期版本中,:not()筛选器只支持简单的选择器,说明我们传入到:not这个filter中的selector可以任意复杂,比如:not(div a) and :not(div,a) & ...

  7. Umbraco(6)-Creating More Pages Using the Master - Part 2(翻译文档)

    创建一个Contact Us页面 我们将创建一个新的”联系我们“页面,在该页面我们将放置简单的联系信息.对于添加这个功能你可能想替换为一个完全成熟的形式. 一些有效的解决方案: 使用表面控制器构建自己 ...

  8. Laravel 清空配置缓存

    清空配置缓存 php artisan cache:clear php artisan config:clear

  9. css3 text-transform变形动画

    详细内容请点击 版本:CSS1 兼容性:IE4+ NS4+ 继承性:有 语法: text-transform : none | capitalize| uppercase| lowercase 参数: ...

  10. 50个常用的笔试、面试sql语句

    50个常用的笔试.面试sql语句 2009-12-17 15:05   Student(S#,Sname,Sage,Ssex) 学生表Course(C#,Cname,T#) 课程表SC(S#,C#,s ...