首先要清楚一点:NFS服务的共享是建立在linux和linux之间的。

配置任何服务之前我们要做的2件事:

iptables  -F

setenforce 0    NFS服务内核防火墙影响不大,主要还是iptables

服务端:

安装nfs服务软件包:

启动nfs服务

下面说一个NFS服务起不来的解决方法,这个错误还是比较常见的。

报错:RPC。。。。。问题,这个是因为我把rpc给关了:

把rpc打开重启下服务:

服务端共享出去/mnt对所有的主机(以只读的方式)

客户端  终端为白色

首先要识别下服务端是否有目录共享出来。

然后我们在挂载:

因为我们给的权限是只读所以写不进去:

提到客户端的挂载,也有2个常见的问题:(错误案列)

这样也是错的,ip前面多了//。域名服务失败,找不到这个共享目录。

第二种、、没截图我把报错说一下:

NO ROUTE TO HOST 没有路由到达主机

(服务端iptables –F解决火墙没刷干净)    

服务端赋予写的权限:

客户端:

可以创建文件,注意看文件的权限

服务端:(以root身份访问nfs服务共享目录,不转换root的权限)

客户端:file1

服务端:使用uid为500的用户身份访问nfs

客户端创建好文件在服务端看下:file2

注意:客户端没有这个用户,我们使用的用户uid也是服务端的用户,客户单看到的只是nobody,客户端只会用nfs,他们不会去看文件的权限,权限的管理还是服务端人员

转换root的权限,我们也不指定以那个用户身份去访问nfs,默认文件的身份nfsnobody

转换所有用户的身份,全部以uid为500 的用户身份去访问nfs

更多的书写方法参考帮助

配置服务端以域名的方式共享出去:

如果出现下面的情况:客户端挂载不上

去服务端配置域名,ip解析

客户端不用配置,然后就ok了

《NFS文件共享服务的搭建》RHEL的更多相关文章

  1. Linux:将rhel yum 切换到centos yum

    Red Hat Enterprise Linux Server(RHEL) yum安装软件时This system is not registered with RHN. RHN support wi ...

  2. Configure a bridged network interface for KVM using RHEL 5.4 or later?

    environment Red Hat Enterprise Linux 5.4 or later Red Hat Enterprise Linux 6.0 or later KVM virtual ...

  3. 在CentOS或RHEL上安装Nux Dextop仓库

    介绍 Nux Dextop是类似CentOS.RHEL.ScientificLinux的第三方RPM仓库(比如:Ardour,Shutter等等).目前,Nux Dextop对CentOS/RHEL ...

  4. 1-linux系统管理(一)之安装RHEL 6.4

    linux系统管理之安装RHEL 6.4 进入安装界面 这里选择跳过 点击下一步 选择安装语言 选择键盘 选择系统储存方式 选择是否格式化储存设备 给安装的系统一个计算机名 选择时区 给root一个密 ...

  5. CentOS 7 (RHEL 7)服务管理命令的变化

    CentOS 7 (RHEL 7)带来了新的服务管理命令,为了保持兼容原有的命令仍可以使用,以下是新旧命令的对照. 启动.停止.重启.重载.检查服务:6: service httpd start|st ...

  6. RHEL 6.3 详细安装教程

    以前刚接触linux时,什么都不懂,为了学习,在电脑上安装双系统(原系统为Win7),吃过不少苦头,在网上搜教程,很多都是语焉不详,导致安装过程中战战兢兢.最近朋友面试运维,面试官有考他对linux安 ...

  7. RHEL 5.7 Yum配置本地源[Errno 2] No such file or directory

    在Red Hat Enterprise Linux Server release 5.7 上配置YUM本地源时,遇到了"Errno 5] OSError: [Errno 2] No such ...

  8. 如何在CentOS/RHEL & Fedora上安装MongoDB 3.2

    MongoDB(名称取自"huMONGOus")是一个有着全面灵活的索引支持和丰富的查询的数据库.MongoDB通过GridFS提供强大的媒体存储.点击这里获取MongoDB的更多 ...

  9. RHEL 6.5 PXE 安装调试 VMWARE ESXi 5.1 安装

    测试环境:win10/vmware workstation 12 pro 操作系统:RHEL 6.5(PXE服务器) [2016.11.30] [遗留问题] 1.ks.cfg通过本地文件方式加载不成功 ...

  10. rhel 5.8 and 6.4 yum配置

    rhel 5.8 and 6.4 yum配置 6.4 [Packages]name=Packagesenabled=1gpgcheck=0baseurl=file:///iso 5.8 [Packag ...

随机推荐

  1. j疑难杂症:ava.lang.NoSuchMethodError: com.opensymphony.xwork2.util.finder.ClassFinder.<init>

    严重: Exception starting filter struts2java.lang.NoSuchMethodError: com.opensymphony.xwork2.util.finde ...

  2. (转)ASP.NET Identity登录原理 - Claims-based认证和OWIN

    在Membership系列的最后一篇引入了ASP.NET  Identity,看到大家对它还是挺感兴趣的,于是来一篇详解登录原理的文章.本文会涉及到Claims-based(基于声明)的认证,我们会详 ...

  3. QMap与QHash

    关联容器可以保存任意多个具有相同类型的项,且它们由一个键索引.Qt提供两个主要的关联容器类:QMap<K, T>和QHash<K, T>. QMap<K, T>是一 ...

  4. ubuntu13.04装配oracle11gR2

    http://jingyan.baidu.com/album/bea41d435bc695b4c41be648.html?picindex=2 http://www.360doc.com/conten ...

  5. 基于Docker服务的java Web服务搭建

    导读 最近想我们的应用需要更新维护,Android.IOS.还有服务器端都要更新,都在忙于写代码没有写文章了.我们的服务器是用java ssh架构的,到时也打算切换成Spring MVC+oauth2 ...

  6. How to Install and Configure Nginx from Source on centos--转

    1.CentOS - Installing Nginx from source http://articles.slicehost.com/2009/2/2/centos-installing-ngi ...

  7. 琐碎-关于Windows调试hadoop

    http://www.aboutyun.com/thread-7784-1-1.html 今天早上看了这个文章后我有点疑问,所以特地实践了一把. 之前也遇到了调试的时候 org.apache.hado ...

  8. EF——Guid类型数据的自增长、时间戳和复杂类型的用法 03 (转)

    EF里Guid类型数据的自增长.时间戳和复杂类型的用法   通过前两章Lodging和Destination类的演示,大家肯定基本了解Code First是怎么玩的了,本章继续演示一些很实用的东西.文 ...

  9. 工作流_JBPM之Helloword

      环境:Eclipse 3.5 + java 6 + MySQL 5.5 + jBPM 4.4   1.建立 Java Project: 2.拷贝 XML配置文件放进工程目录: 3. 建立 JPDL ...

  10. hdu-5683 zxa and xor (位运算)

    题目链接: zxa and xor Time Limit: 16000/8000 MS (Java/Others)     Memory Limit: 65536/65536 K (Java/Othe ...