lnmp环境的使用

安装的软件都安装到了:/usr/local

管理nginx

service nginx start|stop|restart|reload

管理mysql

直接执行mysql即可登录不需要用户名和密码,登录进行之后,需要删除匿名用户 并为root用户设置一个密码。原理:管理MYSQL中的账号,就是直接修改mysql.user表即可

host:允许使用这个账号登录的服务器,可以设置为ip地址,也可以设置为%【允许所有人登录】

service mysqld start|stop|restart

如何判断一个系统中有没有启动web服务器或者是mysql服务器?

使用ps 命令查看有没有启动web这个进程

使用 netstat 命令查看 相应端口号有没有被监听

如何重启PHP?

这和windows不同,在win下如果修改了php.ini只要重启apache就可以了,但是在LNMP里面不可以,必须需要要单独重启PHP。

在nignx下PHP是独立启动的,默认监听是9000端口。

重启流程:

先使用ps命令找出PHP进程的PID

使用kill -15 pid 关闭进程

启动php

&(把命令放入后台执行)

如何配置nginx

配置文件:/usr/local/nginx/conf/nginx.conf

扩展:LINUX下对每个进程都有资源上的限制:可以使用ulimit指令设置和查看

其他影响网络连接数的参数:open files

扩展:unix/linux系统有一个理念:所有的东西都是文件

修改:

nginx默认不支持thinkphp的URL格式如果网站运行TP,那么需要在nginx中添加代码:

实例:把商城上传到lnmp环境下运行

  1. 创建一个目录用来存放我们项目代码

  2. 修改nginx的配置文件,把这个目录配置成一个网站

  3. 上传代码到/www/www.34.com
  4. 把数据库导到服务器上

  5. 重启NGINX
  6. 修改本地的hosts文件把IP地址指向linux服务器

  7. 上传之后修改权限的问题:
    1. 修改PHP以www的权限运行

    b)    重启 PHP

    c)    修改项目目录的归属也为WWW

    总结:平时没有权限的原因是因为默认一般上传的文件可能是属于ROOT账号的,而一般WEB服务器都是以WWW这个账号的权限运行的,当然不能操作属于ROOT的文件。

lnmp环境的使用教程的更多相关文章

  1. LNMP环境搭建详细教程

    之前有一篇博客写的是LAMP的环境搭建,今天来详细介绍一下另外一个模式——LNMP=Linux+Nginx+MySQL+PHP. 一.在Linux系统下nginx的安装过程,先到http://ngin ...

  2. linux系统lnmp环境包搬家教程

    打包搬家apt-get install zip unzip -yyum install zip unzip -y# debian ubuntu 用apt-get,centos用yumcd /home/ ...

  3. CentOS 7 上搭建LNMP环境

    (转自美团云知识库Chris) 简介 LNMP是Linux.Nginx.MySQL(MariaDB)和PHP的缩写,这个组合是最常见的WEB服务器的运行环境之一.本文将带领大家在CentOS 7操作系 ...

  4. centos7 yum搭建lnmp环境及配置wordpress超详细教程

    yum安装lnmp环境是最方便,最快捷的一种方法.源码编译安装需要花费大量的人类时间,当然源码编译可以个性化配置一些其它功能.目前来说,yum安装基本满足我们搭建web服务器的需求. 本文是我根据近期 ...

  5. linux lnmp环境下 安装apache教程

    linux lnmp环境下 安装apache教程 源码安装 apr ,apr-util 安装apache要用<pre>wget http://mirrors.cnnic.cn/apache ...

  6. 新手配置LNMP环境教程

    回顾一下这几天自己配置LNMP环境踩得坑,希望帮助更多人 前期准备:VMtool.Linux.Nginx.Mysql.PHP.cmake 版本如下:Centos6.nginx1.6.0.mysql5. ...

  7. 烂泥:学习ubuntu之快速搭建LNMP环境

    本文由秀依林枫提供友情赞助,首发于烂泥行天下 现在公司使用的都是ubuntu系统,这几天由于个别项目需要,需要搭建一个LNMP环境.为了快速搭建这个环境,我使用是apt-get方式进行安装.具体的操作 ...

  8. 阿里云(ECS)Centos服务器LNMP环境搭建

    阿里云( ECS ) Centos7 服务器 LNMP 环境搭建 前言 第一次接触阿里云是大四的时候,当时在校外公司做兼职,关于智能家居项目的,话说当时俺就只有一个月左右的 php 后台开发经验(还是 ...

  9. linux:lnmp环境搭建

    一.准备工作(把安装环境需要使用到的包都下载好) mysql(官网):http://dev.mysql.com/downloads/ php(官网):http://php.net/downloads. ...

随机推荐

  1. configure: error: lzo enabled but missing

    注意:yum安装的无效,需要手动下载源码安装. wget http://www.oberhumer.com/opensource/lzo/download/lzo-2.06.tar.gz tar zx ...

  2. vue中路由返回上一个页面,恢复到上一个页面的滚动位置

    第一步:路由文件的配置(对你所需要的vue文件进行保存缓存标志的添加) import Vue from 'vue' import Router from 'vue-router' import Hel ...

  3. js 闭包范式概述

    在前几篇文章中我介绍过js的闭包,这一篇主要简单的介绍一下js中闭包的范式. 那么何谓闭包的范式呢? 首先回想一下闭包的概念,闭包是外部函数与函数内部之间通信的桥梁,通过对函数的返回,使得外部的函数能 ...

  4. Install WordPress Plugins without FTP Access

    WordPress will only prompt you for your FTP connection information while trying to install plugins o ...

  5. How to Find Processlist Thread id in gdb !!!!!GDB 使用

    https://mysqlentomologist.blogspot.jp/2017/07/           Saturday, July 29, 2017 How to Find Process ...

  6. OSChina 周日乱弹 —— 超酷炫 58 页年终总结,笑喷!

    猿文:http://my.oschina.net/xxiaobian/blog/368981 借鉴一下以下的各种年终总结吧,总有适合你的... OSCer 们,小小编掐指一算,你命里真的缺我啊,赶紧给 ...

  7. onWindowFocusChanged重要作用 and Activity生命周期

    onWindowFocusChanged重要作用 Activity生命周期中,onStart, onResume, onCreate都不是真正visible的时间点,真正的visible时间点是onW ...

  8. table固定首行(一)

    <html> <head> <title>Untitled Document</title> <meta http-equiv="Con ...

  9. C++ 竞赛常用头文件

    C.传统 C++ #include <assert.h> 设定插入点 #include <ctype.h> 字符处理 #include <errno.h> 定义错误 ...

  10. 解决:HTTP 错误 404.2 - Not Found. 由于 Web 服务器上的“ISAPI 和 CGI 限制”列表设置,无法提供您请求的页面

    错误重现: 在发布网站的过程中,虽然不是第一次发布了,但是还是遇到了很多的问题.为了以后可以轻松解决此类问题还是积累下来比较好. 问题:HTTP 错误 404.2 - Not Found. 由于 We ...