转载自:http://blog.csdn.net/levy_cui/article/details/52461377

官方升级版本说明
http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.0.1/bk_ambari-installation/content/determine_stack_compatibility.html

官方升级步骤
http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.0.1/bk_ambari-upgrade/content/preparing_to_upgrade_ambari.html

官方HDP问题搜索
https://community.hortonworks.com/answers/index.html

Upgrade Ambari

一、升级前准备

Preparing to Upgrade

确认版本
Be sure to review the Release Notes for this Ambari release for Known Issues and Behavioral Changes.

拥有root权限
You must have root, administrative, or root-equivalent authorization on the Ambari server host and all servers in the cluster.

备份ambari数据库
You must backup the Ambari Server database.

备份好ambari.properties配置文件
You must make a safe copy of the Ambari Server configuration file found at /etc/ambari-server/conf/ambari.properties.

二、停止服务、下载新的ambari.repo

关闭Ambari Metrics
If you are running Ambari Metrics service in your cluster, stop the service. From Ambari Web, browse to Services > Ambari Metrics and select Stop from the Service Actions menu.
    
停止ambari-server
Stop the Ambari Server. On the host running Ambari Server:
    ambari-server stop

停止ambari-agent
Stop all Ambari Agents. On each host in your cluster running an Ambari Agent:
    ambari-agent stop

获取新的ambari.repo
Fetch the new Ambari repo and replace the old repository file with the new repository file on all hosts in your cluster.

wget -nv http://public-repo-1.hortonworks.com/ambari/centos6/2.x/updates/2.4.0.1/ambari.repo -O /etc/yum.repos.d/ambari.repo

三、升级操作
Upgrade Ambari Server. On the host running Ambari Server:

yum clean all
    yum info ambari-server

在ambari节点更新ambari-server
In the info output, visually validate that there is an available version containing "2.4"
    yum upgrade ambari-server

显示如下成功:
Updated:
   ambari-server.x86_64 0:2.4.0.1-1      
Complete!

在所有节点更新ambari-agent
Upgrade all Ambari Agents. On each host in your cluster running an Ambari Agent:
    yum upgrade ambari-agent

显示如下成功:
Updated:
  ambari-agent.x86_64 0:2.4.0.1-1

Complete!

查看ambari-agent
After the upgrade process completes, check each host to make sure the new files have been installed:
rpm -qa | grep ambari-agent

升级ambari-server
Upgrade Ambari Server database schema. On the host running Ambari Server:
ambari-server upgrade

[root@testserver2 yum.repos.d]# ambari-server upgrade
Using python  /usr/bin/python
Upgrading ambari-server
Updating properties in ambari.properties ...
WARNING: Can not find ambari.properties.rpmsave file from previous version, skipping import of settings
INFO: Can not find ambari-env.sh.rpmsave file from previous version, skipping restore of environment settings. ambari-env.sh may not include any user customization.
Fixing database objects owner
Ambari Server configured for Embedded Postgres. Confirm you have made a backup of the Ambari Server database [y/n] (y)?
Upgrading database schema
Adjusting ambari-server permissions and ownership...
Ambari Server 'upgrade' completed successfully.

启动ambari-server
Start the Ambari Server. On the host running Ambari Server:
ambari-server start

[root@testserver2 yum.repos.d]# ambari-server start
Using python  /usr/bin/python
Starting ambari-server
Ambari Server running with administrator privileges.
Organizing resource files at /var/lib/ambari-server/resources...
Ambari database consistency check started...
No errors were found.
Ambari database consistency check finished
Server PID at: /var/run/ambari-server/ambari-server.pid
Server out at: /var/log/ambari-server/ambari-server.out
Server log at: /var/log/ambari-server/ambari-server.log
Waiting for server start....................
Ambari Server 'start' completed successfully.

所有节点启动ambari-agent
Start all Ambari Agents. On each host in your cluster running an Ambari Agent:
ambari-agent start

登录ambari管理界面,查看版本,升级成功。

打开管理界面后出现图中内容,使用’ctrl+shift+R’刷新下就好了。

四、增加新版本HDP

浏览Ambari Web > Admin > Stack and Versions.

点击Versions标签,你将看到已经安装的HDP版本

如果看不到已经安装(Current)的版本, 说明客户端没有更新完。

Admin > Manager Ambari > 左侧Versions
点击右上角的按钮Register Version,添加新的hdp版本。

8. 点击Install Packages就能够将hadoop升级到该HDP版本了。

安装后点击upgrade,有两种升级模式,一种是保持服务运行升级,另一种是停止服务升级,后者升级更快些

点击Checks查看警告信息,需要检查TEZ服务,进入TEZ服务,选择“”run service check“”

提示是否升级

选择i have performed the clients will retry on their above. 之后proceed

开始升级,我选择的是停止服务升级,过程中会自动stop服务,有时候需要retry

最后确认是否完成升级,升级后无法回退到旧版本。

HDP2.5已经为当前版本

在添加新服务的时候已经是新版本组件了

看了下hdfs中的数据还在

总结:

对于生产环境hadoop集群升级,绝对是个重量级工作,一定要有敬畏之心,以上升级步骤虽然看着不复杂,也很顺利的完成,我是在测试环境上进行的,没有一点心理负担,

如果是生产环境,不仅需要停止服务,如果在过程中出现问题,后果肯定无法想象,新版本组件也需要在升级前进行测试,业务是否可以运行正常,需要大量的测试实践工作,建议如果真要升级hadoop集群,还是考虑异地备份重要数据,避免数据丢失,比起数据丢失的风险,多买几台服务器进行数据备份,不算什么的,总之不到万不得已,轻易不要升级集群。

升级ambari、HDP版本(ambari 2.1升级到2.4、HDP2.3升级到2.5)的更多相关文章

  1. 该应用的登录功能版本较旧,无法使用QQ账号登录,请升级到最新版本,如果还无法解决,请联系开发者升级。(错误码:100044)

    该原因应该是你的应用数据签名更改的原因 解决步骤已经写到我的公众号,二维码在下面. 欢迎观看我的CSDN学院课程,地址:http://edu.csdn.net/course/detail/2877 本 ...

  2. cent os 6.5+ambari+HDP集群安装

    1. 搭建一个测试集群,集群有4台机器,配置集群中每一台机器的/etc/hosts文件: [root@nn .ssh]# cat /etc/hosts 127.0.0.1 localhost loca ...

  3. Ambari HDP集群搭建文档

    一.配置主机和节点机器之间SSH无密登录 多台外网服务器配置时,需要在/etc/hosts中把本机的IP地址设置为内网IP地址 http://2d67df38.wiz02.com/share/s/0J ...

  4. Hadoop记录-安装ambari hdp集群

    #!/bin/sh #配置用户sudo权限(参考/etc/sudoers文件,在/etc/sudoers.d/新建一个用户配置文件,注意要注销) #需要在/etc/sudoers末尾追加:sfapp ...

  5. Ambari HDP集群搭建全攻略

    世界上最快的捷径,就是脚踏实地,本文已收录[架构技术专栏]关注这个喜欢分享的地方. 最近因为工作上需要重新用Ambari搭了一套Hadoop集群,就把搭建的过程记录了下来,也希望给有同样需求的小伙伴们 ...

  6. Elasticsearch升级1.5版本暴露jdk的bug

    把测试环境的Elasticsearch升级到1.5.1版本,启动的时候报错: [root@node2 elasticsearch-1.5.1]# bin/service/elasticsearch s ...

  7. 20160303 - 升级 Windows 10 版本 1511 后,文件夹默认打开方式为 cmd 的修复

    问题描述:升级 Windows 10 版本 1511 (OS 内部版本 10586.122)后,文件夹的默认打开方式变成了cmd.双击任何一个文件夹,显示相关的提示错误信息如下: [Window Ti ...

  8. InstallShield 2012 Spring优惠升级到最新版本(2015.4.30之前)

    InstallShield 2012 Spring即将EOF,所以仍在使用InstallShield 2012 Spring的用户请注意下面内容: InstallShield 2012 Spring升 ...

  9. sqlserver mdf向上兼容附加数据库(无法打开数据库 'xxxxx' 版本 611。请将该数据库升级为最新版本。)

    最近工作中有一个sqlserver2005版本的mdf文件,还没有log文件,现在需要 附加到sqlserver2012,经过网上一顿搜索,把完整的过程奉上,供大家参考 首先创建数据库 再设置数据库的 ...

随机推荐

  1. SSH连接虚拟机中的Ubuntu(转)

    摘要:主要是解决不能使用ssh远程Ubuntu的问题.使用的远程工具是putty.也可以使用xshell.ubunut12.0.4是装在虚拟机中的.不过这个应该没有什么影响. 一:问题的出现 前两天使 ...

  2. 12.输入一个成绩计算其A,B,C,D,E等级

    #include <stdio.h> #include <stdlib.h> #include <math.h> int main() { int score; s ...

  3. Popover 弹出框 设置top,显示有时是向下的,解决方式

    参数里面有个popper-options,官网给的值是{boundariesElement: 'body', gpuAcceleration: false },将这个加上问题就解决了.

  4. 2017第八届蓝桥杯C/C++ B组省赛-等差素数列

    标题:等差素数列 2,3,5,7,11,13,....是素数序列. 类似:7,37,67,97,127,157 这样完全由素数组成的等差数列,叫等差素数数列. 上边的数列公差为30,长度为6. 200 ...

  5. Spring Boot 揭秘与实战(七) 实用技术篇 - 异步任务

    文章目录 1. Spring Boot 集成异步任务 2. 单发服务模式 3. 请求应答模式 4. 源代码 Spring 对异步任务具有很好的支持.这篇文章,我们透过 Spring Boot 来讲解下 ...

  6. dblogin userid ogg ERROR: Unable to connect to database using user ogg

    测试环境,初步配置ogg,添加ogg用户连接数据库,提示无权限报错. 1.0 报错信息 GGSCI (enmo) > dblogin userid ogg,password ogg ERROR: ...

  7. Ubuntu Core 网络配置

    /********************************************************************************* * Ubuntu Core 网络配 ...

  8. 20155208徐子涵 2016-2017-2 《Java程序设计》第2周学习总结

    20155208徐子涵 2016-2017-2 <Java程序设计>第2周学习总结 教材学习内容总结 第三章 基础语法 3.1 类型.变量与运算符 • 关键字:在定义java文件名的时候要 ...

  9. Linux中ctrl+z,ctrl+d和ctrl+c的区别

    Ctrl-c Kill foreground processCtrl-z Suspend foreground processCtrl-d Terminate input, or exit shell

  10. 斐波那契数列的生成 %1e8 后的结果

    方法一  用数组开,一般开到1e7,1e8 左右的数组就是极限了   对时间也是挑战 #include<bits/stdc++.h> using namespace std; ; int ...