启动etcd的时候报错:

# systemctl restart etcd
Job for etcd.service failed because the control process exited with error code. See "systemctl status etcd.service" and "journalctl -xe" for details. # journalctl -xe
Nov 28 10:26:07 mysql7 systemd[1]: Starting Etcd Server...
-- Subject: Unit etcd.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit etcd.service has begun starting up.
Nov 28 10:26:07 abce etcd[2598]: recognized and used environment variable ETCD_ADVERTISE_CLIENT_URLS=http://10.10.20.70:2379
Nov 28 10:26:07 abce etcd[2598]: recognized and used environment variable ETCD_INITIAL_ADVERTISE_PEER_URLS=http://8.8.8.8:2380
Nov 28 10:26:07 abce etcd[2598]: recognized and used environment variable ETCD_INITIAL_CLUSTER=etcd0=http://8.8.8.8:2380
Nov 28 10:26:07 abce etcd[2598]: recognized and used environment variable ETCD_INITIAL_CLUSTER_STATE=new
Nov 28 10:26:07 abce etcd[2598]: recognized and used environment variable ETCD_INITIAL_CLUSTER_TOKEN=cluster1
Nov 28 10:26:07 abce etcd[2598]: recognized and used environment variable ETCD_LISTEN_PEER_URLS=http://8.8.8.8:2380
Nov 28 10:26:07 abce etcd[2598]: recognized environment variable ETCD_NAME, but unused: shadowed by corresponding flag
Nov 28 10:26:07 abce etcd[2598]: recognized environment variable ETCD_LISTEN_CLIENT_URLS, but unused: shadowed by corresponding flag
Nov 28 10:26:07 abce etcd[2598]: etcd Version: 3.3.11
Nov 28 10:26:07 abce etcd[2598]: Git SHA: 2cf9e51
Nov 28 10:26:07 abce etcd[2598]: Go Version: go1.10.3
Nov 28 10:26:07 abce etcd[2598]: Go OS/Arch: linux/amd64
Nov 28 10:26:07 abce etcd[2598]: setting maximum number of CPUs to 4, total number of available CPUs is 4
Nov 28 10:26:07 abce etcd[2598]: no data-dir provided, using default data-dir ./default.etcd
Nov 28 10:26:07 abce etcd[2598]: the server is already initialized as member before, starting as etcd member...
Nov 28 10:26:07 abce etcd[2598]: listening for peers on http://8.8.8.8:2380
Nov 28 10:26:07 abce etcd[2598]: listening for client requests on 8.8.8.8:2379
Nov 28 10:26:07 abce etcd[2598]: listening for client requests on localhost:2379
Nov 28 10:26:07 abce etcd[2598]: couldn't find local name "default" in the initial cluster configuration
Nov 28 10:26:07 abce systemd[1]: etcd.service: main process exited, code=exited, status=1/FAILURE
Nov 28 10:26:07 abce systemd[1]: Failed to start Etcd Server.
-- Subject: Unit etcd.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit etcd.service has failed.
--
-- The result is failed.
Nov 28 10:26:07 abce systemd[1]: Unit etcd.service entered failed state.
Nov 28 10:26:07 abce systemd[1]: etcd.service failed.
Nov 28 10:26:07 abce systemd[1]: etcd.service holdoff time over, scheduling restart.
Nov 28 10:26:07 abce systemd[1]: start request repeated too quickly for etcd.service
Nov 28 10:26:07 abce systemd[1]: Failed to start Etcd Server.
-- Subject: Unit etcd.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit etcd.service has failed.
--
-- The result is failed.
Nov 28 10:26:07 abce systemd[1]: Unit etcd.service entered failed state.
Nov 28 10:26:07 abce systemd[1]: etcd.service failed.

  

检查配置文件:

#[Member]
ETCD_LISTEN_PEER_URLS="http://8.8.8.8:2380"
ETCD_LISTEN_CLIENT_URLS="http://localhost:2379,http://8.8.8.8:2379"
ETCD_NAME="default" #[Clustering]
ETCD_INITIAL_ADVERTISE_PEER_URLS="http://8.8.8.8:2380"
ETCD_ADVERTISE_CLIENT_URLS="http://8.8.8.8:2379"
ETCD_INITIAL_CLUSTER="etcd0=http://8.8.8.8:2380"
ETCD_INITIAL_CLUSTER_TOKEN="cluster1"
ETCD_INITIAL_CLUSTER_STATE="new"

  

可以看到:

ETCD_NAME="default"
ETCD_INITIAL_CLUSTER="etcd0=http://8.8.8.8:2380"

 

这里参数配置不一致。改成一致就可以了。

etcd启动报错:couldn't find local name "default" in the initial cluster configuration的更多相关文章

  1. springboot 工程启动报错之Consider defining a bean of type ‘XXX’ in your configuration.

    一.前言: 使用springboot自动注入的方式搭建好了工程,结果启动的时候报错了!!!,错误如下图: Description: Field userEntityMapper in com.xxx. ...

  2. ubuntu 下安装 mysql 启动报错:ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

    环境: ubuntu LTS 18.04.1 mysql Ver 14.14 Distrib 5.7.29, for Linux (x86_64) 初探 linux,按照如下安装完mysql sudo ...

  3. apache无法启动报错No space left on device

    apache无法启动报错No space left on device 故障现象:apache无法启动ipcs信号量很多 # service httpd startStarting httpd : [ ...

  4. selenium启动报错“ incorrect JSON status mapping for 'unknown error' (500 expected)”

    前面讲了工程启动报错“selenium启动报错Unable to read VR Path Registry from C:\Users\clinva\AppData\Local\openvr\ope ...

  5. 【原创】大叔问题定位分享(24)hbase standalone方式启动报错

    hbase 2.0.2 hbase standalone方式启动报错: 2019-01-17 15:49:08,730 ERROR [Thread-24] master.HMaster: Failed ...

  6. 使用CXF+Spring发布WebService,启动报错

    使用CXF+Spring发布WebService,启动报错,日志如下: 五月 12, 2017 9:01:37 下午 org.apache.tomcat.util.digester.SetProper ...

  7. Celery 启动报错 can_read() got an unexpected keyword argument timeout

    问题: Celery 启动报错 can_read() got an unexpected keyword argument timeout 方案:更改redis版本和celery版本,我使用下面的ce ...

  8. mlflow ui 启动报错No such file or directory: 'gunicorn': 'gunicorn'

    1.mlflow ui 启动报错,信息如下: [root@localhost mlflow]# mlflow ui /usr/local/python3/lib/python3./importlib/ ...

  9. 【原创】大叔经验分享(67)spring boot启动报错

    spring boot 启动报错: Caused by: java.lang.IllegalArgumentException: LoggerFactory is not a Logback Logg ...

随机推荐

  1. Linux基础:时间同步工具Chrony

    在Linux下,默认情况下,系统时间和硬件时间,并不会自动同步.在Linux运行过程中,系统时间和硬件时间以异步的方式运行,互不干扰.硬件时间的运行,是靠Bios电池来维持,而系统时间,是用CPU t ...

  2. Pandas 之 DataFrame 常用操作

    import numpy as np import pandas as pd This section will walk you(引导你) through the fundamental(基本的) ...

  3. Mysql 存储过程初识

    存储过程 认识 在一些编程语言中, 如pascal, 有一个概念叫"过程" procedure, 和"函数" function, 如VB中的sub. Java, ...

  4. Webpack 打包工具

    1. webpack 概念 [文档地址](https://www.webpackjs.com/concepts/) 2. webpack 命令使用及相关工具包 1. webpack 安装和打包命令: ...

  5. CentOS6.7安装部署之Tomcat多实例

    Tomcat单机多实例配置 操作前的准备:关闭防火墙,配置好IP地址,安装好JAVA环境 1.首先创建tomcat所有实例共同的工作目录/data/webapps以及tomcat所有实例的所在目录/d ...

  6. 快速的在linux服务器上安装jdk8

    1.执行命令 yum -y list java* 查看可安装java版本.执行成功后可以看见如下的结果 选择一个java版本进行安装,这里我们希望安装java1.8,因为我们的机器是64位的,所以选择 ...

  7. Dapper use Table Value Parameter in C# (Sql Server 数组参数)

    Dapper 也可以使用 数组参数 参考:Blog on Github Dapper 调用存储过程 :单个参数 static void Main(string[] args) { var connec ...

  8. Nginx与多版本Php配置

    这次忍住没爆粗口,但真的,通过rpm包,yum安全的php-fpm,让我无言以对. 一个Php程序代码,到处测试,显示的菜单都OK,但独独在正式服务器的php-fpm下,少了很多菜单, 不知道是肿么回 ...

  9. 项目Beta冲刺(团队)--6/7

    课程名称:软件工程1916|W(福州大学) 作业要求:项目Beta冲刺 团队名称:葫芦娃队 作业目标:进行新一轮的项目冲刺,尽力完成并完善项目 团队博客 队员学号 队员昵称 博客地址 04160242 ...

  10. nuxt 项目设置缩进为4个空格

    1..editorconfig 文件下的indent_size: 2更改为indent_size: 4 2..prettierrc 文件 { "singleQuote": true ...