autofs:自动挂载器
自动挂载器是一个监视目录的守护进程,并在目标子目录被引用时,自动执行预定义的NFS挂载
自动挂载器由autofs服务脚本管理
自动挂载器由auto.master配置文件进行配置,该文件引用了一个按惯例称作/etc/auto.misc或其他类似名称的二级配置文件
autofs与NFS两者之间配后用的还是比较多的
 
mount命令参数非常多,如下为与NFS相关的参数。
(1)-a:把/etc/fstab中列出的路径全部挂载。
(2)-t:需要mount的类型,如nfs等。
(3)-r:将mount的路径定为read only。
(4)-v mount:过程的每一个操作都有message传回到屏幕上。
(5)rsize=n:在NFS服务器读取文件时NFS使用的字节数,默认值是1 024个字节。
(6)wsize=n:向NFS服务器写文件时NFS使用的字节数,默认值是1 024个字节。
(7)timeo=n:从超时后到第1次重新传送占用的1/7秒的数目,默认值是7/7秒。
(8)retry=n:在放弃后台mount操作之前可以尝试的次数,默认值是7 000次。
(9)soft:使用软挂载的方式挂载系统,若Client的请求得不到回应,则重新请求并传回错误信息。
(10)hard:使用硬挂载的方式挂载系统,该值是默认值,重复请求直到NFS服务器回应。
(11)intr:允许NFS中断文件操作和向调用它的程序返回值,默认不允许文件操作被中断。
(12)fg:一直在提示符下执行重复挂载。
(13)bg:如果第1次挂载文件系统失败,继续在后台尝试执行挂载,默认值是失败后不在后台处理。
(14)tcp:对文件系统的挂载使用TCP,而不是默认的UDP。
说明:mount NFS服务器的另一个重要参数是hard(硬)mount或soft(软)mount。
 
采用hard mount,NFS客户机会不断地尝试与NFS服务器连接(在后台一般不会给出任何提示信息),直到挂载上为止。
采用soft mount,会在前台尝试与NFS服务器连接,当收到错误信息后终止mount尝试,并给出相关信息。
 
######################简单配置###########################
1、挂载本地分区

安装 yum -y
install autofs

[root@pts/0 ~]# rpm -qa autofs
autofs-5.0.1-0.rc2.143.el5
[root@pts/0 ~]#
 
[root@pts/0 ~]# grep -v '^#' /etc/auto.master
/misc  /etc/auto.misc         #/misc是定义的自动mount的挂载点,/etc/auto.misc里定义了mount的动作

/home  /etc/auto.home         #/home是定义的自动mount的挂载点;/etc/auto.home定义了mount的动作,

#此文件系统默认不存在,需要我们手工创建。
/net    -hosts
+auto.master
[root@pts/0 ~]# grep -v '^#' /etc/auto.misc
 
cd             
-fstype=iso9660,ro,nosuid,nodev :/dev/cdrom
#cd为目标目录名称    中间段则为挂载选项    最后是挂载目录
[root@pts/0 ~]#
 
[root@pts/0 misc]# ls
[root@pts/0 misc]# grep sda4 /etc/auto.master
/misc/sda4      /etc/auto.sda   --timeout=60
[root@pts/0 misc]# grep sda4 /etc/auto.sda
sda4    -fstype=ext3    :/dev/sda4
[root@pts/0 misc]# service autofs start    //启动服务
启动automount:     
                                     [确定]
[root@pts/0 misc]# ls          
//神奇目录自动出现
sda4
[root@pts/0 misc]# cd sda4/
[root@pts/0 sda4]# ls         //进入之后还是什么都没有
[root@pts/0 sda4]# cd sda4    //直接cd
sda4,神奇的一刻到了,竟然进去了
[root@pts/0 sda4]# pwd
/misc/sda4/sda4
[root@pts/0 sda4]# ls
lost+found
[root@pts/0 sda4]# mount | grep sda4   //mount显示挂载成功
/dev/sda4 on /misc/sda4/sda4 type ext3 (rw)
[root@pts/0 sda4]#
 
 
2、挂载NFS共享目录
[root@pts/0 ~]# cat /etc/exports
/tmp    192.168.0.0/24(rw)
[root@pts/0 ~]# service nfs restart
关闭NFS mountd:                                         
[失败]
关闭NFS 守护进程:                                       
[失败]
关闭NFS quotas:                                         
[失败]
关闭NFS 服务:                                           
[失败]
启动NFS 服务:       
                                    [确定]
关掉NFS 配额:                                           
[确定]
启动NFS 守护进程:                                       
[确定]
启动NFS mountd:                                         
[确定]
[root@pts/0 ~]# showmount -e 127.0.0.1  
Export list for 127.0.0.1:
/tmp 192.168.0.0/24
[root@pts/0 ~]# vi /etc/auto.master
[root@pts/0 ~]# grep tmp /etc/auto.master
/misc/tmp       /etc/auto.nfs
[root@pts/0 ~]# vi /etc/auto.nfs
[root@pts/0 tmp]# grep tmp /etc/auto.nfs
tmp     -typefs=nfs,rw  127.0.0.1:/tmp  
#这里是本地测试,远程测试的话把IP地址修改为远程NFS服务端即可
[root@pts/0 ~]# service autofs  restart
停止automount:                                          
[确定]
启动automount:                                          
[确定]
[root@pts/0 ~]# cd /misc/tmp/tmp
[root@pts/0 tmp]# ls
gconfd-root   scim-panel-socket:0-root  whatis.Qs3891
mapping-root  setuplog.txt
[root@pts/0 tmp]#
 
3、挂载samba
挂载samba这里就不作演示了,除了在auto.master中加入之前类似语句,再建立一个auto.smb的文件,填入:
windows    -fstype=smbfs,username=admin%password
://hostname/ShareFolder
即可
 
4、挂载本地镜像
[root@pts/0 ~]# grep iso /etc/auto.master
/misc/iso       /etc/auto.iso
[root@pts/0 ~]# cat /etc/auto.iso
iso            
-fstype=iso9660,ro,nosuid,nodev,loop    :/root/rhel5u5.iso
[root@pts/0 ~]# service autofs restart
停止automount:                
                          [确定]
启动automount:                                          
[确定]
[root@pts/0 ~]# cd /misc/
[root@pts/0 misc]# ls
iso
[root@pts/0 misc]# cd iso/
[root@pts/0 iso]# ls
[root@pts/0 iso]# cd iso
[root@pts/0 iso]# ls
Cluster           
README-te.html           
RELEASE-NOTES-U5-en
ClusterStorage    
README-zh_CN.html        
RELEASE-NOTES-U5-en.html
EULA              
README-zh_TW.html        
RELEASE-NOTES-U5-es.html
eula.en_US        
RELEASE-NOTES-as.html     RELEASE-NOTES-U5-fr.html
GPL 
              RELEASE-NOTES-bn.html    
RELEASE-NOTES-U5-gu.html
------省略------
[root@pts/0 iso]# mount | grep rhel5u5.iso
/root/rhel5u5.iso on /misc/iso/iso type iso9660
(ro,nosuid,nodev,loop=/dev/loop1)
[root@pts/0 iso]#
 
autofs如此便可以结合yum安装软件了,不安装的时候就不挂载,安装软件的时候就自动去挂载
[root@pts/0 mnt]# tail -5 /etc/yum.repos.d/rhel-debuginfo.repo
[repo]
name=repo
baseurl=file:///misc/iso/iso/Server
enabled=1
gpgcheck=0
[root@pts/0 mnt]# yum clean all
Loaded plugins: rhnplugin, security
Cleaning up Everything
[root@pts/0 mnt]# yum list
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
repo                                                    
| 1.3 kB     00:00
repo/primary                  
                          |
753 kB     00:00
repo                                                                 
2348/2348
------省略------
 
 
#####################################

linux autofs自动挂载的更多相关文章

  1. Linux:SAMBA共享、NFS共享、Autofs自动挂载

    SAMBA.NFS共享区别 NFS开源文件共享程序:NFS(NetworkFile System)是一个能够将多台Linux的远程主机数据挂载到本地目录的服务,属于轻量级的文件共享服务,不支持Linu ...

  2. Linux服务——二、配置NFS及autofs自动挂载服务

    一.NFS服务配置步骤 NFS的作用:能够使两台虚拟机之间实现文件共享.数据同步 准备:主机名.网络.yum源 Server端: 1.安装nfs-util和rpcbind:(图形化自带) [root@ ...

  3. Linux命令-自动挂载文件/etc/fstab功能详解

    Linux命令-自动挂载文件etcfstab功能详解 一./etc/fstab文件的作用 磁盘被手动挂载之后都必须把挂载信息写入/etc/fstab这个文件中,否则下次开机启动时仍然需要重新挂载. 系 ...

  4. autofs 自动挂载.

    autofs 自动挂载. 操作环境:redhat 6 一.autofs 说明 自动挂载器是一个监视目录的守护进程,并在目标子目录被引用时,自动执行预定义的挂载 自动挂载器由autofs服务脚本管理 自 ...

  5. 【转载】Linux命令-自动挂载文件/etc/fstab功能详解[转]

    博客园 首页 新随笔 联系 订阅 管理 随笔 - 322  文章 - 0  评论 - 19 Linux命令-自动挂载文件/etc/fstab功能详解[转]     一./etc/fstab文件的作用 ...

  6. autofs自动挂载

    autofs是根据需要自动挂载,默认5分钟不使用自动卸载挂载点!nfs,smb,iso,sd*的挂载 环境:RHEL6.5/Centos6.5    172.24.0.25 01.安装autofs y ...

  7. Linux开机自动挂载Windows分区

    使用Linux的朋友肯定都不会对本文所谈的内容陌生,在Linux系统里,通常不会开机自动挂载Windows文件系统下的分区.Ubuntu系统下要点击Windows分区才会挂载,Fedora下则甚至要输 ...

  8. linux开机自动挂载NTFS-WINDOWS分区

    1.安装ntfs-3g-2009.4.4.tgz 2.输入fdisk -l 看一下分区 由此可见:/dev/sda5,6,7 即是windows下的D,E,F盘(NTFS格式). 3.vim /etc ...

  9. Autofs自动挂载探讨

    Autofs介绍: mount是用来挂载文件系统的,可以在系统启动的时候挂载也可以在系统启动后挂载.对于本地固定设 备,如硬盘可以使用mount挂载:而光盘.软盘.NFS.SMB等文件系统具有动态性, ...

随机推荐

  1. ENSP静态链路聚合实验配置要点及实例

    链路聚合分为:静态链路聚合.动态链路聚合链路聚合的负载分担模式:对于二层数据流,系统会根据MAC地址(源mac地址和目的mac地址来计算),而对于三层数据流则会根据ip地址来进行负载分担计算. 静态链 ...

  2. LeetCode 686. 重复叠加字符串匹配(Repeated String Match)

    686. 重复叠加字符串匹配 686. Repeated String Match 题目描述 给定两个字符串 A 和 B,寻找重复叠加字符串 A 的最小次数,使得字符串 B 成为叠加后的字符串 A 的 ...

  3. python 坑1

    目录 1.编码解码 2.基础数据类型补充: 2.1 str: 2.2list: 2.3tuple: 2.4dict: 2.5set: 3.坑 4.类型转换: 5.数据类型: 1.编码解码 编码:将文字 ...

  4. ModelSerializer组件

    ModelSerializer组件 一 .DRF模型类序列化器 如果我们想要使用序列化器对应的是Django的模型类,DRF为我们提供了ModelSerializer模型类序列化器来帮助我们快速创建一 ...

  5. docker(四):集群swarm

    docker使用入门(四):集群swarm swarm是一组位于同一集群且运行docker的机器,用户可以通过swarm manager向swarm输入命令,swarm中的机器可以是虚拟机也可以是物理 ...

  6. foreach引用坑

    先看下面代码 $arr1 = [1, 2]; foreach($arr1 as $key => $value) { $value = $value + 1; } var_dump($key, $ ...

  7. Java线程的等待与唤醒完整示例代码

    项目结构: 资源类: 输入线程:  输出线程: 测试: 人妖问题发生: 线程安全问题的解决方法: 调用Object的wait()和notify()方法时需注意:必须是锁对象方可调用,否则将抛出无效的监 ...

  8. python爬虫-喜马拉雅_晚安妈妈睡前故事

    这里先说下思路: 1.首先要获取当前书的音频信息 '''获取当前书的音频信息''' all_list = [] for url in self.book_url: r = requests.get(u ...

  9. COCOeval接口使用

    COCOeval类简介 class COCOeval: # Interface for evaluating detection on the Microsoft COCO dataset. # # ...

  10. Form' threw an exception of type 'System.InvalidOperationException'

    环境:VS2017 NetCore 2.2 Razor Layui 在处理异步请求是遇到"((Microsoft.AspNetCore.Http.Internal.DefaultHttpRe ...