【故障处理】CRS-1153错误处理
【故障处理】CRS-1153错误处理
1 CRS-1153: There was an error setting Oracle Clusterware to rolling patch mode.
升级PSU的时候有错误,需要回退patch,但是报错了:
错误信息:
|
HQNHL-ALHR-R01:/oracle/app/12.1.0/grid/crs/install # rootcrs.pl -prepatch Using configuration parameter file: /oracle/app/12.1.0/grid/crs/install/crsconfig_params Oracle Clusterware active version on the cluster is [12.1.0.2.0]. The cluster upgrade state is [ROLLING PATCH]. The cluster active patch level is [0]. PROC-28: Oracle Cluster Registry already in current version CRS-1153: There was an error setting Oracle Clusterware to rolling patch mode. CRS-4000: Command Start failed, or completed with errors. 2016/11/23 18:45:40 CLSRSC-430: Failed to start rolling patch mode Died at crspatch.pm line 783. HQNHL-ALHR-R01:/oracle/app/12.1.0/grid/crs/install # |
1.1 MOS 1943498.1

根据MOS:
CAUSE
The issue happens if the cluster is already in rolling patch mode, it's due to unpublished bug:
BUG 19499021 - 12.1.0.2.1GIPSU: OPATCHAUTO HIT CLSRSC-430: FAILED TO START ROLLING PATCH MODE
SOLUTION
The fix is included in 12.1.0.2 GI PSU1, the workaround is to stop rolling patch and re-run opatchauto:
# crsctl stop rollingpatch
解决:
|
HQNHL-ALHR-R01:~ # /oracle/app/12.1.0/grid/bin/crsctl stop rollingpatch CRS-1169: The cluster is consistent and the cluster active patch level is [0]. CRS-4000: Command Stop failed, or completed with errors. HQNHL-ALHR-R01:~ # HQNHL-ALHR-R01:~ # oerr crs 1169 1169, 0, "The cluster is consistent and the cluster active patch level is [%u]." // *Cause: The cluster has already completed the rolling patch procedure. // *Action: None. HQNHL-ALHR-R01:~ # |
重新执行/oracle/app/12.1.0/grid/crs/install/rootcrs.pl -prepatch命令打PUS补丁即可。
附录:MOS 1943498.1 CRS-1153: There was an error setting Oracle Clusterware to rolling patch mode. (文档 ID 1943498.1)
In this Document
| Symptoms |
| Cause |
| Solution |
APPLIES TO:
Oracle Database - Enterprise Edition - Version 12.1.0.1 to 12.1.0.2 [Release 12.1]
Information in this document applies to any platform.
SYMPTOMS
Applying patch with opatchauto fails with the following:
[root@racnode1 19392646]# /ocw/c102/OPatch/opatchauto apply -oh /ocw/c102 -ocmrf /mnt/OP/ocm.rsp
....
Configuration Validation: Successful
Patch Location: /mnt/OP/C102PSU1/19392646
Grid Infrastructure Patch(es): 19303936 19392590 19392604
RAC Patch(es): 19303936 19392604
Patch Validation: Successful
Stopping CRS ... Failed
Command "/ocw/c102/perl/bin/perl -I/ocw/c102/perl/lib -I/ocw/c102/crs/install /ocw/c102/crs/install/rootcrs.pl -prepatch" execution failed:
Died at /ocw/c102/crs/install/crspatch.pm line 751.
For more details, please refer to the log file "/ocw/c102/cfgtoollogs/opatchauto/19392646/opatch_gi_2014-10-19_11-41-35_deploy.debug.log".
Apply Summary:
Following patch(es) failed to be installed:
GI Home: /ocw/c102: 19303936, 19392590, 19392604
opatchauto failed with error code 2.
From the forementioned log file:
2014-10-19_11-42-02 :
Executing command:
/ocw/c102/perl/bin/perl -I/ocw/c102/perl/lib -I/ocw/c102/crs/install /ocw/c102/crs/install/rootcrs.pl -prepatch
2014-10-19_11-42-08 :
COMMAND EXECUTION FAILURE :
Using configuration parameter file: /ocw/c102/crs/install/crsconfig_params
Oracle Clusterware active version on the cluster is [12.1.0.2.0]. The cluster upgrade state is [ROLLING PATCH]. The cluster active patch level is [0].
PROC-28: Oracle Cluster Registry already in current version
CRS-1153: There was an error setting Oracle Clusterware to rolling patch mode.
CRS-4000: Command Start failed, or completed with errors.
2014/10/19 11:42:06 CLSRSC-430: Failed to start rolling patch mode
ERROR:
Died at /ocw/c102/crs/install/crspatch.pm line 751.
2014-10-19_11-42-08 :
Failed to run this command :
/ocw/c102/perl/bin/perl -I/ocw/c102/perl/lib -I/ocw/c102/crs/install /ocw/c102/crs/install/rootcrs.pl -prepatch
oracle.opatch.gi.RunExecutionSteps.runGenericShellCommands(RunExecutionSteps.java:874)
oracle.opatch.gi.RunExecutionSteps.processAllSteps(RunExecutionSteps.java:197)
oracle.opatch.gi.GIPatching.processPatchingSteps(GIPatching.java:756)
oracle.opatch.gi.OPatchautoExecution.main(OPatchautoExecution.java:125)
Command "/ocw/c102/perl/bin/perl -I/ocw/c102/perl/lib -I/ocw/c102/crs/install /ocw/c102/crs/install/rootcrs.pl -prepatch" execution failed:
Died at /ocw/c102/crs/install/crspatch.pm line 751.
CAUSE
The issue happens if the cluster is already in rolling patch mode, it's due to unpublished bug:
BUG 19499021 - 12.1.0.2.1GIPSU: OPATCHAUTO HIT CLSRSC-430: FAILED TO START ROLLING PATCH MODE
SOLUTION
The fix is included in 12.1.0.2 GI PSU1, the workaround is to stop rolling patch and re-run opatchauto:
About Me
|
............................................................................................................................... ● 本文作者:小麦苗,只专注于数据库的技术,更注重技术的运用 ● 本文在itpub(http://blog.itpub.net/26736162)、博客园(http://www.cnblogs.com/lhrbest)和个人微信公众号(xiaomaimiaolhr)上有同步更新 ● 本文itpub地址:http://blog.itpub.net/26736162/viewspace-2129163/ ● 本文博客园地址:http://www.cnblogs.com/lhrbest/p/6106548.html ● 本文pdf版及小麦苗云盘地址:http://blog.itpub.net/26736162/viewspace-1624453/ ● QQ群:230161599 微信群:私聊 ● 联系我请加QQ好友(642808185),注明添加缘由 ● 于 2016-11-24 15:00 ~ 2016-11-24 19:00 在农行完成 ● 文章内容来源于小麦苗的学习笔记,部分整理自网络,若有侵权或不当之处还请谅解 ● 版权所有,欢迎分享本文,转载请保留出处 ............................................................................................................................... 手机长按下图识别二维码或微信客户端扫描下边的二维码来关注小麦苗的微信公众号:xiaomaimiaolhr,免费学习最实用的数据库技术。
|

【故障处理】CRS-1153错误处理的更多相关文章
- centos mysql 大量数据导入时1153 错误:1153 - Got a packet bigger than 'max_allowed_packet' bytes
参考:http://stackoverflow.com/questions/93128/mysql-error-1153-got-a-packet-bigger-than-max-allowed-pa ...
- 【故障处理】IMP-00010错误 12C的dmp文件导入11G
[故障处理]IMP-00010错误 12C的dmp文件导入11G 1 BLOG文档结构图 2 前言部分 2.1 导读和注意事项 各位技术爱好者,看完本文后,你可以掌握如下的技能,也可以学到一些其 ...
- 【故障处理】ORA-19809错误处理
[故障处理]ORA-19809错误处理 一.1 BLOG文档结构图 一.2 前言部分 一.2.1 导读和注意事项 各位技术爱好者,看完本文后,你可以掌握如下的技能,也可以学到一些其它 ...
- 【故障处理】ORA-12162 错误的处理
[故障处理]ORA-12162: TNS:net service name is incorrectly specified 一.1 场景 今天拿到一个新的环境,可是执行sqlplus / as s ...
- 【ASH】如何导出视图DBA_HIST_ACTIVE_SESS_HISTORY的查询结果数据
[ASH]如何导出视图DBA_HIST_ACTIVE_SESS_HISTORY的查询结果数据 1.1 BLOG文档结构图 1.2 前言部分 1.2.1 导读和注意事项 各位技术爱好者,看完本文后 ...
- 《Google SRE》读后感
注:这是去年国庆时的一篇读书笔记,最近线上故障频繁,重新读了下这篇读书笔记,觉得<Google SRE>非常棒,遂从简书再搬家到博客园,希望大家受益.我的简书地址:daoqidelv 国庆 ...
- 学习笔记:webpack
http://wiki.jikexueyuan.com/project/webpack-handbook/ Webpack 中文指南 http://www.itzjt.cc/2017/04/09/we ...
- Grid Infrastructure 启动的五大问题 (文档 ID 1526147.1)
适用于: Oracle Database - Enterprise Edition - 版本 11.2.0.1 和更高版本本文档所含信息适用于所有平台 用途 本文档的目的是总结可能阻止 Grid In ...
- 航空概论(历年资料,引之百度文库,PS:未调格式,有点乱)
航空航天尔雅 选择题1. 已经实现了<天方夜谭>中的飞毯设想.—— A——美国2. 地球到月球大约—— C 38 万公里3. 建立了航空史上第一条定期空中路线—— B——德国4. 对于孔明 ...
随机推荐
- .NET框架面向对象分层的个人想理
简单.层次清晰不要过度优化,接口这玩意儿就是个双刃剑,玩好了解藕,玩不好自找麻烦,好的代码永远都是傻瓜都能看懂的. 总结成以下几条: 公用层 代码公用并且与第三方DLL和业务逻辑无关的 独立出来 逻辑 ...
- [操作系统实验lab3]实验报告
[感受] 这次操作系统实验感觉还是比较难的,除了因为助教老师笔误引发的2个错误外,还有一些关键性的理解的地方感觉还没有很到位,这些天一直在不断地消化.理解Lab3里的内容,到现在感觉比Lab2里面所蕴 ...
- thread_CyclicBarrier回环栅栏
CyclicBarrier回环栅栏,字面意思是可循环使用(Cyclic)的屏障(Barrier).通过它可以实现让一组线程等待至某个状态之后再全部同时执行. 它要做的事情是,让一组线程到达一个屏障(也 ...
- Python入门笔记(21):Python函数(4):关于函数式编程的内建函数
一.关于函数式编程的内建函数 apply()逐渐被舍弃,这里不讨论 1.filter() #filter(func,seq) """纯Python描述filter函数&q ...
- Orchard 异常
在Orchard项目中碰的各种错误整理 1 打开网站出现404 . 查看日志 日志位置Orchard.Web\App_Data\Logs\orchard-error-2016.03.23.log 错误 ...
- Ajax,谷歌提示AutoCompleteExtender控件
提示内容从数据库中读取: ------------------------------------------页面 <asp:ScriptManager ID="ScriptManag ...
- 平衡二叉树---Shaolin
Description Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temp ...
- [moka学习笔记]yii2设置语言和时区
1.在web/index.php中 (new yii\web\Application($config))->run(); $app = new \yii\web\Application($con ...
- 转载Quandl R Package
Quandl R Package 通过Quandl API可以快速准确地获取宏观经济数据.(https://www.quandl.com/docs/api) 分享两个国外的优秀网站 R和Python在 ...
- Follow me to learn how to use mvc template
Introduction After having gone through many project: Project A Project B Project C I start to write ...
