这是我2018年的第一篇博客...人真是懒了啊...最近在写微信小程序,觉得小程序做的也...

好了不吐槽了,言归正传

前言:

由于我之前不是买了个三年的香港服务器么 , 之前广州2的服务器我就没有续费,把项目搬到香港服务器去了 , 这里埋下了个引子 : 我直接搬运的项目, 也原本就是个要废弃的项目(纯springmvc写的),准备重新用springboot+mybatis重写一遍,所以项目我也没有改,放到上面去了,数据库用的还是老服务器的数据库.

正文:

最近几天,我发现我的阿里云服务器空间被占满了,看了一下我用来缓存图片的目录,也就用了3-5个G,按理说不应该发生这种情况,于是就排查了一下是哪里的问题

先看看磁盘空间还有多少:

df -h

因为Mac上博客园,插图好麻烦的,要截图,保存成图片,再上传,我不弄了,你们输入,看一眼就知道是咋回事了

du -h --max-depth=

这个指令是看一下当前目录下,深度为1的子节点所占用的磁盘大小,一层一层找,找到异常的地方就可以了

后记:

经过排查,我总共40G空间的磁盘,tomcat的logs文件就占了26G,妈耶,打开一看,最近几天的日志异常的大,vim看了一下日志,原来是因为老项目用的是老服务器的数据库连接,由于老服务器关闭了,自然每一次请求就要报一次错,往日志里写一次,而老项目里面有定时任务跑脚本,每天就疯狂的抓数据,往数据库存,导致了log文件巨大无比,纯文本的文件,一天的日志能有2个多G那么大...

那我就把项目关了呗,于是我就在tomcat的server.xml里,把引用老项目的域名都指向了新项目,并重启了Tomcat,按理说我以为,没有指向老项目,那么不被调起来,就没问题了吧.

结果今天,在我想把新代码放到服务器的时候,sftp给我报这个错误:

Couldn't write to remote file

???我特么当时都一头雾水,咋了,是我没权限还是啥?我以为是我Mac用户权限啥的出问题了,我前几天刚切过用户.

折腾了一会,我上服务器一看,文件上去了,大小是0b,我看了一眼磁盘空间,果然又满了.

看了一下,老项目还在启动着...

原来tomcat/webapps文件夹里面的项目,只要tomcat启动,项目也启动啊,由于以前我是放在别的地方,引用过来,启动tomcat以后,只要server.xml里没有引用,项目就不会启动...这次也是给自己长了个教训...

CentOS磁盘用完的解决办法,以及Tomcat的server.xml里无引用,但是项目仍启动的问题的更多相关文章

  1. centos 下yum lock的解决办法

    centos 下yum lock的解决办法 centos7下yum install的时候,报了一堆错误,如下: Another app is currently holding the yum loc ...

  2. 磁盘处于脱机状态"解决办法

    由于管理员设置的策略,该磁盘处于脱机状态"解决办法 1.运行:cmd 2.输入:DISKPART.exe 3.DISKPART> san 4.DISKPART> san poli ...

  3. 本机tomcat的server.xml被还原的问题及解决办法

    将tomcat的server.xml进行修改,但当eclipse发布站点后,发布tomcat中的server.xml会被还原. 原因是eclipse会将自己的tomcat配置文件对tomcat覆盖,解 ...

  4. Centos安装Chrome浏览器失败解决办法

    最近因为项目需要使用到Centos,自己经常使用Chrome,所有的书签以及信息都是同步在Google,所以尝试在Centos上安装Chrome,按照网上的资料都是安装失败,显示缺少资源,不过最终还是 ...

  5. CentOS——yum命令运行错误解决办法

    问题: [root@name user]# yum File "/usr/bin/yum", line 30 except KeyboardInterrupt, e:        ...

  6. 【记录tomcat报错解决办法】tomcat请求组件没有找到的问题

    报错原因: An incompatible version 1.1.14 of APR based Apache Tomcat Native library is installed, while T ...

  7. javaweb 使用页面模板CSS或者Js修改失效的解决办法(Tomcat缓存问题)

    原因是:浏览器的自动缓存机制导致的. 浏览器会自动缓存静态文件以加快访问速度,但是这导致了他不会再从服务器端接收静态文档了,这就导致我在idea里面改的css和js文档,浏览器根本没下载下来. 所以解 ...

  8. CentOS系统缺少库文件解决办法

    By francis_hao    May 31,2017   程序在编译时出现缺少库文件的提示,如下: as: error while loading shared libraries: libz. ...

  9. Win10 磁盘占用 100% 有效解决办法

    立即查看 任务管理器,看看是不是有一个 服务主机 unistack服务组或者找类似名称的,点开以后你会看到里面有同步主机 blablah请你毫不犹豫的结束它!结束它!结束它! 按下WIN+R调出运行, ...

随机推荐

  1. ArcGIS AddIN异常:无法注册程序集 未能加载文件或程序集"ESRI.ArcGIS.Desktop.Addins"

    异常: 无法注册程序集“D:\CodeXX\bin\Debug\XX.dll”.未能加载文件或程序集“ESRI.ArcGIS.Desktop.AddIns, Version=10.1.0.0, Cul ...

  2. swust oj 956

    约瑟夫问题的实现 2000(ms) 65535(kb) 3266 / 10775 n个人围成一个圈,每个人分别标注为1.2.....n,要求从1号从1开始报数 ,报到k的人出圈,接着下一个人又从1开始 ...

  3. java-03-动手动脑

    1. 问题:这两种方式定义的变量是一样的吗? 早期我们经常这样定义变量  int value=100;前面的示例中这样定义变量  MyClass obj = new MyClass(); 回答:一般情 ...

  4. hadoop-1.0.1根目录下的jar包

  5. consul服务配置维护

    1.命令参数 -advertise:通知展现地址用来改变我们给集群中的其他节点展现的地址,默认情况下-bind地址就是展现地址,然而也存在一些路由地址是不能受约束的,这时候会激活一个不同的地址来供应, ...

  6. Linux:dd命令

    dd:“data duplicator” 意为数据复印机,它可以用来拷贝和转换数据. 备份和恢复整个硬盘或分区 备份MBR(主引导记录) 在ASCII和EBCDIC格式之间转换 也可以为Linux内核 ...

  7. day17:递归函数

    1,递归函数是一个函数体系,非常的难 2,练习题一 # 3.用map来处理字符串列表,把列表中所有人都变成sb,比方alex_sb name=['alex','wupeiqi','yuanhao',' ...

  8. 在服务器上搭建node环境

    一般公司的发布是后台人员完成的,但是作为开发不会发布项目还是有点不高级的感觉 因为没有搭建虚拟机于是就直接在我阿里云的服务器上搭建了node环境, 第一步,前往node官网下载linux下的阿里云的镜 ...

  9. ThinkPHP数据库操作相关

  10. windows程序设计 获取系统文件路径

    获取系统文件路径,打印到txt文件中. #include <windows.h> int WINAPI WinMain( HINSTANCE hInstance, HINSTANCE hP ...