首先执行rpm -qa|grep -i mysql检查一下是否已经安装过mysql

mysql-libs-5.1.73-5.el6_6.x86_64

可见已经安装了库文件,应该先卸载,不然会出现覆盖错误。注意卸载时要使用–nodeps选项忽略依赖关系

卸载老版本的库文件:rpm -e mysql-libs-5.1.73-5.el6_6.x86_64 --nodeps。

使用wget方式直接下载rpm的bundle包,里面包含了server、client、devel等安装包:wget https://cdn.mysql.com//Downloads/MySQL-5.6/MySQL-5.6.36-1.el6.x86_64.rpm-bundle.tar

下载完成后解压:tar -xvf MySQL-5.6.36-1.el6.x86_64.rpm-bundle.tar

得到

MySQL-server-5.6.36-1.el6.x86_64.rpm
MySQL-client-5.6.36-1.el6.x86_64.rpm
MySQL-devel-5.6.36-1.el6.x86_64.rpm
MySQL-shared-5.6.36-1.el6.x86_64.rpm
MySQL-test-5.6.36-1.el6.x86_64.rpm
MySQL-embedded-5.6.36-1.el6.x86_64.rpm
MySQL-shared-compat-5.6.36-1.el6.x86_64.rpm

等rpm安装包文件。

接下来执行rpm安装命令:rpm -ivh MySQL-server-5.6.36-1.el6.x86_64.rpm MySQL-client-5.6.36-1.el6.x86_64.rpm安装server和client,可能安装失败,提示错误信息:

warning: MySQL-server-5.6.36-1.el6.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
error: Failed dependencies:
libaio.so.1()(64bit) is needed by MySQL-server-5.6.36-1.el6.x86_64
libaio.so.1(LIBAIO_0.1)(64bit) is needed by MySQL-server-5.6.36-1.el6.x86_64
libaio.so.1(LIBAIO_0.4)(64bit) is needed by MySQL-server-5.6.36-1.el6.x86_64
libnuma.so.1()(64bit) is needed by MySQL-server-5.6.36-1.el6.x86_64
libnuma.so.1(libnuma_1.1)(64bit) is needed by MySQL-server-5.6.36-1.el6.x86_64
libnuma.so.1(libnuma_1.2)(64bit) is needed by MySQL-server-5.6.36-1.el6.x86_64

这都是因为缺少依赖的相关包造成的,解决办法是通过yum直接安装这些依赖包。
yum -y install libaio
yum -y install numactl

依赖包安装好后再次执行rpm -ivh MySQL-server-5.6.36-1.el6.x86_64.rpm MySQL-client-5.6.36-1.el6.x86_64.rpm来安装server和client。

附上一张完整的安装过程图:注意最后的安装过程信息,后面有用。

安装成功之后,我们来启动mysql服务。执行service mysql start。启动成功之后,在执行mysql -uroot -p命令登录数据库,此时提示错误:

ERROR 1045 (28000): Access denied for user ‘root’@’localhost’ (using password: NO)

因为我们没有密码。Mysql 5.6及以后版本出处于安全考虑,root密码不为空,并强制登陆之后要修改密码。所以在MySQL的安装过程中,会生成一个随机密码。但这个随机密码在哪呢?在这里感谢潇湘隐者提供的解决办法。这时候回过头去看我们MySQL的安装日志信息中:

你会看到MySQL生成了root用户的随机密码,并将这个随机密码放置在/root/.mysql_secret中。知道这个就简单了,执行more /root/.mysql_secret查看文件内容:

# The random password set for the root user at Fri Apr 21 08:16:33 2017 (local time): 4fsMZJ8tWAL6IAIJ

最后这个字符串就是随机密码,复制下来,再次执行mysql -uroot -p命令登录,提示输入密码的时候粘贴再回车就好了。此时我们还不能进行其它的操作,错误提示:

ERROR 1820 (HY000): You must SET PASSWORD before executing this statement

提示必须要先修改密码才能进行别的操作,如图:

修改密码为root123:mysql> set password=password('root123');


到这里还有个问题就是不能远程连接到这个数据库,因为默认是只支持本地链接的。一下是解决这个问题的方法:
切换到mysql库:mysql> use mysql
mysql> update user set host = '%' where user = 'root';

ERROR 1062 (23000): Duplicate entry ‘%-root’ for key ‘PRIMARY’

发现主键冲突了,来查看一下这个表的信息:
mysql> select host from user where user="root";

+————————-+
| host |
+————————-+
| % |
| 127.0.0.1 |
| ::1 |
| localhost.elasticsearch |
+————————-+
4 rows in set (0.00 sec)

原来host已经有了%这个值,所以直接运行命令
mysql> flush privileges;

Query OK, 0 rows affected (0.00 sec)

http://blog.csdn.net/vampirehgg/article/details/70308256

http://blog.csdn.net/wqc19920906/article/details/52608460?locationNum=10&fps=1

Linux(CentOS6.X)安装mysql的更多相关文章

  1. Linux(CentOS6.7) 安装MySql5.7数据库

    linux(CentOS6.7) 环境Mysql 5.7.17安装教程分享给大家,供大家参考,具体内容如下: 1系统约定安装文件下载目录:/data/softwareMysql目录安装位置:/usr/ ...

  2. Centos6.5 安装MYSQL 5.5 -5.6.-5.7 一键yum快速安装 ,初始配置

    Centos6.5 安装MYSQL 5.5 ---5.6---5.7 一键yum快速安装 ,初始配置 第一步:安装mysql-5.5---- 5.6 ---- 5.7的yum源 [root@sv03 ...

  3. Mysql系列三:Centos6下安装Mysql和Mysql主从复制的搭建

    一.Centos6下安装Mysql 检测下系统有没有自带的mysql:yum list installed | grep mysql, 如果已经有的话执行命令yum -y remove mysql-l ...

  4. Linux(CentOS6.7) 安装MySql5.7数据库 图文教程

    linux(CentOS6.7) 环境Mysql 5.7.17安装教程分享给大家,供大家参考,具体内容如下: 1系统约定安装文件下载目录:/data/softwareMysql目录安装位置:/usr/ ...

  5. CentOS6.9安装MySQL(编译安装、二进制安装)

    目录 CentOS6.9安装MySQL Linux安装MySQL的4种方式: 1. 二进制方式 特点:不需要安装,解压即可使用,不能定制功能 2. 编译安装 特点:可定制,安装慢 5.5之前: ./c ...

  6. Linux下yum安装MySQL

    写这篇文章的原因是:在刚开始使用Linux操作系统时想要搭建LAMP环境,于是开始在Google和百度上各种寻找资料,碰到了不是很多的问题后,我决定写这篇文章总结一下在Linux下yum安装MySQL ...

  7. 在Linux机器上安装MySQL

    在Linux机器上安装MySQL,仔细认真些就没有问题. CentOS 7下MySQL 5.7安装.配置与应用_数据库技术_Linux公社-Linux系统门户网站 搞不定的话,直接删掉这个MySQL, ...

  8. linux下如何安装mysql和redis

    linux下如何安装mysql(mariadb) linux下如何安装软件? 1. yum安装软件也得注意,一个是配置yum源 1.我们当前的是阿里云的yum源(下载速度特别快) 通过 yum ins ...

  9. Windows10系统的Linux子系统中安装MySQL数据库心得

    后端开发童鞋们, 自己开发机用的是Windows系统电脑(台式机或笔记本), 而开发的程序和使用的数据库等要运行在Linux服务器上, 这种情况有木有? 提前声明: 本文并不讨论操作系统的比较, 以及 ...

  10. Linux中在线安装Mysql和修改密码设置服务启动

    一.说明:本文教大家在linux下在线安装mysql.网上的很多文章写的太乱,我们只取操作最方便的在线安装方式.本文以Centos为例. 二.安装过程. 1.安装客户端和服务端: (1)检查是否已经安 ...

随机推荐

  1. maven + sonar, gradle + sonar

    sonar installation and configuration Download sonar http://downloads.sonarsource.com/sonarqube/ Deco ...

  2. Java 如何实现在线预览文档及修改(文本文件)

    暂时未解决的问题:多用户并发修改一个文件 测试地址: http://sms.reyo.cn 用户名:aa 密码:123456

  3. Linux终端执行shell脚本,提示权限不够的解决办法

    原文:http://blog.csdn.net/this_capslock/article/details/17415409 今天在Linux尝试搭建dynamips的工作环境,在执行shell脚本时 ...

  4. centos 7 版本升级nginx

    1.首先下载对应最新版nginx wget http://nginx.org/packages/centos/7/noarch/RPMS/nginx-release-centos-7-0.el7.ng ...

  5. 用ArrayAdapter来创建Spinner(自定义布局、默认布局、动态内容、静态内容)

             android:dropDownWidth 下拉列表宽度 android:dropDownHorizontalOffset 下拉列表距离左边的距离 android:dropDownV ...

  6. 架构模式数据源模式之:表数据入口(Table Data Gateway)、行数据入口(Row Data Gateway)、活动记录(Active Record)

    一:表数据入口(Table Data Gateway) 表数据入口提供了用于访问单个表或者视图(也包含了联表查询)的所有SQL,通常一个表一个类.其它代码通过它来实现对数据库的交互.基于这个特点,表数 ...

  7. [转]Hadoop Hive sql语法详解

    转自 : http://blog.csdn.net/hguisu/article/details/7256833 Hive 是基于Hadoop 构建的一套数据仓库分析系统,它提供了丰富的SQL查询方式 ...

  8. C#7.0新增功能点

    原文地址:  https://www.cnblogs.com/runningsmallguo/p/8972678.html 第二部分:C#7.0新增的功能 (1)数字字面量的提升: C#7中的数字文字 ...

  9. you have mixed tabs and spaces fix this

    http://blog.csdn.net/tonyyan19781/article/details/60882443 Vs2013 IDE下,编辑C++的工程源码,在打开文件的时候,会出现 " ...

  10. WEB中会话跟踪

    一.     什么叫会话跟踪 记录用户一段时间内的逻辑上相关联的不同访问请求个过程叫“会话跟踪”.通过用户在每次对服务请求时的唯一标识,可以跟踪会话. 二.     会话跟踪产生的原因 我们都知道In ...