解决FileZilla Server因路径错误导致无法启动问题详细图文教程
问题背景
我作为一个配置无数服务器环境的人,对服务器的配置也算有所了解,不管是在linux平台还是win平台都比较熟悉,但这次帮一个朋友配置win2003服务器的时候却遇到了一个问题:前面配置IIS和PHP及MySQL和zend这些常用的软件都没有任何问题。应朋友的需求,他说FTP服务想用FileZilla Server这款软件,我也就照做了,就在网上下载了一个绿色版的压缩包,然后直接就这样运行了,很正常,客户端也能正常连接。但问题就是他重启一次服务器后就发现出问题了,就是了,出现如图结果:

意思就是连接不上服务器,我查了网上的一些资料,也许是大家说的不是这个问题导致的,也许是大家写错了,都不能解决这个问题,于是有了自己一下的分析解决过程。
问题分析
其实遇到这样的问题,我很自然会想到可能是跟FTP服务的某项服务没有启动,于是发现了以下问题:
1、在系统服务中看到了一个服务名称为FileZilla Server FTP server的服务没有启动:

2、但发现这个服务是自启动的,但问题是这里手动启动都没反应,错误提示为“错误3:系统找不到指定路径”

3、点开该服务属性,发现可执行文件的路径还真的有问题

通过上面的分析,我凭借自己的经验就可以得出来这个问题就是因为我当时第一次的时候为了省事直接在压缩包里直接运行FileZilla的FTP服务,所以系统把文件写到内存,并反映到一个Temp文件夹下,而当服务器重启后,这个Temp也随着内容在内存的丢失而丢失,就很自然也就不能执行FTP服务。所以现在的问题就是要修改这个错误的路径。
问题解决
很多人也许不知道怎么修改服务中的可执行文件的路径,因为就在这个属性里边根本无法修改,这里我要告诉大家,其实在注册表里就可以修改掉,当然可能有更好的方式,但我都是这么修改的。
1、运行中输入regedit,打开注册表,在[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesFileZilla Server找到这个路径,也就是FileZilla的路径,有一键名是"ImagePath",也可以利用注册表自带的搜索功能,查找你想要修改的路径;并点开这个键名查看信息,发现就是原来的路径。

2、现在就可以来修改为正确的路径了,比如这里正确的路径是"D:websever tpFileZilla server.exe"。然后确定,并关闭注册表编辑器。

3、回到系统服务列表,重新启动服务,发现FileZilla Server FTP server服务可以正常启动了;

4、重新运行FileZilla Server,发现可以正常连接服务器并可以用FTP客户端远程连接。

至此,FileZilla Server因路径错误导致无法启动问题解决。
总结
虽然互联网中有非常丰富的资料可以让我去参考,但是我在互联网之中可能出现很多新的问题,单凭别人的经验是很难直接解决的,我们需要结合很多其他的方案,然后通过自己的正确分析,并去勇敢的尝试,这样说不定你也可以创造出新的方法或者更加便捷的方法。
解决FileZilla Server因路径错误导致无法启动问题详细图文教程的更多相关文章
- 报错——selinux配置文件修改错误导致无法启动虚拟机
selinux配置文件修改错误导致无法启动虚拟机 问题 错误修改配置文件 [root@centos73 ~]# cat /etc/selinux/config # This file controls ...
- 源码编译路径错误导致的Apache 无法重启问题解决方法
问题现象: 第一次源码编译安装Apache设置路径错误,安装到/usr/local/src/ 目录下了. 删掉该目录下的安装文件,重新编译安装到/usr/local/目录下 重启apache服务时报这 ...
- SQL Server 2005恢复数据库详细图文教程
不少需要用到sql2005的程序,有很多新手还是会操作,这里写个详细的图文教程送个菜鸟们,高手请飘过.适用于独立主机的朋友使用,如果你还没安装,请按照这个教程来安装 SQL Server 2005图文 ...
- 最小配置启动SQL SERVER,更改SQL Server最大内存大小导致不能启动的解决方法
如果存在配置问题而无法启动服务器,则可以使用最小配置启动选项来启动 Microsoft SQL Server 实例. 这就是启动选项 -f. 使用最小配置启动 SQL Server 实例会自动将服务器 ...
- 一个mybatis错误导致无法启动项目的问题
今天遇到Mybatis一个问题,导致项目一直起不来,查了很久发现是MapperXML的错,问题表现为: 系统始终起不来,但也不报错,始终卡到如下信息位置: 信息: Initializing Sprin ...
- 解决MySQL因不能创建 PID 导致无法启动的方法
问题描述 MySQL 启动报错信息如下: ? 1 2 Starting mysqld (via systemctl): Job for mysqld.service failed because t ...
- 解决因block的损坏而导致hdfs启动后进入安全模式
问题描述: 以单机伪分布式方式安装了hadoop2.7.1,并在该机器上安装了hive1.2.1.首先执行 sbin/start-dfs.sh 启动hdfs服务,然后执行hive,这时hive脚本启动 ...
- Eclipse错误导致无法启动The workspace exited with unsaved changes in the previous session
MyOpenSUSE:/home/jin/workspace # tail -f .metadata/.log !SESSION 2014-05-04 11:35:58.869 ----------- ...
- (转载)SQL Server 2008 连接JDBC详细图文教程
点评:SQL Server 2008是目前windows上使用最多的sql数据库,2008的安装机制是基于framework重写的,特点是非常耗时间SQL Server 2008是目前windows上 ...
随机推荐
- GridView(网格视图)+MotionEvent(触控事件)实现可以拖动排序的网格图
1.一触碰,就回调onInterceptTouchEvent(MotionEvent ev)事件,每次的触碰都只回调一次,接着只要还没有放手,就一直回调onTouchEvent(MotionEvent ...
- 微信小程序基础架构
一个微信小程序界面由一个页面描述文件,一个页面逻辑文件,一个样式表文件来进行描述 在主目录中的三个以app开头的文件就是微信小程序的主描述文件 app.js :主逻辑文件,用来注册小程序 app.js ...
- PHP的多进程--防止僵尸进程(转)
原文地址:http://twei.site/2017/08/08/PHP%E7%9A%84%E5%A4%9A%E8%BF%9B%E7%A8%8B-%E9%98%B2%E6%AD%A2%E5%83%B5 ...
- [Mysql]——通过例子理解事务的4种隔离级别(转)
第1级别:Read Uncommitted(读取未提交内容) 第2级别:Read Committed(读取提交内容) 第3级别:Repeatable Read(可重读) 第4级别:Serializab ...
- Django TypeError: isinstance() arg 2 must be a type or tuple of types
报错: TypeError: isinstance() arg must be a type or tuple of types from django.db import modelsfrom dj ...
- vs的【warning C4996:'fopen': This function or variable may be unsafe】解决方案
编译警告:warning C4996 与 Security Enhancements in the CRT 将过去的工程用VS2005打开的时候.你有可能会遇到一大堆的警告:warning C4996 ...
- H5C3动画
1 渐变 /* 渐变:不同颜色之间的柔和过渡 线性渐变:沿着某条直线发生渐变效果 注意:渐变准备来说是一张背景图 语法:linear-gradient */ background-image: lin ...
- Python-多线程之消费者模式和GIL全局锁
一.生产者和消费者模式 什么是生产者消费者模式 生产者消费者模式是通过一个容器来解决生产者和消费者的强耦合问题.生产者和消费者彼此之间不直接通讯,而通过阻塞队列来进行通讯, 所以生产者生产完数据之后不 ...
- 说说为什么会有ssl.CertificateError报错
有一些网站没有获取浏览器的颁发的安全证书 当你在请求这个网站时浏览器会当做不安全网站处理 因此会报ssl.CertificateError 解决办法是 :将默认的证书验证模式修改为不需要验证 代码如下 ...
- Java中关键字static的使用
static 关键字 1).static只能修饰成员变量或成员方法,所有非静态是对象相关的,所有静态是类相关的. 2)被static修饰的成员变量成员方法独立于该类的任何对象,它不依赖类的特定的实例, ...