1.系统安装

微软操作系统 Windows Server 2012 R2 官方原版镜像

Windows Server 2012 R2 是由微软公司(Microsoft)设计开发的新一代的服务器专属操作系统,其核心版本号为 Windows NT 6.3 。提供企业级数据中心与混合云解决方案,直观且易于部署、具有成本效益、以应用程序为重点、以用户体验为中心,深受广大 IDC 运营商青睐。

在 Microsoft 云操作系统版图的中心地带,Windows Server 2012 R2 将能够提供全球规模云服务的 Microsoft 体验带入您的基础架构,特别在虚拟化、管理、存储、网络、虚拟桌面基础结构、访问和信息保护、Web 和应用程序平台等方面具备多种新功能和增强功能。

2013年10月18日,微软面向全球发布正式版 Windows Server 2012 R2 64位版本。2014年4月8日,同 Windows 8.1 一样获得了大量的重要更新,届时推送 Windows Server 2012 R2 With Update1 安装版镜像文件。

主要版本:

1.标准版 – Windows Server 2012 R2 Standard With Update1;
2.数据中心版 – Windows Server 2012 R2 Datacenter With Update1;
3.批量授权大客户:标准版 – Windows Server 2012 R2 VL Standard With Update1;
4.批量授权大客户:数据中心版 – Windows Server 2012 R2 VL Datacenter With Update1;
更多全新特性及应用细节,请查阅百度百科:http://baike.baidu.com/view/10875548.htm

1.1安装密钥

标准版(Standard With Update1):NB4WH-BBBYV-3MPPC-9RCMV-46XCB;
数据中心版(Datacenter With Update1):BH9T4-4N7CW-67J3M-64J36-WW98Y;
下载地址:

1.2简体中文版 Windows Server 2012 R2 64位版

Windows Server 2012 R2 (x64) – DVD (Chinese-Simplified)

文件名:cn_windows_server_2012_r2_x64_dvd_2707961.iso
SHA1:8F9A21C80B80D861E59F69D140E7F66E4C49289F
文件大小:4.11GB
发布时间:2013-09-09
ED2K磁链地址:
ed2k://|file|cn_windows_server_2012_r2_x64_dvd_2707961.iso|4413020160|010CD94AD1F2951567646C99580DD595|/

1.3简体中文版 Windows Server 2012 R2 大客户批量授权版 VL 64位版

Windows Server 2012 R2 VL (x64) – DVD (Chinese-Simplified)

文件名:cn_windows_server_2012_r2_vl_x64_dvd_2979220.iso
SHA1:E7D0944E7F7FB1977AEECA3C5DE65E01BC07DF3D
文件大小:4.15GB
发布时间:2013-10-17
ED2K磁链地址:
ed2k://|file|cn_windows_server_2012_r2_vl_x64_dvd_2979220.iso|4453249024|1F71685C7E33ED30FDC439C7FE0E4E5A|/

1.4简体中文版 Windows Server 2012 R2 with Update 64位版

Windows Server 2012 R2 with Update (x64) – DVD (Chinese-Simplified)

文件名:cn_windows_server_2012_r2_with_update_x64_dvd_4048415.iso
SHA1:8F10E6560122ABD08CA74B9D64242D3390D7602A
文件大小:4.36GB
发布时间:2014-04-08
ED2K磁链地址:
ed2k://|file|cn_windows_server_2012_r2_with_update_x64_dvd_4048415.iso|4684855296|338AA51AF8EF1B9895F17B5FE7636DE6|/

1.5简体中文版 Windows Server 2012 R2 大客户批量授权版 VL 64位版

Windows Server 2012 R2 VL with Update (x64) – DVD (Chinese-Simplified)

文件名:cn_windows_server_2012_r2_vl_with_update_x64_dvd_4051059.iso
SHA1:75BB45680A0CCA0B33E7EE70F20037599BDB2929
文件大小:4.36GB
发布时间:2014-04-08
ED2K磁链地址:
ed2k://|file|cn_windows_server_2012_r2_vl_with_update_x64_dvd_4051059.iso|4683122688|BD0B95997679F83A4EE2D062865D8E64|/

2.安装sql server前的准备工作

2.1安装Java

推荐1.8版本以上

Java JDK安装及环境变量设置

2.2安装缺少的Windows Server 2012 R2 更新程序

在Win Server 2012 R2 上安装SQL 2016,提示KB2919355安装失败,根据提示,去微软官网下载相应的补丁

但是下载后根据提示的顺序安装,提示此更新不适用

仔细看安装说明,原来需要先安装Windows8.1-KB2919442,下载地址:
https://www.microsoft.com/zh-cn/download/details.aspx?id=42153

然后再运行clearcompressionflag.exe(双击一下然后就可以了)

之后再按照以下顺序安装补丁:
KB2919355、KB2932046、KB2959977、KB2937592、KB2938439、KB2934018。

下载KB2919442 
下载KB2919355

3.安装sql server 2016

1.下载好SqlServer2016版本的镜像 右击后选择装载选项 如果没有这个选项可以选择解压或者使用ios镜像打开工具打开

下载地址

2.打开后的文件目录中鼠标左键双击setup文件

3.在打开的安装中心对话界面中点击安装>点击全新Sql Server独立安装

4.一路按默认方式点击下一步,到功能选择,如果不需要使用R语言,取消勾选R服务和R独立Server两项。当然也可以全选,只是有时到最后一步可能会出错。

5.默认方式,一路点击,有添加当前用户的对话框加上当前用户

6.最后,等待安装完成

4.安装sql server management studio(SSMS)

Sql Server 2016与以前的版本不一样,它没有自动携带SSMS,所以需要单独下载安装文件进行安装。 
下载SSMS

下载后的以管理员身份安装文件,默认安装即可。

5.配置sql server实现可远程访问

1.打开Sql Server配置管理器,配置客户端协议,开启TCP/IP。尽量不要修改默认端口(感觉不需要修改,多此一举)

2.打开SSMS,输入用户名和密码后登陆数据库,右键点击数据库>属性>连接>勾选允许远程连接到此服务器

3.在这之后,继续在数据库服务右键,选择【注册】,注册一个数据库服务;点击视图>已注册的服务器>数据库引擎>本地服务器组 可查看该数据库的注册的服务器

4.修改防火墙设置

(1)添加端口(这里是你设置的服务器端口号,默认1433)
打开 控制面板–》Windows 防火墙–>高级设置–>入栈规则–>右键,新建规则–>选择端口–>设置特定本地端口号(输入1433)–>允许链接–>配置文件勾选所有的项–>设置名称–>完成
(2)添加程序,和上一步骤一样,新建规则–>选择程序,添加数据安装路径C:\Program Files\Microsoft SQL Server\MSSQL13.MSSQLSERVER\MSSQL\Binn\sqlservr.exe,
每个人的路径可能不一样,具体看安装的数据库在哪,我是默认安装到c盘,所以路径在c盘中找到sqlservr.exe文件

设置完毕,可以在其他电脑上远程访问该数据库了

Windows Server 2012 R2安装SqlServer 2016的更多相关文章

  1. Windows Server 2012 R2 安装.NET Framework 3.5报错

    简单记录一下,Windows Server 2012 R2 安装.NET Framework 3.5报错,下面是解决方法 载入ISO文件Windows Server 2012 R2,而且在安装的过程中 ...

  2. windows server 2012 r2 安装无法找到install.wim 错误代码0x80070026,以及制作U启动盘决解ISO文件超过5G大小限制的解决方案(转)

    戴尔服务器r530 windows server 2012 r2 安装无法找到install.wim 错误代码0x80070026,以及制作U启动盘决解ISO文件超过5G大小限制的解决方案 关于在服务 ...

  3. Windows Server 2012 R2安装Oracle 11g问题

      1.[INS-13001]环境不满足最低要求 如图:   oracle11g早于Windows Server 2012 R2 解决方法:找到解压目录../win64_11gR2_database\ ...

  4. Windows Server 2012 R2安装部署Office Web Apps Server

    微软官方参考地址https://technet.microsoft.com/zh-cn/library/jj219455.aspx,建议参考官方说明. 注意:每一步进行完成后重启服务器!!! 一.   ...

  5. 阿里云学生优惠Windows Server 2012 R2安装IIS,ftp等组件,绑定服务器域名,域名解析到服务器,域名备案,以及安装期间错误的解决方案

     前言: 这几天终于还是按耐不住买了一个月阿里云的学生优惠.只要是学生,在学信网上注册过,并且支付宝实名认证,就可以用9块9的价格买阿里云的云服务ECS.确实是相当的优惠. 我买的是Windows S ...

  6. windows server 2012 r2 安装IIS失败

    给新的2012服务器安装IIS时报错: 错误原因:就在于选中了.net framework 3.5 . 如果要安装.net framework 3.5 使用以下步骤: 1 加载安装光盘,如果没有可以网 ...

  7. Windows Server 2012 R2 安装密钥(只适用安装,不支持激活)

    标准版 = NB4WH-BBBYV-3MPPC-9RCMV-46XCB 数据中心版 = BH9T4-4N7CW-67J3M-64J36-WW98Y

  8. System x 服务器制作ServerGuide U盘安装Windows Server 2012 R2操作系统

    以下内容来源于:联想官方知识库  http://iknow.lenovo.com.cn/detail/dc_154773.html 本例介绍以U盘方式,通过ServerGuide引导在System x ...

  9. 安装windows server 2012 r2 的那点事儿

    windows server 2012 r2 安装无法找到install.wim 错误代码0x80070026,以及制作U启动盘决解ISO文件超过5G大小限制的解决方案 用UltaISO刻录后,sou ...

随机推荐

  1. Vert.x 线程模型揭秘

    来源:鸟窝, colobu.com/2016/03/31/vertx-thread-model/ 如有好文章投稿,请点击 → 这里了解详情 Vert.x是一个在JVM开发reactive应用的框架,可 ...

  2. 排序1,2......n的无序数组,时间复杂度为o(n),空间复杂度为o(1)

    #include "stdafx.h" #include <iostream> using namespace std; int _tmain(int argc, _T ...

  3. 【bzoj1045】【HAOI2008】 糖果传递

    Description 有n个小朋友坐成一圈,每人有ai个糖果.每人只能给左右两人传递糖果.每人每次传递一个糖果代价为1. Input 第一行一个正整数n<=987654321,表示小朋友的个数 ...

  4. BZOJ_4590_[Shoi2015]自动刷题机_二分答案

    BZOJ_4590_[Shoi2015]自动刷题机_二分答案 Description 曾经发明了信号增幅仪的发明家SHTSC又公开了他的新发明:自动刷题机--一种可以自动AC题目的神秘装置.自动 刷题 ...

  5. BZOJ_2792_[Poi2012]Well_二分答案

    BZOJ_2792_[Poi2012]Well_二分答案 Description 给出n个正整数X1,X2,...Xn,可以进行不超过m次操作,每次操作选择一个非零的Xi,并将它减一. 最终要求存在某 ...

  6. 一个比喻讲明Docker是什么

    之前一直听运维的同事讲Docker,说弄个Docker镜像,打包些应用什么的,还有时不时地在一些帖子里见到过关于Docker的三言两语,然后自己也自我感觉良好的把它总结归纳了一下认为:"往D ...

  7. MySQL 复制 - 性能与扩展性的基石 4:主备切换

    一旦使用 MySQL 的复制功能,就很大可能会碰到主备切换的情况.也许是为了迭代升级服务器,或者是主库出现问题时,将一台备库转换成主库,或者只是希望重新分配容量.不过出于什么原因,都需要将新主库的信息 ...

  8. 免费开源ERP-成功案例分析(1)

    Odoo用户案例 Odoo用户概要 关于Odoo全球的用户,我们来看一些数据: Odoo目前全球有300万使用者 Odoo系统上每天新创建的数据库超过1000个 Odoo和Word.Excel.Pow ...

  9. 【Teradata】TD Unicode编码格式下varchar定义测试

    如下测试表,每个字段字符编码格式均为Unicode. 1.varchar(1)可以存储1个汉字,也只能存储1个ASCII字符. --创建表nc_test,每个字段编码格式均设定为Unicode[使用S ...

  10. brew 安装指定版本命令行工具 tmux 多版本实现

    Homebrew 是 macOS 命令安装工具,其核心库里的命令行在 github homebrew-core 仓库上维护. 核心库命令大概有 5000 条左右,大部分的命令行工具只保留了最新版本的 ...