在linux上用的是xampp,mysql启动没有报任何错误,但就是查找不到进程,于是找mysql错误日志,日志在哪?在lampp/var/mysql 以.err结尾的文件里。里面内容如下;

/opt/lampp/sbin/mysqld: Can't create/write to file '/tmp/ibvSSzKE' (Errcode: 13 - Permission denied)
2015-10-16 12:08:01 b720b700 InnoDB: Error: unable to create temporary file; errno: 13

原来是/tmp目录没有写的权限,改下权限就行了。

关于xampp在linux下配置,可以看

Mysql 於lampp xampp LinuxUbuntu下的配置

http://my.oschina.net/code33/blog/299242?p=1

lampp下的mysql配置文件路径:

/opt/lampp/etc/my.cnf

1 配置默认字符集

於mysqld项下添加

character-set-server=utf8

init_connect ='SET NAMES utf8'

於client项下添加

default-character-set =utf8

酱紫就ok了,尝试着用jetbrains自带的数据连接工具insert一条中文数据尝试一下吧,看看能否正常插入中文UTF8字符数据

2修改默认允许执行最大的sql脚本size

为什么要设置这个项目?

若有一个sql脚本大于了默认值就卡住无法执行下去了

同样是my.cnf

项:mysqld和mysqldump下

max_allowed_packet=500M

设置即可

3迁移默认数据库文件夹路径

刚刚装好的lampp mysql其路径是在/opt下的,也就是系统文件夹下,我们需要把它迁移到指定的专用数据库文件夹

先把默认文件夹拷贝

1
sudo cp -rp /opt/var/mysql /home/xx

然后修改my.cnf中的设置项

client项sock链接文件

sock=/home/xx/mysql/mysql.sock

mysqld项sock链接文件

sock=/home/xx/mysql/mysql.sock

添加数据文件夹变量於 plugin_dir变量下一行

datadir=/home/xx/mysql

完成数据库文档路径迁移;

4 建立linux mysql 客户端链接命令配置

1
sudo apt-get install -y mysql-client-core-5.5

安装好以后配置sock链接

删除原系统mysql命令路径

1
sudo rm -rf /var/run/mysqld

重建文件夹

1
sudo mkdir /var/run/mysqld

重建软连接

1
sudo ln -s /home/xx/mysql/mysql.sock /var/run/mysqld/mysqld.sock

然后在命令行下 直接试一试 mysql命令吧

5 设置innodb的共享文件索引表自增空间

若不设置,也会导致各种莫名其妙的ibdata1 的启动报错

my.cnf设置

innodb_data_home_dir=/home/xx/mysql

innodb_data_file_path=ibdata1:5000M;ibdata2:5000M;ibdata3:1000M;ibdata4:1000M:autoextend:max:5000M

实际开发中此项不需要做修改

这里的意思是每次自增的表空间1000M ,但是最大值是5000M ,可以根据自己实际的磁盘空间来设置,最低值最好不要使用默认的10M 不然实际生产环境中使用很容易出故障

到这里算是告一段落

欢迎转载 并附上原创 谢谢

6lampp的启动mysql启动项命令

启动mysql

找到 startMySQL() 函数

if testrun "$XAMPP_ROOT/var/mysql/$(hostname).pid" mysqld

将其注释

替换成

if testrun "/home/xx/mysql/$(hostname).pid" mysqld

关闭mysql

找到stopMySQL()函数

注释if ! test -f "$XAMPP_ROOT/var/mysql/$(hostname).pid"

替换成

if ! test -f "/home/xx/mysql/$(hostname).pid"

7 修改启动脚本

1
sudo gedit  /opt/lampp/bin/mysql.server

找到datadir=

添加变量值

datadir= /home/xx/mysql

找到

注释lock_file_path="$lockdir/mysql"

替换成

lock_file_path="/home/xx/mysql"

记一次mysql启动不了的问题的更多相关文章

  1. 记一次 mysql 启动没反应

    记一次 mysql 启动没反应 ,重启linux又可以启动 vim /var/log/mysqld.log 2018-02-04 13:22:49 28507 [ERROR] InnoDB: Cann ...

  2. 记mysql 启动不了了的解决方法

    系统: centos7 本地的环境,mysql启动不了,查看 /var/log/mysqld.log 有以下内容 2018-12-24T08:05:38.090527Z 0 [Warning] TIM ...

  3. XAMPP中Apache和Mysql启动失败问题总结

    一.Apache启动失败 xampp启动时显示的错误为: 9:52:41  [Apache]  Attempting to start Apache app... 9:52:41  [Apache]  ...

  4. mysql启动服务出错--发生系统错误 1067。

    记以此安装mysql出错的问题,MySQL 服务无法启动.系统出错  发生系统错误 1067.进程意外终止. 今天在安装本地mysql是,使用net start mysql命令启动服务时,总是报106 ...

  5. Mysql启动自己主动设置max_connections为其它值

    背景 有同学反应.产品连不上,登陆到server.发现连接数不够了. 接着先重新启动mysql,发如今mysql启动的时候会报Waring Warning Changed limits: max_op ...

  6. 记一次mysql数据库被勒索(中)

    背景在上一篇文章里面已经提过了. 现在面临的问题是nextcloud没有mysql数据库,用不起来了. 因为文件没丢,一种方法是启动新的mysql数据库,把文件重新提交一次. 为了程序员的面子,没有选 ...

  7. 记一次mysql数据库被勒索(下)

    背景: nextcloud的mysql数据库被黑,删库勒索.参考:记一次mysql数据库被勒索(上) mysql数据库恢复成功,nextcloud还是无法连接.参考:记一次mysql数据库被勒索(中) ...

  8. Linux 平台MySQL启动关闭方式总结

    MySQL的启动方法有很多种,下面对比.总结这几种方法的一些差异和特性,下面实验的版本为MySQL 5.6.如有疏漏或不足,敬请指点一二.   1:使用mysqld启动.关闭MySQL服务 mysql ...

  9. linux下遇见mysql启动报2002错误解决办法

    前言:目前问题解决了,但是仍不知道是什么原因造成的,在出现问题前安装uWSGI后,mysql就出现这个问题的,哪位大侠说说这是怎么回事? 正文:Linux 下 Mysql error 2002 错误解 ...

随机推荐

  1. Extjs学习笔记--(一vs增加extjs智能感知)

    1,编写class.js var classList=[ "Ext.layout.container.Absolute", "Ext.layout.container.A ...

  2. GIS-006-ArcGIS API 空间关系

    Name Description 解释 SPATIAL_REL_CONTAINS Part or all of a feature from feature class 1 is contained ...

  3. APP适配IOS8,iPhone6和Plus截图简要说明

    本文转载至 http://blog.csdn.net/yongyinmg/article/details/41422873 原文:http://www.zcool.com.cn/article/ZMT ...

  4. MQTT-SN协议乱翻之实现要点

    前言 本篇是MQTT-SN 1.2协议最后一篇翻译了,主要涉及实现要点,很简短. 需要支持QoS 值为 -1 QoS虽默认设置有0,1,2三个值,但还有一种情况其值为-1.来自客户端的PUBLISH消 ...

  5. jQuery性能优化整理

    1.总是从ID选择器开始继承 2.class选择器之前使用tag 3.将jQuery对象缓存起来 4.使用链式操作 5.使用子查询 6.对直接的DOM操作进行限制 7.当需要对dom进行多次操作时,使 ...

  6. 在linux下安装wordpress

    win下的简直傻瓜式操作:xampp打包一键安装 linux下的考虑到一些权限问题 还是有点蛋疼的 现在把流程贴出来做下记录: linux下安装xampp和wordpress的流程 ×由于linux下 ...

  7. Dell、IBM服务器配置远程管理卡

    author: headsen  chen date: 2018-10-09 14:12:32 1,IBM的服务器: 需要在bios里边进行配置,具体配置如下: , 开机画面过完之后,按F1进入bio ...

  8. 【BZOJ4524】[Cqoi2016]伪光滑数 堆(模拟搜索)

    [BZOJ4524][Cqoi2016]伪光滑数 Description 若一个大于1的整数M的质因数分解有k项,其最大的质因子为Ak,并且满足Ak^K<=N,Ak<128,我们就称整数M ...

  9. 【css预处理器】------sass的基本语法------【巷子】

    001.安装sass 1.删除gem源:gem sources --remove https://rubygems.org/ 2.添加国内源:gem sources -a http://gems.ru ...

  10. 170517、Redis 的安装与使用(单节点)

    IP : 192.168.4.111 1环 境: CentOS 6.6s Redis 版 本 : redis- - 3.0 0 (考虑到 Redis3.0 在集群和性能提升方面的特性,rc 版为正式版 ...