环境

操作系统版本:CentOS 6.5 64位
MySQL版本:mysql5.6
节点1IP:192.168.0.235 主机名:taojiang1-mysql-01
节点2IP:192.168.0.236 主机名:taojiang2-mysql-02

注意:
1、主从服务器操作系统版本和位数要保持一致
2、Master和Slave数据库的版本要一致
3、Master和Slave数据库中的数据要一致

一、2台服务器关闭SELinux(安全强化,如果你感兴趣)“是linux中支持安全访问控制策略机制的一种特性”

vi /etc/selinux/config

SELINUX=disabled

reboot 重启服务器

二、配置235服务器

1、配置my.cnf

vim /etc/my.cnf

# 服务器的ID,必须唯一,一般设置自己的IP
server_id=235
# 复制过滤:不需要备份的数据库(MySQL库一般不同步)
binlog-ignore-db=mysql
# 开启二进制日志功能,名字可以随便取,最好有含义(比如项目名)
log-bin=edu-mysql-bin
# 为每个 session 分配的内存,在事务过程中用来存储二进制日志的缓存
binlog_cache_size=1M
# 主从复制的格式(mixed,statement,row,默认格式是 statement)
binlog_format=mixed
# 二进制日志自动删除/过期的天数。默认值为 0,表示不自动删除。
expire_logs_days=7
## 跳过主从复制中遇到的所有错误或指定类型的错误,避免 slave 端复制中断。
## 如:1062 错误是指一些主键重复,1032 错误是因为主从数据库数据不一致,all所有错误
slave_skip_errors=all
# 作为从服务器时的中继日志
relay_log=taojiang1-mysql-relay-bin
# log_slave_updates 表示 slave 将复制事件写进自己的二进制日志
log_slave_updates=1
# 主键自增规则,避免主从同步ID重复的问题
auto_increment_increment=2 # 自增因子(每次加2)
auto_increment_offset=1 # 自增偏移(从1开始),单数

2 、192.168.0.235配置

# 先重启一下服务
 service mysql restart
# 登录到mysql
shell> mysql -uroot -p
# 创建数据库同步用户,并授予相应的权限
mysql> grant replication slave, replication client on *.* to 'repl'@'192.168.0.236' identified by 'repl123';
# 刷新授权表信息
mysql> flush privileges;
# 查看binlog文件的position(偏移)和File(日志文件)的值,从机上需要用到
mysql> show master status;
+----------------------+----------+--------------+------------------+-------------------+
| File | Position | Binlog_Do_DB | Binlog_Ignore_DB | Executed_Gtid_Set |
+----------------------+----------+--------------+------------------+-------------------+
| taojiag1-mysql-bin.000001 | 001 | | mysql | |
+----------------------+----------+--------------+------------------+-------------------+

3 、192.168.0.236配置

配置之前需要在236上能通过添加的用户repl能访问235上的数据库

mysql -h 192.168.0.235 -u repl -p repl123

change master to master_host='192.168.0.235',

master_user='repl',

master_password='repl123',

master_port=3306,

master_log_file='taojiang1-mysql-bin.000001',

master_log_pos=0,

master_connect_retry=30;

如果master_log_pos=0;系统会自动匹配的.

4、查看192.168.0.235节点状态

mysql> show slave status\G;

Slave_IO_Running: No

Slave_SQL_Running: No

表示为启用

三、配置192.168.0.236

1、vim /etc/my.cnf

server_id=236
binlog-ignore-db=mysql
log-bin=edu-mysql-bin
binlog_cache_size=1M
binlog_format=mixed
expire_logs_days=0
slave_skip_errors=all
relay_log=edu-mysql-relay-bin
log_slave_updates=1
#ID自增从2开始,双数
auto_increment_increment=2
auto_increment_offset=2
————————————————

配置好保存重启数据库
service mysql restart

2、创建数据库同步用户,并授予相应的权限

mysql> grant replication slave, replication client on *.* to 'repl'@'192.168.0.235' identified by 'repl123';
# 刷新授权表信息
mysql> flush privileges;
# 查看binlog文件的position(偏移)和File(日志文件)的值,从机上需要用到

mysql> show master status;
+----------------------+----------+--------------+------------------+-------------------+
| File | Position | Binlog_Do_DB | Binlog_Ignore_DB | Executed_Gtid_Set |
+----------------------+----------+--------------+------------------+-------------------+
| taojiang2-mysql-bin.000001 | 439 | | mysql | |
+----------------------+----------+--------------+------------------+-------------------+

3 、192.168.0.235配置

配置之前需要在235上能通过添加的用户repl能访问236上的数据库

mysql -h 192.168.0.236 -u repl -p repl123

change master to master_host='192.168.0.236',

master_user='repl',

master_password='repl123',

master_port=3306,

master_log_file='taojiang2-mysql-bin.000001',

master_log_pos=0,

master_connect_retry=30;

Query OK, 0 rows affected, 2 warnings (0.00 sec)

四 、全部配置好后启动slave;

start slave 启动;

stop slave 停止;

reset slave 重置;

1、验证;

show slave status\G;

Slave_IO_Running: Yes

Slave_SQL_Running: Yes

全部YES即配置成功

2、测试

在两台服务器上新建删除数据库是否成功

MySQL主主数据同步的更多相关文章

  1. LVS+MYCAT+读写分离+MYSQL主备同步部署手册

    LVS+MYCAT+读写分离+MYSQL主备同步部署手册 1          配置MYSQL主备同步…. 2 1.1       测试环境… 2 1.2       配置主数据库… 2 1.2.1  ...

  2. 【转载】LVS+MYCAT+读写分离+MYSQL主备同步部署手册(邢锋)

    LVS+MYCAT+读写分离+MYSQL主备同步部署手册 1          配置MYSQL主备同步…. 2 1.1       测试环境… 2 1.2       配置主数据库… 2 1.2.1  ...

  3. MySQL主备同步延迟

    今天看到mycat的日志,发现在wrapper.log中频繁warning:slave延迟23006秒 查看数据指标: show engine innodb status正常,而且slave的拷贝点在 ...

  4. MySQL 主主同步配置和主从配置步骤

    ★预备知识 : 1.双机热备 对于双机热备这一概念,我搜索了很多资料,最后,还是按照大多数资料所讲分成广义与狭义两种意义来说. 从广义上讲,就是对于重要的服务,使用两台服务器,互相备份,共同执行同一服 ...

  5. MySQL主主同步配置

    1. MySQL主主配置过程 在上一篇实现了主从同步的基础上,进行主主同步的配置. 这里用node19(主),node20(从)做修改,使得node19和node20变为主主同步配置模式 修改配置文件 ...

  6. mysql主主同步设置

    mysql主主同步设置 主主同步设置是同等的地位,所以以下操作在两台机器上都需要进行而且操作是相同的. 服务器 服务器代号 IP hostname A 192.168.70.128 Debian1 B ...

  7. MYSQL 的 MASTER到MASTER的主主循环同步

    MYSQL 的 MASTER到MASTER的主主循环同步   刚刚抽空做了一下MYSQL的主主同步.把步骤写下来,至于会出现的什么问题,以后随时更新.这里我同步的数据库是TEST1.环境描述.   主 ...

  8. mysql主主同步

    Mysql 主主同步方案 第一台机器主 [root@master ~]# vim /etc/my.cnf [mysqld] server-id=1 log-bin=mysql-binlog log-s ...

  9. Linux下MySQL主主同步

    主主复制:主从相互授权连接,读取对方binlog日志并更新到本地数据库的过程:只要对方数据改变,自己就跟着改变. 本节介绍主主复制模式的配置. 前提条件 已安装MySQL两台服务器.服务器规划示例如表 ...

随机推荐

  1. Java知识系统回顾整理01基础02面向对象02属性

    一.根据实例给出"属性"的定义 一个英雄有姓名,血量,护甲等等状态 这些状态就叫做一个类的属性 二.属性的类型 属性的类型可以是基本类型,比如int整数,float 浮点数 也可以 ...

  2. SQL数据库删除和还原的时候提示 被占用 记录一下

    设置离线 1)ALTER DATABASE [datebase] SET OFFLINE WITH ROLLBACK IMMEDIATE设置在线 2)ALTER DATABASE [datebase] ...

  3. Springboot项目集成JPush极光推送(Java SDK)

    1.由于项目的需求,需要在Android APP上实现消息推送功能,所以引用了极光推送(官网:https://www.jiguang.cn/, 文档:http://docs.jiguang.cn/) ...

  4. UDP协议网络Socket编程(java实现C/S通信案例)

    我的博客园:https://www.cnblogs.com/chenzhenhong/p/13825286.html 我的CSDN博客:https://blog.csdn.net/Charzous/a ...

  5. centos6.8 架设 Telnet 服务

    centos6.8 架设 Telnet 非常简单 百度云下载RPM,然后上传到服务器 链接:https://pan.baidu.com/s/1w91HBf1TOJsZsqBMQnO7tA 提取码:au ...

  6. Storm入门教程汇总

    http://www.aboutyun.com/thread-8059-1-1.html

  7. win8怎样才能启用administrator登录 别的用户也是如此

    但是你可以用命令调出administrator账户打开C盘,打开windows文件夹,再打开system32文件夹,找到cmd.exe右键点击选择以管理员身份运行 在里面输入net user admi ...

  8. jmeter环境变量配置

    参考博客:超全 https://blog.csdn.net/qq_39720249/article/details/80721777

  9. CentOS 8 Yum安装ansible

    ansible的安装 直接yum安装ansible会报错,需要先安装epel源. ansible的安装来源于epel仓库,因此在安装前需确保安装了正确的epel源. yum install -y ep ...

  10. LinkedHashMap 实现LRU缓存

    date: 2020-07-09 13:52:00 updated: 2020-07-21 17:40:00 LinkedHashMap 实现LRU缓存 参考 LinkedHashMap是HashMa ...