Nginx双机主备(Keepalived实现)
前言
首先介绍一下Keepalived,它是一个高性能的服务器高可用或热备解决方案,起初是专为LVS负载均衡软件设计的,Keepalived主要来防止服务器单点故障的发生问题,可以通过其与Nginx的配合实现web服务端的高可用。
Keepalived以VRRP协议为实现基础,VRRP是Virtual Router Redundancy Protocol(虚拟路由冗余协议)的缩写,VRRP协议将两台或多台路由器设备虚拟成一个设备,对外提供虚拟路由器IP(一个或多个)。
VRRP出现的目的就是为了解决静态路由的单点故障问题的,它能保证当个别节点宕机时,整个网络可以不间断地运行。
下面我们介绍一下nginx keepalived高可用方案的部署安装。
环境准备
在两台主机上准备如下压缩文件:
keepalived-2.0.20.tar.gz
nginx-1.16.1.tar.gz
虚拟IP 真实IP nginx端口 主从
192.168.124.20 192.168.124.13 80 MASTER
192.168.124.20 192.168.124.14 80 BACKUP
安装nginx
file 新建一个用户:
useradd tianyan
确定安装目录,我这里的安装目录是:/home/tianyan/tianyan_soft/nginx.install。
在这个目录下分别新建两个目录用于安装nginx和keepalived,解压两个压缩包。
执行安装命令:
./configure --prefix=/home/tianyan/tianyan_soft/nginx.install
--sbin-path=/home/tianyan/tianyan_soft/nginx.install/sbin/nginx --conf-path=/home/tianyan/tianyan_soft/nginx.install/conf/nginx.conf
--error-log-path=/home/tianyan/tianyan_soft/nginx.install/error.log
--http-log-path=/home/tianyan/tianyan_soft/nginx.install/access.log
--pid-path=/home/tianyan/tianyan_soft/nginx.install/nginx.pid
--lock-path=/home/tianyan/tianyan_soft/nginx.install/nginx.lock
--user=tianyan --group=tianyan
--with-http_stub_status_module
--with-http_gzip_static_module
--with-http_ssl_module
--with-http_realip_module
--with-threads
--with-pcre
--http-client-body-temp-path=/home/tianyan/tianyan_soft/nginx.install/client/
--http-proxy-temp-path=/home/tianyan/tianyan_soft/nginx.install/proxy/
--http-fastcgi-temp-path=/home/tianyan/tianyan_soft/nginx.install/fcgi/
--http-uwsgi-temp-path=/home/tianyan/tianyan_soft/nginx.install/uwsgi
--http-scgi-temp-path=/home/tianyan/tianyan_soft/nginx.install/scgi
如果报错,记得安装相关依赖:
yum install gcc gcc-c++
nginx: [emerg] bind() to 0.0.0.0:80 failed (13: Permission denied)。
注:以非root权限启动时,会出现 nginx: [emerg] bind() to 0.0.0.0:80 failed (13: Permission denied) 错误。
原因:Linux只有root用户可以使用1024一下的端口
解决办法:
1.按照root权限启动
2.将 /usr/local/nginx/conf/nginx.conf 文件中的80端口改为1024以上。
安装keepalived
./configure --prefix=/usr/local/keepalived
上述命令执行完毕后继续执行:
make && make install
安装完毕后,目录是这个样子:
file
将配置文件拷贝到系统对应的目录下
mkdir /etc/keepalived
cp /usr/local/keepalived/etc/keepalived/keepalived.conf /etc/keepalived/keepalived.conf
cp /usr/local/keepalived/etc/sysconfig/keepalived /etc/sysconfig/keepalived
编辑 master 节点的 keepalived.conf
vim /etc/keepalived/keepalived.conf
内容参考如下:
! Configuration File for keepalived
global_defs {
#一个没重复的名字即可
router_id hyq_slave
}
ng是否运行
vrrp_script chk_nginx {
script "/etc/keepalived/nginx_check.sh"
interval 2
weight -20
}
vrrp_instance VI_1 {
state BACKUP # 必填,可以是MASTER或BACKUP
interface ens33
virtual_router_id 101
priority 90
advert_int 1
# 如果两节点的上联交换机禁用了组播,则采用vrrp单播通告的方式
# 本机ip
unicast_src_ip 192.168.124.14
unicast_peer {
# 其他机器ip
192.168.124.13
}
# 设置nopreempt防止抢占资源
nopreempt
authentication {
auth_type PASS
auth_pass 1111
}
# 与上方nginx运行状况检测呼应
track_script {
chk_nginx
}
virtual_ipaddress {
192.168.124.20
}
}
编辑 slave 节点的 keepalived.conf
vim /etc/keepalived/keepalived.conf
! Configuration File for keepalived
global_defs {
#一个没重复的名字即可
router_id hyq_slave
}
ng是否运行
vrrp_script chk_nginx {
script "/etc/keepalived/nginx_check.sh"
interval 2
weight -20
}
vrrp_instance VI_1 {
state BACKUP # 必填,可以是MASTER或BACKUP
interface ens33
virtual_router_id 101
priority 90
advert_int 1
# 如果两节点的上联交换机禁用了组播,则采用vrrp单播通告的方式
# 本机ip
unicast_src_ip 192.168.124.14
unicast_peer {
# 其他机器ip
192.168.124.13
}
# 设置nopreempt防止抢占资源
nopreempt
authentication {
auth_type PASS
auth_pass 1111
}
# 与上方nginx运行状况检测呼应
track_script {
chk_nginx
}
virtual_ipaddress {
192.168.124.20
}
}
编写nginx_check.sh脚本
在/etc/keepalived目录下新建nginx_check.sh脚本
touch nginx_check.sh
编辑其内容为:
!/bin/sh
A=ps -C nginx --no-header |wc -l
if [ $A -eq 0 ]
then
/usr/sbin/nginx
sleep 1
A2=ps -C nginx --no-header |wc -l
if [ $A2 -eq 0 ]
then
systemctl stop keepalived
fi
fi
含义是:如果 nginx 停止运行,尝试启动,但是如果无法启动,则杀死本机的 keepalived 进程, keepalied将会把虚拟 ip 绑定到 BACKUP 机器上。 注意: /usr/sbin/nginx是nginx的启动命令,如果你安装到其他目录,则相应的替换。
Keepalived的日志
Keepalived日志默认位置是在/var/log/messages目录下。我们将其修改一下。
由于系统是centos7,修改位置为:/lib/systemd/system/keepalived.service
原内容:
EnvironmentFile=-/usr/local/keepalived/etc/sysconfig/keepalived
ExecStart=/usr/local/keepalived/sbin/keepalived $KEEPALIVED_OPTIONS
修改为:
file
修改完毕后重新加载service
systemctl daemon-reload
创建命令软连接:
ln -s /usr/local/keepalived/sbin/keepalived /usr/sbin/keepalived
执行:
keepalived -D -f /etc/keepalived/keepalived.conf
-D 将日志输出到message日志,默认日志也在message
-f 是指定配置文件
修改/etc/sysconfig/keepalived
把KEEPALIVED_OPTIONS="-D" 修改为:KEEPALIVED_OPTIONS="-D -d -S 0"
file
在/etc/rsyslog.conf 末尾添加
local0.* /var/log/keepalived.log
file
最后执行命令:
service rsyslog restart
重启keepalived后就可以看到日志在/var/log/keepalived.log下了。
测试验证VIP
当keepalived和nginx都启动后,我们来测试一下。
首先在浏览器里面访问三个地址
http://192.168.124.20 (vip)
http://192.168.124.13 (master)
http://192.168.124.14 (slave)
我修改了一下nginx的index.html,可以看到当前vip指向是13的master节点:
file
然后,我们手动停止13上的nginx,再次访问http://192.168.124.20。
file
说明安装成功。
其中通过ip address命令可以观察到网卡的变化 file
实验到这里,我们就完成了keepalived + nginx 主从配置的安装部署了。
思考:如何开启双主模式
什么是双主模式?
分别介绍一下两种配置
1、Nginx+keepalived 主从配置
file
这种方案就是上文介绍过的,使用一个vip地址,前端使用2台机器,一台做主,一台做备,但同时只有一台机器工作,另一台备份机器在主机器不出现故障的时候,永远处于浪费状态,仅仅用于灾备,平时都是空闲着的。
2、Nginx+keepalived 双主配置
这种方案,使用两个vip地址,前端使用2台机器,互为主备,同时有两台机器工作,当其中一台机器出现故障,两台机器的请求转移到一台机器负担,如下图:
file
【实战】 elasticsearch 写入速度提升的案例分享
Nginx双机主备(Keepalived实现)的更多相关文章
- 使用Keepalived实现Nginx的双机主备高可用
1.概述 前面我们聊过使用 Nginx 为 后端Tomcat 做负载均衡.高可用,但是这时Nginx又成了单点,如果Nginx不幸挂掉,整个网站便无法访问. 此时我们就会用到另一个软件 -- Keep ...
- nginx+keepalived实现nginx双主高可用的负载均衡
http://kling.blog.51cto.com/3320545/1253474 一.前言: 在互联网上面,网站为用户提供原始的内容访问,同时为用户提供交互操作.提供稳定可靠的服务,可以给用户带 ...
- keepalived+nginx双机热备+负载均衡
Reference: http://blog.csdn.net/e421083458/article/details/30092795 keepalived+nginx双机热备+负载均衡 最近因业务扩 ...
- JAVAEE——宜立方商城03:Nginx负载均衡高可用、Keepalived+Nginx实现主备
1 nginx负载均衡高可用 1.1 什么是负载均衡高可用 nginx作为负载均衡器,所有请求都到了nginx,可见nginx处于非常重点的位置,如果nginx服务器宕机后端web服务将无法提供服务, ...
- 如何使用keepalived实现nginx双机热备
1.linux安装方法:yum -y install keepalived 配置开机启动:sudo chkconfig keepalived on 查看keepalivede运行日志:/var/lo ...
- keepalived+Nginx实现主备保障Nginx的高可用。
1.什么是keepalived? Keepalived是集群管理中保证集群高可用的一个服务软件,用来防止单点故障. Keepalived的作用是检测web服务器的状态,如果有一台web服务器死机,或工 ...
- 企业级Nginx负载均衡与keepalived高可用实战(二)keepalived篇
1.Keepalived高可用软件 1.1.Keepalived介绍 Keepalived软件起初是专门为LVS负载均衡软件设计的,用来管理并监控LVS集群系统中各个服务节点的状态,后来又加入了可以实 ...
- MySQL 5.7 双主复制+keepalived,常规业务一般够用了
业务需求: 为Zabbix搭建2个数据库,一个库给服务器监控用,一个库给网络监控用. 硬件: 两台服务器,硬盘是1.2 T SSD卡,内存128G 架构: 希望做双主复制+keepalived,架构大 ...
- nginx负载均衡配合keepalived服务案例实战
本实验用4台 centos6 虚拟机,2台做负载均衡,2台做web服务器,都先装上nginx lb01:192.168.0.235 --主负载均衡器 lb02:192.168.0.236 --备负 ...
随机推荐
- 在dataframe添加1行(首行,或者尾部),且不覆盖
如果直接用下面的代码添加第1行,则会覆盖掉原来的第1行. #指定位置增加一行: df.loc[0]={'a':1,'b':2} 正确方法: 新建一个同样的 dataframe, 然后合并两个dataf ...
- python 爬虫保存文件的几种方法
import os os.makedirs('./img/', exist_ok=True) IMAGE_URL = "https://morvanzhou.github.io/static ...
- Dykin's blog
回归分析是一种很重要的预测建模技术.主要是研究自变量与因变量之间的因果关系.本文将会从数学角度与代码角度分析不同类型的回归.当你想预测连续型的非独立变量,或者对一系列独立变量或输入项有所反应时,就会使 ...
- 这些科学家用DNA做的鲜为人知事,你估计都没见过!
DNA世界的每一步都给人类带来奇妙甚至吃惊的发现.研究人员越来越多地探索和掌握了生命中的分子.生物与技术之间的界限以前所未有的方式模糊,有时甚至更糟.但DNA也为复杂疾病带来简单的答案,存储奇怪的文件 ...
- Coding and Paper Letter(十五)
资源整理. 1.Nature Climate Change论文"Higher temperatures increase suicide rates in the United States ...
- The Integers and the Real Numbers
以上我們談了一些 邏輯的基礎,接下來我們會談一些 數學的基礎,也就是整數與實數系統.其實我們已經用了很多,非正式地,接下來我們會正式地討論他們. 要 建構 實數系統的一個方法就是利用公理跟集合論來建構 ...
- 6——PHP顺序结构&&字符串连接符
*/ * Copyright (c) 2016,烟台大学计算机与控制工程学院 * All rights reserved. * 文件名:text.cpp * 作者:常轩 * 微信公众号:Worldhe ...
- iMX287A基于嵌入式Qt的新冠肺炎疫情监控平台
目录 1.前言 2.数据接口的获取 3.Qt界面的实现 4.在开发板上运行Qt程序 5.最终效果 6.代码下载 @ 1.前言 之前我使用在桌面版本Qt实现了肺炎疫情监控平台:基于Qt的新冠肺炎疫情数据 ...
- CSS3:TEXT-SHADOW|BOX-SHADOW(炫彩字体)
2016年2月26日个人博客文章--迁移到segmentfault (1)text-shadow(文本阴影) 在介绍css3:text-shadow文本阴影之前,我们先来看看用它都能实现什么效果: 没 ...
- 伪元素 before 和 after 初探
伪元素 before 和 after 初探 使用了 CodePen 做演示,欢迎点击预览 定义 首先来看 MDN 的定义: ::before 创建一个伪元素,作为已选中元素的第一个子元素,常通过 co ...