今天遇到一个问题,istio的组件一直在重启,查看log大概是这个样子

--03T07::.935580Z     info    Epoch  starting
--03T07::.936317Z info Envoy command: [-c /etc/istio/proxy/envoy-rev0.json --restart-epoch --drain-time-s --parent-shutdown-time-s --service-cluster istio-ingress --service-node ingress~57.144.0.82~istio-ingress-5b8b8669b5-hjqrd.istio-system~istio-system.svc.cluster.local --max-obj-name-len -l info --v2-config-only]
[-- ::49.973][][info][main] external/envoy/source/server/server.cc:] initializing epoch (hot restart version=9.200.16384.256.options=capacity=, num_slots= hash=)
[-- ::49.973][][info][main] external/envoy/source/server/server.cc:] statically linked extensions:
[-- ::49.973][][info][main] external/envoy/source/server/server.cc:] access_loggers: envoy.file_access_log,envoy.http_grpc_access_log
[-- ::49.973][][info][main] external/envoy/source/server/server.cc:] filters.http: envoy.buffer,envoy.cors,envoy.ext_authz,envoy.fault,envoy.grpc_http1_bridge,envoy.grpc_json_transcoder,envoy.grpc_web,envoy.gzip,envoy.health_check,envoy.http_dynamo_filter,envoy.ip_tagging,envoy.lua,envoy.rate_limit,envoy.router,envoy.squash,istio_authn,jwt-auth,mixer
[-- ::49.973][][info][main] external/envoy/source/server/server.cc:] filters.listener: envoy.listener.original_dst,envoy.listener.proxy_protocol
[-- ::49.973][][info][main] external/envoy/source/server/server.cc:] filters.network: envoy.client_ssl_auth,envoy.echo,envoy.ext_authz,envoy.http_connection_manager,envoy.mongo_proxy,envoy.ratelimit,envoy.redis_proxy,envoy.tcp_proxy,mixer
[-- ::49.973][][info][main] external/envoy/source/server/server.cc:] stat_sinks: envoy.dog_statsd,envoy.metrics_service,envoy.statsd
[-- ::49.973][][info][main] external/envoy/source/server/server.cc:] tracers: envoy.dynamic.ot,envoy.lightstep,envoy.zipkin
[-- ::49.973][][info][main] external/envoy/source/server/server.cc:] transport_sockets.downstream: alts,raw_buffer,ssl
[-- ::49.973][][info][main] external/envoy/source/server/server.cc:] transport_sockets.upstream: alts,raw_buffer,ssl
[-- ::49.980][][warning][upstream] external/envoy/source/common/config/grpc_mux_impl.cc:] gRPC config stream closed: ,
[-- ::49.980][][warning][upstream] external/envoy/source/common/config/grpc_mux_impl.cc:] Unable to establish new stream
[-- ::49.980][][info][config] external/envoy/source/server/configuration_impl.cc:] loading listener(s)
[-- ::49.980][][info][config] external/envoy/source/server/configuration_impl.cc:] loading tracing configuration
[-- ::49.980][][info][config] external/envoy/source/server/configuration_impl.cc:] loading tracing driver: envoy.zipkin
[-- ::49.980][][info][config] external/envoy/source/server/configuration_impl.cc:] loading stats sink configuration
[-- ::49.980][][critical][main] external/envoy/source/server/server.cc:] error initializing configuration '/etc/istio/proxy/envoy-rev0.json': malformed IP address: istio-statsd-prom-bridge
[-- ::49.981][][info][main] external/envoy/source/server/server.cc:] exiting
--03T07::.983382Z warn Epoch terminated with an error: exit status
--03T07::.983414Z warn Aborted all epochs
--03T07::.983463Z info Epoch : set retry delay to 1m42.4s, budget to

  解决方案

   重启Kubernetes集群的dns和每个节点的flannel

kubectl delete pod -n kube-system kube-dns-*****

  

【Istio】error initializing configuration '/etc/istio/proxy/envoy-rev0.json': malformed IP address: istio-statsd-prom-bridge的更多相关文章

  1. ERROR 2003 (HY000): Can't connect to MySQL server on 'ip address' (111)的处理办法

    远程连接mysql数据库时可以使用以下指令 mysql -h 192.168.1.104 -u root -p 如果是初次安装mysql,需要将所有/etc/mysql/内的所有配置文件的bind-a ...

  2. 【解决】error pulling image configuration: Get https:// ...... x509: certificate has expired or is not yet valid

    [问题]进行镜像拉取时报错 [分析] 很多人会被第一句所蒙蔽,按照网上教程进行修改etc/sysconfig/docker,之后发现还是没有用. 其实这里重点是最后一句"certificat ...

  3. 【故障处理】ERROR 1872 (HY000): Slave failed to initialize relay log info structure from the repository

    今天在使用冷备份文件重做从库时遇到一个报错,值得研究一下. 版本:MySQL5.6.27 一.报错现象 dba:(none)> start slave; ERROR (HY000): Slave ...

  4. 【转】Error:JAVA_HOME is not set and could not be found

    如果stop-dfs.sh也报了这个错,把$HADOOP_HOME/libexec/hadoop-config.sh中的如下内容之前加上 export JAVA_HOME=/home/lqr/Tool ...

  5. 【解决】ERROR in xxx.js from UglifyJs

    当我们运行打包脚本npm run build或者打包iosweexpack build ios有可能会遇到以下报错 ERROR in index.js from UglifyJs ![](https: ...

  6. 【SVN】Error running context: 由于目标计算机积极拒绝,无法连接

    SVN服务没开启,步骤如下: 1.打开[控制面板]→[管理工具]→[服务]: 2.找到[visual SVN Sever],右击选择[启动]: 3.服务开启后,导入数据就成功了!

  7. 【AngularJs】---"Error: [ng:areq] Argument 'fn' is not a function, got undefined"

    项目中把controller.service抽取出来 一步一步没有报错 index那里加 <script src="js/controllers/XXController.js&quo ...

  8. 【AngularJs】---Error: [$injector:modulerr] Failed to instantiate module starter.services

    [遇到问题解决问题,原谅我这个菜鸟] 加了services angular.module('starter', ['ionic', 'starter.controllers', 'starter.se ...

  9. 【MFC】error RC2108: expected numerical dialog constant(转)

    原文转自 http://blog.csdn.net/renyhui/article/details/23120469 [解决方案]在控件ID后面添加 "Static", SS_BI ...

随机推荐

  1. SQL Server 填充因子

    在创建聚集索引时,表中的数据按照索引列中的值的顺序存储在数据库的数据页中.在表中插入新的数据行或更改索引列中的值时,Microsoft®   SQL   Server™   2000   可能必须重新 ...

  2. UVA 1152 4 Values Whose Sum is Zero 和为0的4个值 (中途相遇)

    摘要:中途相遇.对比map,快排+二分查找,Hash效率. n是4000的级别,直接O(n^4)肯定超,所以中途相遇法,O(n^2)的时间枚举其中两个的和,O(n^2)的时间枚举其他两个的和的相反数, ...

  3. jQuery工作中遇到的几个插件

    图片上传插件:uploadify 表单验证插件:formValidator

  4. JS实现全排列

    https://www.jb51.net/article/39291.htm JavaScript全排列的六种算法 具体实现 算法一:交换(递归) 复制代码代码如下: <html xmlns=& ...

  5. python_84_os模块

    'os模块:提供对操作系统进行调用的接口' import os print(os.getcwd())#获取当前脚本工作目录,即当前Python脚本工作的目录路径 os.chdir('C:\\Users ...

  6. 使用Python生成ASCII字符画

    使用Python生成ASCII字符画 在很多的网站主页中或者程序的注释中会有一些好看的字符注释画.显得很牛逼的样子 例如: 知乎 _____ _____ _____ _____ /\ \ /\ \ / ...

  7. java HashMap 内存泄漏

    import java.util.HashMap; import java.util.Map; public class HashMapOver { public static void main(S ...

  8. JDK的安装以及环境变量的配置

    一.JDK的安装 1.百度搜索jdk1.8 2.进入网页选择Downloads 3. 选择电脑的版本(x86 32位 x64 64位) 4.下载好后,直接双击即可,一直下一步即可完成安装 二.环境变量 ...

  9. jdk配置与环境变量配置

    1.1.下载jdk1.8.0,如图所示 解压放在你用的位置 在官网中下载 1.2.配置环境变量 打开环境变量:计算机-->属性-->高级系统配置-->环境变量 配置JAVA_HOME ...

  10. mutt+msmtp做linux邮件客户端

    mutt+msmtp做linux邮件客户端 1. 安装配置msmtp l  安装 wget https://sourceforge.net/projects/msmtp/files/msmtp/1.4 ...