PXC主节点启动完成后,再启动node1,error日志报错:
2017-05-02T15:23:42.830888Z 0 [ERROR] WSREP: Failed to read 'ready <addr>' from: wsrep_sst_rsync --role 'joiner' --address '192.168.30
.221:5020' --datadir '/data/mysql/mysql_3307/data/' --defaults-file '/data/mysql/mysql_3307/my.cnf' --defaults-group-suffix '' --paren
t '5303' ''
Read: ''lsof' not found in PATH'
2017-05-02T15:23:42.831042Z 0 [ERROR] WSREP: Process completed with error: wsrep_sst_rsync --role 'joiner' --address '192.168.30.221:5
020' --datadir '/data/mysql/mysql_3307/data/' --defaults-file '/data/mysql/mysql_3307/my.cnf' --defaults-group-suffix '' --parent '530
3' '' : 2 (No such file or directory)
2017-05-02T15:23:42.831131Z 2 [ERROR] WSREP: Failed to prepare for 'rsync' SST. Unrecoverable.
2017-05-02T15:23:42.831151Z 2 [ERROR] Aborting
检查思路:
1、先检查rsync是否已安装:
[root@localhost mysql]# yum search rsync
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirrors.sohu.com
* extras: mirrors.sohu.com
* updates: mirrors.aliyun.com
================ N/S matched: rsync ===============================
libguestfs-rsync.x86_64 : rsync support for libguestfs
rsync.x86_64 : A program for synchronizing files over a network
Name and summary matches only, use "search all" for everything.
表示rsync已经安装好。
2、检查lsof是否安装:
[root@localhost mysql]# yum search lsof
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirrors.sohu.com
* extras: mirrors.sohu.com
* updates: mirrors.aliyun.com
================= N/S matched: lsof =================
lsof.x86_64 : A utility which lists open files on a Linux/UNIX system
Name and summary matches only, use "search all" for everything.
即lsof未安装。
先查找centos7的lsof的rpm包:
找到后下载,传给服务器:
[root@localhost src]# rpm -ivh lsof-4.87-4.el7.x86_64.rpm
Preparing... ################################# [100%]
Updating / installing...
1:lsof-4.87-4.el7 ################################# [100%]
安装完成后再启动node2,启动完成:
[root@localhost mysql]# ./bin/mysqld_safe --defaults-file=/data/mysql/mysql_3307/my.cnf
2017-05-02T16:18:06.438428Z mysqld_safe Logging to '/data/mysql/mysql_3307/logs/error.log'.
2017-05-02T16:18:06.441666Z mysqld_safe error: log-error set to '/data/mysql/mysql_3307/logs/error.log', however file don't exists. Create writable for user 'mysql'.
[root@localhost mysql]# touch /data/mysql/mysql_3307/logs/error.log
[root@localhost mysql]# chown -R mysql:mysql /data/mysql/mysql_3307/
[root@localhost mysql]# ./bin/mysqld_safe --defaults-file=/data/mysql/mysql_3307/my.cnf
Usage: grep [OPTION]... PATTERN [FILE]...
Try 'grep --help' for more information.
grep: write error: Broken pipe
2017-05-02T16:18:35.846719Z mysqld_safe Logging to '/data/mysql/mysql_3307/logs/error.log'.
2017-05-02T16:18:35.851450Z mysqld_safe Logging to '/data/mysql/mysql_3307/logs/error.log'.
2017-05-02T16:18:35.889501Z mysqld_safe Starting mysqld daemon with databases from /data/mysql/mysql_3307/data
2017-05-02T16:18:35.896799Z mysqld_safe Skipping wsrep-recover for empty datadir: /data/mysql/mysql_3307/data
2017-05-02T16:18:35.900008Z mysqld_safe Assigning 00000000-0000-0000-0000-000000000000:-1 to wsrep_start_position
在主节点上查看:
mysql> show global status like 'wsrep_cluster_size';
+--------------------+-------+
| Variable_name | Value |
+--------------------+-------+
| wsrep_cluster_size | 2 |
+--------------------+-------+
1 row in set (0.01 sec)
添加节点成功!
- Tomcat启动报错org.springframework.web.context.ContextLoaderListener类配置错误——SHH框架
SHH框架工程,Tomcat启动报错org.springframework.web.context.ContextLoaderListener类配置错误 1.查看配置文件web.xml中是否配置.or ...
- 【原】tomcat 7 启动报错:java.lang.NoSuchMethodError: javax.servlet.ServletContext.getSessionCookieConfig()Ljavax/servlet/SessionCookieConfig的解决
现象: tomcat 7 启动报错:java.lang.NoSuchMethodError: javax.servlet.ServletContext.getSessionCookieConfig() ...
- Oracle启动报错ORA-03113解决
环境:RHEL6.4 + Oracle 11.2.0.4 步骤摘要:1.启动报错ORA-031132.查看alert日志查找原因3.根据实际情况采取合理的措施,这里我们先增加闪回区大小,把库启动起来4 ...
- Oracle启动报错ORA-27102解决
环境:RHEL5.5 + Oracle 10.2.0.4 此错误一般是因为数据库的初始化参数文件的内存设置不当导致.本例是因为操作系统参数设置问题导致. 当前现象:Oracle启动报错ORA-2710 ...
- ssh启动报错:org.dom4j.DocumentException: Connection timed out: connect Nested exception: Connection timed out: connect
ssh项目启动报错: org.dom4j.DocumentException: Connection timed out: connect Nested exception: Connection t ...
- SVN 服务启动报错 0x8007042a
服务器环境:Windows Server 2008 R2 企业版,Visual SVNServer 2.6.5 不能签出代码,发现svn服务关闭,手动启动报错: 事件查看器: Error: no li ...
- Tomcat7.0启动报错:java.lang.illegalargumentexception:taglib definition not consisten with specification version
Tomcat7.0启动报错:java.lang.illegalargumentexception:taglib definition not consisten with specification ...
- eclipse 启动报错\workspace\.metadata\.log
eclipse启动报错,让查看.metadata\.log日志 eclipse启动不了,让查看.metadata\.log日志,上面为日志中的错误提示. 解决办法:删除 .metadata\.plug ...
- Weblogic 启动报错:java.lang.NoClassDefFoundError
Weblogic 启动报错:java.lang.NoClassDefFoundError ####<2015-6-17 下午03时30分47秒 CST> <Error> &l ...
随机推荐
- POP3是收邮件的协议,SMTP是发邮件的协议,IMAP是一种邮箱通信协议。
我也是第一次接触这种服务,是因为我自己在做一个小小的自动推送天气情况到自己邮箱.所以才碰到这个的/ 看一下标题,我们可以先这样理解. POP3(Post Office Protocol - Versi ...
- 求两个字符串的最长公共子串(LCS)
http://tianyunpu2008.blog.163.com/blog/static/6559379920089162236915/
- Spring Boot 注解的使用
Spring Boot 优于Spring mvc ,SSM,SSH 的一个亮点就是他使用了好多的注解. 1. @Autowired 这个注解的作用是将其他的类,接口引入,类似于之前的类的初始化等,用这 ...
- jumpserver跳板机
一.安装依赖包 yum -y install epel-release yum clean all && yum makecache yum -y update yum -y inst ...
- python之列表作为函数的参数
函数参数为 列表或者字典 传递一个列表,例如 [1, 2, 3] 将此传给函数get_sum() 求出 各个元素之和 传递一个字典,打印出key/value的对应关系表: #!/usr/bin/env ...
- Spring execution表达式
execution(modifiers-pattern? ret-type-pattern declaring-type-pattern? name-pattern(param-pattern) th ...
- 老李分享:loadrunner用javavuser进行接口测试
老李分享:loadrunner用javavuser进行接口测试 在这里分享一个poptest培训过程中案例,在日常工作中会遇到被测试系统通讯都是通过加密的数据包,加密算法是公司自己开发的,并且发送的数 ...
- AngularJS1.X学习笔记4-内置事件指令及其他
AngularJS为我们定义了一系列事件指令,方便我们对用户的操作作出响应.甚至他还有一个可选模块提供了触摸事件和手势事件的支持,为移动端开发提供了可能.现在开始学习一下AngularJS的事件指令. ...
- 重写NSArray与NSDictionary的descriptionWithLocale方法
重写NSArray的descriptionWithLocale方法: NSArray+log.h #import <Foundation/Foundation.h> @interface ...
- coolpad 5879logcat不能输入日志解决办法
有几天没完手机了,玩一下,发现不能打印日志了,记得最开始的时候 会弹出一个选项选择是否输出日志,在网上找了好的方法. 1.重启adb,点击DBMS 进行刷新. 2重启eclipse. 3.重装驱动. ...