使用NFS安装oracle软件
昨天。使用openfiler创建nas存储系统,安装oracle软件,在所有正面最好,要创建一个数据库时报ora错,原来使用nfs安装oracle数据库,mount选项有特殊要求,如以下。以备查:
RAC
- Binaries is the shared mount points where the Oracle Home and CRS_HOME is installed.
- Datafiles includes Online Logs, Controlfile and Datafiles
|
Operating System |
Mount options for Binaries | Mount options for Oracle Datafiles | Mount options for CRS Voting Disk and OCR |
| Sun Solaris * |
rw,bg,hard,nointr,rsize=32768, |
rw,bg,hard,nointr,rsize=32768, wsize=32768,proto=tcp,noac, forcedirectio, vers=3,suid |
rw,bg,hard,nointr,rsize=32768, wsize=32768,proto=tcp,vers=3, noac,forcedirectio |
| AIX (5L) ** |
rw,bg,hard,nointr,rsize=32768, |
cio,rw,bg,hard,nointr,rsize=32768, |
cio,rw,bg,hard,intr,rsize=32768, |
| HPUX 11.23 **** – | rw,bg,vers=3,proto=tcp,noac, hard,nointr,timeo=600, rsize=32768,wsize=32768,suid |
rw,bg,vers=3,proto=tcp,noac, forcedirectio,hard,nointr,timeo=600, rsize=32768,wsize=32768,suid |
rw,bg,vers=3,proto=tcp,noac, forcedirectio,hard,nointr,timeo=600 ,rsize=32768,wsize=32768,suid |
| Linux x86 # |
rw,bg,hard,nointr,rsize=32768, |
rw,bg,hard,nointr,rsize=32768, wsize=32768,tcp,actimeo=0, vers=3,timeo=600 |
rw,bg,hard,nointr,rsize=32768, |
| Linux x86-64 # | rw,bg,hard,nointr,rsize=32768, wsize=32768,tcp,vers=3, timeo=600, actimeo=0 |
rw,bg,hard,nointr,rsize=32768, wsize=32768,tcp,actimeo=0, vers=3,timeo=600 |
rw,bg,hard,nointr,rsize=32768, wsize=32768,tcp,vers=3, timeo=600,noac |
| Linux – Itanium | rw,bg,hard,nointr,rsize=32768, wsize=32768,tcp,vers=3, timeo=600, actimeo=0 |
rw,bg,hard,nointr,rsize=32768, wsize=32768,tcp,actimeo=0, vers=3,timeo=600 |
rw,bg,hard,nointr,rsize=32768, wsize=32768,tcp,noac,vers=3, timeo=600 |
* NFS mount option “forcedirectio” is required on Solaris platforms when mounting the OCR/CRS files when using Oracle 10.1.0.4 or 10.2.0.2 or later (Oracle unpublished bug 4466428)
** AIX is only supported with NAS on AIX 5.3 TL04 and higher with Oracle 10.2.0.1 and later (NetApp)
*** NAS devices are only supported with HPUX 11.23 or higher ONLY
# These mount options are for Linux kernels 2.6 and above for older kernels please check Note 279393.1
with all versions of RAC on Linux (x86 & X86-64 platforms) until 10.2.0.4. This bug is fixed and included in 10.2.0.4 patchset.
filesystemio_options = DIRECTIO
Single Instance
|
Operating System |
Mount options for Binaries | Mount options for Oracle Datafiles |
| Sun Solaris * (8, 9, 10) |
rw,bg,hard,rsize=32768, |
rw,bg,hard,rsize=32768, wsize=32768,vers=3,[forcedirectio or llock], nointr,proto=tcp,suid |
| AIX (5L) ** |
rw,bg,hard,rsize=32768, |
rw,bg,hard,rsize=32768, |
| HPUX 11.23 **** | rw,bg,hard,rsize=32768, wsize=32768,vers=3,nointr, timeo=600,proto=tcp,suid |
rw,bg,hard,rsize=32768, wsize=32768,vers=3,nointr, timeo=600,proto=tcp,suid |
| Linux x86 # |
rw,bg,hard,rsize=32768, wsize=32768,vers=3,nointr, timeo=600,tcp |
rw,bg,hard,rsize=32768, wsize=32768,vers=3,nointr, timeo=600,tcp,actime=0* |
| Linux x86-64 # | rw,bg,hard,rsize=32768, wsize=32768,vers=3,nointr, timeo=600,tcp |
rw,bg,hard,rsize=32768, wsize=32768,vers=3,nointr, timeo=600,tcp,actime=0* |
| Linux – Itanium | rw,bg,hard,rsize=32768, wsize=32768,vers=3,nointr, timeo=600,tcp |
rw,bg,hard,rsize=32768, wsize=32768,vers=3,nointr, timeo=600,tcp |
* actime=0 or noac can be used
依照上面所看到的,设置參数。结果仍然报错ora-27086,错误信息例如以下:
[oraten@yue ~]$ oerr ora 27086
27086, 00000, "unable to lock file - already in use"
// *Cause: the file is locked by another process, indicating that it is
// currently in use by a database instance.
// *Action: determine which database instance legitimately owns this file.
重新启动openfiler。成功解决这个问题,看来是之前mount不当导致在openfiler端有锁一直没有释放。
尽管oracle支持nfs,但使用nfs现场少。大多数使用nfs要备份数据库或存储归档
版权声明:本文博客原创文章,博客,未经同意,不得转载。
使用NFS安装oracle软件的更多相关文章
- Linux下搭建Oracle11g RAC(7)----安装Oracle 软件
从此步骤开始,我们正式安装oracle软件: ① 以oracle用户登录图形界面,执行/home/oracle/database/runInstaller,进入OUI的图形安装界面: ② 进入OUI安 ...
- OCA读书笔记(2) - 安装Oracle软件
Objectives: •Describe your role as a database administrator (DBA) and explain typical tasks and tool ...
- Linux下Oracle11G RAC报错:在安装oracle软件时报file not found一例
Linux下Oracle11G RAC报错:在安装oracle软件时报file notfound一例 1.现象 之前安装一切都比較顺利,安装oracle软件时,进度到30%时报错:file not f ...
- Oracle 之 Cloning $oracle_home (克隆安装oracle软件)
用途:Cloning an Oracle Home , 可以免去多台机器重复安装oracle软件 1.停止相关进程[root@node1 bin]# ./crsctl stop cluster -al ...
- 安装Oracle软件
1.安装linux操作系统和VMware Tools 2.创建组和用户,以root用户运行以下命令: groupadd -g 1000 oinstall groupadd -g 1001 dba us ...
- 在 Oracle Linux 6.5 上安装 Oracle 11g 单实例数据库
Checking the Hardware Requirements 系统必须满足下面最小的硬件要求 Memory Requirements Minimum: 1 GB of RAMRecommend ...
- linux 之静默安装oracle
Web服务器上面的Linux一般是不会有图形界面的,所有通过图形界面来安装Linux的方式在没有图形界面的Linux上面是行不通的,我们要使用的安装方式叫做Linux的静默安装.即在没有图形界面的Li ...
- Windows Azure功能更新:Oracle软件正式登陆Azure了
今天,Windows Azure国际版发布了新的功能:全面支持Oracle软件,包括Oracle Linux, Oracle 12c数据库,Weblogic 11g和12c,Oracle JDK 6和 ...
- CentOS5.6下安装Oracle10G软件 【保留报错经验】
CentOS5.6下安装Oracle10G ****************************************************************************** ...
随机推荐
- HDU4706:Children's Day
Problem Description Today is Children's Day. Some children ask you to output a big letter 'N'. 'N' i ...
- MyBatis简单的增删改查以及简单的分页查询实现
MyBatis简单的增删改查以及简单的分页查询实现 <? xml version="1.0" encoding="UTF-8"? > <!DO ...
- CF卡技术详解——笔记
知识太全面了,摘抄摘不完,还是粘过来加上注释和笔记吧. 重点以及断句用加粗,注释用红括号. 一.CF卡技术及规格 一.CF卡技术及规格 1.CF卡简史 随着数码产品的高速普及,近年来闪存卡也进入了高速 ...
- adb 命令使用的时候出现Error
在使用adb 命令行的时候会出现Error 重启adb server 即可,使用管理员运行Cmd 命令窗口 adb kill-server adb start-server 如果是连接真机查看的时候再 ...
- uva 140
思路:暴力+剪枝 uva140 wa了好多次……数组开小了……!!! #include <iostream> #include <cstdio> #include <cm ...
- cp命令的实现
#include <unistd.h> #include <fcntl.h> #include <stdlib.h> #define BUFFERSIZE 4096 ...
- 关于yaf的控制器命名,一个纠结的问题(续)
以下方案缺少loader相关的步骤,明天补上!!! 前面写过一篇<关于yaf的控制器命名,一个纠结的问题>.没想到yaf群里面也有跟我遇到一样问题的人,分享下解决办法. 写完那篇博文后,我 ...
- Linux下经常使用的shell命令记录
硬件篇 CPU相关 lscpu #查看的是cpu的统计信息. cat /proc/cpuinfo #查看CPU信息具体信息,如每一个CPU的型号,主频等 内存相关 free -m #概要查看内存情况 ...
- freemarker的TemplateExceptionHandler使用
系统使用freemarker作为页面展示层,为了解决系统统一异常的问题.于是配置了struts2的统一异常解决的方法(这个网上资料非常多,大家能够查看),但是发现freemarker出现异常后,str ...
- CSS中float属性和clear属性的一些笔记
在学习CSS的最后一部分内容中,float属性和clear属性比较难以用语言描述,因此在笔记本中无法准确的记录这两个属性的用法.所以在博客园上以图文的形式记录这两种属性的特征,以备以后查阅. 首先,定 ...