安装ORACLE_RAC遇到的问题与解决方法
while running:
/u01/app/oracle/product/10.2.0/db_1/root.sh
Checking to see if Oracle CRS stack is already configured
/etc/oracle does not exist. Creating it now.
Setting the permissions on OCR backup directory
Setting up NS directories
PROT-1:Failedtoinitializeocrconfig
Failedto upgrade Oracle Cluster Registry configuration
dd if=/dev/zero f=/dev/rdsk/V1064_vote_01_20m.dbf bs=8192 count=2560
dd if=/dev/zero f=/dev/rdsk/ocrV1064_100m.ora bs=8192 count=12800
解决方法1
Failedto upgrade Oracle Cluster Registry configuration
在安装CRS时,在第二个节点执行./root.sh时,出现如下提示,我在第一个节点执行正常.请大虾指点一些,不胜感激!谢谢!
[root@RACtest2 crs]# ./root.sh
WARNING: directory '/app/oracle/product/10.2.0' is not owned by root
WARNING: directory '/app/oracle/product' is not owned by root
WARNING: directory '/app/oracle' is not owned by root
WARNING: directory '/app' is not owned by root
Checking to see if Oracle CRS stack is already configured
Setting the permissions on OCR backup directory
Setting up NS directories
PROT-1:Failedtoinitializeocrconfig
Failedto upgrade Oracle Cluster Registry configuration
错误原因:
是因为安装crs的设备权限有问题,例如我的设备用raw来放置ocr和vote,此时要设置好这些硬件设备以及连接的文件的权限,下面是我的环境:
[root@rac2 oracrs]#
lrwxrwxrwx 1 root root 13 Jan 27 12:49 ocr.crs -> /dev/raw/raw1
lrwxrwxrwx 1 root root 13 Jan 26 13:31 vote.crs -> /dev/raw/raw2
chown root:oinstall /dev/raw/raw1
chown root:oinstall /dev/raw/raw2
chmod 660 /dev/raw/raw1
chmod 660 /dev/raw/raw2
其中/dev/sdb1放置ocr,/dev/sdb2放置vote.
[root@rac2 oracrs]# service rawdevices reload
Assigning devices:
/dev/raw/raw1 --> /dev/sdb1
/dev/raw/raw1: bound to major 8, minor 17
/dev/raw/raw2 --> /dev/sdb2
/dev/raw/raw2: bound to major 8, minor 18
Done
然后再次执行就ok了.
[root@rac2 oracrs]# /oracle/app/oracle/product/crs/root.sh
WARNING: directory '/oracle/app/oracle/product' is not owned by root
WARNING: directory '/oracle/app/oracle' is not owned by root
Checking to see if Oracle CRS stack is already configured
Setting the permissions on OCR backup directory
Setting up NS directories
Oracle Cluster Registry configuration upgraded successfully
WARNING: directory '/oracle/app/oracle/product' is not owned by root
WARNING: directory '/oracle/app/oracle' is not owned by root
clscfg: EXISTING configuration version 3 detected.
clscfg: version 3 is 10G Release 2.
assigning default hostname rac1 for node 1.
assigning default hostname rac2 for node 2.
Successfully accumulated necessary OCR keys.
Using ports: CSS=49895 CRS=49896 EVMC=49898 and EVMR=49897.
node <nodenumber>: <nodename> <private interconnect name> <hostname>
node 1: rac1 priv1 rac1
node 2: rac2 priv2 rac2
clscfg: Arguments check out successfully.
Oracle
gave me a patch that allowed us to format the OCR and voting disk. Now
the problem may just be I need to run root.sh on node1 or wipe both
clean and start fresh.
Devices formatted, now we need to get the CRS daemon up and running on both nodes..
[root@dr2db2 ~]# dd if=/dev/zero f=/dev/raw/raw2 bs=1048576 count=1000
1000+0 records in
1000+0 records out
[root@dr2db2 ~]# /orahome/app/oracle/product/10.1.2.0.2/CRS/root.sh
WARNING: directory '/orahome/app/oracle/product/10.1.2.0.2' is not owned by root
WARNING: directory '/orahome/app/oracle/product' is not owned by root
WARNING: directory '/orahome/app/oracle' is not owned by root
WARNING: directory '/orahome/app' is not owned by root
Checking to see if Oracle CRS stack is already configured
Setting the permissions on OCR backup directory
Setting up NS directories
Oracle Cluster Registry configuration upgraded successfully
WARNING: directory '/orahome/app/oracle/product/10.1.2.0.2' is not owned by root
WARNING: directory '/orahome/app/oracle/product' is not owned by root
WARNING: directory '/orahome/app/oracle' is not owned by root
WARNING: directory '/orahome/app' is not owned by root
Successfully accumulated necessary OCR keys.
Using ports: CSS=49895 CRS=49896 EVMC=49898 and EVMR=49897.
node <nodenumber>: <nodename> <private interconnect name> <hostname>
node 1: dr2db2 dr2db2-eth2 dr2db2
node 2: dr2db1 dr2db1-eth2 dr2db1
Creating OCR keys for user 'root', privgrp 'root'..
Operation successful.
Now formatting voting device: /dev/raw/raw6
Format of 1 voting devices complete.
Startup will be queued to init within 90 seconds.
Adding daemons to inittab
Expecting the CRS daemons to be up within 600 seconds.
CSS is active on these nodes.
dr2db2
CSS is inactive on these nodes.
dr2db1
Local node checking complete.
Run root.sh on remaining nodes to start CRS daemons.
[root@dr2db2 ~]# ps -ef | grep ora
root 6572 2526 0 13:39 ? 00:00:00 sshd: oracle [priv]
oracle 6574 6572 0 13:39 ? 00:00:00 sshd: oracle@pts/1
oracle 6575 6574 0 13:39 pts/1 00:00:00 -bash
root 14172 2526 0 17:54 ? 00:00:00 sshd: oracle [priv]
oracle 14176 14172 0 17:55 ? 00:00:00 sshd: oracle@pts/2
oracle 14177 14176 0 17:55 pts/2 00:00:00 -bash
root
14682 1 0 17:57 ? 00:00:00 /bin/su -l oracle -c sh -c 'ulimit -c
unlimited; cd
/orahome/app/oracle/product/10.1.2.0.2/CRS/log/dr2db2/evmd; exec
/orahome/app/oracle/product/10.1.2.0.2/CRS/bin/evmd '
root 14686 1 0 17:57 ? 00:00:00 /orahome/app/oracle/product/10.1.2.0.2/CRS/bin/crsd.bin reboot
oracle 14959 14682 0 17:58 ? 00:00:00 /orahome/app/oracle/product/10.1.2.0.2/CRS/bin/evmd.bin
root
15018 14942 0 17:58 ? 00:00:00 /bin/su -l oracle -c /bin/sh -c 'ulimit
-c unlimited; cd
/orahome/app/oracle/product/10.1.2.0.2/CRS/log/dr2db2/cssd;
/orahome/app/oracle/product/10.1.2.0.2/CRS/bin/ocssd || exit $?'
oracle
15021 15018 0 17:58 ? 00:00:00 /bin/sh -c ulimit -c unlimited; cd
/orahome/app/oracle/product/10.1.2.0.2/CRS/log/dr2db2/cssd;
/orahome/app/oracle/product/10.1.2.0.2/CRS/bin/ocssd || exit $?
oracle 15057 15021 0 17:58 ? 00:00:00 /orahome/app/oracle/product/10.1.2.0.2/CRS/bin/ocssd.bin
root 15996 14206 0 17:59 pts/2 00:00:00 grep ora
crs_setperm crs_setperm.bin crs_start crs_start.bin crs_stat crs_stat.bin crs_stop crs_stop.bin
[root@dr2db2 ~]# /orahome/app/oracle/product/10.1.2.0.2/CRS/bin/crs_stat -t
CRS-0184: Cannot communicate with the CRS daemon.
on next node
[root@dr2db1 ~]# /orahome/app/oracle/product/10.1.2.0.2/CRS/root.sh
WARNING: directory '/orahome/app/oracle/product/10.1.2.0.2' is not owned by root
WARNING: directory '/orahome/app/oracle/product' is not owned by root
WARNING: directory '/orahome/app/oracle' is not owned by root
WARNING: directory '/orahome/app' is not owned by root
Checking to see if Oracle CRS stack is already configured
/etc/oracle does not exist. Creating it now.
Setting the permissions on OCR backup directory
Setting up NS directories
Oracle Cluster Registry configuration upgraded successfully
WARNING: directory '/orahome/app/oracle/product/10.1.2.0.2' is not owned by root
WARNING: directory '/orahome/app/oracle/product' is not owned by root
WARNING: directory '/orahome/app/oracle' is not owned by root
WARNING: directory '/orahome/app' is not owned by root
/orahome/app/oracle/product/10.1.2.0.2/CRS/bin/crsctl.bin:
error while loading shared libraries: libstdc++.so.5: cannot open
shared object file: No such file or directory
Failure initializing entries in /etc/oracle/scls_scr/dr2db1.
I think whats needed is a clean install.
http://www.puschitz.com/InstallingOracle10gRAC.shtml#CreatingPartitionsForRawDevices
在 node1 上执行:/opt/ora10g/product/10.2.0/crs_1/root.sh; 在 node2 上执行:/opt/ora10g/product/10.2.0/crs_1/root.sh;
通常在最后一个节点执行root.sh时会遇到错误,就我们的情况而言当然就是node2~~
提示:一般常见的错误有如下三种:
A).如果你碰到了这个错误:
/opt/ora10g/product/10.2.0/crs_1/jdk/jre//bin/java: error while loading shared libraries: libpthread.so.0: cannot open shared object file: No such file or directory
可以按照如下方式解决:
===============================
修改vipca文件
[root@node2 opt]# vi /opt/ora10g/product/10.2.0/crs_1/bin/vipca
找到如下内容:
Remove this workaround when the bug 3937317 is fixed
arch=`uname -m`
if [ "$arch" = "i686" -o "$arch" = "ia64" ]
then
LD_ASSUME_KERNEL=2.4.19
export LD_ASSUME_KERNEL
fi
#End workaround
在fi后新添加一行:
unset LD_ASSUME_KERNEL
以及srvctl文件
[root@node2 opt]# vi /opt/ora10g/product/10.2.0/crs_1/bin/srvctl
找到如下内容:
LD_ASSUME_KERNEL=2.4.19
export LD_ASSUME_KERNEL
同样在其后新增加一行:
unset LD_ASSUME_KERNEL
保存退出,然后在node2重新执行root.sh
当然,既然我们已经知道了有这个问题,建议最好在node2执行root.sh之前,首先修改vipca。
其实同时需要你改的还有$ORACLE_HOME/bin/srvctl文件,不然等装完数据库之后,srvctl命令也是会报这个错误地。要知道srvctl这么常用,如果它执行老报错,那可是相当致命啊。不过呢你现在才安装到crs,离create db还远着呢,大可以等到创建完数据库,待到需要管理时再修改该文件。
B).如果你碰到了这个错误:
The given interface(s), "eth0" is not public. Public interfaces should be used to configure virtual IPs.
解决方式如下:
==============================
图形界面上运行$CRS_HOME/bin/vipca,手工重新配置rac1-vip和rac2-vip。
[root@node2 opt]# xhost +
[root@node2 opt]# /opt/ora10g/product/10.2.0/crs_1/bin/vipca
按照提示点击下一步


点击finish即可
vipca开始自动配置
全部配置完成之后,点击exit退出操作窗口。
C).如果你碰到了这个错误:
Error 0(Native: listNetInterfaces:[3])
[Error 0(Native: listNetInterfaces:[3])]
解决方式如下:
===============================
[root@node2 bin]# ./oifcfg iflist
eth1 10.10.17.0
virbr0 192.168.122.0
eth0 192.168.100.0
[root@node2 bin]# ./oifcfg setif -global eth0/192.168.100.0:public[root@node2 bin]# ./oifcfg setif -global eth1/10.10.10.0:cluster_
interconnect
[root@node2 bin]# ./oifcfg getif
eth0 192.168.100.0 global public
eth1 10.10.10.0 global cluster_interconnect
然后在视窗界面重新执行vipca即可,如上b例中所示。
安装ORACLE_RAC遇到的问题与解决方法的更多相关文章
- 在CentOS7.1上安装Gitlab碰到的问题及解决方法
一 前言 关于在CentOS7上安装Gitlab, 官方文档已经很详细了,步骤大家按照官方的安装文档一步一步安装即可, 这里就不在累述.官方安装文档地址: https://about.gitlab. ...
- ASP.NET MVC 此安装不支持该项目类型解决方法
http://www.cnblogs.com/younggun/archive/2011/03/03/1969498.html ASP.NET MVC 此安装不支持该项目类型解决方法 打开 .csp ...
- win7系统总是安装不了net2.0的解决方法
一些网友询问说ghost win7系统总是安装不了net2.0怎么办呢?net2.0是什么?ATI显卡的控制中心 就需要在NET2.0的基础上.可是一些用户说win7系统总是安装不了net2.0如何解 ...
- mysql安装以后无法登陆的的解决方法((ERROR 1698 (28000): Access denied for user 'root'@'localhost'))
mysql安装以后无法登陆的的解决方法((ERROR 1698 (28000): Access denied for user 'root'@'localhost')) 解决步骤: [====> ...
- win7 安装过程中遇到的错误解决方法
win7 安装过程中遇到的错误解决方法 windows安装无法继续.若要安装windows 请单击 确定 重新启动计算机: 当 出现如上提示的时候,按下shift+f10 会打开命令窗口,进入到C:\ ...
- Linux安装ElasticSearch启动报错的解决方法
Linux安装ElasticSearch后,ElasticSearch是不能用root用户启动的,以root用户启动会报错Refer to the log for complete error det ...
- STM32 USB转串口驱动安装不成功出现黄色感叹号解决方法!
相信很多人在做USB转串口时出现过串口驱动安装不成功,出现黄色感叹号问题, 出现这种问题一般是驱动安装不成功造成的. 这里我就这个问题总结几个简单的方法. 方法1: 插上USB,利用驱动人生安装驱动. ...
- 虚拟机中安装Kali遇到的问题及解决方法
title: 虚拟机中安装Kali遇到的问题及解决方法 date: 2018-11-25 12:25:43 tags: 安全 --- 关于Kali版本选择 kail官方下载页面 虚拟机中当然就下载虚拟 ...
- 总结关于Ubuntu 安装 Docker 配置相关问题及解决方法
总结关于Ubuntu 安装 Docker 配置相关问题及解决方法 Tomcat 示例 软件镜像(xx安装程序)----运行镜像----产生一个容器(正在运行的软件,运行的xx): 步骤: 1.搜索镜像 ...
随机推荐
- C# 文件过滤器filter
OpenFileDialog对话框的Filter属性说明: 首先说明一个示例,分析一下Filter属性的构成:“ Excel文件|*.xls ”,前面的“Excel文件”成为标签,是一个可读的字符串, ...
- C# 线程安全与 lock锁
如果你的代码所在的进程中有多个线程在同时运行,而这些线程可能会同时运行这段代码.如果每次运行结果和单线程运行的结果是一样的,而且其他的变量的值也和预期的是一样的,就是线程安全的. 或者说:一个类或者 ...
- 实现mysql按月统计的教程
From: http://www.jbxue.com/db/758.html 实现mysql按月统计的教程 mysql有个字段是DATETIME类型,要实现可以按月统计,该怎么写sql语句? se ...
- ★Wireshark基本介绍和学习TCP三次握手
之前写过一篇博客:用 Fiddler 来调试HTTP,HTTPS. 这篇文章介绍另一个好用的抓包工具wireshark, 用来获取网络数据封包,包括http,TCP,UDP,等网络协议包. 记得大学的 ...
- Oracle-10.2.0.1,打补丁10.2.0.5:在 debian 版本4【不含4】以上,及 ubuntu 7.04【不含7.04】以上都可以安装!
如题. todo 特殊的:ubuntu 16.04 LTS 版本 无法安装成功,原因待查找!!! 最近测试练习安装linux x64上的 oracle10.2.0.5, 都要吐了.
- Lua常用时间函数
常用时间函数 print(os.time()) --当前系统时间值 print(os.date( print(os.date("*t"), os.time()) --当前系统时间表 ...
- PHP日期知识
(1)date用法: date(格式,[时间]);如果没有时间参数,则使用当前时间. 格式是一个字符串,其中以下字符有特殊意义:U 替换成从一个起始时间(好象是1970年1月1日)以来的秒数 Y 替换 ...
- python中是否有单独的字符类型,通过下标的方式表示字符串中的字符
说明: 在python中,没有单独的字符类型,一个字符呢就是一个大小为1的字符串. 并且可以通过下标的方式,表示字符串中的字符. 操作过程: 1.通过[ ]的方式表示字符串中的第几个字符 >&g ...
- 关于OSG+QT+VS版本的问题
CMake3.10.0 Qt5.11.0安装包只有VS2017_64版本,没有VS2017的32位版本,有VS2015的32位版本 Qt5.11.0+osg3.4在CMake的时候,会出现 CMake ...
- 如何使用 SSH 连接 VMWare 虚拟机中的 Ubuntu
环境:VMWare Player 5.0.2,Ubuntu 13.10 VMWare共有3种网络连接模式,分别是: 1. bridged(桥接模式):虚拟机将直接连接到物理局域网,使自身独立于宿主机 ...