From:http://blog.sina.com.cn/s/blog_6734ea6d0102v6sn.html

增加操作系统环境变量:ORACLE_HOSTNAME=localhost

然后在cmd下运行  emca -config dbcontrol db  (如果多个数据库实例,先 执行set oracle_unqname= oralcle_sid,其中oralcle_sid为你的实例名)

C:\Documents and Settings\Administrator>emca -config dbcontrol db

EMCA 开始于 2012-3-10 18:01:26
EM Configuration Assistant, 11.2.0.0.2 正式版
版权所有 (c) 2003, 2005, Oracle。保留所有权利。

输入以下信息:
数据库 SID: xdjwdb10
监听程序端口号: 1521
监听程序 ORACLE_HOME [ D:\app\Administrator\product\11.2.0\dbhome_1 ]: LISTENER
SYS 用户的口令:
DBSNMP 用户的口令:
SYSMAN 用户的口令:
SYSMAN 用户的口令: 通知的电子邮件地址 (可选):
通知的发件 (SMTP) 服务器 (可选):
-----------------------------------------------------------------

已指定以下设置

数据库 ORACLE_HOME ................ D:\app\Administrator\product\11.2.0\dbhome_1

本地主机名 ................ localhost
监听程序 ORACLE_HOME ................ LISTENER
监听程序端口号 ................ 1521
数据库 SID ................ xdjwdb10
通知的电子邮件地址 ...............
通知的发件 (SMTP) 服务器 ...............

-----------------------------------------------------------------
是否继续? [是(Y)/否(N)]: y
2012-3-10 18:01:50 oracle.sysman.emcp.EMConfig perform
信息: 正在将此操作记录到 D:\app\Administrator\cfgtoollogs\emca\XDJWDB10\emca_201
2_03_10_18_01_26.log。
2012-3-10 18:01:54 oracle.sysman.emcp.EMReposConfig uploadConfigDataToRepository

信息: 正在将配置数据上载到 EM 资料档案库 (此操作可能需要一段时间)...
2012-3-10 18:02:59 oracle.sysman.emcp.EMReposConfig invoke
信息: 已成功上载配置数据
2012-3-10 18:03:00 oracle.sysman.emcp.ParamsManager getLocalListener
警告: 检索 localhost 的监听程序时出错
2012-3-10 18:03:04 oracle.sysman.emcp.util.DBControlUtil configureSoftwareLib
信息: 软件库已配置成功。
2012-3-10 18:03:04 oracle.sysman.emcp.EMDBPostConfig configureSoftwareLibrary
信息: 正在部署预配档案...
2012-3-10 18:03:40 oracle.sysman.emcp.EMDBPostConfig configureSoftwareLibrary
信息: 预配档案部署成功。
2012-3-10 18:03:40 oracle.sysman.emcp.util.DBControlUtil secureDBConsole
信息: 正在保护 Database Control (此操作可能需要一段时间)...
2012-3-10 18:03:49 oracle.sysman.emcp.util.DBControlUtil secureDBConsole
信息: 已成功保护 Database Control。
2012-3-10 18:03:49 oracle.sysman.emcp.util.DBControlUtil startOMS
信息: 正在启动 Database Control (此操作可能需要一段时间)...
2012-3-10 18:05:05 oracle.sysman.emcp.EMDBPostConfig performConfiguration
信息: 已成功启动 Database Control
2012-3-10 18:05:07 oracle.sysman.emcp.EMDBPostConfig performConfiguration
信息: >>>>>>>>>>> Database Control URL 为 https://localhost:5500/em <<<<<<<<<<<<BR>2012-3-10 18:05:11 oracle.sysman.emcp.EMDBPostConfig invoke
警告:
************************  WARNING  ************************

管理资料档案库已置于安全模式下, 在此模式下将对 Enterprise Manager 数据进行加密。
加密密钥已放置在文件 D:/app/Administrator/product/11.2.0/dbhome_1/localhost_XDJW
DB10/sysman/config/emkey.ora 中。请务必备份此文件, 因为如果此文件丢失, 则加密数
据将不可用。

***********************************************************
已成功完成 Enterprise Manager 的配置
EMCA 结束于 2012-3-10 18:05:11

PS:

创建一个EM资料库
    emca -repos create
重建一个EM资料库
    emca -repos recreate
删除一个EM资料库
    emca -repos drop
配置数据库的 Database Control
    emca -config dbcontrol db
删除数据库的 Database Control配置
    emca -deconfig dbcontrol db
重新配置db control的端口,默认端口在1158
    emca -reconfig ports
    emca -reconfig ports -dbcontrol_http_port 1160
    emca -reconfig ports -agent_port 3940
先设置ORACLE_SID环境变量后,启动EM console服务 
    emctl start dbconsole
先设置ORACLE_SID环境变量后,停止EM console服务
    emctl stop dbconsole
先设置ORACLE_SID环境变量后,查看EM console服务的状态
    emctl status dbconsole
配置dbconsole的步骤
    emca -repos create
    emca -config dbcontrol db
    emctl start dbconsole
重新配置dbconsole的步骤
    emca -repos drop
    emca -repos create
    emca -config dbcontrol db
    emctl start dbconsole

检查状态:emctl status dbconsole

C:\Documents and Settings\Administrator>emctl status dbconsole

OC4J Configuration issue. D:\app\Administrator\product\11.2.0\dbhome_1/oc4j/j2ee
/OC4J_DBConsole_localhost_orcl not found.

后期:

emctl status dbconsole

Environment variable ORACLE_UNQNAME not defined. Please set ORACLE_UNQNAME to database unique name

解决方法:

在启动的时候先设置一下oracle_unqname

set oracle_unqname=$ORACLE_SID

oracle 11g 一直提示 严重: 监听程序未启动或数据库服务未注册到该监听程序的更多相关文章

  1. oracle 11g在安装过程中出现监听程序未启动或数据库服务未注册到该监听程序

    15511477451 原文 oracle 11g在安装过程中出现监听程序未启动或数据库服务未注册到该监听程序? 环境:win7 64位系统.oracle11g数据库 问题描述:在win7 64位系统 ...

  2. 监听程序未启动或数据库服务未注册到该监听程序。启动该监听程序并注册数据库服务 然后重新运行 em configuration assistant。

    在WIN 7/64Bit上安装ORACLE 11gR2后,管理网页Database Control(如:https://localhost:1158/em)始终登录不进去,总是说密码错误,使用配置工具 ...

  3. oracle server配置:监听程序未启动或数据库服务未注册到该监听程序

    第一次安装oracle时,时完全没有任何问题的, 但是当我去配置oracle_home时,误按之下进入了Database Configuration Assistant, 然后配置已有的一个数据库,就 ...

  4. Oracle监听程序未启动或数据库服务未注册到该监听

    oracle新建数据库的时候提示Could not find appropriate listener for this database要做的操作如下: 1.查看netmanager里面的liste ...

  5. oracle 11g Enterprise Manager配置失败

    Enterprise Manager以下简称em,Database Configuration Assistant简称DBCA. 病症 监听程序未启动或数据库服务未注册到该监听程序.启动该监听程序并注 ...

  6. oracle监听程序无法启动(TNS-12560: TNS: 协议适配器错误,TNS-00530: 协议适配器错误)

    问题描述1:   C:\Users\Administrator>lsnrctl start LSNRCTL for 64-bit Windows: Version 11.2.0.1.0 - Pr ...

  7. ORACLE 11G R2 RAC classical install OGG12.1(LINUX) 经典抽取模式单项同步配置OGG12.1

    博文结构图如下: 一.环境描述以及注意事项 1.1 环境简介 IP 系统 Oracle版本 OGG版本 源端 172.16.10.16/36 RHEL6.5 oracle11204 12.1 目标端 ...

  8. Oracle 11g完全卸载(Windows)(转)

    Oracle 11g完全卸载(Windows) 1.关闭oracle所有的服务.可以在windows的服务管理器中关闭:    一般有以下服务:   (1)Oracle SID VSS Writer ...

  9. Oracle 11g数据库详解(2)

    FAILED_LOGIN_ATTEMPTS 用于指定连续登陆失败的最大次数 达到最大次数后,用户会被锁定,登陆时提示ORA-28000 UNLIMITED为不限制 精确无误差 是 实时 PASSWOR ...

随机推荐

  1. GWT入门学习之下载安装

    1.准备 安装 jdk: 下载路径:http://download.oracle.com/otn-pub/java/jdk/8u92-b14/jdk-8u92-windows-i586.exe?Aut ...

  2. python核心编程学习记录之序列(字符串元组列表)

    可以在元组中放入可变类型如列表,然后修改列表来修改元组

  3. TBB 学习笔记

    #include <tbb/task_scheduler_init.h> #include <tbb/blocked_range.h> #include <tbb/par ...

  4. Black World

  5. Sql Server2005新特性及性能

    举几个例子来简单说明 这些例子我引用了Northwind库. 1. TOP 表达式 SQL Server 2000的TOP是个固定值,是不是觉得不爽,现在改进了. --前n名的订单declare @n ...

  6. MySql + EF6 + .Net Core

    2016年8月17日01:21:29 更新:这里介绍一下一个开源的 EF Core 的 MySQL 组件 [MySQL for .NET Core - Pomelo 扩展包系列][http://www ...

  7. (6) 深入理解Java Class文件格式(五)

    前情回顾 本专栏的前几篇博文, 对class文件中的常量池进行了详细的解释. 前文讲解了常量池中的7种数据项, 它们分别是: CONSTANT_Utf8_info CONSTANT_NameAndTy ...

  8. 【Spring】对象后期处理,BeanPostProcessor

    当我们使用Spring容器管理对象时,需要对对象进行一些后期处理时,比如数据处理.数据预加载,可以使用BeanPostProcessor接口. 简单演示它的用法. 定义扫描包,显示定义BeanPost ...

  9. 不用安装Oracle_Client就能使用PLSQL_Developer

    1. 下载oracle的客户端程序包(30M)       只需要在Oracle官方网站下载一个叫Instant Client Package的软件就可以了,这个软件不需要安装,只要解压就可以用了,很 ...

  10. SE78、SWM0

    声明:原创作品,转载时请注明文章来自SAP师太技术博客( 博/客/园www.cnblogs.com):www.cnblogs.com/jiangzhengjun,并以超链接形式标明文章原始出处,否则将 ...