距离上次写的一篇mongoDB搭建已经有一年多的时间了,刚好这次在公司搭建好在centos7下的mongodb搭建,简单的做一个记录吧

mongo 是一个基于分布式文件存储的数据库,数据主要存储在磁盘跟cpu中(一些基本的介绍我这里就不提了,执行百度)

直接进入正题:

1、我在这里新建了一个目录

mkdir /mongo

1、下载
cd mongodb
wget https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-rhel70-3.2.8.tgz
2、解压
[root@cli mongodb]# tar -zxvf mongodb-linux-x86_64-rhel70-3.2.8.tgz
mongodb-linux-x86_64-rhel70-3.2.8/README
mongodb-linux-x86_64-rhel70-3.2.8/THIRD-PARTY-NOTICES
mongodb-linux-x86_64-rhel70-3.2.8/MPL-2
mongodb-linux-x86_64-rhel70-3.2.8/GNU-AGPL-3.0
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongodump
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongorestore
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongoexport
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongoimport
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongostat
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongotop
mongodb-linux-x86_64-rhel70-3.2.8/bin/bsondump
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongofiles
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongooplog
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongoperf
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongod
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongos
mongodb-linux-x86_64-rhel70-3.2.8/bin/mongo

[root@cli mongodb]# mv mongodb-linux-x86_64-rhel70-3.2.8 mongodb3.2.8
[root@cli mongodb]# cd mongodb3.2.8/
3 在 /usr/local/mongodb/mongodb3.2.4/bin/ 目录中创建一个存放日志的目录:
[root@cli mongodb3.2.8]# mkdir -p data/db
4. 目录中创建一个存放数据文件的目录
[root@cli mongodb3.2.8]# mkdir -p data/logs
5.进入 bin 目录中
[root@cli mongodb3.2.8]# cd bin
6.创建配置文件 mongodb.conf:
[root@cli bin]# vim mongodb.conf

# idae - MongoDB config start - 2017-12-06
# 设置数据文件的存放目录
dbpath = /mongodb/mongodb3.2.8/data/db
# 设置日志文件的存放目录及其日志文件名
logpath =/mongodb/mongodb3.2.8/data/logs/mongodb.log
# 设置端口号(默认的端口号是 27017)
port = 27017
# 设置为以守护进程的方式运行,即在后台运行
fork = true
# nohttpinterface = true
nohttpinterface = true
# idae - MongoDB config end - 2017-12-06

按英文状态下的“:wq”保存并退出;

参数解释:
--dbpath 数据库路径(数据文件)
--logpath 日志文件路径
--master 指定为主机器
--slave 指定为从机器
--source 指定主机器的IP地址
--pologSize 指定日志文件大小不超过64M.因为resync是非常操作量大且耗时,最好通过设置一个足够大的oplogSize来避免resync(默认的 oplog大小是空闲磁盘大小的5%)。
--logappend 日志文件末尾添加,即使用追加的方式写日志
--journal 启用日志
--port 启用端口号
--fork 在后台运行
--only 指定只复制哪一个数据库
--slavedelay 指从复制检测的时间间隔
--auth 是否需要验证权限登录(用户名和密码)
--syncdelay 数据写入硬盘的时间(秒),0是不等待,直接写入
--notablescan 不允许表扫描
--maxConns 最大的并发连接数,默认2000
--pidfilepath 指定进程文件,不指定则不产生进程文件
--bind_ip 绑定IP,绑定后只能绑定的IP访问服务

7 将 mongodb 服务加入到自启动文件中:
vi /etc/rc.local
在文件末尾追加如下命令:
/mongodb/mongodb3.2.8/bin/mongod --config /mongodb/mongodb3.2.8/bin/mongodb.conf
保存并退出:
:wq!
--------------------------------------------------------------------------------

./bin/mongo

use admin

db.createUser({user:"admin", pwd:"123456",roles:[{role:"root", db:"LogSystem"}]})

关闭数据库服务器:
use admin
db.shutdownServer()

在这里主从架构(副本集模式)如果设置 auth = true
那么从服务器没有办法验证主服务器,需要在主从加上验证文件
在主服务器中执行命令
openssl rand -base64 741 >> /mongodb/mongodb.key
生成文件的字节数必须小于1024

生成的文件格式设置成600
chmod 600 /mongodb/mongodb.key
在这里已经生成了 mongodb.key,将他scp到各台从服务器上,然后在各台机器上配置 keyFile

然后在mongodb.conf 中添加
keyFile = /mongodb/mongodb.key

centos7下搭建 MongoDB -01的更多相关文章

  1. centos7下搭建ceph luminous(12.2.1)--无网或网络较差

    本博客的主要内容是在centos7下搭建luminous,配置dashboard,搭建客户端使用rbd,源码安装ceph,最后给出一些较为常用的命令.本博客针对初次接触ceph的人群. 搭建环境: 主 ...

  2. Linux系统:Centos7下搭建PostgreSQL关系型数据库

    本文源码:GitHub·点这里 || GitEE·点这里 一.PostgreSQL简介 1.数据库简介 PostgreSQL是一个功能强大的开源数据库系统,具有可靠性.稳定性.数据一致性等特点,且可以 ...

  3. 在Centos7下搭建Socks5代理服务器

    在Centos7下搭建Socks5代理服务器 http://blog.51cto.com/quliren/2052776   采用socks协议的代理服务器就是SOCKS服务器,是一种通用的代理服务器 ...

  4. 第四百零五节,centos7下搭建sentry错误日志服务器,接收python以及Django错误,

    第四百零五节,centos7下搭建sentry错误日志服务器,接收python以及Django错误, 注意:版本,不然会报错 Docker >=1.11Compose >1.6.0 通过d ...

  5. Hyperledger超级账本在Centos7下搭建运行环境

    超级账本(hyperledger)是Linux基金会于2015年发起的推进区块链数字技术和交易验证的开源项目,加入成员包括:荷兰银行(ABN AMRO).埃森哲(Accenture)等十几个不同利益体 ...

  6. CentOS7下搭建zabbix监控(四)——Zabbix报警设置

    CentOS7下搭建zabbix监控(一)——Zabbix监控端配置 CentOS7下搭建zabbix监控(二)——Zabbix被监控端配置 CentOS7下搭建zabbix监控(三)——Zabbix ...

  7. CentOS7下搭建zabbix监控(三)——Zabbix监控服务配置

    CentOS7下搭建zabbix监控(一)——Zabbix监控端配置 CentOS7下搭建zabbix监控(二)——Zabbix被监控端配置 (1).配置Zabbix监控Apache服务 主机名:yo ...

  8. CentOS7下搭建zabbix监控(二)——Zabbix被监控端配置

    Zabbix监控端配置请查看:CentOS7下搭建zabbix监控(一)——Zabbix监控端配置 (1).在CentOS7(被监控端)上部署Zabbix Agent 主机名:youxi2 IP地址: ...

  9. MongoDB学习笔记—Linux下搭建MongoDB环境

    1.MongoDB简单说明 a MongoDB是由C++语言编写的一个基于分布式文件存储的开源数据库系统,它的目的在于为WEB应用提供可扩展的高性能数据存储解决方案. b MongoDB是一个介于关系 ...

随机推荐

  1. IDA学习笔记 函数调用约定

    stdcall和cdecl: stdcall和cdecl 压栈方向都是从右到左 区别在于c约定是调用方在函数返回后add esp,n指令清除堆栈中的参数,而stdcall在被调函数内使用ret n来清 ...

  2. 华为云照片的爬虫程序更新(python3.6)

    一.背景: 每年终都有一个习惯,就是整理资料进行归档,结果发现手机照片全备份在华为云里,在官网上找了一圈,没找到官方的pc工具用来同步照片. 于是找出上次写的程序,看看能不能爬到数据,然而……果然不好 ...

  3. Python自动化--语言基础6--模块操作之re、MySQL、Excel

    1.Python自有模块正则 import re # re.match只匹配字符串的开始,如果字符串开始不符合正则表达式,则匹配失败,函数返回None print(re.match("aaa ...

  4. Freemarker的基本语法及入门基础

    freemarker的基本语法及入门基础一.freemarker模板文件(*.ftl)的基本组成部分        1. 文本:直接输出的内容部分        2. 注释:不会输出的内容,格式为&l ...

  5. asp.net core 一 Centos 环境部署

             .netcore的运行环境,创建asp.net core 项目    CentOS 7 ,dotnet-sdk-2.0.0-2.0.0-1.x86_64 直接在liunx创建项目并运 ...

  6. 又是一个愚蠢的错误,皆因.xml而起

       论java中的.xml到底有多坑?! 感觉自己都快哭了,再一次被.xml给坑了一下,这次坑的太狠了,一下子导致自己浪费了昨天一下午,一晚上,今天一上午和半个下午呀,中间的过程真的是乏善可陈呀,各 ...

  7. Android ADB Server启动失败

    启动Android Stdio的时候报如下错误: Unable to create Debug Bridge: Unable to start adb server: error: could not ...

  8. AGC010 - B: Boxes

    原题链接 题意简述 给出一个由个数构成的环,每次可以选择一个位置并从这个数起顺时针依次对每个数-1,-2,-3,-,-n.问能否将所有数全变为0. 分析 考虑一次操作对环带来了什么影响. (在后加一个 ...

  9. MacOS App代码申请管理员权限

    原文: https://jacobpan3g.github.io/cn/2018/02/07/gain-root-permission-for-mac-app/,有问题欢迎在原文评论区一起讨论交流,我 ...

  10. probabilistic robotics_bayes filter

    贝叶斯滤波 执行测量后的后验概率: 执行测量前的先验概率: 执行测量后的后验概率推导 根据式2.23的推导方式 可推出 假定xt是complete,即xt可以完全决定测量结果,那么则有2.56式: 带 ...