openshift首页进不去

启动openshift时报的错,大意是:

无法为kubelet构造api.Node对象:无法获取节点master.example.com的IP地址:

所以就联想到新装的centos,没有在网卡配置文件中配置固定IP

添加IPADDR=192.*.*.*

IP还跟默认分配的保持不变就好。

重新启动openshift,OK。

异常内容:

I0522 ::59.046046     endpoints_controller.go:] Waiting for pods controller to sync, requeuing service default/kubernetes
E0522 ::59.098098 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098122 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098128 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098134 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098139 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098144 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098337 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098345 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098351 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098355 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098360 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098364 util.go:] Metric for replenishment_controller already registered
E0522 ::59.098368 util.go:] Metric for replenishment_controller already registered
I0522 ::59.172993 endpoints_controller.go:] Waiting for pods controller to sync, requeuing service default/kubernetes
I0522 ::59.276459 endpoints_controller.go:] Waiting for pods controller to sync, requeuing service default/kubernetes
I0522 ::59.289358 start_master.go:] Started Origin Controllers
I0522 ::59.297654 kubelet.go:] Controller attach/detach is disabled for this node; Kubelet will attach and detach volumes
E0522 ::59.308466 kubelet.go:] Unable to construct api.Node object for kubelet: can't get ip address of node master.example.com: lookup master.example.com on 192.168.238.2:53: no such host
I0522 ::59.376810 endpoints_controller.go:] Waiting for pods controller to sync, requeuing service default/kubernetes
I0522 ::00.108732 kubelet.go:] Controller attach/detach is disabled for this node; Kubelet will attach and detach volumes
E0522 ::00.120079 kubelet.go:] Unable to construct api.Node object for kubelet: can't get ip address of node master.example.com: lookup master.example.com on 192.168.238.2:53: no such host
I0522 ::01.720788 kubelet.go:] Controller attach/detach is disabled for this node; Kubelet will attach and detach volumes
E0522 ::01.756366 kubelet.go:] Unable to construct api.Node object for kubelet: can't get ip address of node master.example.com: lookup master.example.com on 192.168.238.2:53: no such host
I0522 ::04.956605 kubelet.go:] Controller attach/detach is disabled for this node; Kubelet will attach and detach volumes
E0522 ::04.965966 kubelet.go:] Unable to construct api.Node object for kubelet: can't get ip address of node master.example.com: lookup master.example.com on 192.168.238.2:53: no such host
^C2018-- ::06.981664 N | osutil: received interrupt signal, shutting down...

Unable to construct api.Node object for kubelet: can't get ip address of node master.example.com: lookup master.example.com on : no such host的更多相关文章

  1. Genymotion模拟器无法开启的解决方法——Unable to start the virtual device,The virtual device got no IP address

    前言 最近重装了电脑的系统,由win7换成了win8.1.android开发环境也重新配置了一遍.其他的都还好,就是genymotion模拟器一直开启失败. 自己尝试了很多方法,比如卸载重装软件,重新 ...

  2. Java学习(API及Object类、String类、StringBuffer字符串缓冲区)

    一.JAVA的API及Object类 1.API 概念: Java 的API(API: Application(应用) Programming(程序) Interface(接口)) Java API就 ...

  3. 常用API(Object、String、StringBuffer、用户登陆注册)

    常用API 今日内容介绍 u Object u String u StringBuilder 第1章 Java的API及Object类 在以前的学习过程中,我们都在学习对象基本特征.对象的使用以及对象 ...

  4. 代码块和Java的API及Object类

    代码块 局部代码块 特点: 以”{}”划定的代码区域,此时只需要关注作用域的不同即可 方法和类都是以代码块的方式划定边界的 构造代码块 优先于构造方法执行,构造代码块用于执行所有对象均需要的初始化动作 ...

  5. Node.js面试题:侧重后端应用与对Node核心的理解

    Node是搞后端的,不应该被被归为前端,更不应该用前端的观点去理解,去面试node开发人员.所以这份面试题大全,更侧重后端应用与对Node核心的理解. node开发技能图解 node 事件循环机制 起 ...

  6. 《唐三学node.js系列》—魂士篇&&三哥初始node.js

    前言 如果你有一定的前端基础,比如 HTML.CSS.JavaScript.jQuery.那么Node.js 能让你以最低的成本快速过渡成为一个全栈工程师(我称这个全栈为伪全栈,我认为的全栈也要精通数 ...

  7. proftpd启动失败提示unable to determine IP address of “xxx.com”

    proftpd启动失败提示unable to determine IP address of “xxx.com”这种proftpd启动失败的原因是无法解析后面主机的IP地址,解决方法是在DNS列表中增 ...

  8. lwip IP address handling 关于 IP 地址的 操作 API接口

    lwip 2.0.3  IP address handling /** * @file * IP address API (common IPv4 and IPv6) */ 1.u32_t ipadd ...

  9. 【代码笔记】Java常识性基础补充(三)——Java的API及Object类、正则表达式、getTime()方法、DateFormat类、Calendar类

    1.0 Java 的API(API: Application(应用) Programming(程序) Interface(接口)) 2.0 Java API就是JDK中提供给我们使用的类,这些类将底层 ...

随机推荐

  1. MTK NTP和NITZ更新时间的问题

    NITZ(Network Identity and Time Zone,网络标识和时区),是一种用于自动配置本地的时间和日期的机制,同时也通过无线网向移动设备提供运营商信息.NITZ是自从PHASE ...

  2. shell脚本并发执行

    简单的并发脚本 #!/bin/bash #并发数 count= ; i < ${count}; i++ )) do { commands1 }& done #等待循环结束再执行wait后 ...

  3. link元素 rel src href属性

    The SRC and HREF attributes are used to include some external entities like an image, a CSS file, a ...

  4. 【转载】C++中替代sprintf的std::ostringstream输出流详解

    一.简单介绍 ostringstream是C++的一个字符集操作模板类,定义在sstream.h头文件中.ostringstream类通常用于执行C风格的串流的输出操作,格式化字符串,避免申请大量的缓 ...

  5. 浅析 <路印协议--Loopring> 及整体分析 Relay 源码

    作者:林冠宏 / 指尖下的幽灵 前序: 路印协议功能非常之多及强大,本文只做入门级别的分析. 理论部分请细看其白皮书,https://github.com/Loopring/whitepaper 实际 ...

  6. VS Code打开使用IDEA搭建的Spring Boot项目运行提示"snakeyaml was not found on the classpath"错误

    今天用VS Code打开之前基于IDEA搭建并开发的Spring Boot项目,启动调试后出现如下错误: 17:43:05.214 [restartedMain] ERROR org.springfr ...

  7. E - Stones 优先队列

    来源1896 Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning an ...

  8. Java 中的 List —— 有序序列

    List 在 java 中是个有序序列: 一.容量 ArrayList 中有一个容量概念,表示基础数组的大小(无参时默认为 10).在需要的时候(比如 add操作)会自动增加其容量.LinkedLis ...

  9. git最佳实践之feature和hotfix分支

    先来复习一波,git的最佳分支管理流程: 再简单复习各个分支: master: 主分支,主要用来版本发布. develop:日常开发分支,该分支正常保存了开发的最新代码. feature:具体的功能开 ...

  10. react表单的一些小例子

    <!DOCTYPE html> <html lang="en"> <head> <meta charset="UTF-8&quo ...