iis和apache共享80端口
Windows server 2003服务器上安装有默认 IIS 6和Apache两个服务器,IIS运行的一个.net程序,apache运行php程序,现在想让它们同时都能通过80端口访问,设置起来还比较简单。
IIS的.net程序假设绑定81端口,主机名:www.a.com
apache的php程序绑定80端口,主机名:www.b.com

然后假设apache服务器已经安装完成,打开httpd.conf配置文件,找到这些地方去掉#开启代理模块:
|
1
2
3
4
|
LoadModule proxy_module modules/mod_proxy.soLoadModule proxy_connect_module modules/mod_proxy_connect.soLoadModule proxy_http_module modules/mod_proxy_http.soLoadModule proxy_ftp_module modules/mod_proxy_ftp.so |
还有确保这里也取消了注释:
|
1
|
Include conf/extra/httpd-vhost.conf |
然后打开apache/conf/extra目录里面的httpd-vhosts.conf文件,在最后添加如下内容:
|
1
2
3
4
5
6
7
8
9
10
|
NameVirtualHost *:80<VIRTUALHOST *:80> ServerName www.b.com DocumentRoot "D:/web/php站点目录"</VIRTUALHOST ><VIRTUALHOST *:80> ServerName www.a.com ProxyPass / http://www.a.com:81/ ProxyPassReverse / http://www.a.com:81/</VIRTUALHOST> |
打开文件 C:\Windows\System32\Drivers\etc\hosts
在最后面添加
127.0.0.1 localhost
127.0.0.1 www.a.com
127.0.0.1 www.b.com
最后把两个服务器都重启一下,同时打开www.a.com和www.b.com都能正常访问了。
注意 :在启动apache的时候,可能会报错,原因是80端口被占用了 ,我的做法是查看所有的IIS网站,发现都没有使用80端口,干脆将整个IIS都暂停了,也还是报错
方法/步骤
依次点击:开始-运行

在运行输入框中,输入cmd,然后点确定

在弹出的dos输入框中输入netstat -nao,并回车

可以看到刷屏,找到80端口,看到该端口已经打开了,并且被编号为3448的进程占用;如果没有打开,请查阅系列文章《80端口的烦恼——防火墙打开80端口》进行打开

现在就来看看是哪个进程占用了80端口,在任务栏中右键点击选择任务管理器,进入如下画面;点击菜单:查看-选择列

确定第一个选项PID是被选中的,然后点确定

在进程标签页中找到编号为3448的进程(编号上面获取的编号一致);可以看到Apache占用;如果该进程不是你所希望的进程,那么可以去相应程序修改相应端口号(如被下载软件占用,则去相应的下载软件中修改端口号,以释放80端口)
最后我查出来是system占用了,千万别手残终止,否则整个电脑会崩溃,最后排查出来是安装了sqlserver20008后 SQL Server Reporting Services 占用80
iis和apache共享80端口的更多相关文章
- 阿里云服务器win2003下iis整合tomcat共享80端口
阿里云服务器win2003下iis整合tomcat共享80端口 很多机器都用tomcat跟IIS部署不同网站.最近买了阿里云的服务器.于是也想玩一下.网上百度了很多方法.但是都有缺陷说的不是很清楚.通 ...
- IIS与Apache共用80端口方法
IIS与Apache共用80端口 http://www.cnblogs.com/haocool/p/3595282.html Windows server 2003服务器上安装有默认 IIS 6和Ap ...
- iis和apache共用80端口,IIS代理转发apache
为什么共用80端口应该不用多说了,服务器上程序运行环境有很多套,都想抢用80端口,所以就有了共用80端口的解决方案. 网上很多的教程一般都是设置APACHE使用默认80端口,代理转发IIS的网站,II ...
- 通过Nginx反向代理,IIS和apache 共用80端口
#user nobody; worker_processes ; #error_log logs/error.log; #error_log logs/error.log notice; #error ...
- IIS与Apache共用80端口
Windows server 2003服务器上安装有默认 IIS 6和Apache两个服务器,IIS运行的一个.net程序,apache运行php程序,现在想让它们同时都能通过80端口访问,设置起来还 ...
- IIS与Apache同时使用80端口
如果我们在一台服务器即使用IIS作为WEB服务器,同时又想使用Apache作为WEB服务器,那么如何来公用80端口呢? 我们可以使用单IP地址来实现,但是在性能上有损失: 将apache设为使用80端 ...
- 两个IP实现IIS和Apache公用80端口的设置方法
1. 打开命令提示符并确保您位于 X:\Inetpub\Adminscripts 文件夹(其中 X 是 IIS 安装驱动器)中.为此,请在命令提示符下键入以下命令行: X: CD \Inetpub ...
- IIS与Apache共用80端口方法[试用成功]
然后假设apache服务器已经安装完成,打开httpd.conf配置文件,找到这些地方去掉#开启代理模块: LoadModule proxy_module modules/mod_proxy.so L ...
- apache和IIS共享80端口问题
使用apache代理功能和IIS共享80端口的解决办法. 第一步:把iis所发布的网站默认端口由80改为8080: 第二步:修改apache的httpd.conf配置文件. 首先,要让apache支 ...
随机推荐
- cv resource
http://blog.sina.com.cn/s/blog_5086c3e20101kdy5.html
- dm8148 开发之---IDR帧
IDR帧属于I帧. 解码器收到IDR帧时,将所有的参考帧队列丢弃(用x264_reference_reset函 数实现——在encoder.c文件中).这点是所有I帧共有的特性,但是收到IDR帧 时, ...
- RAC中数据文件创建到了本地路径(非系统表空间) 使用rman转移
环境: 11.2.0.1 + RHEL5.8 參考文档ID:1678747.1 1.模拟创建 一节点: SQL> create tablespace tdb datafile '/u02/app ...
- C++编译过程与内存空间
为什么须要知道C/C++的内存布局和在哪能够能够找到想要的数据?知道内存布局对调试程序很有帮助,能够知道程序运行时,究竟做了什么,有助于写出干净的代码.本文的主要内容例如以下: 源文件转换为可运 ...
- Tomcat访问日志详细配置(转)
在server.xml里的<host>标签下加上<Valve className="org.apache.catalina.valves.AccessLogValve&qu ...
- 用SQL语句生成唯一标识
以前都是在代码中生成GUID值,然后保存到数据库中去,今天发现用sql也能生成GUID值,觉得很新奇,所以记下来. sellect newid(); //得到的即为GUID值 此sql内置函数返回的 ...
- 如何避免升级 Linux 实例内核后无法启动
如何避免升级 Linux 实例内核后无法启动_系统配置_操作运维 Linux_常见问题_云服务器 ECS-阿里云 https://help.aliyun.com/knowledge_detail/59 ...
- 微信开发模板--easywechat
链接地址:https://easywechat.org/zh-cn/docs/installation.html
- velocity 遍历EventHandler Iterator
EventHandlerUtil 类的 iterateOverEventHandlers方法 for (Iterator i = handlerIterator; i.hasNext();){ Eve ...
- 003-ARP地址解析协议
一.概念 地址解析协议,即ARP(Address Resolution Protocol),是根据IP地址获取物理地址的一个TCP/IP协议.主机发送信息时将包含目标IP地址的ARP请求广播到网络上的 ...
步骤阅读