弄了两天的nginx,从了解开始,可能是我理解能力太差了,惭愧惭愧!但是还好看了一些大神的文章总算有点眉目了,此篇用来当作自己的笔记,大家看不懂,勿喷,但是如果有问题,直接回复,我可以给你解答一下,前提是如果我懂的话,嘻嘻。

  前提条件:服务器要能够访问80端口,服务器上安装tomcat8.0并能成功运行。

  在使用中,发现重启服务器,系统就占用了80端口,以致于nginx启动报错:bind() to 0.0.0.0:80 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions) 。

  可以通过netstat -aon | findstr :80 命令查看80端口被谁占用,如果是system占用,通过以下步骤解决:  

1、打开注册表:regedit
 
2、找到:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP
 
3、找到一个REG_DWORD类型的项Start,将其改为0
 
4、重启系统,System进程不会占用80端口

  一、安装nginx,下载地址:http://nginx.org/ ;

    直接解压就可以了,这里解压到E盘根目录:E:\nginx;

    命令行(win+r    输入cmd)切换到该目录下:cd E:\nginx,输入start nginx.exe 窗口闪一下,一般就启动成功了,去任务管理器查看一下是不是有两个nginx的进程运 行,有就成功了。浏览器输入http://localhost会出来NGINX的欢迎界面;

  二、配置动静态分离和反向代理:

    在nginx安装路径下的conf文件夹下面新建几个文件(新建了复制代码进去就好,主要是我也不知道啥意思):

    tips:文件中的内容复制过去后要把中文注释删掉,不然可能出现编码问题,实在不行就不要复制了,勤快点,手敲嘛。

    Gzip.conf:    

gzip              on;
gzip_min_length 1000;
gzip_types text/plain text/css application/x-javascript;

    Proxy.conf(这个文件好像目前没用到的,可以不用新建):

proxy_redirect          off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
client_max_body_size 10m;
client_body_buffer_size 128k;
proxy_connect_timeout 300;
proxy_send_timeout 300;
proxy_read_timeout 300;
proxy_buffer_size 4k;
proxy_buffers 4 32k;
proxy_busy_buffers_size 64k;
proxy_temp_file_write_size 64k; gzip on;
gzip_min_length 1000;
gzip_types text/plain text/css application/x-javascript; Proxy.conf

    修改nginx.conf文件:

worker_processes  1;

events {
worker_connections 1024;
} http {
charset utf-8;#设置编码
include gzip.conf;#include表示引用文件
include mime.types;
upstream localhost {
server localhost:8080; #配置tomcat地址,即需要nginx转向的地址
} server {
listen 80; #表示监听80端口,配合上面的tomcat地址使用,访问80端口,就会转向localhost:8080
server_name localhost; #设定访问静态文件直接读取不经过tomcat
location ~ .*\.(gif|jpg|jpeg|png|bmp|swf|html)$
{
root E:\static;#静态文件(gig|jpg|jpeg|png|bmp|swf|html)的存放地址
expires 30d;#设置缓存为30天
} location ~ .*\.(js|css)?$
{
root E:\static;#静态文件(js|css)的存放地址
expires 1h;#设置缓存为1小时
}
  
  location = / {#设置首页(直接访问服务器ip或域名就可以访问E:\static目录下的index.html,如果是其他名字需要其它设置,这里没做深究,用到了再来)
    root E:\static;
   }
location / {
proxy_connect_timeout 3; #连接超时时间
proxy_send_timeout 30; #发送超时时间
proxy_read_timeout 30; #访问8080超时时间
proxy_pass http://localhost; #引用前面upstream的名字
    } 
  }
}

  现在可以去E盘的static文件夹下面新建一个html页面测试是不是能够访问了(修改了配置文件需要重新加载配置文件或重启nginx),如:http://ip地址/index.html

  三、常用命令(切换到nginx安装目录来执行):

  start nginx.exe   :启动nginx

  nginx.exe -s stop   :停止nginx

  nginx.exe -s reload  : 配置文件修改,重新加载配置文件

  nginx -t  :查看nginx是否启动成功

  nginx -v  :查看nginx版本

阿里云服务器windows server2008r2+tomcat8.0+nginx1.12的更多相关文章

  1. 如何在IIS上发布网站 在阿里云服务器windows server2012r iis上部署.net网站

    如何在IIS上发布网站   本片博客记录一下怎么用IIS发布一个网站,以我自己电脑上一个已经开发完成的网站为例: 1.打开项目 这是我电脑上的一个项目,现在我记录一下将这个项目发布到iis上的整个过程 ...

  2. 阿里云服务器Windows Server 2008/2012部署Office Web Server 2013

    以前成功将Office Web Server 2013部署在了本地服务器上,此次是将Office Web Server 2013部署在阿里云服务器Windows Server 2008和2012上,中 ...

  3. 阿里云服务器(windows server 2012 r2 64位)安装MYSQL8.0.18数据库 (小白必备)

    今儿中午询问了朋友关于服务器的一些事情后,就开始安装了,从中午大概一点,整到晚上九点,终于装成功了,感觉安装过程能遇到的问题全遇到了,给后面的朋友一些参考意见把. 第一次碰云服务器,措辞不当或不正确之 ...

  4. vue项目部署到阿里云服务器(windows),Nginx代理!

    项目构成: 前端:vue+vant-ui, 数据库:mysql, 后端:node.js 部署方式:nginx代理: 一,首先要拥有自己的服务器,阿里,腾讯都可以,我用的是阿里的: 如果只是做个人项目的 ...

  5. 在阿里云服务器windows server2012r iis上部署.net网站

    先说一堆废话:之前在阿里云上租了一个服务器,也配置了相关的环境,然后准备把自己手上的一个小网站挂上去,就按照我的上篇博客记载的方法把发布好的网站发布到服务器的iis上,结果发布之后死活访问不了,始终显 ...

  6. 阿里云服务器(windows)配置项目域名

    一.数据库是放在阿里云上!二.项目部署到服务器上,tomcat会一直运行(除非你手动停止)三.设置域名及tomcat配置(1)在阿里云控制台上的域名解析设置中添加记录,将域名映射到你的阿里云esc公网 ...

  7. 阿里云服务器CentOS7中Tomcat8.x启动慢问题解决记录

    公司服务器刚换CentOS7,在内部的刀片机上一直跑的很溜,迁移到阿里云上后Tomcat启动竟然要6.7分钟!这还了得. 且日志上无任何错误,在日志中查看到如下信息: Log4j:[2015-10-2 ...

  8. 阿里云服务器windows系统C盘一键清理脚本

    @ECHO OFF @echo @echo @echo 清理几个比较多垃圾文件的地方 DEL /F /S /Q "C:\WINDOWS\PCHealth\ERRORREP\QSIGNOFF\ ...

  9. 阿里云服务器 Windows连接不成功 提示“你的凭证不工作” 解决方法

    HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control ->Terminal Server -> Wds ...

随机推荐

  1. 【BZOJ2730】[HNOI2012]矿场搭建 Tarjan

    [BZOJ2730][HNOI2012]矿场搭建 Description 煤矿工地可以看成是由隧道连接挖煤点组成的无向图.为安全起见,希望在工地发生事故时所有挖煤点的工人都能有一条出路逃到救援出口处. ...

  2. java学习笔记——数据类型及类型转换

    数据类型分为: 1.引用类型(字符型); 2.基本数据类型(数值型); 以下为基本数据类型介绍(括号内的数字表示该类型所占据的字节数) a.整型 byte(8)   short(16)   int(3 ...

  3. 1070 Bash游戏 V4

    1070 Bash游戏 V4 基准时间限制:1 秒 空间限制:131072 KB 分值: 40 难度:4级算法题 有一堆石子共有N个.A B两个人轮流拿,A先拿.每次拿的数量最少1个,最多不超过对手上 ...

  4. 【转】哈希(Hash)与加密(Encrypt)的基本原理、区别及工程应用

    0.摘要 今天看到吉日嘎拉的一篇关于管理软件中信息加密和安全的文章,感觉非常有实际意义.文中作者从实践经验出发,讨论了信息管理软件中如何通过哈希和加密进行数据保护.但是从文章评论中也可以看出很多朋友对 ...

  5. ArcGIS Server Q&A

    持续更新.. 一. AGS Server10发布mobile data access 出现错误 问题描述: "ArcGIS Server: Configuration <name> ...

  6. tomcat单应用多实例部署报错 应用jar不存在

    使用tomcat部署war包,同一环境有tomcat7和tomcat8两个应用,我这边使用tomcat7, 应用部署在其他目录,通过在启动脚本中设置CATALINA_HOME和CATALINA_BAS ...

  7. CentOS 7.4系统优化/安装软件

    源改为国内源 阿里云yum源 https://opsx.alibaba.com/mirror 清华yum源 https://mirrors.tuna.tsinghua.edu.cn/ 网易163yum ...

  8. 浅析 Pycharm 内存、cpu 占用率

    浅析 Pycharm  内存.cpu 占用率 本机配置参数: ------------------------------------------ Windows 10 专业版   X64 ----- ...

  9. java NIO 模型(一)

    1. 阻塞I/O通信模型 1.性能:一连接一线程模型导致服务端的并发接入数和系统吞吐量受到极大限制 2.可靠性:由于IO操作采用同步阻塞模式,当网络拥塞或者逻辑处理缓慢会导致IO线程被挂住,阻塞时间无 ...

  10. 如何删除github中的仓库?

    使用Github管理项目确实有些好处,但删除仓库(repositories)确实不太好找到. 首先进入要删除的仓库,点击右下角的“settings” 然后拉到页面最下面在danger zone 按“d ...