【Docker】基本使用
服务
- 启动docker
systemctl start docker
- 重启docker
systemctl restart docker
- 停止docker
systemctl stop docker.socke
systemctl stop docker
- 如果linux重启需要重启docker服务
systemctl daemon-reload
systemctl restart docker.service
- 设置中国镜像
# vi /etc/docker/daemon.json
{
"registry-mirrors": [
"http://hub-mirror.c.163.com",
"https://docker.mirrors.ustc.edu.cn",
"https://registry.docker-cn.com",
"http://520emlt4.mirror.aliyuncs.com"
]
}
# systemctl daemon-reload
# systemctl restart docker
镜像
- 查看镜像
docker images
- 删除镜像
docker rmi IMAGE ID
*ps: 删除镜像(需要先删除容器)
docker ps -a # 查看容器
docker stop <#id> # 停止一个或多个容器
docker rm <#id> # 删除一个或多个容器
docker image ls -a # 查看镜像
docker rmi <#id> # 删除一个或多个镜像
- 拉取镜像
docker pull jenkins/jenkins
- 运行镜像
docker run -d -uroot -p 8888:8080 -p 50000:50000 --name jenkins -v /home/jenkins_home:/var/jenkins_home -v /etc/localtime:/etc/localtime jenkins/jenkins
| 命令 | 描述 |
|---|---|
| -d | 后台运行容器,并返回容器ID |
| -uroot | 使用 root 身份进入容器,推荐加上,避免容器内执行某些命令时报权限错误 |
| -p 9095:8080 | 将容器内8080端口映射至宿主机9095端口,这个是访问jenkins的端口 |
| -p 50000:50000 | 将容器内50000端口映射至宿主机50000端口 |
| --name jenkins | 设置容器名称为jenkins |
| -v /home/jenkins_home:/var/jenkins_home | :/var/jenkins_home目录为容器jenkins工作目录,我们将硬盘上的一个目录挂载到这个位置,方便后续更新镜像后继续使用原来的工作目录 |
| -v /etc/localtime:/etc/localtime | 让容器使用和服务器同样的时间设置 |
| jenkins/jenkins | 镜像的名称,这里也可以写镜像ID |
- 查看日志
docker logs jenkins
容器
- 查看容器
- 此时的状态有 Up About / Exited
docker ps -a
- 删除容器
- 将 Exited 状态的容器删除
docker rm 容器ID
- 启动/重启/停止容器
docker start 容器ID
docker restart 容器ID
docker stop 容器ID
- 进入/退出容器
docker exec -it 容器ID bash
exit
docker restart 容器ID
查看docker中的xxx容器版本
- 拉取镜像
docker pull redis

- 运行镜像
docker run -p 6379:6379 -v $PWD/data:/data -d redis:latest redis-server --appendonly yes --requirepass 123456
-p 6379:6379 : 将容器的6379端口映射到主机的6379端口
-v $PWD/data:/data : 将主机中当前目录下的data挂载到容器的/data
redis-server --appendonly yes : 在容器执行redis-server启动命令,并打开redis持久化配置
- 以查看redis版本为例
docker exec -it edfb37d82fde redis-server -v


docker-compose
这里以启动一个jenkins为例
- 配置
mkdir -p /usr/local/jenkins
cd /usr/local/jenkins
vim docker-compose.yml
# docker run -p 8080:8080 -p 50000:50000 -v jenkins_home:/var/jenkins_home jenkins/jenkins:lts-jdk11
jenkins
restart: always
image: jenkins/jenkins:2.204.5
ports:
- "8080:8080"
- "50000:50000"
volumes:
- ./data:/var/jenkins_hom
- 启动
cd /usr/local/jenkin
mkdir -p data # 注意如果重装jenkins,先删除这个文件夹并重新生成
chmod -R 777 data # yml中的 volumes对应的映射目录 ./dat
systemctl restart docker # 如果报错每次修改请重启docker
docker-compose up -d # 启动jenkins
docker-compose ps # state的状态为up即启动成功
docker-compose logs -f # 实时查看启动情况,注意记录初始密码
常用程序看装
mysql
官网
安装
- 安装钱查看系统是否安装lnmp,停止其中的mysql
lnmp status
lnmp mysql stop

- 拉取mysqlDdocker镜像

- 运行容器
docker run -itd --name mysql5739 -p 3306:3306 -e MYSQL_ROOT_PASSWORD=root mysql daff57b7d2d1/daff57b7d2d1
【Docker】基本使用的更多相关文章
- docker——容器安装tomcat
写在前面: 继续docker的学习,学习了docker的基本常用命令之后,我在docker上安装jdk,tomcat两个基本的java web工具,这里对操作流程记录一下. 软件准备: 1.jdk-7 ...
- Docker笔记一:基于Docker容器构建并运行 nginx + php + mysql ( mariadb ) 服务环境
首先为什么要自己编写Dockerfile来构建 nginx.php.mariadb这三个镜像呢?一是希望更深入了解Dockerfile的使用,也就能初步了解docker镜像是如何被构建的:二是希望将来 ...
- Docker 第一篇--初识docker
已经多年不写博客, 看完<晓松奇谈>最后一期猛然觉醒, 决定仔细梳理下自己这几年的知识脉络. 既然决定写, 那么首先就从最近2年热门的开源项目Docker开始.Docker 这两年在国内很 ...
- 在docker中运行ASP.NET Core Web API应用程序(附AWS Windows Server 2016 widt Container实战案例)
环境准备 1.亚马逊EC2 Windows Server 2016 with Container 2.Visual Studio 2015 Enterprise(Profresianal要装Updat ...
- docker for mac 学习记录
docker基本命令 docker run -d -p 80:80 --name webserver nginx 运行容器并起别名 docker ps 展示目前启动的容器 docker ps -a 展 ...
- scrapy爬虫docker部署
spider_docker 接我上篇博客,为爬虫引用创建container,包括的模块:scrapy, mongo, celery, rabbitmq,连接https://github.com/Liu ...
- [原][Docker]特性与原理解析
Docker特性与原理解析 文章假设你已经熟悉了Docker的基本命令和基本知识 首先看看Docker提供了哪些特性: 交互式Shell:Docker可以分配一个虚拟终端并关联到任何容器的标准输入上, ...
- 开发者的利器:Docker 理解与使用
困扰写代码的机器难免会被我们安装上各种各样的开发工具.语言运行环境和引用库等一大堆的东西,长久以来不仅机器乱七八糟,而且有些相同的软件还有可能会安装不同的版本,这样又会导致一个项目正常运行了,却不小心 ...
- 使用python自动生成docker nginx反向代理配置
由于在测试环境上用docker部署了多个应用,而且他们的端口有的相同,有的又不相同,数量也比较多,在使用jenkins发版本的时候,不好配置,于是想要写一个脚本,能在docker 容器创建.停止的时候 ...
- 微服务与Docker介绍
什么是微服务 微服务应用的一个最大的优点是,它们往往比传统的应用程序更有效地利用计算资源.这是因为它们通过扩展组件来处理功能瓶颈问题.这样一来,开发人员只需要为额外的组件部署计算资源,而不需要部署一个 ...
随机推荐
- Java笔记_方法重载
/** * @ClassName OverLoadExercise * @Description TODO * @Author Orange * @Date 2021/4/19 8:29 * @Ver ...
- 源码编译mariadb
1.写一个一键安装 mariadb 数据库脚本. [root@centos8mini ~]#vim install_mariadb #!/bin/bash#安装包PACKAGE="maria ...
- ubuntu新建的用户的终端前不能/没有显示路径
在/etc/passwd中找到相应用户,并将/bin/sh改为/bin/bash.然后重启
- kubeadm安装
目录: 环境准备 所有节点安装docker 部署K8s集群 部署Dashboard 安装Harbor私有仓库 安装 master(2C/4G,cpu核心数要求大于2) 192.168.63.100 d ...
- global 函数
x = 15 # 全局变量Gdef func_a(): print(x)def func_b(): print(x)def func_c(): global x # 在定义函数内声明x为全局变量后,才 ...
- hive元起动报错:Exception in thread "main" java.lang.NoSuchMethodError: com.google.common.base.Preconditions.checkArgument(ZLjava/lang/String;Ljava/lang/Object;)V
错误原因: 1.系统找不到这个类所在的jar包 2.jar包的版本不一样系统不知道使用哪个. hive启动报错的原因是后者 解决办法: 1.com.google.common.base.Precond ...
- shell 每秒调用某个地址的方法
#!/bin/bash step=1 for (( i = 0; i < 60; i=(i+step) )); do curl http://fn.k6akg6f.bar/chat.php sl ...
- oracle 分配权限命令
Oracle分配权限 以管理员身份登录数据库 创建用户:create user [username] identified by [password]; 赋予登录权限:grant create ses ...
- php框架之odp-环境部署安装
一.安装配置 1.安装很简单,创建安装目录,然后在linux上使用wget命令从获取地址下载,然后解压,最后在安装目录下执行bin/odp_install即可. 例如:(只是举例,请安装最新的版本) ...
- Java除法运算精度问题
结论:不要将两个int类型的变量直接相除,会出现精度丢失问题,最好将其中一个变量强制转化成浮点型 现象: 两个int类型相除的结果要取整,如果相除得到0.53,那么结果会变成0,出现精度丢失的问题 D ...

