MYSQL使用二进制日志来恢复数据
mysqlbinlog工具的使用,大家可以看MySQL的帮助手册。里面有详细的用,
在这个例子中,重点是--start-position参数和--stop-position参数的使用。
·--start-position=N
从二进制日志中第个位置等于N参量时的事件开始读。
·--stop-position=N
从二进制日志中第个位置等于和大于N参量时的事件起停止读。
OK,现在开始,要启动二进制日志记录,要先在my.cnf / my.ini文件的mysqld里添加
log-bin=日志名
在这里,偶是的设置是log-bin=liangck
然后再启动mysql服务,因为偶是用windows系统,所以执行net start mysql命令即可。
然后在一测试数据库里,创建一个表,并添加记录。
mysql> create table test(id int auto_increment not null primary key,val int,data varchar(20));
mysql> insert into test(val,data) values(10,'liang');
Query OK, 1 row affected (0.03 sec)
mysql> insert into test(val,data) values(20,'jia');
Query OK, 1 row affected (0.08 sec)
mysql> insert into test(val,data) values(30,'hui');
Query OK, 1 row affected (0.03 sec)
mysql> flush logs; --产生第二个日志文件
Query OK, 0 rows affected (0.09 sec)
mysql> insert into test(val,data) values(40,'aaa');
Query OK, 1 row affected (0.05 sec)
mysql> insert into test(val,data) values(50,'bbb');
Query OK, 1 row affected (0.03 sec)
mysql> insert into test(val,data) values(60,'ccc');
Query OK, 1 row affected (0.03 sec)
mysql> delete from test where id between 4 and 5; --删除记录
Query OK, 2 rows affected (0.05 sec)
mysql> insert into test(val,data) values(70,'ddd');
Query OK, 1 row affected (0.03 sec)
mysql> flush logs; --产生第三个文件文件
Query OK, 0 rows affected (0.11 sec)
mysql> insert into test(val,data) values(80,'dddd');
Query OK, 1 row affected (0.05 sec)
mysql> insert into test(val,data) values(90,'eeee');
Query OK, 1 row affected (0.03 sec)
mysql> drop table test; --删除表
Query OK, 0 row affected (0.05 sec)
――――――――――――――――――――――――――――――――――
OK,现在测试数据已经建好了,要求是什么呢?
就是将test表的数据全部恢复出来。
先用mysqlbinlog工具将日志文件生成txt文件出来分析。
F:/Program Files/MySQL_Data/data/log>mysqlbinlog liangck.000001 > G:/001.txt
F:/Program Files/MySQL_Data/data/log>mysqlbinlog liangck.000002 > G:/002.txt
F:/Program Files/MySQL_Data/data/log>mysqlbinlog liangck.000003 > G:/003.txt
通过这三个命令,可以在G盘下生成个文件,里面分别记录了日志文件的内容,也就是用户操作的步骤。
因为我们需要重做第一个日志文件的所有操作,所以这里只需要将第一个日志文件全恢复就行了。
F:/Program Files/MySQL_Data/data/log>mysqlbinlog liangck.000001 | mysql -uroot –p
Ok,接着,我们需要分析的是第二个日志文件。为什么要分析它呢,因为它中途执行了一个操作是DELETE,因为我们要做的是恢复全部数据,也就是我们不希望去重做这个语句。所以在这里我们要想办法去绕开它。
我们先打开.txt文件来分析一下。
/*
/*!40019 SET @@session.max_insert_delayed_threads=0*/;
/*!50003 SET @OLD_COMPLETION_TYPE=@@COMPLETION_TYPE,COMPLETION_TYPE=0*/;
DELIMITER /*!*/;
# at 4
#090427 15:27:56 server id 1 end_log_pos 106 Start: binlog v 4, server v 5.1.32-community-log created 090427 15:27:56
BINLOG '
fF71SQ8BAAAAZgAAAGoAAAAAAAQANS4xLjMyLWNvbW11bml0eS1sb2cAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAEzgNAAgAEgAEBAQEEgAAUwAEGggAAAAICAgC
'/*!*/;
# at 106
#090427 15:28:37 server id 1 end_log_pos 176 Query thread_id=1 exec_time=0 error_code=0
use mytest/*!*/;
SET TIMESTAMP=1240817317/*!*/;
SET @@session.pseudo_thread_id=1/*!*/;
SET @@session.foreign_key_checks=1, @@session.sql_auto_is_null=1, @@session.unique_checks=1, @@session.autocommit=1/*!*/;
SET @@session.sql_mode=1344274432/*!*/;
SET @@session.auto_increment_increment=1, @@session.auto_increment_offset=1/*!*/;
/*!/C gbk *//*!*/;
SET @@session.character_set_client=28,@@session.collation_connection=28,@@session.collation_server=28/*!*/;
SET @@session.lc_time_names=0/*!*/;
SET @@session.collation_database=DEFAULT/*!*/;
BEGIN
/*!*/;
# at 176
#090427 15:28:37 server id 1 end_log_pos 204 Intvar
SET INSERT_ID=4/*!*/;
# at 204
#090427 15:28:37 server id 1 end_log_pos 312 Query thread_id=1 exec_time=0 error_code=0
SET TIMESTAMP=1240817317/*!*/;
insert into test(val,data) values(40,'aaa')
/*!*/;
# at 312
#090427 15:28:37 server id 1 end_log_pos 339 Xid = 12
COMMIT/*!*/;
# at 339
#090427 15:28:46 server id 1 end_log_pos 409 Query thread_id=1 exec_time=0 error_code=0
SET TIMESTAMP=1240817326/*!*/;
BEGIN
/*!*/;
# at 409
#090427 15:28:46 server id 1 end_log_pos 437 Intvar
SET INSERT_ID=5/*!*/;
# at 437
#090427 15:28:46 server id 1 end_log_pos 545 Query thread_id=1 exec_time=0 error_code=0
SET TIMESTAMP=1240817326/*!*/;
insert into test(val,data) values(50,'bbb')
/*!*/;
# at 545
#090427 15:28:46 server id 1 end_log_pos 572 Xid = 13
COMMIT/*!*/;
# at 572
#090427 15:29:35 server id 1 end_log_pos 642 Query thread_id=1 exec_time=0 error_code=0
SET TIMESTAMP=1240817375/*!*/;
BEGIN
/*!*/;
# at 642
#090427 15:29:35 server id 1 end_log_pos 670 Intvar
SET INSERT_ID=6/*!*/;
# at 670
#090427 15:29:35 server id 1 end_log_pos 778 Query thread_id=1 exec_time=0 error_code=0
SET TIMESTAMP=1240817375/*!*/;
insert into test(val,data) values(60,'ccc')
/*!*/;
# at 778
#090427 15:29:35 server id 1 end_log_pos 805 Xid = 14
COMMIT/*!*/;
# at 805
#090427 15:30:21 server id 1 end_log_pos 875 Query thread_id=1 exec_time=0 error_code=0
SET TIMESTAMP=1240817421/*!*/;
BEGIN
/*!*/;
# at 875
#090427 15:30:21 server id 1 end_log_pos 981 Query thread_id=1 exec_time=0 error_code=0
SET TIMESTAMP=1240817421/*!*/;
delete from test where id between 4 and 5
/*!*/;
# at 981
#090427 15:30:21 server id 1 end_log_pos 1008 Xid = 15
COMMIT/*!*/;
# at 1008
#090427 15:30:34 server id 1 end_log_pos 1078 Query thread_id=1 exec_time=0 error_code=0
SET TIMESTAMP=1240817434/*!*/;
BEGIN
/*!*/;
# at 1078
#090427 15:30:34 server id 1 end_log_pos 1106 Intvar
SET INSERT_ID=7/*!*/;
# at 1106
#090427 15:30:34 server id 1 end_log_pos 1214 Query thread_id=1 exec_time=0 error_code=0
SET TIMESTAMP=1240817434/*!*/;
insert into test(val,data) values(70,'ddd')
/*!*/;
# at 1214
#090427 15:30:34 server id 1 end_log_pos 1241 Xid = 16
COMMIT/*!*/;
# at 1241
#090427 15:30:41 server id 1 end_log_pos 1282 Rotate to liangck.000003 pos: 4
DELIMITER ;
# End of log file
ROLLBACK /* added by mysqlbinlog */;
/*!50003 SET COMPLETION_TYPE=@OLD_COMPLETION_TYPE*/;
―――――――――――――――――――――――――――――――――――――
*/
在这个文件中,我们可以看到DELETE的操作的起始位置是,终止位置是.那么我们只要重做第二个日志文件的开头到的操作,然后再从到末尾的操作,我们就可以把数据给恢复回来,而不会DELETE数据。所以执行两个命令:
F:/Program Files/MySQL_Data/data/log>mysqlbinlog liangck.000002 --stop-pos=875 | mysql -uroot -p
F:/Program Files/MySQL_Data/data/log>mysqlbinlog liangck.000002 --start-pos=1008 | mysql -uroot -p mytest
OK,现在第二个日志文件的数据了。
第三个日志文件也是同理,只要找到DROP TABLE的位置,就可以了。
F:/Program Files/MySQL_Data/data/log>mysqlbinlog liangck.000003 --stop-pos=574 | mysql -uroot –p
现在我们再查一下数据看看:
mysql> select * from test;
+----+------+-------+
| id | val | data |
+----+------+-------+
| 1 | 10 | liang |
| 2 | 20 | jia |
| 3 | 30 | hui |
| 4 | 40 | aaa |
| 5 | 50 | bbb |
| 6 | 60 | ccc |
| 7 | 70 | ddd |
| 8 | 80 | dddd |
| 9 | 90 | eeee |
+----+------+-------+
9 rows in set (0.00 sec)
可以看到,全部数据都回来了。
MYSQL使用二进制日志来恢复数据的更多相关文章
- mysql数据安全之利用二进制日志mysqlbinlog恢复数据
mysql数据安全之利用二进制日志mysqlbinlog恢复数据 简介:如何利用二进制日志来恢复数据 查看二进制日志文件的内容报错: [root@xdclass-public log_bin]# my ...
- mysql通过binlog日志来恢复数据
简介 在生产的过程中有这么一个业务场景:比如我在2016-11-19 09:30:00 通过mysqldump的方式备份了数据库,但是在2016-11-19 10:30:00的时候数据库崩溃了,如果通 ...
- 如何通过Mysql的二进制日志恢复数据库数据
经常有网站管理员因为各种原因和操作,导致网站数据误删,而且又没有做网站备份,结果不知所措,甚至给网站运营和盈利带来负面影响.所以本文我们将和大家一起分享学习下如何通过Mysql的二机制日志(binlo ...
- mysql数据安全之利用二进制日志mysqlbinlog备份数据
mysql数据安全之利用二进制日志mysqlbinlog备份数据 简介:如何利用二进制日志来备份数据 什么是二进制日志: 二进制日志就是记录着mysql数据库中的一些写入性操作,比如一些增删改,但是, ...
- mysql 开启binlog日志,恢复误删的表、数据、mysql库
linux下开启mysql的binlog日志功能 1.配置mysql配置文件my.cnf(内容如下). #配置文件储存的位置log-bin=mysql-bin#5.7以及以上版本需要配置这一行(保证唯 ...
- mysql学习------二进制日志管理
MySQL二进制日志(Binary Log) a.它包含的内容及作用如下: 包含了所有更新了数据或者已经潜在更新了数据(比如没有匹配任何行的一个DELETE) 包含关于每个更新数据库( ...
- mysql使用二进制日志恢复数据
一.恢复到某个二进制文件 1.开启二进制日志 在mysqld的配置节点下添加如下配置 log-bin="E:/Mysql57BinLog/binlog"(windows下的路径,l ...
- mysql根据二进制日志恢复数据/公司事故实战经验
根据二进制日志恢复 目的:恢复数据,根据二进制日志将数据恢复到今天任意时刻 增量恢复,回滚恢复 如果有备份好的数据,将备份好的数据导入新数据库时,会随着产生二进制日志 先准备一台初始化的数据库 mys ...
- MySQL使用二进制日志恢复数据库
一.二进制日志简介 MySQL有不同类型的日志,其中二进制文件记录了所有对数据库的修改,如果数据库因为操作不当或其他原因丢失了数据,可以通过二进制文件恢复. 在my.ini文件中设置了log-bin, ...
随机推荐
- PHP微信开发代码
1,SAE上申请服务器 2,绑定测试账号 3,Token验证 <?php /* http://www.cnblogs.com/xrhou12326/ CopyRight 2014 All Rig ...
- shell自定义函数
Linux中提供了很多内置的函数,但有时我们需要根据自己的需求来创建自定义函数.下面介绍一下关于shell编程中的自定义函数. 1.函数定义 function hello(){ echo &qu ...
- DataSet数据导出为Excel文档(每个DataTable为一个Sheet)
Web项目中,很多时候须要实现将查询的数据集导出为Excel文档的功能,很多时候不希望在工程中添加对Office组件相关的DLL的引用,甚至有时候受到Office不同版本的影响,导致在不同的服务器上部 ...
- go语言实现线程池
话说真的好久没有写博客了,最近赶新项目,工作太忙了.这一周任务比较少,又可以随便敲敲了. 逛论坛的时候突发奇想,想用go语言实现一个线程池,主要功能是:添加total个任务到线程池中,线程池开启num ...
- Technical diagrams for SharePoint 2013
sharepoint2013技术图表 http://technet.microsoft.com/zh-cn/library/cc263199.aspx SharePoint 2013 的可下载内容 h ...
- My97DatePicker{js日历插件}
VS自带了一个日历控件:Calendar,但是它有一个缺陷:即在选择,隐藏,显示的时候都会引起回传 Calendar控件的一些用法: 取值:Calendar1.SelectedDate.ToSh ...
- BeanFactory和FactoryBean
BeanFactory和FactoryBean 1.BeanFactory BeanFactory定义了 IOC 容器的最基本形式,并提供了 IOC 容器应遵守的的最基本的接口,也就是Spring I ...
- sqlmap文件在tomcat7中运行报错原因及<![CDATA[ ]]>
sqlmap在eclipse中运行,好好的.放到tomcat7中抛出如下异常: Caused by: java.lang.RuntimeException: Error occurred. Cause ...
- 盘点 OSX 上最佳的 DevOps 工具
[编者按]对于运维人员来说,他们往往需要各种各样的工具来应对工作需求,近日 Dustin Collins 通过「The Best DevOps Tools on OSX」一文对 OSX 平台上的工具进 ...
- jquery.cookie.js使用介绍
Cookies概述: Cookies是一种能够让网站服务器把少量数据储存到客户端的硬盘或内存,或是从客户端的硬盘读取数据的一种技术.Cookies是当你浏览某网站时,由Web服务器置于你硬盘上的一个非 ...