redis master配置了密码进行主从同步
1.如果master不设置密码,那么直接在slave服务器配置slaveof即可 配置如下
#slaveof ip 端口
slaveof 221.224.85.186
配置好我们看下redis的日志 看是否同步成功
:S Jan ::53.667 * Connecting to MASTER 221.224.85.186:
:S Jan ::53.667 * MASTER <-> SLAVE sync started
:S Jan ::53.700 * Non blocking connect for SYNC fired the event.
:S Jan ::53.734 * Master replied to PING, replication can continue...
:S Jan ::53.832 * Partial resynchronization not possible (no cached master)
:S Jan ::53.867 * Full resync from master: 4d6221e370675f397c396c9222b1b60bfcea1efb:
:S Jan ::53.985 * MASTER <-> SLAVE sync: receiving bytes from master
:S Jan ::53.985 * MASTER <-> SLAVE sync: Flushing old data
:S Jan ::53.985 * MASTER <-> SLAVE sync: Loading DB in memory
:S Jan ::53.985 * MASTER <-> SLAVE sync: Finished with success
5014:S 25 Jan 10:53:53.667 * Connecting to MASTER 221.224.85.186:6379
这句是从上面slave服务器日志里面获取的,我们可以看到连接的master的服务器的ip是221.224.85.186 MASTER <-> SLAVE sync: Finished with success
看到输出的语句是success表示同步成功. 2.master设置密码的情况下同步数据,其实很简单,我们只要让slave能连上master就可以了,我们在slave的配置文件中加一句话即可。
masterauth
OK。
不然可能会出现一下错误
:S Jan ::20.450 # MASTER aborted replication with an error: NOAUTH Authentication required.
:S Jan ::21.291 * Connecting to MASTER 120.27.137.142:
:S Jan ::21.292 * MASTER <-> SLAVE sync started
:S Jan ::21.317 * Non blocking connect for SYNC fired the event.
:S Jan ::21.342 * Master replied to PING, replication can continue...
:S Jan ::21.368 * (Non critical) Master does not understand REPLCONF listening-port: -NOAUTH Authentication required.
:S Jan ::21.393 * (Non critical) Master does not understand REPLCONF capa: -NOAUTH Authentication required.
:S Jan ::21.393 * Partial resynchronization not possible (no cached master)
:S Jan ::21.419 # Unexpected reply to PSYNC from master: -NOAUTH Authentication required.
:S Jan ::21.419 * Retrying with SYNC...
:S Jan ::21.444 # MASTER aborted replication with an error: NOAUTH Authentication required.
redis master配置了密码进行主从同步的更多相关文章
- redis配置文件详解及实现主从同步切换
原理:redis复制是怎么进行工作 如果设置了一个slave,不管是在第一次链接还是重新链接master的时候,slave会发送一个同步命令 然后master开始后台保存,收集所有对修改数据的命令.当 ...
- CentOS7安装配置MariaDB(mysql)数据主从同步
CentOS7安装MariaDB并配置主从同步 环境声明: 防火墙firewalld及SElinux均为关闭状态 主库节点:192.168.0.63 从库节点:192.168.0.64 配置主库节点: ...
- Linux centosVMware MySQL主从介绍、准备工作、配置主、配置从、测试主从同步
一.MySQL主从介绍 MySQL主从又叫做Replication.AB复制.简单讲就是A和B两台机器做主从后,在A上写数据,另外一台B也会跟着写数据,两者数据实时同步的 MySQL主从是基于binl ...
- redis的主从复制(读写分离)/哨兵(主从切换)配置
准备两个redis服务,两台机器,依次命名文件夹子master,slave1 10.10.10.7 10.10.10.8 1.master修改配置文件 [root@db2 conf]# cat 637 ...
- 这次一定要教会你搭建Redis集群和MySQL主从同步(非Docker)
前言 一直都想自己动手搭建一个Redis集群和MySQL的主从同步,当然不是依靠Docker的一键部署(虽然现在企业开发用的最多的是这种方式),所以本文就算是一个教程类文章吧,但在动手搭建之前,会先聊 ...
- redis 安装 主从同步 哨兵模式
一.redis 的安装1.先将安装包放到linux的一个文件夹下面 2.解压压缩包如图所示 3.解压后进入解压文件 4.安装: make 出现it.s a good idea to run 'make ...
- 烂泥:mysql5.5主从同步复制配置
本文由秀依林枫提供友情赞助,首发于烂泥行天下. 在上篇文章<烂泥:学习mysql数据库主从同步复制原理>中,我们介绍了有关mysql主从复制的基本原理.在这篇文章中,我们来实际测试下mys ...
- mysql5.5主从同步复制配置
在上篇文章<烂泥:学习mysql数据库主从同步复制原理>中,我们介绍了有关mysql主从复制的基本原理.在这篇文章中,我们来实际测试下mysql5.5的主从同步复制功能. 注意mysql5 ...
- redis配置认证密码
redis配置密码1.通过配置文件进行配置yum方式安装的redis配置文件通常在/etc/redis.conf中,打开配置文件找到 #requirepass foobared 去掉行前的注释,并修改 ...
随机推荐
- [水煮 ASP.NET Web API2 方法论](3-4)设置路由可选项
问题 怎么样创建一个路由,不管客户端传不传这个参数,都可以被成功匹配. 解决方案 ASP.NET WEB API 的集中式路由和属性路由都支持路由声明可选参数. 在用集中式路由中可以通过 RouteP ...
- ASP.NET MVC5 网站开发实践
http://www.cnblogs.com/mzwhj/p/3538108.html
- 2016ASP.NET使用QQ邮箱发送信息最全+无错误
public static bool SendEmail(string mailTo, string mailSubject, string mailContent) { // 设置发送方的邮件信息, ...
- 关于C#读取MySql数据时,返回DataTable中某字段数据是System.Array[]形式
我在使用C#(VS2008)读取MySql数据库(5.1版本)时,返回的DataTable数据中arrivalDate字段数据显示为System.Array[]形式(程序中没有对返回的数据进行任何加工 ...
- 才知道百度也提供了智能DNS服务 - 加速乐
http://jiasule.baidu.com/ 智能DNS 依托百度多年积累的高精度DNS识别库,平均只需5秒全球DNS服务器全部生效,百度蜘蛛1秒生效.抗攻击.无限解析记录,免费支持电信.联通. ...
- AC自动机---病毒侵袭
HDU 2896 题目网址: http://acm.hust.edu.cn/vjudge/contest/view.action?cid=110773#problem/B Description 当太 ...
- mysql zip install
1.Question Description: 1.1 version: mysql-5.7.11-64 1.2 form: zip file 1.3 >mysqld --install (su ...
- sqlite3之基本操作(一)
简单的介绍 SQLite数据库是一款非常小巧的嵌入式开源数据库软件,也就是说没有独立的维护进程,所有的维护都来自于程序本身.它是遵守ACID的关联式数据库管理系统,它的设计目标是嵌入式的,而且目前已经 ...
- memcache与memcached扩展的区别
一.服务端 之前理解错误了.服务端只有一个memcache,一般把服务端称作memcached(带d),是因为守护进程的名称就是叫做memcached(一个这样的执行程序文件). 编写的语言:c语言 ...
- Android性能优化之一:ViewStub
ViewStub是Android布局优化中一个很不错的标签/控件,直接继承自View.虽然Android开发人员基本上都听说过,但是真正用的可能不多. ViewStub可以理解成一个非常轻量级的Vie ...