linux 下 tomcat 运行报错 Broken pipe

有可能是linux的线程机制会产生JVM出错的问题,特别是在连接高峰期间经常出现这样的问题,tomcat在linux下也出现类似情况。
  解决办法是在环境变量中设置: _JAVA_SR_SIGNUM = 12 基本就可以解决。

在WIN环境变量中设置: _JAVA_SR_SIGNUM=12, 若Linux下用 export _JAVA_SR_SIGNUM=12, 基本就可以解决. 
  sun的解释:
  --posted by: cooper 
  Below is a clipping from Sun on working around JVM crashes under high 
  thread counts in the JVM 1.3 for Linux 
  On Linux, use a larger signal number for hotspot thread 
  suspension/resumption handler. The signal number being used is 
  specified by environment variable _JAVA_SR_SIGNUM. Setting it to a 
  number larger than SIGSEGV (11) will solve the PRoblem. A good number 
  to use is 12, which is SIGUSR2. Using signal 16 to work around the 
  problem might have potential problems. So on tcsh, "setenv 
  _JAVA_SR_SIGNUM 12" can solve the problem.

---------------------

本文来自 ruan_learning 的CSDN 博客 ,全文地址请点击:https://blog.csdn.net/ruan_learning/article/details/50502366?utm_source=copy

这个异常是由于以下几个原因造成。

1、客户端再发起请求后没有等服务器端相应完,点击了stop按钮,导致服务器端接收到取消请求。  通常情况下是不会有这么无聊的用户,出现这种情况可能是由于用户提交了请求,服务器端相应缓慢,比如业务逻辑有问题等原因,导致页面过了很久也没有刷新出来,用户就有可能取消或重新发起请求。

2、Tomcat服务器在接受用户请求的时候,有其自身的处理能力,线程、服务器等各个资源限制,超出Tomcat承载范围的请求,就会被tomcat停掉,也可能产生该错误。

3、linux的线程机制会产生JVM出错的问题,特别是在连接高峰期间经常出现这样的问题,tomcat在linux下也出现类似情况。 
Java代码

  1. 1.sun的解释:
  2. 2.--posted by: cooper
  3. 3.Below is a clipping from Sun on working around JVM crashes under high
  4. 4.thread counts in the JVM 1.3 for Linux
  5. 5.
  6. 6.On Linux, use a larger signal number for hotspot thread
  7. 7.suspension/resumption handler. The signal number being used is
  8. 8.specified by environment variable _JAVA_SR_SIGNUM. Setting it to a
  9. 9.number larger than SIGSEGV (11) will solve the problem. A good number
  10. 10.to use is 12, which is SIGUSR2. Using signal 16 to work around the
  11. 11.problem might have potential problems. So on tcsh, "setenv
  12. 12._JAVA_SR_SIGNUM 12" can solve the problem.
  13. sun的解释:
  14. --posted by: cooper
  15. Below is a clipping from Sun on working around JVM crashes under high
  16. thread counts in the JVM 1.3 for Linux
  17. On Linux, use a larger signal number for hotspot thread
  18. suspension/resumption handler. The signal number being used is
  19. specified by environment variable _JAVA_SR_SIGNUM. Setting it to a
  20. number larger than SIGSEGV (11) will solve the problem. A good number
  21. to use is 12, which is SIGUSR2. Using signal 16 to work around the
  22. problem might have potential problems. So on tcsh, "setenv
  23. _JAVA_SR_SIGNUM 12" can solve the problem.

复制代码

“_JAVA_SR_SIGNUM=12”等号两边必须没有空格,等号是半角

资料:
Broken pipe产生的原因通常是当管道读端没有在读,而管道的写端继续有线程在写,就会造成管道中断。(由于管道是单向通信的) SIGSEGV(Segment fault)意味着指针所对应的地址是无效地址,没有物理内存对应该地址。 以下是UNIX的信号解释: 11 / SIGSEGV: Unerlaubter Zugriff auf Hauptspeicher (Adressfehler). 12 / SIGUSER2: User-defined Signal 2 (POSIX). 把_JAVA_SR_SIGNUM改成12只是将信号至成user-defined,让它不报出来而已,不能解决问题。 建议采取的方式: 
1. 资源没有完全释放,用完后要至NULL 值(JAVA的GC没那么完善) 
2. 数据库连接顺序关闭!(RS,PS,CONN) 
3. 优化JAVA虚拟机 加入相应的内存参数! 
4. 不要在数据库中获取大段文本(即一个栏位的值不要太大) 
5. JAVA 不推荐 用String 获取大量信息。(容易造成内存泄露,建议用StringBuffer) 
6. 页面重复提交 
7. 尽量将METHOD移到JAVA中,在JSP中所有的方法都看做全局变量,编译执行本身就有很多问题。 
8. 如果是查询功能,尽可能的使用非XA(事务)。 
9. 尽量用较新较稳定版本的JDK,低版本的JVM本身也有很多BUG,比如1。5的垃圾回收比起1。2,1。3一定是非常明显的进步。 
10. LINUX系统本身没有这么稳定,有些问题无法避免的~~:)

 
分类: 软件设计

linux 下 tomcat 运行报错 Broken pipe的更多相关文章

  1. 关于windows下编写的shell脚本在linux下无法运行报错问题

    首先,你写的shell脚本必须是正确的, 其次,无法运行的原因:因为windows下的换行是两个字节,而你上传到linux,linux下换行是两个字节,所以编译的酒不正确的,导致无法 运行脚本, 这种 ...

  2. Linux环境Tomcat运行报错java.lang.OutOfMemoryError

    java.lang.OutOfMemoryError thrown from the UncaughtExceptionHandler in thread "http-bio-8080-ex ...

  3. Linux下Oracle11G RAC报错:在安装oracle软件时报file not found一例

    Linux下Oracle11G RAC报错:在安装oracle软件时报file notfound一例 1.现象 之前安装一切都比較顺利,安装oracle软件时,进度到30%时报错:file not f ...

  4. 单点登录(五)-----遇到问题-----cas server 源码部署tomcat运行报错BeanCreationException:Error creating bean with name 's

    我们在上一篇文章已经解决了把下载好的cas server源码部署到tomcat缺少子项目编辑文件或者jar包导致找不到class报错的问题 单点登录(四)-----遇到问题-----cas serve ...

  5. 单点登录(四)-----遇到问题-----cas server 源码部署tomcat运行报错ClassNotFoundException: org.jasig.cas.CasEnvironmentCo

    情况 cas单点登录 cas server 源码部署tomcat运行报错 把cas server的代码下载下来后使用gradle插件或者maven插件以及转化成eclipse·后导入发现部署到tomc ...

  6. tomcat运行报错Failed to start component [StandardEngine[Catalina].StandardHost[localhost].

    tomcat运行报错Failed to start component [StandardEngine[Catalina].StandardHost[localhost].多半情况是找不到jar包 解 ...

  7. linux下安装php报错configure: error: Cannot find MySQL header files under /usr/include/mysql.

    linux下安装php报错configure: error: Cannot find MySQL header files under /usr/include/mysql. 2013-03-04 1 ...

  8. Linux下Electron loadURL报错 ERR_FAILED(-2) Not allowed to load local resource

    Linux下Electron loadURL报错 ERR_FAILED(-2) Not allowed to load local resource 背景 使用electron-vue的时候,窗体创建 ...

  9. Jenkins - Linux下启动Jenkins报错hudson.WebAppMain#contextDestroyed: Shutting down a Jenkins instance that was still starting up

    报错截图 在Linux下直接运行jenkins.war报错,导致启动失败 报错原因 运行端口已被其他进程占用 解决方法 换个启动端口就可以啦!

随机推荐

  1. (1.9)SQL优化——mysql导入导出优化

    (1.9)SQL优化——mysql导入导出优化 1.大批量插入数据 [1.1]MyISAM: (1)如果存在表且有数据,插入前先关闭所有非唯一索引. (2)如果表是空的,默认就是先导入数据再创建索引, ...

  2. 字符集更改步骤,mysql乱码

    关键字:Mysql乱码,mysql字符集修改 #字符集更改步骤~

  3. wget 下载命令

    //下载单个文件 wget http://116.199.2.206:81/2Q2WADC9FB8D469200FF61C643601888142263926D08_unknown_65A3E1A23 ...

  4. spark on yarn任务提交缓慢解决

    1.为什么要让运行时Jar可以从yarn端访问spark2以后,原有lib目录下的大JAR包被分散成多个小JAR包,原来的spark-assembly-*.jar已经不存在 每一次我们运行的时候,如果 ...

  5. 别再说找不到Python练手项目了,这80个拿去过冬

    开头真的很重要!!!一个吻,一部小说,一篇文章......好的开头就像一个漂亮女孩的问候,问完了,你还期待着她接下来会对你说些什么甜蜜的话呢. 真可惜!我不是漂亮女孩,我的这个开头也不好.但开头不好, ...

  6. electron 前端开发桌面应用

    electron是由Github开发,是一个用Html.css.JavaScript来构建桌面应用程序的开源库,可以打包为Mac.Windows.Linux系统下的应用. 快速开始 接下来,让代码来发 ...

  7. TestNG-详解preserve-order的作用与测试case的执行顺序

    在TestNG xml配置文件中,关于<test>的配置里面,有一个属性叫preserve-order,一开始以为这个属性可以用来控制测试case(那些被@Test注解标注的方法)的执行顺 ...

  8. SVM、LR、决策树的对比

    一.LR LR,DT,SVM都有自身的特性,首先来看一下LR,工业界最受青睐的机器学习算法,训练.预测的高效性能以及算法容易实现使其能轻松适应工业界的需求.LR还有个非常方便实用的额外功能就是它并不会 ...

  9. ####### Scripts Summary #######

    Scripts Summary Version: 1.0.1 issueDate: 2017-11-11 modifiedDate: 2017-11-28 0.configuration 1.oper ...

  10. shell基础:输入输出重定向

    输出重定向将命令输出存入到文件,类似日志.便于查看.2和>>间没空格.但这种方法没用 ,命令执行时并不知道对错. /dev/null下的null就是一个垃圾箱,脚本中的一些命令并不需要保存 ...