Jenkins安装和Host key verification failed问题的处理
在Centos7上安装的Jenkins 2.303.1
命令行安装为服务
因为新版本的Jenkins的war是用java -jar启动, 并且无法后台运行, 所以要么通过screen创建一个session来运行war, 要么就直接按官网的步骤安装为服务. 下面是安装为服务的步骤:
yum install wget
sudo wget -O /etc/yum.repos.d/jenkins.repo https://pkg.jenkins.io/redhat-stable/jenkins.repo
sudo rpm --import https://pkg.jenkins.io/redhat-stable/jenkins.io.key
yum upgrade
yum install epel-release java-11-openjdk-devel
yum install jenkins
systemctl status jenkins
systemctl is-enabled jenkins
浏览器访问后, 用提示文件的管理员密码登录, 选择默认的插件安装
这样安装的Jenkins, 会创建一个jenkins用户,
[root@vm_00 ~]# more /etc/passwd
root:x:0:0:root:/root:/bin/bash
bin:x:1:1:bin:/bin:/sbin/nologin
...
jenkins:x:997:994:Jenkins Automation Server:/var/lib/jenkins:/bin/false
可以看到对应的工作目录在 /var/lib/jenkins
在Jenkins中创建的项目目录, 就在 /var/lib/jenkins/jobs
在构建中需要用到的settings.xml, 可以新建 /var/lib/jenkins/settings 目录, 放到这个目录下
用war安装,以screen启动
# 安装git
yum install git
# 添加tomcat用户
useradd tomcat
passwd tomcat
# 安装JDK
cd backup/
tar xvf jdk-11.0.8_linux-x64_bin.tar.gz
tar xvf jdk-8u261-linux-x64.tar.gz
cd /opt/
mkdir jdk
cd jdk/
mv ~/backup/jdk1.8.0_261 .
mv ~/backup/jdk-11.0.8 .
ln -s jdk-11.0.8 latest
vi /etc/profile.d/sh.local
## 增加内容开始
PATH=$PATH:/opt/jdk/latest/bin
## 增加内容结束
# 将jenkins war放入 /home/tomcat/run目录后
vi scripts/start_jenkins.sh
## 内容开始
java -server -Djava.awt.headless=true -jar /home/tomcat/run/jenkins.2.277.2.war --httpPort=9090
## 内容结束
# 因为jenkins的war只能使用前台启动, 搜索到的解决方案都是用 nohup java -jar jenkins.war &, 但是这样会导致日志堆积, 估采用screen
screen -S jenkins
# 在screen session里
./scripts/start_jenkins.sh
问题和解决
启动Jenkins报NPE错误
通过安装fontconfig解决
https://github.com/AdoptOpenJDK/openjdk-docker/issues/75
yum install fontconfig
SSH Agent 出现 Host key verification failed
首先确认
- Jenkins的Git使用的ssh, 不需要预先记录known_hosts, 配置好就可以直接用
- SSH Agent必须要先在命令行下访问一下对方IP, 记录了known_hosts后, 才能正常使用
因为安装为服务的Jenkins使用的是jenkins用户, 而且是/bin/false的用户, 不能像普通用户那样登录然后ssh一下对方IP, 你需要按以下方式处理
# 以root或sudo user身份, 切换到jenkins用户
su -s /bin/bash jenkins
# 前往jenkins的home目录
cd /var/lib/jenkins/
# 查看.ssh下是否已经有known_hosts, 有的话, 是什么内容, 正常情况下, 这时候是没有对应IP记录的
cd .ssh/
more known_hosts
# 访问一下对应IP, 记录公钥
ssh 192.168.123.123
# 再次查看, 应该就有记录了
more known_hosts
在上面的操作之后, 再执行任务, SSH Agent就不会报Host key verification failed错误了.
Jenkins安装和Host key verification failed问题的处理的更多相关文章
- jenkins报错 Host key verification failed.
一.Host key verification failed 问题描述 在本地windows机器上安装了jenkins,在git bash命令行窗口可以使用git pull命令,但是在jenkins ...
- Jenkins构建从github上克隆时,报Host key verification failed.
首先在本地通过CMD执行git clone xxxxx时,可以成功的通过免密(SSH_KEY)克隆下来代码,但是通过Jenkins克隆时,就报如下信息: Cloning into 'GitHub'.. ...
- 【sublime xftp插件】 Host key verification failed ,错误处理
错误背景: 1.CentOS7上面作为运行环境,Coding在本机的windows环境 2.在windows上安装sublime 3,然后保存代码通过xftp保存到centos7虚机上面. 3.Cen ...
- Host key verification failed解决
SSH 登录失败:Host key verification failed 由于公钥不一样了,所以无法登录,提示信息是 KEY 验证失败. 解决方法是: 在 /root/.ssh/known_host ...
- SSH登录失败:Host key verification failed
转载自:https://help.aliyun.com/knowledge_detail/41471.html 注意:本文相关 Linux 配置及说明已在 CentOS 6.5 64 位操作系统中进行 ...
- SSH连接时出现Host key verification failed的原因及解决方法
SSH连接的时候Host key verification failed. [root@cache001 swftools-0.9.0]# ssh 192.168.1.90@@@@@@@@@@@@@@ ...
- 登录ssh时Host key verification failed错误
工作中总是测试不同的路由设备, 路由器的ip都是 192.168.111.1 ,ssh登录的时候总是出现这个错误. macos上,错误如下 spawn ssh -p 22 root@192.168.1 ...
- 大数据集群ssh登录其他机器失败 RSA host key for zb03 has changed and you have requested strict checking. Host key verification failed.
[hadoop@zb02 .ssh]$ scp authorized_keys hadoop@zb03:/home/hadoop/.ssh @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ ...
- ssh 报错Host key verification failed 或Ubuntu connect to serve 失败
ssh 报错Host key verification failed 或Ubuntu connect to serve 失败 通常是因为没有装ssh sudo apt-get install o ...
- ssh远程登录出现Host key verification failed.解决办法
今天通过ssh和域名连接主机: IcarusdeMacBook-Pro:~ icarus$ ssh root@icarusyu.me 出现了如下错误: @@@@@@@@@@@@@@@@@@@@@@@@ ...
随机推荐
- SV Interface and Program
内容 验证平台与待测设计的连接 VTB driver和dut之间的连线通过tb中声明wire连线 通过例化dut的方式进行连接 A module的input连接到B module的output SVT ...
- C++模板显示指定类型时使用引用遇到的问题
1.问题 这里我想让模板函数接收int和char类型的参数,并进行相加,显示指定参数类型为int. 第一个调用理论上会自动将char类型强转成int类型,后进行相加: 第二个调用理论上会自动将int类 ...
- 解决在Edge浏览器中使用不了(找不到)new bing的情况
1.问题 我们有时候看不到下图圈出部分的信息,无法找到New Bing的入口(这边是空的) 2.解决方式 1.选择右上角的三条杠,并选择其中的settings 2.将其中的country一项改为外国即 ...
- Linux 中常用的基础命令
by emanjusaka from https://www.emanjusaka.top/2024/01/linux-base-command 彼岸花开可奈何 本文欢迎分享与聚合,全文转载请留下原文 ...
- java - 创建文件
package practice; import java.io.File; import java.io.IOException; public class CreateFile { public ...
- [转帖]没 K8s 用不了 Chaos Mesh?试试 Chaosd
https://cn.pingcap.com/blog/cannot-use-chaosmesh-without-k8s-then-try-chaosd Chaosd 是什么? 相信大家对 Chaos ...
- [转帖]KingbaseES wal(xlog) 日志清理故障恢复案例
https://www.cnblogs.com/kingbase/p/16266365.html 案例说明:在通过sys_archivecleanup工具手工清理wal日志时,在control文件中查 ...
- [转帖]iptables ip_conntrack_max 调整
https://www.diewufeiyang.com/post/583.html 一.概念 ==================== -允许的最大跟踪连接条目:CONNTRACK_MAX(默认值是 ...
- 【转帖】nginx变量使用方法详解-3
https://www.diewufeiyang.com/post/577.html 也有一些内建变量是支持改写的,其中一个例子是 $args. 这个变量在读取时返回当前请求的 URL 参数串(即请求 ...
- 【转帖】Linux查看二进制文件:一招制敌(linux二进制查看文件)
https://www.dbs724.com/146055.html 一招制敌:学会Linux查看二进制文件 在Linux操作系统中,二进制文件是一种常见的文件类型.如果你想深入了解一个二进制文件,可 ...