OpenStack安装keyston 错误BError: (pymysql.err.InternalError) (1071, u‘Specified key was too long; max key length is 767 bytes‘) [SQL: u‘\nCREATE TABLE migrate_ver
折腾了两天的错误,BError: (pymysql.err.InternalError) (1071, u‘Specified key was too long; max key length is 767 bytes‘) [SQL: u‘\nCREATE TABLE migrate_ver
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters [-] DBAPIError exception wrapped from (pymysql.err.InternalError) (1071, u'Specified key was too long; max key length is 767 bytes') [SQL: u'\nCREATE TABLE migrate_version (\n\trepository_id VARCHAR(250) NOT NULL, \n\trepository_path TEXT, \n\tversion INTEGER, \n\tPRIMARY KEY (repository_id)\n)\n\n']
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters Traceback (most recent call last):
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters File "/usr/lib/python2.7/dist-packages/sqlalchemy/engine/base.py", line 1139, in _execute_context
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters context)
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters File "/usr/lib/python2.7/dist-packages/sqlalchemy/engine/default.py", line 450, in do_execute
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters cursor.execute(statement, parameters)
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters File "/usr/lib/python2.7/dist-packages/pymysql/cursors.py", line 166, in execute
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters result = self._query(query)
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters File "/usr/lib/python2.7/dist-packages/pymysql/cursors.py", line 322, in _query
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters conn.query(q)
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters File "/usr/lib/python2.7/dist-packages/pymysql/connections.py", line 835, in query
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters self._affected_rows = self._read_query_result(unbuffered=unbuffered)
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters File "/usr/lib/python2.7/dist-packages/pymysql/connections.py", line 1019, in _read_query_result
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters result.read()
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters File "/usr/lib/python2.7/dist-packages/pymysql/connections.py", line 1302, in read
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters first_packet = self.connection._read_packet()
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters File "/usr/lib/python2.7/dist-packages/pymysql/connections.py", line 981, in _read_packet
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters packet.check_error()
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters File "/usr/lib/python2.7/dist-packages/pymysql/connections.py", line 393, in check_error
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters err.raise_mysql_exception(self._data)
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters File "/usr/lib/python2.7/dist-packages/pymysql/err.py", line 107, in raise_mysql_exception
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters raise errorclass(errno, errval)
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters InternalError: (1071, u'Specified key was too long; max key length is 767 bytes')
2018-01-02 10:32:40.924 76081 ERROR oslo_db.sqlalchemy.exc_filters
2018-01-02 10:32:40.927 76081 CRITICAL keystone [-] DBError: (pymysql.err.InternalError) (1071, u'Specified key was too long; max key length is 767 bytes') [SQL: u'\nCREATE TABLE migrate_version (\n\trepository_id VARCHAR(250) NOT NULL, \n\trepository_path TEXT, \n\tversion INTEGER, \n\tPRIMARY KEY (repository_id)\n)\n\n']
2018-01-02 10:32:40.927 76081 ERROR keystone Traceback (most recent call last):
2018-01-02 10:32:40.927 76081 ERROR keystone File "/usr/bin/keystone-manage", line 10, in <module>
2018-01-02 10:32:40.927 76081 ERROR keystone sys.exit(main())
2018-01-02 10:32:40.927 76081 ERROR keystone File "/usr/lib/python2.7/dist-packages/keystone/cmd/manage.py", line 45, in main
2018-01-02 10:32:40.927 76081 ERROR keystone cli.main(argv=sys.argv, config_files=config_files)
2018-01-02 10:32:40.927 76081 ERROR keystone File "/usr/lib/python2.7/dist-packages/keystone/cmd/cli.py", line 1312, in main
2018-01-02 10:32:40.927 76081 ERROR keystone CONF.command.cmd_class.main()
2018-01-02 10:32:40.927 76081 ERROR keystone File "/usr/lib/python2.7/dist-packages/keystone/cmd/cli.py", line 467, in main
2018-01-02 10:32:40.927 76081 ERROR keystone CONF.command.version)
2018-01-02 10:32:40.927 76081 ERROR keystone File "/usr/lib/python2.7/dist-packages/keystone/common/sql/upgrades.py", line 251, in offline_sync_database_to_version
2018-01-02 10:32:40.927 76081 ERROR keystone expand_schema()
2018-01-02 10:32:40.927 76081 ERROR keystone File "/usr/lib/python2.7/dist-packages/keystone/common/sql/upgrades.py", line 271, in expand_schema
2018-01-02 10:32:40.927 76081 ERROR keystone _sync_common_repo(version=None)
2018-01-02 10:32:40.927 76081 ERROR keystone File "/usr/lib/python2.7/dist-packages/keystone/common/sql/upgrades.py", line 171, in _sync_common_repo
2018-01-02 10:32:40.927 76081 ERROR keystone init_version=init_version, sanity_check=False)
2018-01-02 10:32:40.927 76081 ERROR keystone File "/usr/lib/python2.7/dist-packages/oslo_db/sqlalchemy/migration.py", line 73, in db_sync
2018-01-02 10:32:40.927 76081 ERROR keystone current_version = db_version(engine, abs_path, init_version)
2018-01-02 10:32:40.927 76081 ERROR keystone File "/usr/lib/python2.7/dist-packages/oslo_db/sqlalchemy/migration.py", line 131, in db_version
2018-01-02 10:32:40.927 76081 ERROR keystone db_version_control(engine, abs_path, version=init_version)
在执行su -s /bin/sh -c "keystone-manage db_sync" keystone 时
这是因为字符集不一致一样引起的
在mysql的配置文件下,修改所有的文件中的字符集格式为utf8,utf8mbz修改为utf8
root@hett-virtual-machine:/etc/mysql/mariadb.conf.d 在此配置文件下面修改
然后进入mysql 把先前创建的keystone数据库删除,重新建,就完成了啊


折腾了好几天啊 终于解决了啊
OpenStack安装keyston 错误BError: (pymysql.err.InternalError) (1071, u‘Specified key was too long; max key length is 767 bytes‘) [SQL: u‘\nCREATE TABLE migrate_ver的更多相关文章
- sqlalchemy.exc.InternalError: (pymysql.err.InternalError) (1091, "Can't DROP 'users_ibfk_1'; check that column/key exists") [SQL: ALTER TABLE users DROP FOREIGN KEY users_ibfk_1]
flask 迁移数据库报错 报错: sqlalchemy.exc.InternalError: (pymysql.err.InternalError) (1091, "Can't DROP ...
- laravel错误1071 Specified key was too long; max key length is 1000 bytes
Laravel 5.5 环境,php artisan migrate 之后,出现错误如题. 检查了一下,代码是这样的: $table->increments('id'); $table-> ...
- pymysql.err.InternalError: (1205, 'Lock wait timeout exceeded; try restarting transaction')错误处理
问题描述: 在使用pymysql库时,利用游标执行插入操作,产生错误,会出现pymysql.err.InternalError: (1205, 'Lock wait timeout exceeded; ...
- pymysql.err.InternalError: (1054, "Unknown column 'None' in 'field list'")
错误提示: Traceback (most recent call last): File "D:/projectwc/test/dd.py", line 43, in <m ...
- 解决pymysql.err.InternalError: (1366, "Incorrect string value: '\\xF0\\x9F\\x8C\\xB8' for column 'headline' at row 1")
解决pymysql.err.InternalError: (1366, "Incorrect string value: '\\xF0\\x9F\\x8C\\xB8' for column ...
- 报错:pymysql.err.InternalError: (1054, "Unknown column 'AType' in 'field list'")
报错背景: 报错前sql代码展示: List = ['] # sql = "insert into test(id, name) value ("+"'"+ L ...
- sqlalchemy.exc.InternalError: (pymysql.err.InternalError) (1366, "Incorrect string value: '\\xE6\\xB1\\x89\\xE8\\xAF\\xAD...' for column 'className' at row 1") [SQL: INSERT INTO classmessage (`classId
sqlalchemy.exc.InternalError: (pymysql.err.InternalError) (1366, "Incorrect string value: '\\xE ...
- Mysql失败,异常pymysql.err.InternalError: (1366, "Incorrect string value: '\\xF0\\x9D\\x90\\xBF;......
问题描述: 插入Mysql时失败了,python代码报如下异常: pymysql.err.InternalError: (1366, "Incorrect string value: '\\ ...
- Hive集成Mysql作为元数据时,提示错误:Specified key was too long; max key length is 767 bytes
在进行Hive集成Mysql作为元数据过程中.做全然部安装配置工作后.进入到hive模式,运行show databases.运行正常,接着运行show tables:时却报错. 关键错误信息例如以下: ...
随机推荐
- Aaronson
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)Total Submissio ...
- ECharts使用问题
Echarts官网上给的例子,在最后有一个分号. 使用ajax请求,在eval()转化时出现错误,原因就是因为多了一个分号
- ElasticSearch基础之查询功能
[01]查询类型: [02]基本查询和组合查询是参与打分的 1.创建映射: 注意事项:基于上面映射的创建: "type": "keyword" # 如果某个字段 ...
- mysql慢日志记录
DBA工作:通过日志找到执行慢的sql语句 慢日志: - 执行时间 > 10 - 未命中索引 配置: - 基于内存 show variables like '%query%'; set glob ...
- 设置a 标签打开新窗口新姿势
设置页面中的所有a标签都打开新窗口 1,在写的时候就加上target="_blank" 2,在页头<head></head>里加上 <base tar ...
- HDU2594 【KMP】
题意: 给两个字符串s1,s2,求最长的s1前缀匹配s2后缀的字符串,以及长度 思路: 利用KMP看下最终匹配到了哪个位置:一个是利用常规匹配,另一个是利用next数组的跳转. #include< ...
- 阿里mavne中央仓库
https://www.cnblogs.com/ae6623/p/4416256.html 待整理
- 线程安全 原子性 可见性 顺序性 volatile
- [hdu1686] Oulipo【KMP】
传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1686 保存KMP模版,代码里P是模版串,next[]就是为它建立的.T是文本串,就是一般比较长的.nex ...
- ZJOI2017 day2 T2 线段树 想法题
考完D2发现自己简直zz了...花式扔基本分 首先这道题有个显然的套路:树上一些点到一个定点的距离和=这些点深度和+点数*定点深度和-2*lca深度和 ——上一次见这个套路是LNOI2014,上次做的 ...