问题描述:

CentOS安装完成Tomcat后,访问本地:http://localhost:8080/正确。但局域网内无法访问,而且服务器可ping通

经查原因为防火墙开启:

[root@localhost conf]#  service iptables status
iptables: Firewall is running.

有两种解决方案:一是关闭防火墙;二是开放8080端口

直接关闭防火墙会影响服务器的安全性,比较暴力,开放相应的端口号来说更符合安全性,更温和

第一种方案:关闭iptables ,相对比较简单

service iptables stop

若想永久关闭: chkconfig --level 35 iptables off

 第二种方案:配置防火墙,开放8080端口,相对复杂点,但是值得推荐

  首先查看一下iptables的配置

[root@bogon ~]# vi /etc/sysconfig/iptables
# Firewall configuration written by system-config-firewall
# Manual customization of this file is not recommended.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:RH-Firewall-1-INPUT - [0:0]
-A INPUT -j RH-Firewall-1-INPUT
-A FORWARD -j RH-Firewall-1-INPUT
-A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-host-prohibited
-A FORWARD -j REJECT --reject-with icmp-host-prohibited
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 8080 -j ACCEPT
COMMIT

  其中红色部分为自己添加的,其意义:

:RH-Firewall-1-INPUT - [0:0]

  上面可以理解为定义了一个子链 RH-Firewall-1-INPUT

-A INPUT -j RH-Firewall-1-INPUT
-A FORWARD -j RH-Firewall-1-INPUT

 其实上面这两条规则就是将子链RH-Firewall-1-INPUT分别加到INPUT和FORWORD主链中,把父链INPUT和FORWARD的所有数据包都转发到子链RH-Firewall-1-INPUT,也就意味着,当一个数据包进入主机后,首先会进入INPUT链和FORWARD链,然后再由INPUT和FORWARD链进入RH-Firewall-1-INPUT进行处理

-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 8080 -j ACCEPT

  使用子链RH-Firewall-1-INPUT,配置8080端口,允许8080端口的数据包传输

如上配置并重启iptables就可以在局域网内访问8080端口了

[root@bogon ~]# service iptables restart
iptables: Setting chains to policy ACCEPT: filter [ OK ]
iptables: Flushing firewall rules: [ OK ]
iptables: Unloading modules: [ OK ]
iptables: Applying firewall rules: [ OK ]

---------------------------------------------------------------------------------------------------------------------------------------------

防火墙相关命令:

service  iptables  status        查看防火墙状态
service iptables start 开启防火墙
service iptables stop 关闭防火墙
service iptables restart 重启防火墙

这里简单讨论一下iptables:

iptables是Linux内置的数据包过滤软件(即 防火墙)。它定义了进出Linux数据包的过滤规则。Iptables由多个表格组成,每个表格由若干链组成,每个链由若干规则组成。

其中最常用也是最重要的是管理本机进出数据包的filter(过滤器)表格,filter默认包含以下3个链:

  • INPUT链:定义了进入Linux主机的数据包的过滤规则;
  • OUTPUT链:定义了送出Linux主机的数据包的过滤规则;
  • FORWORD链:这个链与本机没有什么关系,它可以转递数据包到后台的计算机中,与iptables中的另外一个表格nat相关性较高;

上面三个链是filter表格中默认的链,可以称作父链。用户还可以自定义自己的链规则,可以称作子链。当数据包满足一定规则,则由父链跳转到子链进行特定的处理。

上面iptables配置信息中:开头的为防火墙filter过滤器定义的4个链:INPUT,FORWARD,OUTPUT,RH-Firewall-1-INPUT。其中前面三个链是系统默认的链,称为父链;RH-Firewall-1-INPUT是用户自定义的链,称为子链。

局域网访问不到linux下的tomcat的更多相关文章

  1. Linux下,Tomcat启动成功,发现ip:8080访问失败

    Linux下,Tomcat启动成功,发现ip:8080访问失败 Chasel_H 2018.04.23 20:47* 字数 195 阅读 566评论 0喜欢 3 相信很多人都和我一样,在Linux环境 ...

  2. Linux下安装Tomcat服务器和部署Web应用

    一.上传Tomcat服务器

  3. Linux下配置Tomcat服务器

    Linux下配置Tomcat服务器和Windows下其实差不多,可以去官网下载安装包释放或者在线下载,只是当时下载的windows.zip文件,现在下载.tar.gz格式的即可,下面使用命令行的方式安 ...

  4. 转】Linux下安装Tomcat服务器和部署Web应用

    原博文出自于: http://www.cnblogs.com/xdp-gacl/p/4097608.html 感谢! 一.上传Tomcat服务器

  5. Linux下搭建tomcat集群全记录(转)

    本文将讲述如何在Linux下搭建tomcat集群,以及搭建过程中可能的遇到的问题和解决方法.为简单起见,本文演示搭建的集群只有两个tomact节点外加一个apache组成,三者将安装在同一机器上:ap ...

  6. 在linux下用tomcat部署java web项目的过程与注意事项

    在linux下用tomcat部署java web项目的过程与注意事项 一.安装JDK 到http://www.oracle.com/technetwork/java/javase/downloads/ ...

  7. linux下安装tomcat和部署web应用

      孤傲苍狼 只为成功找方法,不为失败找借口! Linux下安装Tomcat服务器和部署Web应用 一.上传Tomcat服务器

  8. Linux下配置tomcat+apr+native应对高并发

    摘要:在慢速网络上Tomcat线程数开到300以上的水平,不配APR,基本上300个线程狠快就会用满,以后的请求就只好等待.但是配上APR之后,Tomcat将以JNI的形式调用Apache HTTP服 ...

  9. linux下配置tomcat集群的负载均衡

    linux下配置tomcat集群的负载均衡 一.首先了解下与集群相关的几个概念集群:集群是一组协同工作的服务实体,用以提供比单一服务实体更具扩展性与可用性的服务平台.在客户端看来,一个集群就象是一个服 ...

随机推荐

  1. VSCode cpptools 插件在Centos 7下不能正确显示符号列表的解决办法

    vscode 的插件cpptools 0.9.3 需要glibc 2.18的版本,但是Centos 7 下没有这个版本的GLIBC,所以导致链接库丢失,后台服务不能正常运行.按以下步骤操作可修复此问题 ...

  2. Orchard Core 文档翻译 (四)CMS ModulesTitle (OrchardCore.Title)

    Title (OrchardCore.Title) 标题模块提供Title Part ,允许用户定义内容项的标题.它还定义了ContentItemMetadata方面的DisplayText属性 Th ...

  3. 建立自己的git账户并保存资料的重要性

    Github是一个代码托管平台和开发者社区,开发者可以在Github上创建自己的开源项目并与其他开发者协作编码.创业公司可以用它来托管软件项目,开源项目可以免费托管,私有项目需付费.[2] GitHu ...

  4. vue-router异步加载组件

    export default { routes: [ { path: '/fund', name: 'FundManagement', component: function(resolve) { r ...

  5. Python 用多线程上传和下载文件

    # -*- coding: utf-8 -*- __author__ = 'louis' from ftplib import FTP import multiprocessing import ti ...

  6. C++函数委托

    环境: win7_x64旗舰版.VS2015企业版 场景: C++标准库提供std::function类来将一个对象的调用操作封装在一个对象内部,然后可以委托调用,但是有一些弊端,例如下面的需求: 我 ...

  7. Softmax vs. Softmax-Loss: Numerical Stability

    http://freemind.pluskid.org/machine-learning/softmax-vs-softmax-loss-numerical-stability/ softmax 在 ...

  8. 学习Apache的mod rewrite、access写法

    Apache的mod_rewrite是提供了强大URL操作的杀手级的模块,可以实现几乎所有你梦想的URL操作类型,其代价是你必须接受其复杂性,因为mod_rewrite的主要障碍就是初学者不容易理解和 ...

  9. Ajax去除缓存

    1.在Ajax发送请求钱加上anyAjaxObj.setRequestHeader("If-Modeified-Since","0").2.在Ajax发送请求钱 ...

  10. svn cleanup failed–previous operation has not finished; run cleanup if it was interrupted

    svn提交遇到恶心的问题,可能是因为上次cleanup中断后,进入死循环了. 错误如下: 解决方法:清空svn的队列 1.下载sqlite3.exe 2.找到你项目的.svn文件,查看是否存在wc.d ...