四、测试

在第一台机器上,关闭网络负载平衡管理器后,用鼠标右键单击“网络负载平衡群集”,从出现的菜单中选择“连接到现存的”,将会弹出“连接”界面。输入第一台计算机的名称或IP地址,点击“连接”按钮,在“群集”下面将列出群集的IP地址,选择此IP地址,并点击“完成”按钮,连接群集即可完成。

ipconfig /all 运行结果:

第一台机器:

C:/>ipconfig /all
    Windows IP Configuration

Host Name . . . . . . . . . . . . : win2003-1
       Primary Dns
Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . :
Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy
Enabled. . . . . . . . : No

Ethernet adapter 本地连接:

Connection-specific DNS Suffix  . :
       Description . . . . . .
. . . . . : VMware Accelerated AMD PCNet Adapter
       Physical Address. . .
. . . . . . : 00-0C-29-04-B1-21
       DHCP Enabled. . . . . . . . . . . :
No
       IP Address. . . . . . . . . . . . : 192.168.0.200
       Subnet
Mask . . . . . . . . . . . : 255.255.255.0
       IP Address. . . . . . . . .
. . . : 10.0.0.201
       Subnet Mask . . . . . . . . . . . :
255.255.255.0
       Default Gateway . . . . . . . . . :

第二台机器:
    C:/>ipconfig/all
    Windows IP Configuration

Host Name . . . . . . . . . . . . : win2003-2
       Primary Dns
Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . :
Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy
Enabled. . . . . . . . : No

Ethernet adapter 本地连接 :

Connection-specific DNS Suffix  . :
       Description . . . . . .
. . . . . : VMware Accelerated AMD PCNet Adapter
       Physical Address. . .
. . . . . . : 00-0C-29-CE-C8-65
       DHCP Enabled. . . . . . . . . . . :
No
       IP Address. . . . . . . . . . . . : 192.168.0.200
       Subnet
Mask . . . . . . . . . . . : 255.255.255.0
       IP Address. . . . . . . . .
. . . : 10.0.0.202
       Subnet Mask . . . . . . . . . . . :
255.255.255.0
       Default Gateway . . . . . . . . . :

可以看到,每个本地连接的网卡都在原来的内部地址之外,又加入了IP地址192.168.0.200。虽然都在一个局域网中,它们还没冲突,很奇怪吧?因为是“虚拟IP”嘛。

测试一下群集的效果:

1,分别在 win2003-1、win2003-2、win2003-3 上配置
IIS,建立虚拟主机,IP为192.168.0.200,主机头为cluster.mydomain.com。
    再建立脚本
index.htm,分别为:
    win2003-1 上:
    <html>
      This windows
2003 - 1
    </html>

win2003-2 上:
    <html>
      This windows 2003 - 2
   
</html>

win2003-3 上:
    <html>
      This windows 2003 - 3
   
</html>

2,找一台可以访问 192.168.0.200 的机器,ping 一下 192.168.0.200,应该是通的。再运行 arp -a
命令,可以看到:
    192.168.0.200  03-bf-c0-a8-00-c8   dynamic
    说明
03-bf-c0-a8-00-c8 的 mac 地址也是虚拟的。

然后修改 hosts 文件,加一条记录:
    192.168.0.200   cluster.mydomain.com

再重新打开浏览器,访问网站 http://cluster.mydomain.com,应该看到其中一台机器上的网页,显示
This windows 2003 - ……
    一般看到的是 win2003-1 上的网页显示“This windows 2003 -
1”。

这时,人为的关闭win2003-1机器,或禁止其网卡,使其不提供 Web 服务。再打开访问网站 http://cluster.mydomain.com,应该看到另两台机器中,其中一台机器上的网页。说明网络负载平衡已经发挥作用,有效的进行了无缝的故障转移。注意在实际的生产环境中,各机器上的网站其内容是完全相同的(同步),尽管发生了转移,其外在表现则是完全相同的,这正是网络负载平衡要达到的目的。网络负载平衡的另一个作用,是进行负载的动态均衡分配,可以用一些压力工具来验证。

五、遇到的问题
    在加第二台服务器的时候,一直加不上去,报如下错误:“没有接口可用于安装新的群集”。
   
原因:作试验时,其它机器是从第一台机器的 Windows 2003 克隆建立的。克隆的虚拟机,其MAC地址等参数可能是一样的,导致了该错误的出现。
   
解决方法:在设备管理器中,卸载(删除)原先的网卡。重新安装一下,就可以了。

六、改进设想
    1,所有机器所在的局域网最好是千兆网卡和千兆交换机组建的千兆以太网。
   
2,本实验使用了“内部IP”,以确保IP地址不够的问题。实际使用时,最好让内部IP和虚拟IP(即对外提供Web服务的IP)均为公网IP,这样在远程登录管理时,可直接登录指定的服务器,因为远程服务也会被网络负载平衡进行动态路由,想登录哪台服务器不能被有效控制。
   
3,如果可能,尽量为服务器配置双网卡,让网络负载平衡由多块网卡分担。

七、群集下应用程序的会话(session)问题

对真正的负载平衡来说,每当用户点击一个连接时,它就改变服务器的状态,每当浏览一个新页面时都潜在地丢失他们的 session 信息。所以群集会对网站应用程序的会话(session)产生影响。
    所以在实施网络负载平衡之前,一定要对网站应用进行审核。

为适应网络负载平衡的网站结构,网站代码一般一般采取以下办法:

○ 不使用 session
    ○ 使用 cookies
    ○ 购买第三方组件来处理 session 的存贮和管理
    ○ 仅对 Web
的第一次点击进行负载平衡,即只要进入某台服务器,就不再动态切换。

Windows Server 2003 下实现网络负载均衡(2) (转)的更多相关文章

  1. 为什么基于Windows Server 2008 R2的网络负载均衡(NLB)配置的时候总会报错“主机不可访问”?

    配置基于Windows的网络负载均衡是很容易的,操作也很简单,点点鼠标基本上就能完成,但是在进行节点(真实服务器)操作的过程中有时候会遇到一些主机不可访问的报错信息.这个又是为什么呢? Figure ...

  2. Windows Server 2003 下如何安装及配置 FTP 服务器(转)

    Windows Server 2003 下如何安装及配置 FTP 服务器 一.安装 FTP 服务器组件: 写在这里的一点 : 安装及配置 FTP 服务器之前 , 必须先手工配置服务器本身的 IP 地址 ...

  3. Windows Server 2003下ASP.NET无法识别IE11的解决方法

    由于IE11对User-Agent字符串进行了比较大的改动,所以导致很多通过User-Agent来识别浏览器的程序,都相应的出现了无法识别IE11的情况.(普通用户端则可以通过这个方法来进行设置.) ...

  4. Windows Server 2003下ASP.NET无法识别IE11的解决方法【转】

    http://www.iefans.net/windows-server-2003-asp-net-ie11-shibie/ 由于IE11对User-Agent字符串进行了比较大的改动,所以导致很多通 ...

  5. Windows Server 2003下配置IIS6.0+php5+MySql5+PHPMyAdmin环境

    配置环境: 操作系统:Windows Server 2003 sp2企业版 Web服务器:系统自带的IIS6.0 所需工具: PHP:php-5.2.12-Win32.zip(官方网址:http:// ...

  6. Windows Server 2003下DHCP服务器的安装与简单配置图文教程

    在前面的内容中,我们提到了DHCP这个词,为什么要用到DHCP呢,企业里如果有100台计算机,那样,我们一台台的进行配置Ip,我想还是可以的,因为少嘛,如果成千上万台,那我们也去一台台的配置,我相信这 ...

  7. [数据库] windows server 2003下mysql出现10048错误的解决办法 Can't connect to MySQL server on '127.0.0.1' (10048)(抄)

    网站访问量大了的时候mysql连接数自然就多了,当超出mysql最大连接数的时候就会出现错误,当出现too many字样的错误的时候一般是因为连接数的问题,只需要修改最大连接数max_conectio ...

  8. LVS + KEEPALIVED + WINDOWS SERVER 2008 R2 ------高可用负载均衡(转)

    工作原理此处不作讲解,自己去官方网站学习(http://www.linuxvirtualserver.org),这里重点讲如何配置!注:最好从官方网站对其进行了解,不至于会对某些问题产生误解,尽管是英 ...

  9. windows server 2003下安装iis6+php

    参照http://www.myhack58.com/Article/sort099/sort0100/2012/35579.htm 这篇文章,即可! 前 面我写了<windows安装PHP5.4 ...

随机推荐

  1. mac 用密钥远程登陆

    window远程登陆命令:mstsc A为本地主机(即用于控制其他主机的机器) ;B为远程主机(即被控制的机器Server), 假如ip为192.168.60.110;A和B的系统都是Linux 在A ...

  2. html中元素的id和name的区别(2016-1-22)

    HTML中元素的Id和Name属性区别 一直以来一直以为在html中,name和id没什么区别,今天遇到一个坑才发现(PHP获取不到表单数据,原因:元素没有name,只定义了id),这两者差别还是很大 ...

  3. Mermaid 学习

    基础 在 VS code 中安装插件 Markdown Preview Mermaid Support,则便可支持 Mermaid 流程图 flowchart graph LR; A-->B; ...

  4. MOD 10,11算法(GB/T 17710-1999 数据处理 校验码系统 )的 Python实现

    以上是算法简要说明,以下代码为Python实现,不过注意代码中的N=15,不是16. # GB/T 17710 双模校验算法 # QQ 3257132998 def GB_Code(str): str ...

  5. jQuery 插件写法示例

    1.插件 taskStaticBar.js /**自定义任务进度条插件,用于发布任务单的显示进度 * 先初始化init() * 配置项type:1,任务发布方:type=2,生产方 * 然后传入sho ...

  6. C# 序列化简单格式XML

    问师傅反序列化和序列化到底是什么, 然后师傅鄙视一下我的智商,让我做个反序列化解析XML. 一边听着师傅在旁边跟女朋友打电话收到暴击伤害,一边写,搞了一个半小时. XML文件: <?xml ve ...

  7. JMS异步消息机制

    企业消息系统 Java Message Service 是由 Sun Microsystems 开发的,它为 Java 程序提供一种访问 企业消息系统 的方法.在讨论 JMS 之前,我们分来析一下企业 ...

  8. Contest Reviews(Updating)

    现在每天至少一套题又不太想写题解…… 那就开个坑总结下每场的失误和特定题目的技巧吧 2018.8.25[ZROI] T3传送门 T1:找规律找崩了…… 最好不要一上来就钻进大讨论,先想有没有普适规律 ...

  9. Lost connection to MySQL server at 'reading initial communication packet', system error: 0的一个解决方案

    -A INPUT -p tcp -m state --state NEW -m tcp --dport 3306 -j ACCEPT在icmp之前/etc/init.d/iptables restar ...

  10. Easy File Sharing Web Server 6.9远程溢出漏洞

    from struct import pack import socket,sys import os host="192.168.109.129" port=80 junk0 = ...